タグ付けされた質問 「apt」

Debianとその派生物の標準ソフトウェアパッケージ管理システムであるAPT(Advanced Packaging Tool)の使用、設計、機能などに関する質問。



5
Super Cow Powersの背後にあるストーリーは何ですか?
私たちが知っているように、apt-getスーパーカウパワーをaptitude持っていますが、していません: $ apt-get --help | grep -i cow This APT has Super Cow Powers. $ aptitude --help | grep -i cow This aptitude does not have Super Cow Powers. そしてもちろん、APTにはイースターエッグがあります: $ apt-get moo (__) (oo) /------\/ / | || * /\---/\ ~~ ~~ ...."Have you mooed today?"... 私は興味があります、このイースターエッグの背後に物語がありますか?その歴史は何ですか?古いDebianリリースのaptソースの簡単なgrepから、それがDebian 2.2(potato; apt ...
287 debian  apt  history 

10
「apt-get」と「aptitude」の本当の違いは何ですか?(「wajig」はどうですか?)
私はその両方を知っているapt-getし、aptitudeDebianの上のコマンドラインのパッケージ管理インターフェイスは、さまざまなオプションで、Linuxの派生ですが、私はまだ多少混乱しています。内部では、同じAPTシステムを使用していませんか? Debianはなぜこれらの並列ツールを管理しているのですか?(ボーナス質問:wajigとは一体何ですか?)

9
apt-getがIPv6方式を使用しないように説得する
私が働いているISPは、最終的にIPv6インターネットに接続するための準備として、内部IPv6ネットワークをセットアップしています。その結果、このネットワークのサーバーのいくつかは、実行時にデフォルトでIPv6アドレスを介してsecurity.debian.orgに接続しようとするapt-get updateため、何らかの更新をダウンロードするたびに長いタイムアウトを待つ必要があります。 IPv4を優先するか、IPv6を完全に無視するようにaptに指示する方法はありますか?
239 apt  ipv6 


5
apt-getを使用してGitの新しいバージョンに更新するにはどうすればよいですか?
Ubuntu Oneiric 11.10で新しいマシンをセットアップし、実行しました apt-get update apt-get upgrade apt-get install git 今、私がgit --versionそれを実行すると、私が持っていると教えてくれますgit version 1.7.5.4が、私のローカルマシンにはもっと新しいものがありますgit version 1.7.9.2 ソースからインストールして最新バージョンを入手できることは知っていますが、可能な限りパッケージマネージャーを使用してすべてを標準化することをお勧めします。 のapt-get新しいバージョンを取得するために使用することは可能gitですか?それを行う正しい方法は何ですか?
156 ubuntu  apt  upgrade  git 

4
Debianのシェルからリポジトリを追加する方法は?
Ubuntuでは、次のコマンドを使用してリポジトリを追加できます- sudo add-apt-repository ppa:yannubuntu/boot-repair UbuntuはDebianのコードベースに基づいているため、Debianでも同じことが機能すると期待していましたが、機能しません。 この理由は何ですか? 同じことを達成するために使用できる他のシェルコマンドはありますか? 注:を編集できることは知っていますが/etc/apt/sources.list、これをシェルから実現したいと思います。また、コードベースが同じ場合に同じコマンドが機能しない理由も知りたいです。
141 shell  debian  apt  repository  ppa 

9
インストール日ごとにaptベースのシステム上のパッケージを一覧表示する
インストールされたパッケージをインストール日ごとに一覧表示するにはどうすればよいですか? debian / ubuntuでこれを行う必要があります。他のディストリビューションへの回答もいいでしょう。 特定のコードをコンパイルするために多くのものをインストールしましたが、インストールする必要があるパッケージのリストを取得したいと思います。

2
gpg:鍵サーバーの受信に失敗しました:dirmngrなし
Debian Stretchサーバーでキーを受信しようとすると、次のエラーが表示されます。 sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys 3FA7E0328081BFF6A14DA29AA6A19B38D3D831EF Executing: /tmp/apt-key-gpghome.4B7hWtn7Rm/gpg.1.sh --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys 3FA7E0328081BFF6A14DA29AA6A19B38D3D831EF gpg: failed to start the dirmngr '/usr/bin/dirmngr': No such file or directory gpg: connecting dirmngr at '/tmp/apt-key-gpghome.4B7hWtn7Rm/S.dirmngr' failed: No such file or directory gpg: keyserver receive failed: No dirmngr
94 debian  apt  gpg 

5
64ビットのUbuntuでパッケージ `docker-ce`が見つかりません
公式のインストールガイドに従って、 Ubuntu 64マシンにDockerをインストールしようとしています。 残念ながら、Ubuntuはdocker-ceパッケージを見つけることができないようです。それを修正するか、少なくとも何が起こっているかを追跡するためのアイデアはありますか? ここであなたのためのいくつかの詳細... $ uname --all; sudo grep docker /etc/apt/sources.list; sudo apt-get install docker-ce Linux ubuntu 4.4.0-62-generic #83-Ubuntu SMP Wed Jan 18 14:10:15 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux deb [arch=amd64] https://download.docker.com/linux/ubuntu xenial stable. # deb-src [arch=amd64] https://download.docker.com/linux/ubuntu xenial stable. Reading package lists... Done Building dependency tree Reading ...

4
「apt-get update」と同等のyumとは何ですか?
Debian apt-get updateはパッケージインデックスを取得して更新します。私はこの方法で物事を行うことに慣れているため、それyum updateがすべてを実行し、システムをアップグレードすることに驚いた。このため、何もインストールせずにパッケージインデックスを更新する方法に興味がありました。

9
どのインストール済みソフトウェアパッケージがDebianで最も多くのディスク容量を使用していますか?
ルートパーティションのディスク領域が不足しているため、システムから一部のアプリケーションを削除します。どのソフトウェアパッケージが最も多くのディスク容量を使用しているかを確認するにはどうすればよいですか?それを表示することは可能aptitudeですか? dfまたはのような汎用ディスクスペースアナライザーについては知っていbaobabますが、インストールされたアプリケーションのソリューションが必要です。
77 apt  disk-usage 

4
「次のパッケージは保存されていません」とはどういう意味ですか?
を実行するapt-get upgradeと、「次のパッケージは保存されました」というメッセージが表示されることがあります。例えば: $ sudo apt-get upgrade Reading package lists... Done Building dependency tree Reading state information... Done The following packages have been kept back: linux-headers-server linux-image-server linux-server 0 upgraded, 0 newly installed, 0 to remove and 3 not upgraded. これはどういう意味ですか?明らかに、パッケージは抑制され、インストールされていませんが、なぜですか? 次の質問は、これらの保存されたパッケージをどのようにアップグレードしますか?
72 apt  upgrade 

3
-bash:sudo:コマンドが見つかりません
djangoアプリをデプロイしようとしています。印刷する apt-get update と見える W: Unable to read /etc/apt/apt.conf.d/ - DirectoryExists (13: Permission denied) W: Unable to read /etc/apt/sources.list.d/ - DirectoryExists (13: Permission denied) W: Unable to read /etc/apt/sources.list - RealFileExists (13: Permission denied) E: List directory /var/lib/apt/lists/partial is missing. - Acquire (13: Permission denied) E: Unable to read /var/cache/apt/ ...
63 debian  apt  sudo  su 

弊社のサイトを使用することにより、あなたは弊社のクッキーポリシーおよびプライバシーポリシーを読み、理解したものとみなされます。
Licensed under cc by-sa 3.0 with attribution required.