Unix & Linux

Linux、FreeBSDおよび他のUn * xのようなオペレーティングシステムのユーザーのためのQ&A

1
opensslコマンドを使用して大きなサイズの暗号化ファイルを作成する方法
AIXでの暗号化ファイルの作成中に、次のエラーを受け取りました。 $ openssl enc -aes-256-cbc -salt -in test.img -out test.img.enc test.img: Value too large to be stored in data type 14221428:error:0200107F:system library:fopen:Value too large to be stored in:bss_file.c:356:fopen('test.img','r') 14221428:error:20074002:BIO routines:FILE_CTRL:system lib:bss_file.c:358: test.imgのファイルサイズは35 GBです 同じコマンドが100GBファイルのLinuxで機能しました。
8 aix  openssl 

1
デフォルトでマルチスレッドmakeを使用しますか?
コマンドラインにmake追加-j6するだけでなく、システム全体でマルチスレッド(私のシステムでは6スレッドが理想的)を使用する方法はありますか?つまり、実行するとmake、実行していた場合と同じように動作しmake -j6ますか?AURからpacaur(Arch を使用して)多くのパッケージをインストールし、makeコマンドを直接実行しないため、この機能が必要です。

3
パスワードプロンプトからCTRL ^ Cを削除するにはどうすればよいですか?
suコマンドを開始し、それをキャンセルしたいとします。 Control+ Cがのsuように機能しないsudo...プロンプトを終了する必要があります(パスワードを十分に間違えるか、正しくすることにより)。 パスワードプロンプトを強制終了するために入力できるものはありますか?

3
systemdが「ループが速すぎる」と出力するのはなぜですか?
Debian 8.3(jessie)でサーバー(VPS)を実行していて、systemdがさまざまなプロセスを管理しています。システムの負荷は1未満ですが、ほぼすべてのメモリとスワップ領域の一部を使用しています。サービスを停止して開始しようとすると systemctl stop process@1 ログファイルは言う Mar 1 08:03:50 abcde systemd[1]: Looping too fast. Throttling execution a little. このメッセージは毎秒表示され、それ以上は起こりません。^C端末に送信すると、ようやくプロセスが停止します。デーモンを再起動しようとすると、同じことが起こります。Systemdのバージョン:215-17 + deb8u3 このメッセージが表示されるのはなぜですか?このメッセージなしでデーモンをシャットダウンするにはどうすればよいですか?
8 systemd  daemon 

4
gnome-keyringとArch Linuxの「パスに/そのような秘密のコレクションはありません」を修正するにはどうすればよいですか?
Arch Linuxを実行しています。Vinagre(VNCクライアント)を使用して資格情報を保存しようとすると、エラーが発生します。 ロックされたキーリングの資格情報の保存中にエラーが発生しました ロックされたコレクションにアイテムを作成できません Arch wikiでこのガイドを見つけ、それに従いました。トラブルシューティングセクションでは、次のようになっています。 タツノオトシゴパッケージがインストールされていることを確認して開き(システム設定の「パスワードとキー」)、[表示]> [キーリング別]を選択します。左側の列にキーリングがない場合(ロックアイコンでマークされています)、[ファイル]> [新規]> [パスワードキーリング]に名前を付けます。パスワードの入力を求められます。キーリングにパスワードを指定しないと、自動ログインを使用している場合でも自動的にロックが解除されますが、パスワードは安全に保存されません。最後に、作成したキーリングを右クリックして、「デフォルトに設定」を選択します。 私がタツノオトシゴを起動すると、それはありません持っているパスワードを持つセクションLoginその右にあるロックアイコンのフォルダを。うねりね?まあ、私が知る限り、実際には何も機能しません(フィードバックはありませんが、どうやらそれを削除することができました) 新しいキーリングを作成しようとすると、次のように表示されます。 キーリングを追加できませんでした パスにそのような秘密のコレクションはありません:/ まったく同じメッセージでこの問題が見つかりました~/.local/share/keyringsが、drwxr-xr-x権限があります(自分の名前とグループがあります)。 では、このエラーを解決して、キーリングにキーを格納するにはどうすればよいですか? 編集: さらに詳しい情報-役に立たない鍵リングを削除した後、Vinagreは代わりに次のメッセージを表示します。 パス/ org / freedesktop / secrets / collection / loginのオブジェクトには、このようなインターフェース「org.freedesktop.Secret.Collection」はありません

1
md raid5:md内部セクター番号をオフセットに変換します
TL; DRの要約:mdセクター番号を/dev/mdXデバイス内のオフセットに変換し、それをで調査する方法xfs_db。セクター番号はからのものsh->sectorですlinux/drivers/md/raid5.c:handle_parity_checks5()。 MDの内部がわからないので、printk追加したログからの出力をどうするか正確にわかりません。 コンポーネントデバイス(ddまたはhexエディター/ビューアー)へのオフセットも興味深いでしょう。 Linux-raidメーリングリストでこれを尋ねるべきだと思います。サブスクライバーのみですか、またはサブスクライブせずに投稿できますか? 私のデスクトップでは、4つのディスクのMD RAID5の上に直接xfsがあります(LVMなし)。最近のスクラブでゼロ以外が検出されましたmismatch_cnt(mdは一度に4kiBページで動作するため、実際には8)。 これはRAID5であり、通常の動作中に!= 0が発生する可能性があるmismatch_cnt RAID1 / RAID10 ではありません。(このWikiページの下部にある他のリンクは、一部の人々にとって役立つかもしれません。) 私は盲目的にできましたrepairが、どのファイルを再構築するかを選択する機会を失う以外に、破損の可能性をチェックするファイルがわかりません。 同様の質問に対するFrostschutzの回答は、ファイルシステムの違いを追跡するために私が見つけた唯一の提案です。面倒で遅いので、最初にいくつかのファイルに絞り込むために、より良いものを使用したいと思います。 ロギングを追加するカーネルパッチ 奇妙なことに、mdのチェック機能は、エラーが見つかった場所を報告しません。 私は追加printkログインするには、MD / raid5.cにsh->sectorにif増加することを支店mddev->resync_mismatches内handle_parity_checks5()(小さなパッチgithubの上で公開され、もともとkernel.orgから4.5-RC4に基づいて、。)これは一般的な使用のためにOKであるために、それはおそらくする必要があります不一致が多い修理でログが殺到しないようにします(たぶん、新しい値がresync_mismatches1000未満の場合にのみログを記録しますか?)。また、ログのみでログはないかもしれcheckませんrepair。 同じ関数がそのセクター番号をのエラー処理の場合にswitch出力するので、(MDの内部を知らなくても)何か有用なものをログに記録していると確信しています。 変更したカーネルをコンパイルして起動し、チェックを再実行しました。 [ 399.957203] md: data-check of RAID array md125 ... [ 399.957215] md: using 128k window, over a total of 2441757696k. ... [21369.258985] md/raid:md125: check found mismatch at sector …

1
起動シーケンスの最後に飛ぶメッセージを一時停止(またはキャプチャ)するにはどうすればよいですか?
「起動シーケンス」1の終わりに向かって、ログインプロンプト2が表示される直前に、長い一連の診断メッセージが非常に速く飛んでいくのがわかります。 すべてではないにしても、この短命の出力を構成する行のほとんどは、以下に示す文字列のいずれかで始まります。 [ OK ] [FAILED] ... OKは緑色で、FAILEDは赤色です3。 これらのメッセージが短すぎて私には読めません。 私の質問は: これらのメッセージを読みやすくする方法はありますか? 頭に浮かぶ可能性のある解決策は次のとおりです(優先順): これらのメッセージをそのまま 4番で永続的なログファイルにティーイン(または単にリダイレクト)します。 ページングタイプのメカニズムを有効にする(Press any key to continue...); これらのメッセージが出力された後、(構成可能な長さの)ポーズを挿入する。 いくつかのキー(またはキーの組み合わせ)を有効にして、画面への出力を一時停止します5。 編集:私がこれまでに得たコメントに基づいて、私はできる限り強調しましたが、上記の(1)の逐語的な言葉は理解されていないか、真剣に受け取られていないと結論付けなければなりません。フラッシュできたら… EDIT2:meuhがコメントで与えた提案は私に有望であるように見えますが、まだ機能させることができていません。これが私がしたことです: まず、の最後に次のコードを追加しました/etc/rsyslog.conf。 # Save boot messages also to boot.log local7.* /var/log/boot.log ...そして再起動しました。通常の診断メッセージが飛び交うのを見ましたが、/var/log/boot.logファイルは作成されませんでした。 次に、(確かにありそうもないことですが)/var/log/boot.logがすでに存在していなければならないというイベントでrsyslog書き込みができるようにして、(rootとして)実行しました。 touch /var/log/boot.log chgrp adm /var/log/boot.log chmod 640 /var/log/boot.log ... chgrpとchmodコマンドは、の所有権と権限を/var/log/boot.log、にある他のすべてのログファイルの所有権と権限と一致させることを目的としています/var/log。その後、再起動し、メッセージなどを確認しました/var/log/boot.log。この再起動後、ファイルは空のままでした。 (の権限をに変更したときに、同じ結果が得られませんでし/var/log/boot.logた666。) 私はgrep「の出力編journalctl --bootと下のファイル/var/log、私は私で何かのゆがんを指していると考えることができ何のためにrsyslog、しかし、何も見つかりませんでした。(私はにあまり詳しくないrsyslogので、私の検索はかなり無能だったと思います。) これまでに行ったことは、目的のログを有効にするのに十分ではないことは明らかです。私は今私が行方不明のものを探しています。ただし、関連するドキュメントを見つけることはできませんでした。たとえば、何であるかを説明することはありませrsyslog.conf(5)ん。rsyslogd(8)local7rsyslog.conf(5) EDIT3 …

2
なぜ補助グループにsetgid()する必要があるのですか?
set*gid()非常にまれな場合を除いて、さまざまなシステムコールには、グループを変更するための特権が必要です。プライマリグループをプロセスの補足グループの1つに変更することは、それらの1つではないようです。たとえば、newgrp/ sgコマンドは、プライマリグループを切り替えるために特権を昇格する必要があります。 setgid()/ setegid()/ setregid()/ setfsgid()特権のない補足グループへの切り替えを許可しない理由はありますか?もしそうなら、理由は何ですか?

1
CentOSサーバーでssl.confファイルが見つからない場合はどうすればよいですか?
多くの1つである、新しいCentOS Linuxサーバーを準備しています。このサーバーでSSLを構成しようとすると、ssl.confファイルがないことに気付きました。ではなく、では/etc/httpd/conf.d/ssl.confありません/etc/httpd/conf/ssl.conf。 私も試しましたlocate ssl.confが、結果はありませんでした。 自分で作成する必要がありますか?持っている他のCentOSサーバーからファイルをコピーできますか?よろしいですか? Centos 6.3(64ビット)、Apache / 2.2.15(CentOS)、PHPバージョン5.3.3、MySQLi 5.1.73
8 centos  ssl 


1
ノードJS-FQDNを取得する[終了]
閉まっている。この質問はトピックから外れています。現在、回答を受け付けていません。 この質問を改善してみませんか? 質問を更新して、 Unix&Linux Stack Exchangeのトピックとなるようにしてください。 4年前休業。 ノードが実行されているマシンのFQDN(完全修飾ドメイン名)を取得するにはどうすればよいですか? os.gethostname()通常は修飾されていないDNのみを返すため、これは十分ではありません。同じことdns.reverse(ip, callback)-IPがホスト名に関連付けられているものであると仮定しdns.lookup(os.gethostname()[, options], callback)ます(例:を使用して取得)。 また、aを実行するshell.exec("hostname -f", { silent: true }, cb)ことはオプションではありません。POSIXに準拠していないため、Solarisなどでは失敗します。また、exec()は非常に高価な呼び出しwrt であるため、これは本当に悪いハックです。RAMやCPUなどのリソース(コンテキスト切り替えの原因)。
8 node.js 

2
特定のファイルのファイルシステム情報を取得するにはどうすればよいですか?
ファイルに関するファイルシステム情報を見つける最善の方法は何ですか。 たとえば、ファイルがある場合 /media/xyz/path/to/file.ext そして/etc/fstabが含まれています //server1/Share1 /media/xyz cifs option1=value1,... ファイルがSamba共有にあること、ローカルパスが/path/to/file.extあり、ファイルシステムがマウントされているオプションを確認するにはどうすればよいですか? mountポータブルソリューションの出力を解析していますか?または解析しfindmntますか?それを達成するためのPOSIX準拠の方法はありますか?
8 mount  posix 

2
セキュアブートを使用してinitrdとgrub.cfgを保護するにはどうすればよいですか?
ubuntuインストールをセキュアブートするために、shimとgrub2でデフォルトのubuntuアプローチを使用し、独自のプラットフォームキー(sbsignを使用した自己署名shim)と暗号化されたルートパーティションを組み合わせています。ただし、これはgrubx64.efiとカーネルのみを検証しますが、暗号化されていないブートパーティション上のinitrd.imgおよびgrub.cfgファイルを悪意のある変更から保護しません。 では、ブートに使用する前に、おそらくsha256ハッシュを使用して、initrdとgrubの構成を確認するにはどうすればよいですか?その検証は、shim、grub、またはshimやgrubに加えて、またはその代わりに使用する他のツールで発生する可能性があります。 この質問の目的は、変更された環境(カーネルコマンドラインとinitrd)でカーネルを実行して、ルートパーティションの暗号化パスワードがどこかに漏洩するのを防ぐことです。 UbuntuとLinux FoundationのPreLoader.efiを含むセキュアブートに関するWebチュートリアル/ブログを数日間読んだにもかかわらず、ブート構成を検証する方法は見つかりませんでした。これらはすべて、カーネルモジュールを含む実行可能ファイルの検証がどのように機能するかを説明していますが、どれもこれはgrub.cfgと(内部のシェルスクリプトと構成ファイル)initrdについて言及しているため、起動プロセスで非バイナリの検証を要求するのは私が初めてのようです。私が見つけた最高の情報源は、ロッド・スミスの情報源です。 私がまだ試していないのは、shimやgrubのソースコードを変更したり、フォークを作成したり、それらに直接貢献することです。それが唯一の方法でしょうか?

3
イーサネットケーブルを介した「パイプ」Wi-Fi信号
現在、私が働いている建物のイーサネットポートはダウンしていますが、Wi-Fiは機能しています。Wi-Fi対応のラップトップ(Ubuntu 14.04 LTS(Trusty Tahr))と、イーサネットプラグのみを備えた非Wi-Fi対応のワークステーション(Debian 8(Jessie))を持っています。 イーサネットケーブルを介して2つを接続し、ワークステーションでネットワーク接続を取得することは可能ですか?

1
awkスクリプトでCtrl-Cをトラップする
私は信じているCtrl- Cのbashスクリプトでトラップすることができます。そのイベントを処理するために、Awkスクリプト内にトラップすることもできますか? たとえば、処理を中止するが、静かに終了するのではなく、すでに処理された結果を出力する場合はどうでしょうか。

弊社のサイトを使用することにより、あなたは弊社のクッキーポリシーおよびプライバシーポリシーを読み、理解したものとみなされます。
Licensed under cc by-sa 3.0 with attribution required.