タグ付けされた質問 「upgrade」

パッケージ、システム、ハードウェアのアップグレードに関する質問。

6
apt-getを使用して単一のパッケージをアップグレードする方法は?
単一のパッケージを更新するにはどうすればよいですか?man apt-get言う限りではapt-get upgrade、パラメーターとしてパッケージ/パッケージのリストを取りません: アップグレード upgradeは、に列挙されているソースから現在システムにインストールされているすべてのパッケージの最新バージョンをインストールするために使用され /etc/apt/sources.listます。現在利用可能な新しいバージョンでインストールされているパッケージが取得され、アップグレードされます。現在、インストールされているパッケージが削除されたり、まだインストールされていないパッケージが取得およびインストールされたりすることはありません。別のパッケージのインストールステータスを変更せずにアップグレードできない現在インストールされているパッケージの新しいバージョンは、現在のバージョンのままになります。パッケージの新しいバージョンが利用可能であることをapt-getが認識できるように、最初に更新を実行する必要があります。
827 apt  upgrade 


2
apt-getアップグレード中に開始されるDwarf Fortress
apt-get upgradeUbuntu 17.04マシンで実行すると、Dwarf Fortressが自動的に起動する場合があります。 少なくとも2回はすでに発生しているので、おそらくある種の一時的なものではなかったでしょう。また、apt-get upgradeDwarf Fortressを手動で終了するまで、の実行は一時停止しているように見えたので、おそらく他の何かがその時間に実行されていることが原因ではありません。 当時のコンソールは、Unpacking xxx.どこに名前xxxがあるのか​​を言っていmysqlました。しかし、今日のようにapt-get upgrade多くのmysql関連パッケージをアップグレードしたパッケージを正確に知りません。 何が起こるのか、それを止める方法を知りたい。あなたのアイデアをありがとう。

5
apt-get dist-upgradeではなくapt-get upgradeを使用する理由
apt-get update && apt-get upgradeGUIの代わりに更新とアップグレードを実行するのが普通です。これは、GUIがより速く実行されるようだからです。 しかし、最近、アップグレードの1つが保留されたというメッセージを頻繁に受け取ることに気付きました。それから私は通常dist-upgradeそれを実行するために走り、それはうまく働きます。この質問とその答えを読んだ後、私が知る限りdist-upgrade、同じことをしてからいくつかを行います。 だから、私の質問は次のとおりapt-get upgradeです。apt-get dist-upgradeいつも使ってみませんか?なぜapt-get upgrade存在するのでしょうか?

4
apt-getが0で止まる[us.archive.ubuntu.comへの接続]
アップグレードすると、次のようになります。 user@plato:~# sudo apt-get upgrade Reading package lists... Done Building dependency tree Reading state information... Done Calculating upgrade... Done The following packages will be upgraded: bind9-host coreutils cpio curl dnsutils libbind9-90 libc-bin libc-dev-bin libc6 libc6-dev libcgmanager0 libcurl3 libcurl3-gnutls libdns100 libdrm-intel1 libdrm-nouveau2 libdrm-radeon1 libdrm2 libisc95 libisccc90 libisccfg90 libjasper1 liblwres90 libplymouth2 libsepol1 ...

14
/ bootパーティションが100%に達したため、アップグレードできません。古いカーネルを削除してスペースを空けることはできません
私がしようとしたとき、私の最初の問題でしたapt-get updateかapt-get upgrade。アップグレード時に、次のエラーが表示されます。 You might want to run 'apt-get -f install' to correct these. The following packages have unmet dependencies: linux-image-server : Depends: linux-image-3.2.0-27-generic but it is not installed E: Unmet dependencies. Try using -f. 私はapt-get install -fを実行しようとしましたが、これは出力です(プロンプトでyesと言った後) (Reading database ... 186183 files and directories currently installed.) Unpacking linux-image-3.2.0-27-generic (from ...

15
ディストリビューションをアップグレードせずにカーネルを最新のメインラインバージョンに更新する方法
現在、Linux-3.0を実行しています。http://www.kernel.orgで言及されているように、最新の安定したカーネルリリースであるLinux-3.3.1に更新したいと考えています。クラッシュのリスクなしでUbuntuで3.3.1に更新できますか?Update Managerが提供するようにカーネルを定期的に更新しています。現在、Linux -3.0.0.17があります。更新できますか? 注意: ユーザーがUbuntuで使用することになっている最新のカーネルバージョンは、Update Managerを介して自動的に更新されるため、通常、ユーザーはカーネルのアップグレードに関してアクションを必要としません。質問の著者が言及しているのはメインラインカーネルです。「メインライン」カーネルにアップグレードする必要がありますか?を参照してください 。
146 upgrade  kernel  updates 

10
アップグレード時に十分な空きディスク容量がない
毎日更新しようとすると、ソフトウェアアップデーターでエラーが発生します。それは言います: The upgrade needs a total of 25.3 M free space on disk `/boot`. Please free at least an additional 25.3 M of disk space on `/boot`. Empty your trash and remove temporary packages of former installations using `sudo apt-get clean`. sudo apt-get cleanターミナルに入力しようとしましたが、まだメッセージが表示されます。私が読んだページはすべて、経験豊富なUbuntuer向けです。Ubuntu 12.10を実行しています。13.04にアップグレードしたいのですが、最初にこれらを完了する必要があることを理解しています。 これは、cat /etc/fstabターミナルへの入力からの出力です。 # /etc/fstab: static ...
142 apt  upgrade 

9
16.04アップグレードによりmysql-serverが破損しました
私の全体的なアップグレードはうまくいきましたが、mysql-serverがそれ自体をインストールできないという非常に長引く問題が残っています。 これは、インストール/再インストールしようとしたときに表示されるエラーです。 Setting up mysql-server-5.7 (5.7.11-0ubuntu6) ... Job for mysql.service failed because the control process exited with error code. See "systemctl status mysql.service" and "journalctl -xe" for details. invoke-rc.d: initscript mysql, action "start" failed. dpkg: error processing package mysql-server-5.7 (--configure): subprocess installed post-installation script returned error exit status 1 dpkg: ...
127 upgrade  mysql  16.04 

7
/ bootのディスク容量が少ないためアップグレードできません
私はしようとしますdo-release-upgrade が、それから私は得る: 十分な空きディスク容量がありません アップグレードは中止されました。アップグレードには、ディスク '/ boot'に合計25.7 Mの空き領域が必要です。'/ boot'に少なくとも25.7 Mの追加のディスク領域を解放してください。ごみ箱を空にし、「sudo apt-get clean」を使用して以前のインストールの一時パッケージを削除します。 出力df: 237251272 214797108 10402504 96% / udev 488120 4 488116 1% /dev tmpfs 198676 668 198008 1% /run none 5120 0 5120 0% /run/lock none 496684 0 496684 0% /run/shm /dev/sda1 233191 225867 0 100% /boot ブート時にスペースが残らないのはなぜですか?の出力はls -as /boot次のとおりです。 ...


9
32ビットから64ビットへの「アップグレード」は可能ですか?
タイトルどおり、32ビットのセットアップに成功し、ソフトウェアをインストールした後、64ビットバージョンにアップデートできるかどうかを知りたいと思います。 私は分割する方法を知っている(実際には解決策の一つが設定することで/、/etc、/home、/var/www、と/opt別々のパーティションなど)と私はきれいに汚れよりもずっといいですインストールすることを知って、まだ私はそれが可能ですか/かどうかを知りたいですそれを行う。
105 upgrade  64-bit  32-bit 

10
あるLTSから次のLTSリリースにスムーズにアップグレードできますか?
質問はUbuntuのリリースプロセスに関するものです。nリリースからn + 1リリースへの移行は予定されていますか? Ubuntu 14.04 LTSがインストールされたサーバーがあると仮定します。apt-get upgradeを介してUbuntu 16.04 LTSにスムーズにアップグレードできますか? 仮定: スコープはソフトウェアです したがって、特定のハードウェアが両方のリリースでサポートされていると想定しています(アップグレードからアップグレードまで) そのため、常にアップグレードの前に、障害が発生した場合に復元できるようにバックアップを作成するように求められます



弊社のサイトを使用することにより、あなたは弊社のクッキーポリシーおよびプライバシーポリシーを読み、理解したものとみなされます。
Licensed under cc by-sa 3.0 with attribution required.