多くのIf-None-Match値が原因で、リクエストヘッダーフィールドのサイズがサーバーの制限を超えています
クライアントが「400 Bad Request」エラーを受け取り、Apache / 2.2.22を使用してUbuntu 12.04.3 LTSでホストされているdrupalホームページを表示できないように見える興味深いケースを次に示します。 不正なリクエスト ブラウザがこのサーバーが理解できないリクエストを送信しました。 リクエストヘッダーフィールドのサイズがサーバーの制限を超えています。 パケットスニッフィング出力: ... T 2013/09/02 15:23:10.458167 ###.###.###.###:40027 -> ###.###.###.###:80 [A] GET / HTTP/1.0. If-None-Match: "1363160742-0", "1363165573-1", "1363175854-1", "1363175854-0", "1363179616-0", "1363181811-0", "1363239319-1", "1363255903-0", "1363259282-0", "1363263398-1", "1363274564-0", "1363329642-0", "1363332613-1", "1363333851-0", "1363599826-0", "1363678909-0", "1363684227-1", "1363699732-0", "1363755181-0", "1363765691-1", "1363767178-0", "1363780208-0", "1363787589-0", "1363795259-1", "1363852409-1", "1363863225-1", "1363928115-0", …