サーバー管理者

システムおよびネットワーク管理者向けのQ&A

2
宛先ポートを定義するLinux SCP
宛先IPのポートを指定するにはどうすればよいですか?私が行うとscp -p 0000、それはまだポート22に接続しようと、私は指定していない1。 scp svn_backup.tgz user@xxx.xxx.xx.xxx:/path/to/new/svn/
8 linux  scp 

2
postfixが電子メールをキューに入れるまで60〜90ミリ秒かかります—通常ですか?
ローカルのPostfixサーバーに個別のメールを送信するときに、(多分?)奇妙な遅延が発生しています。 問題の診断に役立つように、5つのメールを送信する小さなテストプログラムを作成しました。 get smtp 1ms ( 1 ms) email 0 677ms (676 ms) email 1 802ms (125 ms) email 2 890ms ( 88 ms) email 3 973ms ( 83 ms) email 4 1088ms (115 ms) 最初のメールのハンドシェイクを割り引くと、1メールあたり約90ミリ秒になります。これらのタイミングは、別のコードパスを使用して他の誰かが作成した別のテストアプリでも確認されているため、サーバーに関連しているようです。 詳細なロギングをオンにしたところ、メッセージの終わりと受信の間に遅延があることがわかり\r\n\r\nます。 [16:31:29.95] [SEND] \r\n.\r\n [16:31:30.05] [RECV] 250 2.0.0 Ok: queued as B128E1E063\r\n [16:31:30.08] [SEND] …
8 postfix  queue 

6
192.168.122.1は有効なIPですか?
私の理解から、ネットワークは次のとおりです Class A: 10.0.0.1 - 10.255.255.254 Class B: 172.16.0.1 - 172.16.255.254 Class C: 192.168.0.1 - 192.168.0.254 しかし、それから私ifconfig virbr0は自分のLinuxコンピューターを調べます。 virbr0 Link encap:Ethernet HWaddr 42:40:99:CB:02:7F inet addr:192.168.122.1 Bcast:192.168.122.255 Mask:255.255.255.0 UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1 RX packets:0 errors:0 dropped:0 overruns:0 frame:0 TX packets:16 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:0 RX bytes:0 (0.0 …


5
Apacheが起動しない問題を解決する最良の方法は?
最近、プライマリサーバーがダウンした場合に備えて、すべてのデータをミラーリングするバックアップサーバーを取得しました。 すべてのサイトデータをrsyncで更新し、すべてのapache構成とデータベースを更新しました。両方のマシンは、Ubuntu 9(プライマリで9.04、バックアップで9.10)を使用しています。 したがって、この時点ではほとんどすべてが同期されているように見え(ユーザーの同期を把握する必要があります)、Apacheを起動しようとします。私は得る * Starting web server apache2 [fail] 問題が何であるかを示すものは他にありません。 私はあなたたちからの解決策を期待するのに十分な情報を持っていないので、私はこの問題をさらに調査するためにここからどこに行くことができるか知りたいのですが。このためのエラーログはありますか? ありがとう!

2
Sharepoint Foundation 2010の初回構成を正常に実行できません
構成データベースと管理データベースの名前を設定したいので、Power Shellを使用して非GUIバージョンの構成ウィザードを実行しようとしています。GUIウィザードは、構成のすべての可能なオプションを提供するわけではありません(ただし、それができない場合でも)。 私はこのコマンドを実行します: New-SPConfigurationDatabase -DatabaseName "Sharepoint2010Config" -DatabaseServer "developer.mydomain.pri" -AdministrationContentDatabaseName "Sharepoint2010Admin" -DatabaseCredentials (Get-Credential) -Passphrase (ConvertTo-SecureString "%h4r3p0int" -AsPlainText -Force) もちろん、これらはすべて同じ行にあります。読みやすくするために、それらを別々の行に分割しました。このコマンドを実行すると、次のエラーが発生します。 New-SPConfigurationDatabase : Cannot connect to database master at SQL server a t developer.mydomain.pri. The database might not exist, or the current user does not have permission to connect to it. At line:1 …


3
データを失うことなくファイルシステムのフォーマットをxfsからext4に変更する
新しいLucid Lynx(Ubuntu 10.04)をラップトップで実行しています。ここで、ファイルシステムを次のように定義しました。 マウントポイント/ ext4(46 Gb) jfs上のマウントポイント/ home(63 GB) 3 Gbとしてスワップ AC電源なしで、私はいくつかのタスクを実行するために機械を一晩放置しました。翌日の朝、私はそれをスタンバイで見つけ、タスクは完了しましたが、ファイルシステムに到達できませんでした。I / Oエラーが発生した jfsとstandbyに問題があるようです。 とにかく、面倒を避けるために、このマウントポイントをjfs形式からext4に移動したいと思います。 データを失うことなく、変換が完了するまでデータを一時的な場所に置く必要なく、これを行うことができますか? 申し訳ありませんが、Windowsの時代には、データを失うことなくFAT16をFAT32に、またはFAT32をNTFSに変更することを思い出します。これがLinuxで利用できることを願っています。 更新 / homeファイルシステムはjfsではなくxfsであり、何らかの理由でこのファイルシステムにバグがあるようです。全体がext4になるまでOSを2回再インストールする必要がありました/ ただし、結論としては、変換する方法がないようです
8 linux  ubuntu  xfs  ext4  jfs 

9
リモートSVN管理用のシンプルなWebフロントエンド?[閉まっている]
閉まっている。この質問はトピックから外れています。現在、回答を受け付けていません。 この質問を改善してみませんか? サーバー障害のトピックになるように質問を更新します。 5年前休業。 SVNリポジトリを実行します。上級ユーザーの一部は、システム管理者に依存せずにSVN管理を実行できる必要があります。 彼らは、SVNリポジトリの作成、SVNリポジトリの削除、「svnadmin dump」や「svnadmin load」などのコマンドを実行できる必要があります。 これらのFreeBSDマシンでのSSHアクセスを回避し、Web UIを介してサービスインターフェイスを提供したいと考えています。 PerlまたはPHPを使用する単純なスクリプト(または少数のスクリプト)を探しています。私はsvnadmin(Jochen Hoenickeから)またはsvnadmin.pl(Doug munsingerから)を見つけましたが、より大きなユーザーコミュニティで、または他のユーザーから推奨されているものを見つけたいと思っていました。 TracはSVNの管理を許可しているようですが、必要な機能が追加されている場合があります。

6
WHMまたはSSH経由で1か月あたりのDNSクエリ数を確認してください。
出来ますか?DNSサーバーと実際にポイントされているサーバーを完全に制御できます。Ultra DNSに移行するため、現在取得しているDNSクエリの数に関心がありますが、1か月に取得する可能性のあるクエリの数を知る必要があります。 これは理解することは可能ですか?追跡を開始する前にサービスを開始する必要がありますか?またはシェルを使用してデータにアクセスしますか?

4
VPSにはファイアウォールが必要ですか?
今日注文したVPSにファイアウォールは必要ですか? もしそうなら、どれをお勧めしますか? 私は、Java、php、mysqlでクラシファイド広告のWebサイトを実行する予定です。私のOSはubuntu 9.10です ありがとう ところで:iptablesとは何ですか?

2
「亜鉛ウィスカ」の問題?
おはようございます; データセンターでは、一時的に「亜鉛ウィスカ」が原因と考えられる断続的な電源障害が発生しています。私はそれらについて読み始めたばかりで(用語をグーグルで検索して選択し始めた)、他のユーザーとの経験や、クリーンアップと回復の経験に興味があります。ありがとう!

2
大企業は、管理者権限のないユーザーのソフトウェア更新をどのように処理しますか?
ちょうど中小企業でITサポートを始めたところです。たぶん150人以下のユーザー。 現在、すべてのユーザーが自分のマシンに対する管理者権限を持っています。これにより、アップデートやその他の必要なものをインストールできます。 私は、自分が身に付けたがらくたで膨れ上がっているユーザーのマシンに乗るのに疲れました。だから私の最初の考えは、彼らのコンピュータの管理者権限を奪うことだろう。これには、ウェブ上で大量のドライブバイマルウェアを防止するなど、他の利点もあります。 ユーザーがアップデートをインストールできないという問題が発生します。(とにかくこれらをほとんど無視していると思いますが) 大企業はすべてのクライアントマシンでソフトウェアアップデートをどのように処理しますか? 編集:Windows環境。ほとんどのサーバーはWindows Server 2003 Enterpriseです。クライアントはすべてWindowsです。Windows XP、Vista、および7を獲得します。

2
CentOSダウンロードディレクトリ/ var / cache / yum / base / packagesに十分なスペースがない
私が得たときにlibpcapをインストールしようとしていました Error Downloading Packages: 14:libpcap-0.9.4-15.el5.i386: Insufficient space in download directory /var/cache/yum/base/packages * free 0 * needed 108 k df -hからの出力は次のとおりです。 Filesystem Size Used Avail Use% Mounted on /dev/sda1 20G 19G 0 100% / /dev/sda3 202G 38G 154G 20% /home tmpfs 1.5G 0 1.5G 0% /dev/shm そしてfdisk -l: Disk /dev/sda: 250.0 …

3
ルートを使用せずにスーパーバイザを実行するにはどうすればよいですか?
supervisordが非rootユーザーとして実行されない理由を理解するのに問題があるようです。ユーザーをjason(pid 1000)に設定して起動すると、ログファイルに次のようになります。 2010-05-24 08:53:32,143 CRIT Set uid to user 1000 2010-05-24 08:53:32,143 WARN Included extra file "/home/jason/src/tsched/celeryd.conf" during parsing 2010-05-24 08:53:32,189 INFO RPC interface 'supervisor' initialized 2010-05-24 08:53:32,189 WARN cElementTree not installed, using slower XML parser for XML-RPC 2010-05-24 08:53:32,189 CRIT Server 'unix_http_server' running without any HTTP authentication checking 2010-05-24 …

弊社のサイトを使用することにより、あなたは弊社のクッキーポリシーおよびプライバシーポリシーを読み、理解したものとみなされます。
Licensed under cc by-sa 3.0 with attribution required.