サーバー管理者

システムおよびネットワーク管理者向けのQ&A

1
Python / Django / WSGI / Apache-「ImportError:サイトという名前のモジュールはありません」
私のローカルubuntuマシンでdjangoアプリケーションを使用しようとしています。ただし、サイトが機能せず、次の/var/log/apache2/errors.logようなメッセージが表示されます。 ImportError: No module named site 私/var/log/apache2/error.log(今日の場合)は次のようになります。 $ cat error.log | uniq -c 1 [Wed Jun 29 09:37:37 2011] [notice] Apache/2.2.17 (Ubuntu) mod_wsgi/3.3 Python/2.7.1+ configured -- resuming normal operations 12966 ImportError: No module named site これは、マシンの電源を入れたときに起動し、12,966行すべてがno module named siteメッセージを発したという通知です 日時フィールドがないことに注意してください。これらのエラーは、Webサイトにアクセスしていない場合(つまり、Webリクエストを実行していない場合でも)繰り返されます。ブラウザーでWebサイトにアクセスすると、大量のダウンロードを待つようにハングアップします。 設定 Apacheモジュール 私は、pipでインストールされた多くのパッケージ(django 1.1を含む)でpython 2.5 virtualenvを使用しています。mod_wsgiをロードしました: $ ls -l /etc/apache2/mods-enabled/wsgi* …

4
適切なドキュメントルートが存在する場合にのみVirtualDocumentRootを使用する*
構成を再ロードせずにApache仮想ホストを動的に作成できる環境をセットアップしたいと思います。 これはmod_vhost_aliasで実行できます。デフォルトの仮想ホストを次のように設定します <VirtualHost *> UseCanonicalName Off VirtualDocumentRoot /var/www/sandboxes/domains/%0 ServerName catchall.host </VirtualHost> これは問題なく機能しますが、現在設定されていないホスト名に対してリクエストが行われた場合、404 Not Foundエラーが発生します。 私が本当にやりたいことは、ドキュメントルートが存在する場合にのみ、このVirtualHostを有効にすることです。それ以外の場合は、別のvhostに一致させようとします(つまり、VirtualDocumentRootの存在を、 ServerAlias) これを2つ目のvhostにしてみましたが、最初のvhostがすべての要求を処理するだけでしたが、これは機能しませんでした。VirtualDocumentRootが構成されているドメインに対する要求は、デフォルトのvhostにフォールスルーしました。 それで、どうすれば動的に構成されたvhostを作成できますが、まだ構成されていないものについては別のvhostにフォールバックできますか?

2
Amazon EC2でドメインのメールアドレスを設定するにはどうすればよいですか?
私はクラウドホスティングに慣れていません。以前はcPanelを介してメールアカウントをセットアップするだけでしたが、これは利用できないため、Amazon EC2アカウントでこれを行うにはどうすればよいですか?メールサーバーを実行する必要があると思いますか?Linuxインスタンスに「postfix」をインストールしました。それで?

6
間違ったシステムクロックからどのような結果/影響が生じますか?
システムクロックの設定が間違っていると、どのような問題が発生するのでしょうか。 主にサーバー、特にLinuxまたはUNIXのようなシステムに影響を与える潜在的な問題に関心があります。 そして、システム時間がどれだけオフになっているかに応じて、これらの結果はどのくらい深刻ですか?たとえば、5分、30分、1時間、1日です。

2
rpm仕様:ディストリビューションバージョンに基づく条件付き要求
RHEL / CentOS / SL 5および6の単一のrpm仕様を記述しようとしています。この仕様はpythonアプリ用であるため、ビルドプロセスに違いはありません。しかし、RHEL / CentOS5では、さらに1つの依存関係を追加する必要があります。 el5のみの依存関係をどのように定義しますか?私は以下を試しました: %if 0%{?redhat} == 5 || 0%{?centos} == 5 Requires: kmod-coretemp %endif 機能しません(CentOS5でビルドしても、kmod-coretemp依存関係は追加されません)。 私も以下を試しました: %if %{?dist} == "el5" 構文エラーを報告します。distマクロが設定されていて、 'el5'が含まれていると思います。しかし、rpmのif条件の構文が何であるかわかりませんか?rpmguideに詳細な回答はありません。
8 redhat  centos5  rpm 

3
Powershellを使用してExchange 2010で電子メールを自動転送/リダイレクトしているユーザーを見つける
私たちはLive @ eduを使用していますが、これは基本的にHosted Exchange Serverであり、いくつかの追加機能と回避するための制限があります。私は自分のアカウントからメールを転送またはリダイレクトしている全員を見つけようとしています。 使用されていない古いアカウントを削除しようとしていますが、ユーザーにメールをリダイレクトする手順があります。そのため、一部のユーザーが実際にメールをリダイレクトしているため、最後のログイン/ログオフ時間にそれらが使用されているかどうかが反映されないことが予想されます。実際、自動転送または自動リダイレクトのルールを使用しています。 Exchange 2010 Powershellコマンドレットを使用して、転送またはリダイレクトのルールを持つユーザーのリストを見つけるにはどうすればよいですか? /編集:ルールが転送/リダイレクトするか、他のアクションを実行するかに関係なく、サーバー側のルールがあるかどうかを確認するだけで十分です。

1
Amazon EC2へのJIRAのインストール
600 MBしかないEC2マイクロインスタンスにJIRAをインストールしようとしています。Tomcatを起動した瞬間、JIRAは既存のメモリをほぼすべて使い果たし、非常に遅く、完全に起動することすらありません。 EC2にJIRAをインストールした経験がある人はいますか?1GB以上のメモリが必要ですか?JIRAテクニカルサポートにメールを送信したところ、AmazonにJIRAをインストールした経験や知識がないため、あまり役に立たなかったとの回答がありました。


2
Windows Server 2008 R2インストールファイルへのスリップストリームSP1
以前のバージョンでは、スリップストリームWindowsサービスパックは単純なプロセスでした-特別なコマンドラインスイッチでEXEを実行するだけです。Windows Server 2008 R2 Service Pack 1でこのようなスイッチが見つからないようです。スリップストリームするにはどうすればよいですか?TechNetは「統合されたインストール」について言及しているため、それは可能ですが、実際にそれを行う方法の詳細はありません!

1
WindowsドメインでCA証明書の有効期限が切れると、暗号化メールはどうなりますか
ドメイン認証ネットワークでルート認証局の証明書が期限切れになったときに、暗号化/署名されたメールがどうなるか誰もが知っていますか?証明書はクライアントから引き続き検証できますか。クライアントは、メールが暗号化/署名されたときに証明書が有効であったことを認識しますか? 新しいインフラストラクチャへの移行が行われた場合、または新しいルートCAをインストールした場合、それぞれどうなりますか?期限切れのルート証明書も移行する必要はありますか?


3
GPOを介したローカル管理者ユーザー
私はWindows 2008R2 DC(セットアップのみ)を持っています。すでに約25のWindows 7プロフェッショナル/アルティメットクライアントがあり、これを新しいドメイン/ dcに参加させます。ユーザーは既にマシンを使用しており、そのマシンのローカル管理者でした。 すべてのローカルWindows 7ボックスで作成され、ローカル管理者権限を持つGPOを介してユーザーを展開するか、ドメイン上のすべてのPC(Windows XP、7)でローカル管理者権限を持つドメインユーザーを展開します。 誰かがこれを支援してくれるとありがたいです-私は自分でユーザーを作成しようとしましたが、作成されませんでしComputer Settingsた。GPOEditでグループを使用してユーザーを作成しました。 読んでくれてありがとう-あなたのガイダンスRihatumを楽しみにしています

5
BitTorrentのブロック
1つの小規模オフィスネットワークでBitTorrentおよび類似のピアツーピア(P2P)サービスをどのようにブロックするか、大幅に遅くすることができますか? Server Faultを検索したところ、これに関する最良の技術的アイデアの結集点として機能する質問を見つけることができませんでした。既存の質問はすべて特定の状況に関するものであり、支配的な回答は本質的に社交的/法的です。これらは有効なアプローチですが、純粋に技術的な議論は多くの人に役立つと思います。ネットワーク上のマシンにアクセスできないとします。 P2Pトラフィックでの暗号化の使用が増加しているため、ステートフルパケットインスペクションはあまり機能しないソリューションになりつつあるようです。私にとって理にかなっていると思われるアイデアの1つは、ヘビーユーザーを送信または受信しているものに関係なく、単にIPでスロットルすることです。しかし、現時点では、多くのルーターがその機能をサポートしていないようです。 P2P / BitTorrentトラフィックをどのように抑制できますか?

2
Puppetのincludeとrequireの違いは何ですか
次のコードがある場合、私は人形のクラスを持っています: class A { require B .... } 循環依存エラーが発生します。私が持っている場合: class A { include B .... } すべてうまくいきます
8 puppet 

3
このDNS構成について説明してください。
DNS構成についてはほとんど知りません。誰かが私にプレーンな英語で、次のDNS構成が達成することを説明していただけませんか?これは私のホスティングプロバイダーのデフォルト設定です。 NAME/TYPE/VALUE/PRIORITY A X.X.X.X 0 * A X.X.X.X 0 smtp A Y.Y.Y.Y 0 MX smtp 10 NS foo1.bar.com. 0 NS foo2.bar.com. 0 example.com. TXT v=spf1 a mx +all 0 いくつかの重要なポイント: ドメインの最後にDOTがあるのはなぜですか? MXレコードにいくつかの優先順位が設定されているのはなぜですか、なぜ10ですか? 最初の2つのレコードの違いは何ですか?

弊社のサイトを使用することにより、あなたは弊社のクッキーポリシーおよびプライバシーポリシーを読み、理解したものとみなされます。
Licensed under cc by-sa 3.0 with attribution required.