サーバー管理者

システムおよびネットワーク管理者向けのQ&A

4
rsyncでフォルダーを移動するときに空のソースディレクトリを削除する方法
rsyncmv以下のオプションを使用して、従来のものと非常によく似た移動フォルダに同軸化できます。 rsync -axvvES --remove-source-files source_directory /destination/ しかし、まだ実現できていないように見えるのは、元のディレクトリを削除することです。--remove-source-filesフラグは、ソースファイルではなく、ソースディレクトリを削除だけ、ということありません。--remove-source-directories旗もあるといいのですが、ありません。 どうすればこれに対処できますか? 私rm -frは移動後だけを発行できると思いますが、間違いの可能性を導入するのではなく、手順をすべて1つのプロセスに留めておきたいと思います。
8 bash  shell  rsync  zsh 

2
ライブUDPエコーサーバーのIPとポートが必要
エコーサーバーを使用してUDPプログラムをテストする必要があります。このアプリケーションをLANでテストしましたが、今ではインターネットでテストする必要があります。 私のアプリケーションで直接使用できる有名なECHOサーバーはありますか? 助けてください、ありがとう.... 編集 私はすでにデスクトップ上で実行し、Wifiを使用してモバイルに接続するJavaベースのエコーサーバープログラムを持っています。アプリをインターネットで確認したいので、一部のIPによって提供されるDayTimeサービスと同様に、一部のライブサーバーのIPポートが必要です。
8 testing  udp  echo 

3
Sysinternals ADInsightに代わるものはありますか?
ワークステーションからのActive Directory呼び出しをトレースするためにSysinternalsのADInsightを使用していましたが、アプリケーションが失敗しました。 以前はActive Directoryイベントがトレースおよびログに記録されていましたが、アプリケーションがキャプチャモードであるかどうかにかかわらず、ウィンドウは空白のままです。管理者として実行し、再起動して、新しいバージョンをダウンロードしました。これらのアクションのいずれも、プログラムを機能状態に戻していません。 このツールは頻繁に失敗することが知られているため、Sysinternalsフォーラムにはあまり期待が持てません。 同様の機能を持つツールはありますか? ご質問 アカウントで別のワークステーションから実行すると、ツールは失敗しますか?はい 他の誰かのアカウントを使用しているあなたの(そして/または)別のワークステーションから失敗しますか?はい ワークステーションのイベントログに何かありますか?番号


2
Hyper-Vでの仮想化ファイアウォール?
現在、コンテンツフィルター、キャプティブポータル、および一般的なファイアウォールとして機能するように、Hyper-V R2ベースのサーバーにpfSenseのインスタンスをインストールすることを検討しています。 ファイアウォール/ゲートウェイを仮想化することは通常悪い習慣ですが、時々あなたが持っているもので作業しなければならないことがあります!:) 2つの物理NICがあります。1つはインターネット(WAN)に面し、もう1つは内部LANに面しています。 すべてのインターネットアクセスがpfSense VMを通過することを確認するにはどうすればよいでしょうか。 pfSense VMをバイパスしてLAN NICにトラフィックが入る可能性を排除する構成はありますか? ばかげた質問なら申し訳ありませんが、私は毎日開発者です:D

3
Office365へのPostfixリレー
LinuxボックスにPostfixサーバーをセットアップして、すべてのメールをOffice365(MicrosoftがホストするExchange)メールサーバーに中継しようとしていますが、送信アドレスに関するエラーが発生し続けます。 BB338140DC1:to = relay = pod51010.outlook.com [157.56.234.118]:587、delay = 7.6、delays = 0.01 / 0 / 2.5 / 5.1、dsn = 5.7.1、status = bounced(ホストpod51010.outlook.com [ 157.56.234.118]言った:550 5.7.1クライアントには、この送信者として送信する権限がありません(DATAコマンドの終了に応じて)) Office 365では、MAIL FROMおよびFrom:ヘッダーの送信アドレスが、認証に使用されるアドレスと同じである必要があります。私はこれを機能させるために構成で考えられるすべてのものを試しました。俺のpostconf -n: append_dot_mydomain = no biff = no config_directory = /etc/postfix debug_peer_list = 127.0.0.1 inet_interfaces = loopback-only inet_protocols = all mailbox_size_limit = 0 mydestination …


1
次のUTF-8文字を表示するようにPuTTYを構成できますか?
このツイートにあるように、キャラクターをレンダリングできるようにしたいと思います。 ツイートのJSONデータを保存し、テスト用に1行のPythonスクリプトを作成しました。 python -c 'import json,urllib; print json.load(urllib.urlopen("http://c.sente.cc/BUCq/tweet.json"))["text"]' 次の画像は、2つの異なるputtyセッションでのこのコマンドの出力を示しています。1つはBitstream Vera Sans Monoフォントを使用し、もう1つはを使用していCourier Newます。 次は正しい出力の例です(私はPuTTYを使用していませんでした): 元のJSONは、TwitterのAPIを使用してこのリンクにあります。 PuTTYでこれらの文字を表示するにはどうすればよいですか?


1
HTMLメールを表示するようにcPanelでHordeを構成するにはどうすればよいですか?[閉まっている]
閉まっている。この質問はトピックから外れています。現在、回答を受け付けていません。 この質問を改善してみませんか? サーバー障害のトピックになるように質問を更新します。 5年前休業。 cPanelでは、Hordeはデフォルトでリッチテキスト/ HTMLメールを表示せず、プレーンテキストバージョンのみを表示します。HTMLメールを表示するオプションがあることは知っていますが、cPanelでそれを有効にする方法がわかりません。 私はセットする必要があることを言って、オンラインフォーラムの投稿をたくさん読ん$mime_drivers['html']['inline']=true;でmime_drivers.php。ただし、このファイルを変更すると、cPanelによって上書きされるのではないかと心配です。cPanelは、変更したファイルを上書きする傾向があります。 HTMLメールを表示するようにcPanelでHordeを構成するにはどうすればよいですか?
8 email 

6
PowerShell 2010 Remoting w / Exchange 2010:値をnullにすることはできません
リモートPowerShellセッションを介してExchange 2010コマンドレットを実行するのに問題があります。 ローカルPowerShellセッションを管理者として開始し、次のコマンドを発行します- PS C:\Windows\system32> $mailcred = Get-Credential PS C:\Windows\system32> $mailSession = New-PSSession -ComputerName MAILSRV -Credential $mailcred PS C:\Windows\system32> Enter-PSSession $mailSession [MAILSRV]: PS C:\Users\jdoe\Documents> Add-PSSnapin Microsoft.Exchange.Management.PowerShell.E2010 [MAILSRV]: PS C:\Users\jdoe\Documents> hostname MAILSRV [MAILSRV]: PS C:\Users\jdoe\Documents> Get-ExchangeServer Value cannot be null. Parameter name: serverSettings + CategoryInfo : + FullyQualifiedErrorId : System.ArgumentNullException,Microsoft.Exchange.Management.SystemConfigurationTasks.GetExchangeServer [MAILSRV]: …

1
特定のuid(root、apache、nobody)の発信接続をブロックする
CentOS 5および6 Linuxのiptablesで、root、apache、または誰も実行していないプロセスが発信接続を開始しないようにするにはどうすればよいですか? CentOS 5 Linuxでは、次の行を/ etc / sysconfig / iptablesに入れてみました。 -A OUTPUT -m owner --uid-owner root -j DROP -A OUTPUT -m owner --uid-owner apache -j DROP -A OUTPUT -m owner --uid-owner nobody -j DROP しかし、残念ながらエラーが発生します: # sudo service iptables restart iptables: Flushing firewall rules: [ OK ] iptables: Setting …

1
「サーバーがKerberosデータベースに見つかりません」エラーが原因でNFS(Kerberosを使用)マウントが失敗する
実行時: sudo mount -t nfs4 -o sec=krb5 sol.domain.com:/ /mnt クライアントでこのエラーが発生します: mount.nfs4: access denied by server while mounting sol.domain.com:/ そして私が読んだサーバーのsyslogで UNKNOWN_SERVER: authtime 0, nfs/mercury.domain.com@SOL.DOMAIN.COM for nfs/ip-#-#-#-#.ec2.internal@SOL.DOMAIN.COM, Server not found in Kerberos database UNKNOWN_SERVER: authtime 0, nfs/mercury.domain.com@SOL.DOMAIN.COM for krbtgt/EC2.INTERNAL@SOL.DOMAIN.COM, Server not found in Kerberos database UNKNOWN_SERVER: authtime 0, nfs/mercury.domain.com@SOL.DOMAIN.COM for krbtgt/INTERNAL@SOL.DOMAIN.COM, Server …


4
Cisco 3550をルーターとして使用できますか?
ごく最近、私はさまざまなネットワークの問題に対処する必要がある電気工学インターンシップを担当しているため、ネットワーキングで遊んだり、シスコのコマンドライン構成に慣れたりするためにCisco 3550を選びました(そうです、 CSNAがこのタスクにはるかに適していることに同意しますが、その仕事の要件の一部なので、私はそれについて学びたいと思っています。 私が思っていたのは、私の3550がルーターとして機能できるかどうかです。私はそのL3スイッチを知っていますが、それはルーターの代わりになることができるということですか? 編集:私の3550をルーターとして機能するように設定することは可能であるように思われるので、これを設定するのに役立つかもしれないいくつかのドキュメントを教えてもらえますか?ip routeコマンドを使用する必要があると思いますが、それが正しいアプローチかどうかは完全にはわかりません。

弊社のサイトを使用することにより、あなたは弊社のクッキーポリシーおよびプライバシーポリシーを読み、理解したものとみなされます。
Licensed under cc by-sa 3.0 with attribution required.