サーバー管理者

システムおよびネットワーク管理者向けのQ&A

2
ネストされたESXiラボにはトランクポートグループが必要ですか?
このガイドに従って、ネストされたESXi 5ラボを単一のボックスにセットアップします。各仮想ESXiボックスに4つのポートを作成します。1つはVMNetworkに、3つはトランクポートグループに作成します。これは、仮想ESXiボックスにVLANを作成できるようにするために、これを行う必要があることを示しています。 これはどのように正確に機能しますか?VMネットワークポートはトランクポートと異なりますか?仮想ESXiボックスには同じ違いはありません。 これがなぜ、どのように必要なのか頭を悩ませています。

3
OS X:ファイルの「@」属性はどういう意味ですか?
Snow Leopardマシンのターミナルで: la ~/src/rmcl/ | grep RMCL -rw-r--r--@ 1 claytonstanley staff 6766167 Nov 13 2009 RMCL 「@」属性とは何ですか? このファイルは、Rosettaで実行される古いOS Xプログラムの一部です。Rosettaで実行されている一部の古いプログラムで、ファイルを開くときに@属性が必要になるという問題があります。しかし、私はその属性が何であるかわからないので、私はそれを追加/削除する方法を知る方法がありません。 私はこれで徹底的なグーグル検索を試みました、しかし私は答えを見つけることができませんでした。これは簡単に見つかると思いました。たぶん、1つの@特殊文字が原因で、Googleクエリが適切に機能していません。 どんな情報でも。感謝しています。 ありがとう!
8 mac-osx  unix 

2
イカがキャッシングしない
Squidをキャッシュサーバーとして構成しようとしています。Webサーバー(apache)が192.168.122.11squidに192.168.122.21あり、クライアントがにあるLANがあります192.168.122.22。問題は、Squidのアクセスログを見ると、TCP_MISSメッセージだけが表示されていることです。Squidはまったくキャッシュしていないようです。キャッシュディレクトリにすべての適切な権限があることを確認しました。ここで他に何がうまくいかないことがありますか?これが私のイカの設定です: acl manager proto cache_object acl localhost src 127.0.0.1/32 ::1 acl to_localhost dst 127.0.0.1/8 0.0.0.0/32 ::1 acl SSL_ports port 443 acl Safe_ports port 80 acl Safe_ports port 21 acl Safe_ports port 443 acl Safe_ports port 70 acl Safe_ports port 210 acl Safe_ports port 1025-65535 acl Safe_ports port 280 acl Safe_ports …


2
IISは失敗した要求の完全なエラーメッセージを取得します
IISをセットアップし、Webサービスを提供しています。残念ながら、Webサービスが例外をスローした場合、タイトルが失敗した要求が表示された青いボックスだけが表示されます。 何がうまくいかなかったかを実際に確認するには、どのようなオプションがありますか?例外メッセージとスタックトレースを取得したいと思います。 「Failed Request Tracing」はすでに設定されていますが、ディレクトリは空のままです。可能であれば、ブラウザでスタックトレースを直接取得することをお勧めします。 これが重要な場合は、Win 7 64 ProボックスにIIS 7.5をインストールしています。WebサービスはWCF C#プロジェクトです。
8 iis-7.5  windows  wcf  iis 

2
1MBを超えるファイルのアップロード=接続のリセット
フロントエンドでnginxを「プロキシキャッシュ」として、バックエンドでapacheを使用しています。PHP設定を次のように設定しました。 error_log = /var/www/site1/php_error.log error_reporting = 22527 file_uploads = On log_errors = On max_execution_time = 0 max_file_uploads = 20 max_input_time = -1 memory_limit = 512M post_max_size = 0 upload_max_filesize = 1000M どうしたの?1MB未満のファイルのアップロードは成功しますが、それを超えるものは、Google Chromeで出力されます。 Error 101 (net::ERR_CONNECTION_RESET): The connection was reset. エラーログファイルを既に確認しましたが、ディレクトリに存在しません。私もチェックしました/var/log/httpd/error_logが、アップロードに関する問題はありませんでした。問題の原因となった可能性のある他に何も知らないので、私はあなたの救いの手を差し伸べました。ありがとう!
8 apache-2.2  php  nginx 

1
CentOSは私の公開鍵を無視しています
SSHを使用して自分のCentOSサーバーに接続しようとしています。パスワードでうまく接続できます。公開鍵で接続しようとしていますが、サーバーが公開鍵認証を試みていません。CentOS wikiのこのページのすべての指示に従い、次のことを確認しました。 CentOS 6.0以降を実行しています 私のsshd_configには次のものが含まれています。 PermitRootLogin no PubkeyAuthentication Yes RSAAuthentication yes AuthorizedKeysFile .ssh/authorized_keys クライアントのホームディレクトリの.ssh /フォルダーに秘密鍵を作成しました (によって生成されたssh-keygen)公開鍵の全文は、サーバーのホームディレクトリにある.ssh / authorized_keysファイルの1行を占めます。 クライアントとサーバーの両方で次の許可モードを設定しています。 chmod 700 .ssh chmod 600 .ssh/*

1
プレーンなAmazon ec2インスタンスとbeanstalkの違いは何ですか?
私は一人の開発者で、展開しているサイトは非常に小さく、通常は趣味のサイトです。Amazonサービスについていくつか質問があります。 Beanstalkを使用する理由はありますか、それとも単一のec2インスタンスをそのまま使用する必要がありますか? データベースにRDSを使用する必要がありますか?ec2インスタンスにデータベースをインストールするだけで安くできると誰かが言うのを聞きました。すべてをできるだけ安く保つようにしています。 カスタムドメインを自分のサイトにポイントする必要があります。つまり、エラスティックIPを扱う必要があるということです。それらはbeanstalkで機能しますか、それとも個々のec2インスタンスでのみ機能しますか? 前もって感謝します!

2
「rsyslog」を使用して、syslog ip範囲を特定のファイルに
私は、Debianサーバーにログを送信する多くのCisco / JunOSルーターとスイッチを使用していますrsyslogd。 rsyslogd送信元IPアドレスに基づいて、これらのルーターまたはスイッチのログを特定のファイルに送信するように構成するにはどうすればよいですか?これらのエントリで一般的なシステムログを汚染したくありません。 例えば: シカゴのすべてのルーター(ソースIPブロック:172.17.25.0/24)のみにログを記録し/var/log/net/chicago.logます。 Dallas内のすべてのルーター(ソースIPブロック172.17.27.0/24)はにのみログを記録し/var/log/net/dallas.logます。 APF-3-RCV_UNSUPP_MSGログに記録せずにすべてのメッセージを削除する という名前のファイルに172.17.4.4のログを送信します /var/log/net/firewall.log UDPポート514を使用してファイアウォールログを10.14.12.12に転送する 最後に、これらのログは最大30日間毎日ローテーションして圧縮する必要があります。 注:私は自分の質問に答えています

2
.localはいつ使用すべきですか?
そのため、私は自分の時間内にいくつかのWin Servをセットアップし、内部ネットワークを外部ネットワークから分離するルーターがある場合は常に.localを行いました。* nixボックスを初めてセットアップするようになったので、この概念はまだ適用されますか?私のFQDN(/etc/hostname)に、ネットワーク内のすべてのマシン(混合:Linuxサーバー、Winワークステーション)の.localまたは.comを表示しますか? この質問は、Active Directoryが常にDNSマシンを手動でセットアップしているすべての段階で私の手を握るという状況で発生します。

3
apache2-SSLSessionCacheは実行されていますが機能していません
私はdebian squeeze標準のApacheインストール(2.2)を実行し、SSLClientCertificatesを利用してユーザーを認証します。これはこれまでのところうまくいきます。 しかし、いくつかの並列リクエストのスローダウンに気づき、自分SSLSessionCacheが機能しているかどうかを確認しようとしました。 そのため、localhost / server-statusを確認すると、次のようになります。 SSL/TLS Session Cache Status: cache type: SHMCB, shared memory: 512000 bytes, current sessions: 0 subcaches: 32, indexes per subcache: 133 index usage: 0%, cache usage: 0% total sessions stored since starting: 0 total sessions expired since starting: 0 total (pre-expiry) sessions scrolled out of …

2
MMSはunameからホスト名を取得し、それに接続できません
3ノードのレプリカセットを監視する10genのMongoDB監視サービスを取得しようとしています。AWS VPCで実行されているレプリカセット。各ノードは異なる[仮想]マシンで実行されます。それらのIPが192.168.1.1(プライマリまたはセカンダリ)、192.168.1.2(プライマリまたはセカンダリ)、192.168.1.3(アービター)であると想定します。 ソースをざっと見たところ、MMSは実行されているマシンのホスト名を次のように取得しているように見えます。 platform.uname()[1] 私のVPC EC2インスタンスの場合、これは次のようなものを返します ip-192-168-1-1 MMSはこのホスト名への接続を試みますが、解決されません。IPアドレスを使用したいのですが(常に静的であるため)、ハードコードされたplatform.uname()[1]inの使用はそれをmmsAgent.py排除しているようです。 それで、これからエレガントな方法は何ですか?ハック/etc/hosts?私はこのためだけにDNSサーバーを設定していません。MMSの設定方法を誤解しているだけかもしれません。

2
ドメインコントローラーの代替としてGoogle Apps / Cloudサービスを使用する
これは、Active Directoryに代わるクラウドサービスに関する正規の質問です。 Windowsドメインコントローラー(ADインフラストラクチャ全体を置き換える)の代わりにGoogle Appsまたは別のクラウドサービスを使用することはできますか? 具体的には、ローカルのWindowsサーバーへの依存を取り除きたいと思います。現在、ファイルおよび印刷サービスでドメインコントローラーとして機能します。このサーバーを、ホストされているアプリケーションに基づいたものにシームレスに置き換えたいと思います。サーバーを専用サーバーまたは連結サーバーに移動するだけではありません。 プリンターなどの共有をつなぎ合わせる方法はまだわかりません。誰かがこれについて何らかの洞察を持っている場合、それは高く評価されます。最終的には、すべてのサーバーをクラウドに移動し、全体のケーススタディを作成することが目標です。

3
上部に高温の通気口があるサーバーをラックにマウントしますか?
HP DL360 G7をいくつか購入したところ、上部に通気口があることに気づきました。これらの通気孔からは、背面のどこよりも多くの熱気が出るようです。過去のすべてのサーバーは、常に後方から熱気をすべて排出していました。 トップベント付きのこれらのサーバーはどのようにマウントする必要がありますか?ラックに隙間を作らない方が空気の流れは良いといつも言われていますが、そのすぐ上のサーバーは大量の熱を受け取るようです。

3
Mailmanリストのサブスクリプションを特定のドメインに制限する方法は?
Mailmanメーリングリストを1つの特定のドメインからのサブスクリプションのみを許可するように制限する方法はありますか? 特定の電子メールアドレスまたはドメインのサブスクライブを禁止する方法は知っていますが、example.comなどではないすべてのドメインを禁止する方法はありますか?または、いくつかの特定のドメイン? ボットネット1のスパマーであると私が確信しているリストから、一部のリストへのサブスクリプションの試みに見舞われ始めており、それは迷惑なリスト所有者です。一部のリストは、「承認が必要」または「確認して承認」のsubscribe_policyで構成されています。これは、リストがローカルユーザーのみを対象としているため、外部の電子メールからのサブスクリプションを自動的に拒否することにより、リストの所有者の煩わしさを最小限に抑えることができるためです。とにかくリストの所有者による購読を許可されないアドレス。 世界中のユーザーを対象としたリストがあり、「ローカル」ユーザーの一部はどこにでもいるため、ローカルネットワークへのアクセスを単純に制限することはできません。 1つの電子メールアドレスが、数時間にわたってさまざまなIPからの数十の無関係なリストに登録します。その後、翌日、新しい電子メールアドレスと異なるIPを使用した次のラウンド。いくつかのケースでは、リストの所有者が彼らにリストにサインアップした理由についての質問を電子メールで送信し、応答がありませんでした。

弊社のサイトを使用することにより、あなたは弊社のクッキーポリシーおよびプライバシーポリシーを読み、理解したものとみなされます。
Licensed under cc by-sa 3.0 with attribution required.