サーバー管理者

システムおよびネットワーク管理者向けのQ&A

1
低速または不安定なネットワークリンクを介した信頼性の高いファイル転送
低品質のブロードバンドリンクを介して多数のファイルをサーバーに転送する必要があります。ファイルはサイズが大きく、ファイルごとの転送には約30分かかります。 私はscpを使用していますが、ハングすることがあります-転送はエラーで失敗せず、実行を続けますが、それ以上のデータは転送されません。 そこで、「フェイルセーフ」アップロードソリューションを探しています。これは、リンクが数分間失敗した場合や、信頼性が低い場合でも機能するソリューションです。 私の考えは: 大きなファイルを小さな部分に分割する タイムアウト付きでパーツをアップロードし、失敗した場合は再試行します 質問: このアイデアを実装するすぐに実行できるツールはありますか?(scpの特定の必要性はありません。ftpやその他の可能性があります) scpがハングしたことを検出する方法はありますか?(つまり、まだ実行中ですが、データは転送されません)
8 ssh  scp  upload  failsafe 

3
VMware esxi 5、スナップショットを作成できず、統合が失敗する、古いREDOログを削除または統合する方法
正常に機能しているように見えるVMがありますが、VMWare DR(または私)がスナップショットを作成しようとすると失敗し、VMの概要ページを表示すると、上部にディスクがあることを示す警告が表示されます統合する必要があります。 そのため、VMのスナップショットマネージャーに移動して、統合を選択します(スナップショットマネージャーでは、実際にリストされているスナップショットはありません)。このエラーで失敗した場合: この仮想マシンのスナップショットツリーの1つのブランチには、255以上のREDOログがあります。サポートされている最大数に達しているため、新しいスナップショットの作成は許可されません。新しいスナップショットを作成するには、古いスナップショットを削除するか、REDOログを統合してください。 データストア(十分な空き領域があり、2 TBであり、このvmが40 GB未満)を参照すると、vmフォルダーで、実際には0255まで番号が付けられた一連のファイルが表示されます。 myvm-000255-ctk.vmdk myvm-000255-delta.vmdk myvm-000255.vmdk どうすればこれをすべてクリーンアップできますか?SSHコマンドラインコマンドはありますか、それとも一部のファイルを安全に削除できますか?ありがとう!

2
Exchange 2010 SP2サーバーの名前を変更する手順
msex0「MicroSoft EXchange」の略であると感じていたExchangeサーバーに名前を付けたときに、残念ながらエラーが発生しました。問題のサーバーは、Windows Server 2008 R2を実行しており、最新のアップデートがすべて適用されています。現在は問題なく機能していますが、名前から「sex」を削除するために名前を変更したいと思います。おそらく、exchange0のような名前にします。 Exchangeでのホスト名変更の手順やガイドの包括的なリストが見つかりませんでした。問題がなければ、私のWindowsインスタンスはVMWareで仮想化されています。


1
エラー2006:MySQLサーバーが廃止されました
CentOSサーバーでuWSGIとnginxを使用してPython Pyramidアプリを実行しています。SQLAlchemyをORMとして、MySQLdbをAPIとして、MySQLをデータベースとして使用しています。サイトはまだ稼働していないため、トラフィックは私と会社の他の従業員だけです。データベースにデータを追加するためにデータを購入したため、最大(かつ最も頻繁に照会される)テーブルは最大150,000行です。 昨日、ウェブサイトの4つの新しいタブを連続して開いたところ、502のBad Gatewayエラーがいくつか返されました。uWSGIログを調べたところ、次のことがわかりました。 sqlalchemy.exc.OperationalError: (OperationalError) (2006, 'MySQL server has gone away') 'SELECT ge... 重要な注意: このエラーは、MySQLのwait_timeoutが原因ではありません。そこに行って、それをやった。 この問題は、同時リクエストが同時に処理されたために発生したのではないかと思いました。私は自分を貧乏人の負荷テスターに​​しました: for i in {1..10}; do (curl -o /dev/null http://domain.com &); done; 案の定、これらの10件のリクエスト内で、少なくとも1件は2006エラーをスローし、多くの場合はそれ以上になります。時々エラーはさらに奇妙なものになるでしょう、例えば: sqlalchemy.exc.NoSuchColumnError: "Could not locate column in row for column 'table.id'" 列が最も確実に存在し、他のすべての同一のリクエストで正常に機能したとき。または、これ: sqlalchemy.exc.ResourceClosedError: This result object does not return rows. It has …
8 mysql  python  uwsgi 

1
分離ネットワーク上の単一のNTPサーバー
隔離されたネットワーク上に2つのLinuxマシン(AとB)があります。それらは時間同期されている必要があります。マシンAは断続的に電力が供給され、信頼できるタイムソース(GPS)に接続されているため、時間を提供する必要があります。マシンBは、マシンAに電力が供給されている場合にのみ電力供給されますが、組み込みLinuxデバイスであり、その電力状態は頻繁に変化します。どちらのマシンも他のシステムにアクセスできません。それは閉じたネットワークです。 NTPは通常、複数のサーバーとの通信を想定しているため、これはNTPにとって非常に難しい注文であることを理解しています。これをマシンBで正常に機能させるのに問題があります。マシンAはGPSと正常に同期し、マシンBはマシンAに到達でき、時間クエリも実行できますが、マシンAは信頼されていません(おそらくそれ自体ですか?)。マシンAが安定して1時間稼働した後、これは突然変化し、マシンBが動作しました。ただし、マシンA(およびマシンB)がダウンすると、マシンBは再び適切な時間同期を見つけることができなくなります。 これがntpdateの情報です。マシンAのストラタムが1の場合でも、最後に同じ出力で操作が失敗することに注意してください。 10.10.10.1:サーバーが削除されました:階層が高すぎます サーバー10.10.10.1、ポート123 階層16、精度-19、飛躍11、信頼000 refid [10.10.10.1]、遅延0.02614、分散0.00000 送信4、フィルター4 参照時間:00000000.00000000 Thu、Feb 7 2036 6:28:16.000 元のタイムスタンプ:d3a9bdc4.27ebb350 2012年7月12日木曜日21:19:00.155 送信タイムスタンプ:bc17c803.b42dfffe Sat、Jan 1 2000 0:25:39.703 フィルター遅延:0.02625 0.02614 0.02618 0.02625 0.00000 0.00000 0.00000 0.00000 フィルターオフセット:39544160 39544160 39544160 39544160 0.000000 0.000000 0.000000 0.000000 遅延0.02614、分散0.00000 オフセット395441600.451568 1月1日00:25:39 ntpdate [677]:同期に適したサーバーが見つかりません 私の推測では、マシンAは時間を提供すること自体を信頼していません。51分の稼働時間(以前に起こった可能性がありますが、私にはわかりません)とそのクロックがGPSに同期された後、マシンAが時間を正しく提供し始め、マシンBがそれを取得しました。私はこれがもっと早く起こるために必要です。可能であれば、数秒以内に。 次の構成(および多くの待機)を使用すると、最終的には成功します。 マシンA ntp.conf: サーバー127.127.28.0はtrue minpoll 4 maxpoll …
8 linux  time  ntp 

5
nginxが一部の写真の接続を閉じる
に問題がありnginxます。クライアントがダウンロードを完了する前に接続を閉じます。それは次のようになります: $ wget -O /dev/null http://www.site.com/images/theme/front/clean.jpg --2012-07-11 21:37:03-- http://www.site.com/images/theme/front/clean.jpg Resolving www.site.com (www.site.com)... 123.234.123.234 Connecting to www.site.com (www.site.com)|123.234.123.234|:80... connected. HTTP request sent, awaiting response... 200 OK Length: 90707 (89K) [image/jpeg] Saving to: `/dev/null' 26% [===============> ] 24,291 --.-K/s in 8.7s 2012-07-11 21:37:12 (2.74 KB/s) - Connection closed at byte 24291. Retrying. …

1
Apache2の*:80と_default_:80の違いは何ですか?
次の2つの用語の違いを理解しようとしています。 *:80 _default_:80 Apache構成ファイル内。ここのドキュメントは私には不明確であり、ここで見つけることができた唯一のメーリングリストの会話は、この問題についても(わかりやすく、私には)明らかにしていません。 次のように宣言された名前ベースの仮想ホストがたくさんあります。 <VirtualHost *:80> ServerName example.com ... そして、それらのどれも一致しない場合、つまり、仮想ホスト名なしで、または宣言されていない仮想ホスト名を使用してリクエストが受信されたときに起動するエントリが欲しいのですが。*:80または使用する必要がありますか_default_:80?

2
MySQLスロー書き込み
次の表への挿入は、完了するまでに最大70秒かかります。 CREATE TABLE IF NOT EXISTS `productsCategories` ( `categoriesId` int(11) NOT NULL, `productsId` int(11) NOT NULL, PRIMARY KEY (`categoriesId`,`productsId`), KEY `categoriesId` (`categoriesId`) ) ENGINE=InnoDB DEFAULT CHARSET=utf8; テーブルには約100,000行あり、ディスク上で7MBを使用しています。 MySQLには、書き込みパフォーマンスを改善できるいくつかの設定がありますか? 私のmy.cnfファイルは次のとおりです: log-slow-queries="/var/log/mysql/slow-query.log" long_query_time=1 log-queries-not-using-indexes innodb_buffer_pool_size=4G innodb_log_buffer_size=4M innodb_flush_log_at_trx_commit=2 innodb_thread_concurrency=8 innodb_flush_method=O_DIRECT query_cache_size = 6G key_buffer_size = 284M query_cache_limit = 1024M thread_cache_size = 128 table_cache …
8 mysql  innodb 

1
max_binlog_size&ログビンサイズ
ディスク全体に問題がある -rw-rw---- 1 mysql mysql 1073741982 2012-07-03 18:14 mysql-bin.000034 -rw-rw---- 1 mysql mysql 1073741890 2012-07-04 14:39 mysql-bin.000035 -rw-rw---- 1 mysql mysql 1073741988 2012-07-05 09:16 mysql-bin.000036 -rw-rw---- 1 mysql mysql 1073741964 2012-07-06 00:04 mysql-bin.000037 -rw-rw---- 1 mysql mysql 1073741974 2012-07-06 21:45 mysql-bin.000038 -rw-rw---- 1 mysql mysql 1073741923 2012-07-07 19:05 mysql-bin.000039 -rw-rw---- …

5
haproxy-tcpモードで元の/リモートIPを渡す
perpraクラスターのロードバランシングとIPフェイルオーバーのためにkeepalivedでhaproxyをセットアップしました。それがうまく機能するので、別のサービス/デーモンに同じlb /フェイルオーバーを使用したいと思います。 私はこのようにhaproxyを設定しました: listen my_service 0.0.0.0:4567 mode tcp balance leastconn option tcpka contimeout 500000 clitimeout 500000 srvtimeout 500000 server host1 xxx.xxx.xxx.xx1:4567 check port 4567 inter 5000 rise 3 fall 3 server host2 xxx.xxx.xxx.xx2:4567 check port 4567 inter 5000 rise 3 fall 3 ロードバランシングは正常に機能しますが、サービスはクライアントの実際のIPではなくロードバランサーのIPを認識します。httpモードでは、リモートIPに沿ってhaproxyを渡すのは非常に簡単ですが、tcpモードではどうすればよいですか?これは、負荷分散する必要のあるサービスの性質上重要です。 ありがとう!ヴィート

2
NPMは依存関係をインストールしませんか?
npm install -d定義されたpackage.jsonファイルのあるプロジェクトディレクトリにNPMが依存関係をインストールするのに問題があります。 これが私のものpackage.jsonです:https://gist.github.com/3068312 プロジェクトルートのノードモジュールフォルダー(rm -rf node_modules)をワイプした後、プロジェクトルートで実行するnpm install -dと、次のようになります。 (ssh) /vagrant git:master ❯ npm install -d npm info it worked if it ends with ok npm info using npm@1.1.4 npm info using node@v0.6.12 npm info preinstall redeye@0.0.1 npm http GET https://registry.npmjs.org/sinon npm http GET https://registry.npmjs.org/underscore npm http GET https://registry.npmjs.org/mocha npm …
8 ubuntu  node.js 

1
php.iniの代わりにphp-fpm confでphp値を設定する
php.iniで通常設定されている値をphp-fpm confファイルに設定したいのですが。nginxを使用しています。 次の設定を作成しましたが、これが機能するかどうかはわかりません。 php_value[memory_limit] = 96M php_value[max_execution_time] = 120 php_value[max_input_time] = 300 php_value[php_post_max_size] = 25M php_value[upload_max_filesize] = 25M これで大丈夫かと思いますか? php.iniとphp-fpm confファイルの両方に値が設定されている場合はどうなりますか?php-fpmはiniをオーバーライドしますか? 最後に、この方法ですべての仮想ホストに異なる値を設定できることは問題ではありませんか?php.iniはグローバル設定のように見えますが、これはホストに依存しています。異なるホストは異なるメモリ制限などで実行できますか?

1
DNS:世界はどのようにして私のネームサーバーを見つけるのですか?
ドメインmydomain.com.auがあります。このドメイン用に2つのネームサーバーns1.mydomain.com.auとns2.mydomain.com.auを作成し、それらにNSレコード、Aレコード、MXレコード、その他ホスティングしたいと思うものをすべてロードします。 では、どうすればこれらを使用できますか?レジストラに行って、mydomain.com.auのネームサーバーがns1.mydomain.com.auとns2.mydomain.com.auであると言うと、ルックアップアドレスに接続するためのIPを検索するにはどうすればよいですか。私のネームサーバーのパブリックIPを知っている世界では...私のネームサーバー。 ここに明らかなものがありません。それが何であるか教えてください:-)

2
ドメインの機能レベルを上げるのはいつですか?
ごく最近、Server 2003 R2を実行している2つの古いドメインコントローラーを廃止するプロジェクトを完了しました。それらは現在、光沢のある新しい2008 R2ボックスに置き換えられています。ただし、ドメインの機能レベルは、2008 R2サーバーではまだ更新されていません。古いコントローラーへのロールバックが必要になったという長い目で見た場合のみです。次の週末までにドメインを更新することはすべて明確になると思います。 また、デスクトップクライアントが95%Windows XPであることにも注意してください。しかし、今年の終わりまでに200人程度のクライアントをWindows 7に更新するプロジェクトを開始しようとしています。 特に一部の管理ステーションがまだXPであることを考えると、Windows 7よりも多くのWindows XPをサポートしている間に、2003年の機能レベルでドメインを保持することには利点がありますか? 更新:以前にいくつかのレガシーソフトウェアをサポートするWindows 2000サーバー(ドメインコントローラではない)がまだあることを言及するのを忘れていました。私はそれらを置き換えるために取り組んでいますが、それまでの間、Windows 2000が2008 R2ドメインに参加できることを確認する必要があります。

弊社のサイトを使用することにより、あなたは弊社のクッキーポリシーおよびプライバシーポリシーを読み、理解したものとみなされます。
Licensed under cc by-sa 3.0 with attribution required.