サーバー管理者

システムおよびネットワーク管理者向けのQ&A

1
フォークされたプロセスのセットのメモリフットプリントをどのように測定しますか?
200MBのメモリを使用するプロセスがあり、fork()sを実行するとします。 python -c "import os; data='x'*200000000; os.fork(); raw_input()" 「top」のようなプログラムは、各プロセスが200MBを使用しており、SHRdメモリが非常に少ないため、プロセスが合計で400MBを使用しているように見えます。ただし、fork()はプロセスのメモリページにコピーオンライト(COW)を実装しているため、プロセスは合計で200MBしか使用していません。 なぜtopはメモリのどの部分がCOWであるかを表示しないのですか?そうする方法はありますか?または、代わりに使用できる別のコマンドはありますか? 注:OSXの 'top'には、私が期待することを行うRSHRD列があるようです。Linuxに関する質問です。

4
ソフトウェアインストールポリシーを使用してFlash Playerをデプロイしました。アップグレードするには?
DCとしてWindows Server 2008マシンを使用しています。今年の初めに、Adobe Flash PlayerプラグインMSIを展開するためのソフトウェアインストールGPOを作成しました。私はコンピューターにポリシーを割り当てました。約半分はWindows XP x86を実行し、残りの半分はWindows 7 x64を実行します。それはすべて時計仕掛けのように機能します。 ソフトウェアインストールポリシーを作成したとき、OrcaでMSIを編集して、Flash Playerプラグインの自動更新機能を無効にしました。これは、すべてのマシンでまったく同じバージョンのプラグインを実行したかったためです。 しばらくして、Flash Playerプラグインの新しいバージョンがリリースされました。プラグインの更新されたバージョンをプッシュする時が来ました。すでに新しいMSIを持っていますが、次に何をするか迷っています。 ソフトウェアインストールGPOに[アップグレード]タブが表示されますが、そこに表示されるすべての内容は、大規模なマスタープログラムへのアドオンに使用され、時間の経過とともにリリースされる更新には使用されません。 新しいMSIで新しいソフトウェアインストールポリシーを作成し、古いGPOを取り消して、新しいGPOを割り当てるのが最善であると読みました。時間が経つにつれ、アクティブなポリシーよりも取り消されたポリシーが増えていくように感じます。 また、古いMSIを新しいMSIに置き換えて、GPOに再展開するように指示するだけで成功した人もいることを読みました。これは私をトラブルに巻き込むだけのバックドアの方法のようです。 要するに、グループポリシーを介して新しいバージョンをロールアウトするための正しい、ベストプラクティス、または優先される方法は何ですか?

1
必須属性のデフォルト値はありません
テンプレートのように、その属性に適切なデフォルトがない場合にリソースで属性を使用するための推奨されるアプローチは何ですか。属性値は実行時に提供されることが期待されています。そうでない場合、シェフレシピの実行はエラーになります。 テンプレートに適用したときの属性値が空の文字列になっている方法。 /recipes/default.rb template "/var/tmp/my_script.sh" do source "my_script.erb" mode "0755" variables({ :url => node['environment']['url'] }) end /templates/default/my_script.erb #!/bin/bash echo "The url is: <%= @url %>" 結果の/var/tmp/my_script.shファイルは次のようになります。 #!/bin/bash echo "The url is: " しかし、私はそれがエラーになることを望みます。何かアドバイス?
8 chef  chef-solo 

1
Postfixキューのファイルにある電子メールの受信者アドレスを変更する
mailqにいくつかの電子メールがあり、それらは正当な理由で返送されています。電子メールアドレスが間違っています。受信者のアドレスをその場で変更できるかどうか疑問に思っていました。遅延メールが保存されているディレクトリを確認できますが、おそらくそこに変更を加えることができますが、これを行う適切な方法があるかどうか疑問に思っています。 何か考えは?
8 linux  email  postfix 

3
Webベースのディスクスペースビジュアライザー
ディスクスペースの移動先を追跡し、ディスクスペースを最小限に抑えたいLinux Webサーバーがいくつかあります。 通常、私はSSHにログインduし、ディスク領域が無駄になっている場所を見つけるために使用しますが、これは面倒で時間がかかります。KDirStatのような視覚化ツールが理想的ですが、最低でもXサーバーをインストールする必要があり、目的を達成できません。 Webベースのディスクスペースビジュアライザーはありますか?私は別の解決策を受け入れます。

3
カスタムopensshシェル
環境はUbuntu Server 12.04です ログファイルでtail -fを実行し、プログラムが終了するとセッションを閉じるシェルにsshでしかアクセスできないサーバー上にユーザーを作成します(Ctrl + Cキー)。 これを達成する方法はありますか?
8 linux  ubuntu  ssh  shell 

7
Ubuntu 12.04でrabbitmq-serverを起動できません
rabbitmq-serverubuntu-server 12.04 にインストールしようとしましたが、失敗しました。 次に、http://www.rabbitmq.com/install-debian.htmlのガイドに従って、aptソースリストを追加します しかし、再インストールしても、次と同じエラーが発生します。 $ sudo aptitude install rabbitmq-server ... Setting up rabbitmq-server (2.8.7-1) ... * Starting message broker rabbitmq-server * FAILED - check /var/log/rabbitmq/startup_\{log, _err\} ...fail! invoke-rc.d: initscript rabbitmq-server, action "start" failed. dpkg: error processing rabbitmq-server (--configure): subprocess installed post-installation script returned error exit status 1 No apport …

1
ドメインの信頼が機能するためには、どのファイアウォールポートを開く必要がありますか?
2つの異なるフォレストに2つのActive Directoryドメインがあります。各ドメインには2つのDC(すべてWindows Server 2008 R2)があります。ドメインは、ファイアウォールで接続された異なるネットワークにもあります。 2つのドメインとフォレストの間に双方向のフォレスト信頼を作成する必要があります。 これを許可するようにファイアウォールを構成するにはどうすればよいですか? 私はこの記事を見つけましたが、DC間で必要なトラフィックと、一方のドメインのドメインコンピュータともう一方のドメインのDCとの間で必要なトラフィック(ある場合)については明確に説明していません。 DC間のすべてのトラフィックを許可することは許可されていますが、1つのネットワーク内のコンピューターが他のネットワーク内のDCにアクセスすることを許可するのは少し難しいでしょう。

4
DNSレコードが「このドメインにはメールサーバーがない」と言う方法はありますか?
「このドメインにはメールサーバーがありません」というDNSレコードを設定する適切な方法は何ですか? これを行うには特別なMXレコードが必要だと思います。そうでない場合は、Aレコードが答えであると想定されます。 この質問をするのは、最前線でメールを停止した方がよいと思われるため、問題のドメイン宛のメールを拒否することはWebサーバーの責任ではないためです。

4
とにかく、ファイルにログを記録する代わりにmsiexecをstdoutにエコーさせる方法はありますか
継続的デリバリーパイプラインの一部として、特定のマシンにmsiをインストールしたいと思います。msiexecとpsexecはこれを完全に実行しますが、msiexecはファイルにのみログを記録できるようで、stdout / stderrにログを記録する必要があります。 現在、出力をCIソフトウェアに戻すには、ログの内容をエコーする2番目のステップを追加する必要がありますが、これは少し無意味なようです。 誰かが以前にこの問題に直面しました(そしてそれを克服しましたか?) ここで助けてくれてありがとう。 マーク
8 logging  stdout  stderr  msi 

3
サーバーのドキュメントが実際の設定と同期しなくなるのをどのように回避しますか?
私たちの環境に適したドキュメント(AsciiDoc形式)があり、最近、他の人がセットアップ全体を30分未満で最初から再作成できるようになりました。 ただし、最初のセットアップ後、システムに小さな変更が加えられたことが簡単に発生することに気付きました(たとえば、inetdが無効になり、IMAPサーバーがManageSieve接続の追加ポートでリッスンし、exim構成に新しいルーターが追加されます)。 (もしあれば)すぐにドキュメントに記載されることはありません。 これを実装する1つの方法は、配置するかもしれ-私の考えでは、その中にコンフィギュレーションファイルおよびコメントの外にドキュメントを生成する(?部分的に)することで、この問題を回避するためだった/etcと/usr/local/etcいくつかのソースコード管理システムに(と言う- gitの)、その後、Aを実行しますコミットごとにドキュメントを再生成するスクリプト。しかし、それがやりすぎであるか、正しく理解するのが難しすぎるかはわかりません(結局のところ、ドキュメントのソースファイルの完全なコピーではなく、diffだけが必要です)。 他の人々はサーバーのドキュメントが古くなるのをどのように避けますか?それらを自動的に同期を保つための良い方法はありますか、それともシステムを変更すると同時にドキュメントを更新する規律がありますか?

3
FreeNASを認証サーバー(SMBまたはLDAP)、ファイルサーバー、Ubuntuを「クライアント」(Kerberos auth-pam)として配置することは可能ですか?
FreeNASサーバーを認証サーバー(ubuntuクライアントに認証するためのユーザーFreeNASローカルユーザー)およびNASサーバーとして構成したいのですが、もちろんです。私はクライアントとしてUbuntuを使用しており、それらはDHCP / PXEを介してブートしているため、すべてを迅速に構成できます。 上記のプロセスのリストを投稿します。[OK]は機能していることを意味し、[TODO]はご存知のように... 構造プロセス: [OK]クライアントがIPオファーをリクエストしています... [OK]ファイアウォールはファイル名「pxelinuz.0」と、TFTP、NFS、SMBを提供するFreeNASのIPで応答します。 [OK]クライアントはvmlinuzとinitrd.lzをロードし、必要に応じてNFSからsquashfsのロードを開始します... [ TODO ]私のFreeNASはLDAPまたはActive Directory DCを(SMB経由で)提供するはずですが、FreeNASでそれが可能かどうかわかりません(私の質問の1つ)... [ TODO ]クライアントはFreeNASからNFSまたはSMB経由で/ homeをマウントする必要があります。 [ TODO ]クライアントはFreeNASに接続し、ユーザーがログインできるようにユーザーのリストを取得する必要があります。 私の目的は、さまざまなコンピューターを接続し、必要に応じてユーザーがパーソナルコンピューターにログインし、ハードドライブのOSに変更を加えることなく、常に「ホーム」ファイルにアクセスできるネットワークを作成することです。 PS:squashfsは簡単に編集できます。そのためのスクリプトはすでに作成しました。

1
gitですべてのコミットに自動的に署名する[終了]
閉まっている。この質問はトピックから外れています。現在、回答を受け付けていません。 この質問を改善してみませんか? サーバー障害のトピックになるように質問を更新します。 7年前休業。 git 1.7.9では、-Sオプションを使用してコミットに署名することができます。それをデフォルトに設定することは可能git config --globalですか? だからではなくgit commit -S -m 'Commit message'、それだけgit commit -m 'Commit message'です。
8 git  pgp 

2
シンプルなWindows + Linuxサーバーのプロビジョニング?シェフ・人形・アンシブルなど【閉店】
現在のところ、この質問は、Q&A形式には適していません。回答は事実、参考文献、専門知識によって裏付けられると期待していますが、この質問は、討論、議論、投票、または拡張ディスカッションを求める可能性があります。この質問を改善でき、再開できると思われる場合は、ヘルプセンターにアクセスしてください。 7年前休業。 私は主に開発者であり、非常勤です。プロジェクトのあちこちでサーバーを管理します。 今後プロジェクトで使用するWebサーバー、アプリサーバー、データベースサーバーのプロビジョニングを自動化したい WindowsとLinuxの両方のサーバー(VPS、クラウド、専用)を管理しています 調査したChef / Puppet / Ansibleについて簡単に説明しました。そして私は何かを見つけたいと思っています: 学びやすく理解しやすいです。複雑な技術を理解するために何週間も投資したくありません。 理想的には、構成を保持するためにサーバー(「マスターサーバー」)を必要としない WindowsおよびLinuxサーバーのプロビジョニングをサポート 開始するための適切なドキュメントが付属しています どのツールが最も適しているかについて誰かアドバイスはありますか? ありがとう
8 puppet  chef 

1
vconfigコマンドなしでvlanを追加する方法 [閉まっている]
現在のところ、この質問は、Q&A形式には適していません。回答は事実、参考文献、専門知識によって裏付けられると期待していますが、この質問は、討論、議論、投票、または拡張ディスカッションを求める可能性があります。この質問を改善でき、再開できると思われる場合は、ヘルプセンターにアクセスしてください。 7年前休業。 vconfigを使用せずにvlanインターフェイスを作成する方法はありますか?KVMコンソールとトランクポートのみがマシンに接続されているため、インターネットにアクセスできないため、aptを使用できません。/ etc / network / interfacesでvlanを定義しましたが、vlanインターフェースが作成されていないため機能しません。ありがとう。
8 linux  debian  vlan 

弊社のサイトを使用することにより、あなたは弊社のクッキーポリシーおよびプライバシーポリシーを読み、理解したものとみなされます。
Licensed under cc by-sa 3.0 with attribution required.