サーバー管理者

システムおよびネットワーク管理者向けのQ&A

2
データを送信しても、グラファイトですべてのデータポイントに「なし」と表示される
nginxとPostgresSQLを使用してPuppet(https://forge.puppetlabs.com/dwerder/graphite)からGraphiteをインストールしました。データを手動で送信すると、メトリックが作成されますが、そのデータポイントはすべて「なし」(別名null)です。これは、Graphiteに付属のexample-client.pyを実行した場合にも発生します。 echo "jakub.test 42 $(date +%s)" | nc 0.0.0.0 2003 # Carbon listens at 2003 # A minute or so later: $ whisper-fetch.py --pretty /opt/graphite/storage/whisper/jakub/test.wsp | head -n1 Sun May 4 12:19:00 2014 None $ whisper-fetch.py --pretty /opt/graphite/storage/whisper/jakub/test.wsp | tail -n1 Mon May 5 12:09:00 2014 None $ whisper-fetch.py --pretty …

2
ビュー間で共有されるBIND動的ゾーンへの更新が遅れる
ここですばやく簡単に説明します。ビュー間で共有される動的ゾーンを持つBIND9で、nsupdateを実行し、nsupdateを実行したのと同じビューに該当するクライアントからそのレコードをクエリすると、レコードの更新/作成/削除が正常に機能します。から。 nsupdateで使用したビューとは異なるビューからクエリを実行すると、NXDOMAINがスローされるか(新しいレコードを追加する場合)、変更/更新が発生した場合に、任意の時間まで古いレコード情報が表示されます(たとえば15分)パス、または私は強制的に行います$ rndc freeze && rndc thaw。 $ rndc sync問題を解決するために何もしないようです-ジャーナルのフラッシュは約15分でフラッシュするように文書化されているので、それが単なるジャーナルファイルであることを望んでいました。 それが明確でない場合は、開始するための擬似コードを次に示します。 BINDビュー view "cdn-redir" { match-clients { 10.1.1.0/24; 10.1.2.0/24; }; include "cdn-zone.db"; include "dynamic-zone.db"; }; view "default" { match-clients { any; }; include "dynamic-zone.db"; }; コマンドラインの例 user@ns:~$ nsupdate -k rndc.key > server localhost > zone example.com. > update add foohost.example.com. …

2
debug1:SSH2_MSG_KEX_DH_GEX_GROUPが必要です
私は2つのサーバーAとBを持っています。AとBはお互いと他のサーバーにsshできますが、サーバーCにはsshできません。すべてのサーバーがAとB(サーバーCを含む)にsshできます。 debug1: SSH2_MSG_KEX_DH_GEX_REQUEST sent debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP そして最終的にはタイムアウトします。実行するnetstat -aと、サーバーCとサーバーAまたはBで確立された接続が表示されます。サーバーCでログを記録すると、接続試行が表示されますが、完了しません。双方向でpingとtracerouteを実行できます。
8 ssh 


1
4Kセクターディスク上のZFS RAIDZ2のオーバーヘッドはどこに行きますか?
まず、正確に10億バイトの16個の空のファイルを作成しました。 for i in {1..16}; do dd if=/dev/zero of=/mnt/temp/block$i bs=1000000 count=1000 &> /dev/null; done 次に、ファイル上にますます大きなRAIDZ2ボリュームを作成し、ashift = 12に4Kセクタードライブをシミュレートするように強制しました。 zpool create tank raidz2 -o ashift=12 /mnt/temp/block1 /mnt/temp/block2... df -B1実際のサイズを確認するために使用して比較しました。 Filesystem 1B-blocks tank 12787777536 私の結果: +-------+-------------+-------------+------------+------------+ | disks | expected | actual | overhead | efficiency | +-------+-------------+-------------+------------+------------+ | 3 | 1000000000 | …

5
mongodのulimitsを設定するにはどうすればよいですか?
mongodCentOSでプロセス/ユーザーのulimitを設定するにはどうすればよいですか? 私は公式ドキュメントを読みましたが、 OS固有の手順は提供していません。 これを設定してulimit -u 64000、再起動後も維持する必要があります。 CentOS 5.5を実行していますが、間もなく6.5にアップグレードします。 パッケージマネージャーによってインストールされたスクリプトを変更したくない

4
yumリポジトリをミラーリングして、各パッケージの最新バージョンのみをダウンロードするにはどうすればよいですか?
http://yum.puppetlabs.com/にある次のYum / RPMリポジトリをミラー化したいと思います。 http://yum.puppetlabs.com/el/6/products/ http://yum.puppetlabs.com/el/6/dependencies/ http://yum.puppetlabs.com/el/5/products http://yum.puppetlabs.com/el/5/dependencies/ Puppetリポジトリには、これまでにリリースされたすべてのPuppet製品が含まれており、サイズは約8GBと非常に大きいです。最新バージョンのファイルのみをミラーリングする必要があります。 私は使用してリポジトリをミラーリングしようとしましたreposync --newest-only: reposync --config=puppetlabs.repo.el6 --repoid=puppetlabs-products --repoid=puppetlabs-deps --newest-only --download_path=el/6 --quiet --downloadcomps これで、必要な最新のパッケージがダウンロードされます。しかし、reposyncは自動的に通常のディレクトリ構造(作成されませんx86_64、noarch、SRPMS、など)と、ミラー化されませんrepodata.xml。その結果、yumクライアントは次のようなエラーを受け取ります。 [root@web1 ~]# yum --quiet install puppet http://mirrors.example.org/pub/puppet/el/6/puppetlabs-deps/x86_64/repodata/repomd.xml: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404 Not Found" Trying other mirror. Error: Cannot retrieve repository metadata (repomd.xml) for …
8 linux  redhat  yum  fedora  rpm 

1
非rootユーザーがchrootシステムコールを使用できないのはなぜですか?
私はウィキペディアhttp://en.wikipedia.org/wiki/Setuidで setuidに関する説明を読んでいました ウィキペディアの次の段落で言及されているように、chrootとsetuidの関係を理解できませんでした setuid実行可能ファイルの存在は、Unixの非rootユーザーがchrootシステムコールを使用できない理由を説明しています。詳細については、chrootの制限を参照してください。
8 chroot  setuid 

7
バージョン管理職長と人形
Foremanを初めてセットアップしたばかりで、すべての構成をバージョン管理下に置く方法がわかりません。Puppetマスターにインストールする各モジュールにGitを使用できることはわかっていますが、モジュールだけでなく、各ホストに関連付けられているクラスやホストに設定されている変数も網羅する、より包括的なソリューションを好むでしょう。提案があれば、関連するワークフローとともに大歓迎です。必要に応じて、GitLabをサイトの中央Gitサーバーとしてセットアップし、JenkinsなどのCIサーバーをすぐにセットアップする予定です。

3
openssl(ハートブリード)を更新した後、snakeoil証明書を更新する必要がありますか?
debian wheezyサーバーを最新バージョンのopensslパッケージに更新しました。 私はサーバーでSSLをサポートしていますが、snakeoil証明書でのみサポートしています。snakeoil certの更新についても実際にセキュリティ上の懸念があるのか​​、それともsnakeoil certなのでそれをそのままにしていいのかと思っていました。 この質問は、sslに関する知識が不足しているために発生する可能性があります...しかし、snakeoil certを変更する必要があるかどうかと、そうである場合は、理由を説明してください。

5
ローカルユーザーアカウントの作成日を確認するにはどうすればよいですか?
ローカルユーザーアカウントの作成日を取得したい(重要な場合はWin 7)。私は次のWMIオブジェクト(そしてもちろんGoogle)を見てきました。 Win32_UserAccount Win32_NetworkLoginProfile から返されたオブジェクトにNetworkLoginProfileは最終ログイン時刻がありますが、作成日はありません。Date Createdプロファイルフォルダーのプロパティを確認すると、フォルダーが作成された日付が示されるだけで、必ずしもアカウント自体は示されません。

4
サーバー2012R2にKB2919355をインストールした後のInaccessible_boot_device
KB2919355(Windows 8.1およびServer 2012用に最近リリースされたメガ800 + MBパッチ)をインストールしたばかりのサーバー2012r2マシンがあります。サーバーはDell Poweredge R715です。ディスクは、H200コントローラー上のRAID1で2x500GB SASです。 サーバーはアップデートまで完全に機能していました。デルの管理ツールがインストールされているので、障害のあるディスクアラートなどは発生していません。H200コントローラーのファームウェアをアップグレードする前日に、システムは問題なく再起動しました。 更新のために再起動すると、移動可能なマウスカーソルが表示された黒い画面になりましたが、他には何もありません。Ctrl-Shift-EscとCtrl-Alt-Delは何もしません。1時間以上そのままにしておきます。何も変わりません。 「BSODで自動的に再起動しない」オプションで起動しINACCESSIBLE_BOOT_DEVICE、エラー理由として取得します。不思議なことに、「いくつかのエラー情報を収集しているので、再起動できます。(0%完了)」と表示され、0%のままで、何も進行しません。 前回正常起​​動時の構成、同じBSODで再起動しようとしました。 コンピュータを修復するための再起動は機能します。コマンドプロンプトから、すべてのパーティションとすべてのファイルが変更されていないように見えます。chkdskはエラーを報告しません。 この後、サーバーは正常に1度起動できました。再起動した後、何度も起動を試みても元に戻らず、すべてがINACCESSIBLE_BOOT_DEVICEブルースクリーンで終了します。 問題は、LSI RAIDコントローラカードにあるようです。スーパーマイクロマシンと同様の問題を持つ人を報告TechNetのスレッドがあります- http://social.technet.microsoft.com/Forums/en-US/6bf5815f-55d9-4403-8f41-a16ebcb83735/patch-kb2919355-makes- supermicro-machines-crash?forum = winserver8setup デルでサポートケースを開いています。デルはこの問題をラボで再現しようとしています。おそらく他に誰もここでできることは何もないでしょう。 更新 デルのアドバイスに従って、システムを一掃し、GUIを使用してServer 2012R2 Datacenterの新規インストールを実行しました。Windowsの更新プログラムをインストールする以外は何もしませんでした。 KB2919355をインストールした後、サーバーは正しく再起動しました。再起動後、INACCESSIBLE_BOOT_DEVICEエラーでブルースクリーンになりました。 この問題が解決するまで、LSIベースのRAIDカードを搭載したサーバーにこのアップデートをインストールしないことを強くお勧めします。うまくいけば、デルはすぐに解決策を考え出すでしょう。 デルサポートからのアップデート これは私たちが現在大規模に調査している問題であり、Dellよりも広く普及しているため、Microsoftが対処する必要がある可能性が高いです。リソースが使い果たされるまで、作業を続けます。私たちが見つけたものについてあなたに投稿し続けます。 デルサポートからの別のアップデート デルはこの問題をラボで再現することができませんでした。私のシステムの2つに同じ問題があることを確認しました。再現は簡単です。ウィンドウをインストールし、KB2919355が表示されるまでアップデートをインストールします。アップデートのインストール後、2回目の再起動時にサーバーが停止します。 彼らは私に交換機を構築していて、そのうちの1つを交換するため、テスト用の壊れた機械があります。うまくいけば、彼らはそれを迅速に解決するのに役立ちます。

2
`ping`の出力での` pipe <number> `はどういう意味ですか?
疑わしいネットワークの問題を診断するテストを実行しているときに、次の出力を取得しましたping。 --- r01c01b11n02 ping statistics --- 30000 packets transmitted, 29995 received, 0% packet loss, time 6309ms rtt min/avg/max/mdev = 0.091/0.343/118.051/3.605 ms, pipe 9, ipg/ewma 0.210/0.130 ms PING r01c02b06n01 (10.1.1.61) 56(84) bytes of data. これpipe 9まで見たことのない部分。現在、私はこの2つのホストでのみ取得しており、実際の数はさまざまです(例: pipe 8またはpipe 2)。 出力で何をpipe &lt;number&gt;意味しpingますか?

2
IIS httpErrors ExecuteURLは、500; http://mysite.com/failed-pageなどの奇妙なクエリ文字列をターゲットURLに追加します
IISエラーページの奇妙な動作に気づきました。私はこの設定を持っています: &lt;httpErrors errorMode="Custom" existingResponse="Replace"&gt; &lt;remove statusCode="500" /&gt; &lt;error statusCode="500" responseMode="ExecuteURL" path="/error-page" /&gt; &lt;/httpErrors&gt; クエリ文字列が長すぎるためにASP.NETエラーが発生した場合、エラーページのURLを実行しようとすると、すぐに2番目のエラーが発生します。IISが次のようにエラーページのURLに元のURLを追加するという事実まで、問題を追跡しました。 Original: http://example.com/someurl?id=some_very_long_query_string_causing_security_exception Error: /error-page?500;http://example.com/someurl?id=some_very_long_query_string_causing_security_exception これは大きな問題です。クエリ文字列が長すぎるために元のURLが失敗した場合、それに追加されたものを含むエラーページも、クエリ文字列がさらに長いため失敗します。 これはIISの最も愚かなバグだと思います。そのためのサービスパックのパッチがあったかどうか誰かが知っていますか?今までに何も修正されていない場合の最悪のシナリオ、この動作を無効にする方法、またはIISがエラーページに一方的なものを追加するのを停止するトリックはありますか?カスタムエラーページのメカニズム全体を壊すからです。
8 iis  iis-7.5 

3
svchost.exe -k netsvcsが1GB以上のメモリを使用
私の運用サーバー "svchost.exe -k netsvcs"が1GBを超えるRAMメモリを着実に使用していることに気付きましたが、これは少し過剰だと思います。 これは、tasklist / svcがこのプロセスに対して私に与えるものです: Appinfo, CertPropSvc, gpsvc, IKEEXT, iphlpsvc, LanmanServer, ProfSvc, Schedule, SENS, SessionEnv, ShellHWDetection, Winmgmt, wuauserv このメモリリークの原因となっているプロセスと、それを修正する方法を考えていました。過去にこれと同じ行動をした人はいますか? サーバーはWindows Server 2008 R2(ビルド7601:Service Pack 1)を実行しており、主な機能は社内のアプリケーションプロセッサワーカーを実行することです。

弊社のサイトを使用することにより、あなたは弊社のクッキーポリシーおよびプライバシーポリシーを読み、理解したものとみなされます。
Licensed under cc by-sa 3.0 with attribution required.