サーバー管理者

システムおよびネットワーク管理者向けのQ&A

2
「停止中」状態でハングする仮想マシンを停止/強制終了する方法は?
「Stopping」状態で常にハングする仮想マシンがあります。 マシンのvmwp.exeプロセスを強制終了することを提案するいくつかの投稿を赤にしましたが、Windowsタスクマネージャーからも、管理コマンドプロンプトからも、prockill / PID xxxx / Fを使用してこのプロセスを強制終了できませんでした。プロセスID。私の唯一の結果は、マシンが「停止中-クリティカル」状態になることです。 さらに悪いことに、その時点から(仮想マシンが停止時にハングした状態)、同じホスト上の他の仮想マシンを管理(停止または起動)できません。その場合の唯一の「解決策」は、仮想マシン管理サービス(vmms.exe)を停止して、物理ホストを再起動することです。最初にvmms.exeサービスを停止しないと、物理ホストも再起動中にハングします。 また、イベントビューアにエラーは記録されません。 私はそれらの問題について不平を言っている他の投稿をいくつか見つけました。それらすべてについて、唯一の提案はvmwp.exeプロセスを強制終了することでしたが、これも明らかに機能しません。 誰かがこれで私たちを助けることができますか、pls? ありがとう

4
MySQL 5.1または5.5?
バージョン5.1と5.5の間に大きな違いはありますか? 問題のサーバーは、中規模のvBulletinフォーラムをホストするために使用されます。 5.1の主な利点は、apt-getを通じて利用できることです。
9 mysql 

7
LinuxネットワークがSambaを使用するのはなぜですか?
Linuxディストリビューションの「ファイルとプリンターの共有」機能は、主にSambaです。Sambaは、Microsoftのネットワークファイルシステムの解釈です。 OS間の互換性はもちろん重要ですが、なぜLinuxシステムがこのMicrosoftテクノロジーにデフォルト設定されているのですか? Microsoftのネットワークファイルシステムはとても良いですか?Sambaは明らかに非常にうまく機能し、私はそれを「分析」していません。 または、「ネットワークを介してファイルとプリンターを共有するLinuxネイティブの方法は何でしょうか?」という質問を言い換えると、

2
Active Directoryを新しいサーバーに移行しますか?
新しいサーバーを購入し、現在のサーバーをオフにしたいと考えています。Active DirectoryとDHCPおよびDNS(現在のサーバーの状態)を新しいものに復元するにはどうすればよいですか?Active Directory、DNS、DHCPがあります。私たちの古いサーバーはWindows Server 2003で、新しいサーバーはWindows Server 2008です

5
cURLまたはSSLの問題、解決方法は?
私はこのエラーを受け取り続けます: No cURL data returned for https://XXX.XXXX.XXX:XXXX [0] SSL certificate problem, verify that the CA cert is OK. Details: error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed よくわからない、またはこの問題の原因がわからない。そして、これを解決する方法は?助けてください!


4
Amazon ELBでキープアライブタイムアウトが尊重されない
Ubuntu(JDK 1.6)でTomcat 6.0.24を使用していて、HTTPSコネクターでコメットスタイルのリクエストを実行するアプリを使用しています(APRを使用せずに、Tomcatに対して直接)。 キープアライブを5分に設定したいので、ロングポーリング接続を更新する必要はありません。これが私の設定です: <Connector port="8443" protocol="HTTP/1.1" SSLEnabled="true" maxThreads="1000" keepAliveTimeout="330000" scheme="https" secure="true" clientAuth="false" sslProtocol="TLS" /> 残念ながら、サーバーは65秒後に接続を閉じているようです。サンプルセッションのpcapは次のようになります。 T=0 Client sends SYN to server, handshake etc. T=65 Server sends FIN to client T=307 Client sends FIN to server (クライアントでの5分のタイムアウトは、HTTP libがサーバー側でソケットのクローズを検出していないことが原因だと思いますが、いずれにしても、サーバーが接続を早く閉じるべきではありません) (編集:これは、標準のHTTPコネクターを使用する場合に期待どおりに機能します)


6
ユーザーがログオンしたコンピューター名を見つける方法
特定のユーザーが現在ログオンしているコンピューター名を知るためのツールやスクリプト、またはその他の方法はありますか?それともログオンしましたか? ユーザー "HRDrone"が、ホスト名が "HRStation01"のマシンで作業しているとします。 私のシステム管理デスクに座っていると、ユーザー名が「HRDrone」であることしか知りません。ユーザーに尋ねることなく「HRStation01」にログオンしていることを確認する方法はありますか?ADイベントビューア?何か? ありがとう!

1
ポート587を介してGmail(smtp.gmail.com)を送信/リレーするようにPostfixを構成する
Centos 5.4とPostfixを使用します。私はできる mail foo@gmail.com subject: blah test . Cc: メッセージはgmailに送信されますが、これは予想されるスパムフォルダーに存在します。 私の目標は、電子メールメッセージを生成し、それらを通常の受信トレイに表示することです。Postfix / Gmailを理解しているので、ポート587を使用して、認証済み/有効なユーザーを経由してメールを送信/リレーするようにPostfixを設定できます。これにより、メールはスパムとして表示されなくなります。 私は「ネット」からのさまざまなサイト/記事に基づいていくつかのパラメーターを試しましたが、うまくいきませんでした。一部の記事は、実際には他の記事と競合しているようです。私はこれに関するstacflowの投稿も調べましたが、まだ何かが足りません...また、IRC(Centos / Postfix)で何人かと話し、まだ質問があります。 それで、私は再びServerfaultに目を向けます! これを成し遂げた人がいる場合、main.cf、sasl-passwd、およびこれを機能させるために使用するその他のconfファイルを投稿していただけませんか。設定ファイルを確認できれば、うまくいけば、どこで失敗したかがわかり、問題を修正する方法がわかります。 これを読んでくれてありがとう、そしてあなたが提供したヘルプ/ポインタ! PS、私が見逃したかもしれない、これについて話すスタックフロー投稿がある場合は、遠慮なく私に指摘してください! -tom


1
CNAME DNSエントリはSEOに影響しますか?
私は、ホスティングおよび保守するクライアント用のWebサイトをセットアップしており、最も苦痛のないセットアップを決定しようとしています。私の考えは次のようにすることです: でクライアントドメインを設定する client.mydomain.com クライアントにDNSレコード*.client.comをCNAMEに更新させるclient.mydomain.com 実用的な観点から見ると、特にDNSコントロールパネルへのアクセスを維持する必要がないので、これは私にとって最良の方法です。さらに、Webサイトを別のホストに移動する必要があると判断した場合は、場所を更新するだけで、知らないうちにシームレスに実行できますclient.mydomain.com。 そうは言っても、私の懸念は私がのSEOに影響を与えることですclient.com。私がSEOにまったく影響を与える場合は、Aレコードのルートを使用してそれを適切と見なしますが、影響がない場合は、CNAMEルートの方が適しています。 考え? (余談ですが、私はこのアプリにGoogleマップを含めており、別のTLDからアプリを押すとAPIキーが私に怒鳴っています... client.mydomain.comとclient.com。単一のGoogle APIキーを要求する方法はありますかCNAMEで処理されたドメインを処理できますか?コードでこれを処理できますが、より簡単な解決策があるかどうかはわかりませんでした。)

5
サーバーのIPを指す別のドメイン名?
先日、専用サーバーから実行されるドメインの逆DNSエントリをチェックアウトしていました。 別の人/会社のドメインが私のサーバーを指していることに気付きましたか?私はこの会社が誰なのか、またはなぜ私のサーバーのIPでドメインを指しているのかわかりません。 これを停止したり、強制的に変更したりするにはどうすればよいですか?

4
アタッチされたebsボリュームをEC2にマウントする
EC2インスタンスを作成し、EBSボリュームを作成して、実行中のインスタンスに接続し、インスタンスに正常にSSHで接続しました。 ドライブは/ dev / sdfとして接続されています 次に、ドライブをマウントしてみました。 mkdir /testName mount -t ext3 /dev/sdf /testName しかし、それから私はエラーメッセージを受け取ります: mount: wrong fs type, bad option, bad superblock on /dev/sdf, missing codepage or helper program, or other error In some cases useful info is found in syslog - try dmesg | tail or so 何が悪いのですか? ありがとう。

3
新しいsubversionリポジトリにトランク、ブランチ、タグディレクトリを作成する方法とタイミング
トランク、ブランチ、タグディレクトリを作成するのに最適な時期はいつですか? 私は実行svnadmin create --fs-type fsfs /home/firefli/web/projects/subversionして、自分自身に空のリポジトリを持っています。たとえば、次trunkを使用してディレクトリを作成した場合svn mkdir file:///home/firefli/web/projects/subversion/trunkそれし問題なく動作しますが、リビジョン1に移動します。 リビジョン1への移行が問題になるわけではありません。以前とは異なる方法で実行したことがあると確信しているので、ベストプラクティスを探しています。 ありがとう
9 svn 

弊社のサイトを使用することにより、あなたは弊社のクッキーポリシーおよびプライバシーポリシーを読み、理解したものとみなされます。
Licensed under cc by-sa 3.0 with attribution required.