サーバー管理者

システムおよびネットワーク管理者向けのQ&A

3
ネイティブSATAドライブをESXi上のゲストにどのようにパススルーしますか?
Intel Core i7 930プロセッサを搭載したIntel DX58S0 MothboardboardでESXi 4.0を実行しています。VT-dも有効です。 システムに3つのドライブがあります。ドライブ0はESXiに使用されます。ドライブ1と2には古いマシンのデータが含まれており、構成の[ストレージアダプター]セクションに表示されます。 ゲストマシンがこれらのドライブ上のデータにアクセスできるようにします(可能な限り自然に)。マザーボードの内蔵SATAコントローラ(Intel / Marvell 88SE6121)のパススルーを有効にしました。このコントローラーはゲストOSに表示されますが、ゲストには通常の仮想ドライブ以外のドライブは表示されません。LinuxゲストとWindows7を試しました。また、SATAコントローラーのIDE / RAID / ACHIモードを試すようにホストマシンを構成しました。 これらのドライブの生データを取得するようにゲストの1人を構成する方法はありますか?

3
無料のネットワーキングラボはありますか?
ネットワークを勉強したい。しかし、私はサンプルネットワーク(ルーター、DNS、IP4、IP6 Windows Linux混合異種システム)にアクセスできません。勉強するオンラインネットワークを知っていますか(可能な限り無料)。仮想マシンを使用して、1台のPCでネットワークトポロジをシミュレーションすることは可能ですか。もしそうなら、私を案内してくれませんか?


3
コンソールから別のPowershellコンソールを起動しますか?
単一のPowerShellコンソールで作業しているときに、別のPowerShellコンソールウィンドウを起動したい場合は、 これを行う方法はありますか? プロンプトで「powershell」と入力すると、新しいウィンドウは起動せず、現在のコンソールウィンドウ内で新しいpowershellインスタンスを起動するだけです。 何かご意見は?

4
Linuxでのファイル監査:ディレクトリツリーの削除を監視する方法は?
サーバーでフォーラムスクリプトを実行していますが、どういうわけか少数の添付ファイルが失われ始めます。何が何を削除しているのかを知りたい。Linuxのauditd(auditctl)を設定して、ディレクトリツリー(添付ファイルはマルチレベルのディレクトリツリー内に保存されます)を監視して、ファイルの削除を監視する方法を教えてください。 これには他のツールを使用する必要がありますか?
9 linux  centos  audit  auditd 

2
Visioの無料のWebベースの代替ですか?[閉まっている]
現在のところ、この質問はQ&A形式には適していません。回答は事実、参考文献、専門知識によって裏付けられると期待していますが、この質問は、議論、議論、投票、または拡張ディスカッションを求める可能性があります。この質問を改善でき、再開できると思われる場合は、ヘルプセンターにアクセスしてください。 7年前休業。 Visioを使用してネットワーク構造を計画し、エクスポート機能を使用して、IP、ホスト名などで検索可能なHTMLページを作成しました。これは本当に素晴らしいツールであり、頻繁に使用しています。 ただし、Internet Explorerを使用していないユーザーが検索機能を使用できるようにしてください。ここでVisioに代わるものは何ですか?オブジェクトが検索可能なネットワーク図を描きたい。 ありがとう! 更新: Visio 2010 Betaをインストールして、オスカーの提案を試しました。Visio図をSVGとして保存できるようになりましたが、機能はまだありません。 実際、Visio 2010は、VMLやIEでも検索が正常に機能するWebページをエクスポートしません。

2
Perfmonの「%Processor Time」カウンターが100%を超えるにはどうすればよいですか?
カウンターはProcess(sqlservr)\% Processor Time、私のデータベースサーバーの1つで約300%停止しています。このカウンターは、SQL ServerがCPUでの実行に費やした合計時間の割合を反映します(ユーザーモード+特権モード)。『Sql Server 2008 Internals and Troubleshooting』という本には、80%を超えるものは問題であると記載されています。 そのカウンターが100%を超えることはどうして可能ですか?

6
Pythonを使用するはずの場所にボリュームがマウントされているかどうかを確認するにはどうすればよいですか?
ソースディレクトリをコピーする前に宛先ディレクトリを作成するPythonで記述されたバックアップスクリプトがあります。/external-backup外付けハードドライブをマウントする場所として使用するように構成しました。ハードドライブをオン(またはマウント)せずにスクリプトを実行したところ、内部ハードドライブにバックアップを作成しましたが、バックアップを作成するのに十分な空き領域がありませんでしたが、スクリプトは正常に機能していました。 私の質問は、書き込み前にボリュームが正しい場所にマウントされているかどうかを確認するにはどうすればよいですか?/external-backupマウントされていないことを検出できれば、書き込みを禁止できます。 ボーナスの質問は、ディレクトリが別のデバイスに存在するはずであるとOSが認識しているときに、なぜこれが許可されたのか、そしてそのデバイス(外付けハードドライブ)を後でマウントすると(内蔵ハードドライブ上の)データはどうなるのかということです。明らかに、同じパスの異なるデバイスに2つのコピーを置くことはできません。 前もって感謝します!
9 linux  python  mount 

1
Nginxでカスタム503エラーページを使用するにはどうすればよいですか?
Nginxでレート制限を実装しました(ちなみにこれは非常にうまく機能します)。カスタムの503エラーページを表示したいと考えています。 私は運が悪いのにウェブで例を追ってきました。 私は次のようなシンプルな構成を実行しています: listen x.x.x.x:80 server_name something.com root /usr/local/www/something.com; error_page 503 /503.html; location / { limit_req zone=default burst=5 nodelay; proxy_pass http://mybackend; } レート制限のあるユーザーには、何が起こっているのかを説明する特別なページが表示されるという考え方です。レート制限は機能していますが、組み込みの503ページがレンダリングされています。 何か案は?
9 nginx 

4
Windowsエクスプローラーのネットワークユーザー名と共有名のキャッシュを削除または空にするにはどうすればよいですか?
SambaとWindowsネットワークの問題をトラブルシューティングしているときに、Windowsエクスプローラーがリモート共有のログイン資格情報を記憶していることを確認しました。たとえば、\\servername\sharenameユーザー名とパスワードを入力して共有にアクセスし、Windowsエクスプローラを閉じた後、ネットワークドライブと同じ共有を追加すると、ユーザー名が同じかどうかに関係なく、次のメッセージが表示されます。 指定されたネットワークフォルダは現在、別のユーザー名とパスワードを使用してマップされています。 別のユーザー名とパスワードを使用して接続するには、まずこのネットワーク共有への既存のマッピングをすべて切断します。 を使用NET USEしても共有は表示されません。コンピューターを再起動した後、別の資格情報を使用して共有にアクセスしても問題はありません。ただし、他の資格情報をテストするためだけに再起動するのは面倒です。トラブルシューティング中。Windows Vistaを使用してこのキャッシュを削除するにはどうすればよいですか? 注:を使用してnbtstat -R[R]、ipconfig /renewexplorer.exeを強制終了するか、ネットワークカードを無効化/再有効化しても解決しませんでした。

3
MySQL:テーブルはクラッシュとしてマークされています
ディスクがいっぱいになると、サーバー上のMySQL DBの1つがバックアップしようとすると、次のエラーが表示されます。 [root@mybox ~]# mysqldump -p --result-file=/tmp/dbbackup.sql --database myDBname Enter password: mysqldump: Got error: 145: Table './myDBname/myTable1' is marked as crashed and should be repaired when using LOCK TABLES 少し調べてみると、2つのテーブルにこの問題があることがわかります。 破損したテーブルを修正するために何をする必要がありますか?
9 mysql 

7
どうすればupstartでnginxを起動できますか?
バックグラウンド: DISTRIB_ID=Ubuntu DISTRIB_RELEASE=10.04 DISTRIB_CODENAME=lucid DISTRIB_DESCRIPTION="Ubuntu 10.04 LTS" nginxをビルドしました。upstartを使用して開始します。 サイトからのnginx upstartスクリプト: description "nginx http daemon" start on runlevel 2 stop on runlevel 0 stop on runlevel 1 stop on runlevel 6 console owner exec /usr/sbin/nginx -c /etc/nginx/nginx.conf -g "daemon off;" respawn initctlを使用して実行しようとすると「不明なジョブ」が表示されます。これは、エラーがあることを意味します(エラーを説明するための「Error」の何が問題になっていますか?) 誰かが私を正しい方向に向けることができますか?私はドキュメントをそのまま読みましたが、SysV initの置き換えではまばらなようです...しかし、このジョブをリストに追加して実行する必要があるものは何でも、私の人生の残りの部分に取り掛かります。 .. 任意のヒント? 編集:initctl version init(upstart 0.6.5)

7
Mysql:14億のレコードにインデックスを作成する
14億レコードのテーブルがあります。テーブルの構造は次のとおりです。 CREATE TABLE text_page ( text VARCHAR(255), page_id INT UNSIGNED ) ENGINE=MYISAM DEFAULT CHARSET=ascii 要件は、列にインデックスを作成することtextです。 テーブルサイズは約34Gです。 次のステートメントでインデックスを作成しようとしました。 ALTER TABLE text_page ADD KEY ix_text (text) 10時間待った後、ようやくこのアプローチをやめました。 この問題に対して実行可能な解決策はありますか? UPDATE:テーブルが更新、挿入、または削除されることはほとんどありません。列にインデックスを作成する理由textは、この種のSQLクエリが頻繁に実行されるためです。 SELECT page_id FROM text_page WHERE text = ? 更新:テーブルをパーティション分割することで問題を解決しました。 テーブルは、列で40個に分割されていますtext。その後、テーブルにインデックスを作成すると、完了するまでに約1時間かかります。 テーブルのサイズが非常に大きくなると、MySQLインデックスの作成が非常に遅くなるようです。また、パーティション化により、テーブルがより小さなトランクに縮小されます。
9 mysql  indexing 

4
oom-killer killingプロセスの原因を診断する方法
私はCentOSとwww / mail / dbを実行している小さな仮想プライベートサーバーを使用していますが、最近Webサーバーとsshが応答しなくなったいくつかの問題が発生しました。 ログを見ると、おそらくメモリ不足とスワップが原因で、oom-killerがこれらのプロセスを強制終了したことがわかりました。 最新のインシデントを引き起こした可能性のあるものを診断する方法について、誰かが私にいくつかの指針を与えることはできますか?最初のプロセスが強制終了された可能性がありますか?他にどこを見ればいいですか?
9 linux  centos  rhel5 

3
SMTP 4xxコードですぐに失敗する1つの理由を挙げてください
私はこれについて本当に興味があります。質問(太字で強調表示): 誰かがONE GOOD REASONという名前を付けて、4xxコードで自動失敗/即時失敗するようにメールサーバーを永続的に設定することはできますか? 率直に言って、「彼らの」セットアップは最初から壊れているように思えます。 SMTPはインスタントメッセージングではありません。 IRC、Jabber、MSN、またはinsert-IM-technology-hereのような扱いをやめます。SMTPセットアップで「即時配信または失敗」の考え方を持つ人々が何を所有しているかはわかりませんが、彼らはそれをやめる必要があります。それはただ単純に物事を壊します。2、3年ごとに、私はこれに遭遇します。誰かが、どこかで、4xxコードが即時の失敗であると彼らの無限の知恵で決定しました、そして突然、そのOMGWTFBBQ THE INTARNETZが壊れました。メッセージが届かないのが突然「私の問題」になるのには驚きます 誤って構成された「それらの」SMTPサービス。 サーバーをこのように永続的にセットアップする正当な理由がある場合、最初の適切な答えがチェックされます。 正当な理由がない場合(そしてその理由がないと思われる場合)は、論理的に欠陥のある最初の良い音の答えがチェックされます。

弊社のサイトを使用することにより、あなたは弊社のクッキーポリシーおよびプライバシーポリシーを読み、理解したものとみなされます。
Licensed under cc by-sa 3.0 with attribution required.