サーバー管理者

システムおよびネットワーク管理者向けのQ&A

1
Nginxでサーバー固有のENV値をどのように設定しますか?
環境変数を使用してデータベース接続などを設定するプロジェクトを開始しています。(人々は不注意でそれらを上書きするので、彼らは設定ファイルを使いたくありませんでした)。 とにかく、私はnginxを使用していて、それはenvをサポートしていますが、十分にサポートしているようには見えません。サーバーブロックごとに env値を設定することはできません。つまり、これは機能しません。 server { listen 80; server_name domain; env FOO = "bar"; } これを行う必要があります: env FOO = "bar"; http { server { listen 80; server_name domain; } } つまり、vhost固有の値を設定することはできません。したがって、各サイトのvhost構成全体を作成し、値を正しく設定するために、現時点で必要なものだけをアクティブにする必要があります。 これを回避する方法はありますか?

3
ChefでMavenアーティファクトをダウンロードするにはどうすればよいですか?
私はシェフのレシピでこのようなことをしたいです: maven_artifact "/opt/foo/my.jar" do source "com.foo:my:0.1:jar" end しかし、私はこれを提供する料理本を見つけることができません。基本的にこれを行うものを書きましたが、スナップショットを処理しないため、maven-metadata.xmlを解析する必要があります。これに突入する前に、これは基本的なユースケースのように見えるので、明らかなものを見落とさないようにしたかったのです。
9 chef  maven 

1
同じクラス/モジュール/ whatevereveritisが複数回
人形は私を憎むに違いない。私は何時間もドキュメントを読んでいますが、それでも次のことを達成することができません: 変数が含まれているクラスまたはモジュール(またはその名前)(パラメーター化されたクラス?) このクラスは、単一のホストに複数回含まれます。 疑似コードでは、次のようになります。 # The class classorwhatever myclass ($value) { notify { "$value world" } } # In the node definition node whatever { myclass("Hello") myclass("Goodbye") } 馬鹿げていると思っても面白くない。私はそれが実行可能でなければならないことを知っています。しかし、どうやって?:(
9 puppet 

2
SSHトンネルを使用して、同じサーバー上の別のIP /ポートでリッスンしているWebサーバーにアクセスできますか?
まだ一般的に利用できる状態になっていないWebサーバーがありますが、リモートでテストしたいものがあります。SSHトンネルを利用してサーバーに接続し、そのトンネルを使用して同じサーバーで動作しているWebサービスにルーティングできますか?もしそうなら? ファイアウォールの例外を実装する方が簡単だと思いますが、現時点ではこれはオプションではありません。 これが紛らわしい場合は申し訳ありません。私はそれが独特のシナリオであることに同意します。 CentOS 5.x

2
Solaris 11へのアップグレード以降、私のARCサイズは、30GBのRAMがあるにもかかわらず、常に119MBをターゲットにしています。何?どうして?
Solaris 11がリリースされる前に、Solaris 11 ExpressでNAS / SANボックスを実行しました。ボックスは、D2700が取り付けられたHP X1600です。合計すると、12x 1TB 7200 SATAディスク、12x 300GB 10k SASディスクが別々のzpoolにあります。合計RAMは30GBです。提供されるサービスは、CIFS、NFS、およびiSCSIです。 すべて順調で、ZFSのメモリ使用量グラフは次のようになりました。 約23GBのかなり健全なArcサイズ-キャッシュに使用可能なメモリを利用します。 しかし、それが出たとき、私はSolaris 11にアップグレードしました。これで、グラフは次のようになります。 の部分的な出力arc_summary.plは次のとおりです。 System Memory: Physical RAM: 30701 MB Free Memory : 26719 MB LotsFree: 479 MB ZFS Tunables (/etc/system): ARC Size: Current Size: 915 MB (arcsize) Target Size (Adaptive): 119 MB (c) Min Size …
9 zfs  solaris-11 

2
RAIDアレイの機能が低下したときに電子メールでアラートを受け取るにはどうすればよいですか?VMware ESXi 5.0、MegaRAID SAS 9260-4i
最近、VMware ESXi 5.0を実行する「ホワイトボックス」サーバーを購入しました(vSphere 5 Essentials Kitを使用する予定です)。VMwareの互換性ガイドによると、サーバーのLSI Logic MegaRAID SAS 9260-4i RAIDコントローラーは互換性があります(「サポートタイプ」は「受信トレイ」としてリストされています)。 ホストにESXi 5.0をインストールするまで、vCenter Server Applianceもインストールしました。vSphere Clientを使用してvCenter Serverに接続しました。「ホストストレージステータス」が変化したときにトリガーされるアラームなど、事前定義されたアラームのリストが表示され、必要なように聞こえます。 RAIDアレイからドライブの1つを引き出してみました(その結果、RAIDコントローラーから予期されるビープ音が鳴りました)が、vCenterで何も起こっていないようです。「ホストストレージステータス」アラームがトリガーされていないようです。 私が本当に必要なことは、RAIDアレイが劣化している場合に電子メールを送信するようにvCenterを構成し、デッドドライブを認識して交換できることを確認することです。アラームがトリガーされない場合でも、それは有望ではありません。 ここで何か不足していますか?私はVMwareやサーバーハードウェアの専門家ではないので、これについて誰に質問すればよいのかさえわかりません。 前もって感謝します!

2
別のユーザーとして実行
RedHatシステムで、シェルを持たない別のユーザーでプログラムを起動しようとしています。/ etc / passwdでは、シェルは/ sbin / nologinです。 私が試してみました: su myuser -c /home/myuser/script.sh結果:このアカウントは現在使用できません。 chownとsetuidの場合:chown myuser:mygroup /home/myuser/script.sh chmod + s /home/myuser/script.sh /home/myuser/script.sh結果:script.shはまだサインインしているユーザーとして実行されます(ルート)。
9 redhat  users  daemon 

1
ユーザーの作成時にパペットにパスワードのみを設定させるにはどうすればよいですか?
Puppetがパスワードを管理する(つまり、パスワードが変更されたときにリセットする)のではなく、Puppetがユーザーを作成するときに初期パスワードを設定するようにしたい。 パスワードを設定notifyするExecリソースに対してを実行することを考えていましたが、これは、Puppetが管理するプロパティ(グループメンバーシップ、ホームディレクトリなど)が変更されたときにトリガーされます。それは欲しくない。 何か案は?

2
Windows 7でローミングプロファイルのどの部分がアップロードされますか?
以前のバージョンのWindowsでは、ユーザーがログオフしたときにのみ移動プロファイルがアップロードされます。ただし、Windows 7では、グループポリシー設定により、レジストリファイルをバックグラウンドでアップロードできます。設定はと呼ばれBackground upload of roaming user profile’s registry file while user is logged onます。 ただし、この設定を行っても、WMI のフィールドには最後のログオフのみが反映されます。これは、完全なアップロードと見なされるためには、サーバーにアップロードする必要があるのはレジストリファイルだけではないためだと思います。Win32_UserProfile LastUploadTime だから、私の質問は:ログオフ時にアップロードされるプロファイルの他の部分は何ですか?


2
Excelファイルがネットワーク共有でロックされている場合、誰がファイルをロックしたかはどのようにしてわかりますか?
私たちはExcel 2010を使用しており、ユーザーがネットワーク共有から作業している場合があります。ネットワーク上のユーザーがExcelでファイルを開くと、ファイルは編集用にロックされます-これは予想される動作です。別のユーザーがファイルを開こうとすると、Excelからメッセージが表示される [ファイル名]は編集のため「John Doe」によってロックされています 問題は、ユーザーが実際にファイルを開いているかどうかに関係なく、ユーザーは常にこの特定のユーザーの名前であるということです。Excelはどこでこの情報を取得し、どのように修正すればよいですか? 更新:私は、Excelの[オプション(全般)]で、正しいユーザー名が設定されていることを述べました。これは、このユーザー名の由来ではありません。

1
USBドライブをlibvirt KVM仮想マシンに直接マッピングしますか?
libvirtを使用して、既存のドライブ(USBドライブ)をKVM仮想マシンにマッピングする方法について検索しています。私はhttp://libvirt.org/formatstorage.html#StoragePoolTargetを調べてきました。しかし、既存のデバイスをVMに公開するために必要なオプション(またはそれが可能かどうか)がよくわかりません。 私が読んでいることから、target要素はpath、ファイルベースのイメージを格納するために、マシン上のフォルダーへの要素を期待しています。pathなどのデバイスになることはできます/dev/sdc1か?とtypeのraw?

1
OpenVPN:チェーン内の自己署名証明書
TunnelBlick証明書を使用して接続するために(正常に動作することがわかっているOS / X OpenVPN 2.2.1クライアント)を使用することに非常に失敗しています。ここに私が受け取る(無害化された)エラーメッセージがあります: 2012-01-11 11:18:26 TLS:**。**。**。**:1194からの初期パケット、sid = 17a4a801 5012e004 2012-01-11 11:18:26検証エラー:深さ= 1、エラー=証明書チェーン内の自己署名証明書: / C = US / ST = ** / L = ** / O = ** / CN = ** / emailAddress = ** 2012-01-11 11:18:26 TLS_ERROR:BIO読み取りtls_read_plaintextエラー:エラー:14090086:SSLルーチン:SSL3_GET_SERVER_CERTIFICATE:証明書の検証に失敗しました 2012-01-11 11:18:26 TLSエラー:TLSオブジェクト->受信プレーンテキスト読み取りエラー 2012-01-11 11:18:26 TLSエラー:TLSハンドシェイクが失敗しました 2012-01-11 11:18:26 TCP …

2
フォワーダーDNS要求をTCPモードに強制する
マルチホームサーバーのSLES10(現在は9.6をバインド)にDNSサーバーを設定しました。このサーバーは、すべての内部ネットワークからクエリを実行でき、すべての内部ネットワークに応答を提供します。2つの別個のDNS「マスター」ゾーンがあります。これらの各ゾーンは、いくつかの信頼できるWindows-DNSサーバーによってサービスされています。 現在、私のlinux-serverは、これらのゾーンの1つ(プライベート内部ゾーン)のセカンダリDNSサーバーであり、他のゾーン(パブリック内部ゾーン)のフォワーダーとして機能しています。 最近まで、このセットアップは問題なく機能していました。今私は-パブリック内部ゾーンをクエリすると(例えばhost、Linuxクライアントのコマンドによって)エラーメッセージが表示されます ;; 切り捨て、TCPモードで再試行 Wiresharkダンプが原因を明らかにしました:最初のクエリはUDPモードで送信され、回答はUDPに適合しません(信頼できるNSのリストが長いため)、TCPモードで再試行され、正しい回答が提供されます。 ここで質問: 最初にUDPを試行せずにTCPモードでフォワーダーをクエリするようにバインドを構成できますか? 更新:ASCIIアートを試してみる... +--------------+ +--------------+ +-----------------+ | W2K8R2 DNS | | SLES 10 DNS | | W2K8R2 DNS | | Zone private +---+ All internal +---+ Zone public | | internal 2x | | Zones | | internal 30+ x | +--------------+ +-+----------+-+ +-----------------+ …

3
ドライブサイズが異なるZFSプール
2つの2 TBドライブと2つの1TBドライブを使用してFreeNAS ZFSプールをセットアップすることを計画しています。どういうわけかデータの冗長性が欲しいのですが。私が読んで、この私の二つの選択肢がRAIDZ使用して1TBあたり2TBのドライブを失うか、(データの冗長性を確保するために必要なスペースを倍にする)このコマンドを使用するようにしている示唆しているようだポスト: zfs set copies=2 poolname これを処理し、DroboのBeyond RAIDまたはNetgearのXRAIDのようなものを実現するより良い方法はありますか?または、各2 TBドライブを1 TBパーティションに分割し、両方のパーティションをプールに入れることはできますか?
9 zfs  freenas 

弊社のサイトを使用することにより、あなたは弊社のクッキーポリシーおよびプライバシーポリシーを読み、理解したものとみなされます。
Licensed under cc by-sa 3.0 with attribution required.