サーバー管理者

システムおよびネットワーク管理者向けのQ&A

4
localhostは偽装できますか?
リモートマシンがループバックIPをスプーフィングすることによって別のマシンのローカルホストデータにアクセスすることは可能ですか? 自分のネットワーク外のどこかから接続する場合、ログイン資格情報を提供する必要があり、すべての機密操作にパスワードが必要になる設定が必要だとしましょう。ただし、自分のコンピューターから接続する場合は、とにかくそのデバイスのネットワークにアクセスするためにOSにログインする必要があるため、これらの資格情報は必要ありません。このようにして、セキュリティ対策としてループバックアドレスを利用できますか?または、攻撃者がローカルで接続しているように見せかけることは可能ですか?

3
MyISAMと混合すると、mysqldump中にInnoDBテーブルがロックされますか?
私のmysqlサーバーのバックアップソリューションを探しています。ダウンタイムをできるだけ少なくする必要があります。私は以下を持っています: MySQLサーバー それらは複製されません 各サーバーはそれ自体を表します この数は増える可能性があるため、マスター/スレーブレプリケーションを設定することはお勧めできません。 私が見る最も簡単なバックアップ方法は、mysqldumpを「automysqlbackup」などのソフトウェアで使用することです。私の最も重要なデータはInnoDBを使用しています。私のInnoDBテーブルはかなり重いです。 問題は、サーバーのすべてのデータベースにmysqldumpを実行すると、Innodbテーブルがロックされるのでしょうか。

3
yumはlibreofficeの代わりに廃止されたopenofficeをインストールします
残念ながら、私が使用しているソフトウェア(Alfresco)では、libreofficeではなく、openofficeのインストールが必要です。libreofficeを使用するように設定すると、起動時にエラーが発生します。openofficeパッケージをインストールしようとすると: yum install openoffice* すべてのパッケージで次のようなエラーが表示されます。 Package openoffice.org-langpack-bg_BG is obsoleted by libreoffice-langpack-bg, trying to install 1:libreoffice-langpack-bg-3.4.5.2-16.el6.x86_64 instead 次にlibreofficeをダウンロードしようとします。私はman yum時代遅れのパッケージのインストールに関して何も見ていません。古いバージョンではなく、yumを介して古いパッケージをインストールする方法はありますか?
9 yum  openoffice 

3
SASL auxprop / sasldbがpostfix / Ubuntu 12.04で動作しない
私はPostfix 2.5.1を実行しているUbuntu 8.04LTSシステムを持っています。そのシステムでは、SMTP AUTHは問題なく実行されます。の内容は次の /etc/postfix/sasl/smtpd.confとおりです。 pwcheck_method: auxprop auxprop_plugin: sasldb mech_list: PLAIN SASL関連のプロパティは次のとおりです。 smtpd_sasl_type = cyrus smtpd_sasl_auth_enable = yes smtpd_sasl_path = smtpd smtpd_sasl_security_options = noanonymous broken_sasl_auth_clients = yes smtpd_sasl_local_domain = $myhostname 私がするとき私はsudo sasldblistusers2得ます: authusername@mail.mydomain.com: userPassword 私が言ったように、それはすべて8.04LTSシステムでうまく働きます。 しかし、私はこれをPostfix 2.9.3を実行しているUbuntu 12.04LTSシステムに移行しようとしており、それを機能させることができません。私はすべて同じことをしていますが、postfixは毎回認証エラーを出します。 /etc/sasldb2ファイルではありません。古いシステムからファイルを引き継いでみましたが、うまくいきません。そして、私は以下を使用して新しいファイルを作成しました: saslpasswd2 -c -u mail.mydomain.com authusername それはかかわらず、それは、ない仕事をしWILL私は、ファイルと何も間違っているがあります知っている方法です古いシステムにそれをコピーした場合、古いシステム上で動作します。 同様に、私はpostfixがsmtpd.confファイルを見ていることを知っています。mech_listファイルの行にさらにメカニズムを追加すると、smtpdデーモンに接続したときに、それらの余分なメカニズムがアドバタイズされていることがわかります。そして、私がそれらを取り除くと、彼らは再び消えます。だから、/etc/postfix/sasl/smtpd.conf明確に慣れてきています。 私は実際のメールクライアントを使用して、これを使ってトークンを生成した後、手動でサーバーと通信してテストしています。 perl -MMIME::Base64 -e …

2
サーバーのすべてのメモリを利用するApache "httpd"プロセス
CentOSに基づいてAmazon AMIを実行している1.7 GBのメモリを備えた私の小さなec2インスタンスは、Apacheがメモリを必要以上に利用しているという問題があります。スクリーンショットを見ると、httpdサービスを再起動するまでメモリ使用量は90-100%になり、サービスが最初から再開され、90%以上に戻ります。 問題を特定する方法について支援をいただければ幸いです。利用可能なすべてのメモリを利用するために、これはおそらく「通常の」Apache動作ですか?または私が追い詰めなければならない可能性のある漏れがありますか?現時点で私は何が起こっているのかについて少し困惑しています。 私たちはApache MPMプリフォークを使用しており、SQLやそれに類するものは使用していません。ただapacheです。ウェブサイトはこちら。

4
GNOMEのないサーバーにssconvert(gnumericの一部)をインストールします
サーバーでgnumericのファイル変換ツールssconvertを使用する必要があります。 問題は、gnumericはgnomeアプリケーションであり、デスクトップがインストールされていないとインストールできないことです。 また、ssconvertの個別のパッケージはなく、ソースコードからコンパイルできません... この特定の変換ツールが必要なのは、他のExcel変換ツールではできなかったExcel XML形式からCSVへの変換が可能なためです。 私はubuntu 12.04サーバーで作業しています。任意のアイデアをいただければ幸いです。

2
pecl install mongo-間違ったモジュールAPIでコンパイルし続ける
ここでUbuntu 12.04、nginxおよびphp5-fpmを操作する 私はmongoをphp 5.3でうまく動作させてから、ondrej / php5 ppaを追加し、php5.4に更新しました。GDとCURLの拡張は維持されましたが、mongoは維持されませんでした。この行をphp.iniファイルに再度追加しましたが、何もしませんでした。次に、起動エラーを有効にしてこれを取得しました: PHP Startup: Unable to load dynamic library '/usr/lib/php5/20100525/mongo.so' - /usr/lib/php5/20100525/mongo.so: cannot open shared object file: No such file or directory だから、ワイルドな推測、私はfind -name 'mongo.so'ファイルを実行して20090626 /から20100525 /に移動しました...このエラーが発生しました: PHP Startup: mongo: Unable to initialize module Module compiled with module API=20090626 PHP compiled with module API=20100525 These …
9 php5  mongodb  pecl  php-fpm 

2
OpenVPN DNSが解決に失敗する
VPNをデフォルトゲートウェイとしてリダイレクトし、内部DNSサーバーをプッシュするオプションが構成されているOpenVPNサーバーに接続しています。 push "dhcp-option DNS 192.168.1.2" push "redirect-gateway def1" 私がするとき: ipconfig /all リストに自分の192.168.1.2 DNSサーバーが表示されます。私もping 192.168.1.1成功することができます。 私の問題はping somesite.internal.dom、内部DNSサーバーから結果が得られないことです。OpenDNS(VPN以外のDNSトラフィックを処理しています)から、サイトが存在しないという結果を得ています。 ping somesite.internal.domネットワークに直接接続されている(つまり、VPNに接続されていない)マシンの場合、適切に解決されます。 OpenVPN接続でVPN DNSサーバーを最初に試すにはどうすればよいですか?または、ローカルDNSトラフィックをすべて無視するには?

4
公開SSHキーを使用して一時パスワードを暗号化する
私は仮想オフィスを管理しており、スタッフは認証にSSHキーとパスワードの両方を使用しています。スタッフの1人がパスワードを忘れた場合、RSAの公開sshキーを使用して一時的なパスワードを暗号化し、電子メールで送信できるようにする方法はありますか? これに関連する他の質問を見たことがありますが、「回答」では一般に公開/秘密SSHキーを使用して一般的な暗号化/復号化を実行することは推奨されておらず、可能かどうかは実際には述べていません。それが本当に可能かどうか、およびパスワードを暗号化してから復号化する手順は何ですか?

2
CentOSで既存および将来のすべてのカーネルのデフォルトのカーネルパラメータを設定するにはどうすればよいですか?
CentOS 6でカーネルを起動するときにデフォルトで使用されるrhgbとquietカーネルパラメータを削除したいのですが、これを現在インストールされているすべてのカーネルだけでなく、将来インストールされるカーネルにも適用したいと考えています。スクリプトからこれを行う必要があるので、手動でファイルを編集することはできません。ファイルの変更はできるだけきれいに行う必要があります。 Debian / Ubuntuでは、に切り替えGRUB_CMDLINE_LINUX_DEFAULTて/etc/default/grub実行しupdate-grubます。私はこのような設定で見つけることができない/etc/sysconfig/grubか、/etc/sysconfig/kernelしかしを、またそこにあるupdate-grubスクリプトが。

3
プロセッサコアが常に* 100%読み込まれるのは危険ですか?
私のHFTソフトウェアでは、株価指数の計算に1つのコアを使用する予定です。それはwhile(true)遅延なしで単純にループし、コンポーネントを可能な限り頻繁に(合計して1秒間に数百万回)計算します。私はそれを毎日1日8時間実行する予定です。 私は自分のコンピューターを毎日フルタイムで毎日レギュラーにロードすることはありませんでした。危ないですか?プロセッサにはある種の「リソース」(もちろん非常に大きい)があり、その後は動作を停止できますか?


1
Postfixを含む特定のメールを送信したユーザーを特定するにはどうすればよいですか?
SMTPリレーへの認証を必要とするPostfixサーバーがあります。MySQLデータベースでは仮想メールボックスを使用します。 システムを介してメッセージがリレーされたため、メッセージの送信に使用されたユーザーアカウントを特定する必要があります。 メッセージヘッダーには以下が含まれます。 Received: from User (c-76-109-241-139.hsd1.fl.comcast.net [xx.109.xxx.139]) by ourserver.com (Postfix) with ESMTPA id 7BA184B4AD4; Tue, 3 Jul 2012 05:42:59 -0400 (EDT) 「ユーザー」というユーザーがいないため、IPアドレスはメールの送信元ではありません。メッセージの送信時に送信者が認証したユーザーアカウントを確認します。 これを追跡する方法はありますか?

3
別のNFSマウント内にマウントされたNFSマウントがランダムに消える
入れ子になったNFSマウントが時々ランダムに消えてしまうというかなり奇妙な問題があります。 fstabエントリは、次のようになります。 nfs:/home /home nfs rw,hard,intr,rsize=32768,noatime,nocto,proto=tcp 0 0 nfs:/bigdir /home/bigdir nfs rw,hard,intr,rsize=32768,noatime,nocto,proto=tcp,bg 0 0 問題は、共有がまだマウントされているとmtabが判断しても、「/ home / bigdir」フォルダが空になることがあるということです。nfsstatなど al。共有はまだマウントされていると思いますか。 機能するのは、アンマウントしてから、bigdir共有を(再)マウントすることだけです。 サーバー側はネットアップです。クライアント側はRHEL5.5、2.6.18-194カーネルです(はい、5.8がリリースされていることはわかっていますが、私が見る限り、この特定の問題に関するエラッタはありません)。 自動マウントや別のパスにマウントしてから--mount bindを使用するなど、さまざまなハックを使用できますが、根本的な問題を修正したいと思います。

6
複数のスイッチ上の単一のLACPチャネルは冗長性を高めますか?
LACPを使用して複数のスイッチのポートに複数のインターフェイスを結合すると冗長性が向上するという意見、調査結果、または証拠に興味があります。以前に結合されたインターフェースは、常に単一のスイッチであり、別のポートへの冗長チャネルがあります。 ベンダーの詳細に触れずに、これは単一のLACPであるため、イベントまたは変更が広範囲にわたるサービス停止につながる可能性があると私は考えています。多様なスイッチでこの単一チャネルをテストするための予備の機器または時間がないと、私よりもネットワークの知識が豊富な人なら誰でも、結合されたインターフェイスを作成したサーバーへのネットワーク接続を停止させるネットワーク側のイベントがあるかどうかを教えてください別のスイッチの2つのポートに? サーバーから複数のスイッチ(使用できることをお勧めします)全体でボンディングされたイーサネットチャネルを使用すると、スループットが向上し(疑いなく)、冗長性が向上します(不確実)。スイッチの障害、ポートの移行、パッチの適用、回復などのネットワークイベントにより、両方のサーバーネットワークインターフェイスのチャネルが使用できなくなる可能性がありますか? 前もって感謝します。

弊社のサイトを使用することにより、あなたは弊社のクッキーポリシーおよびプライバシーポリシーを読み、理解したものとみなされます。
Licensed under cc by-sa 3.0 with attribution required.