サーバー管理者

システムおよびネットワーク管理者向けのQ&A

1
ドメインネームシステム(DNS)サーバーコマンドレットの小さな問題
私が抱えている問題でキャッシュまたは何かをクリアする必要があるかどうか疑問に思っています。 DNSゾーンからAレコードを削除し、それらを同じホスト名を持つCNameレコードに置き換えようとしています。 Remove-DnsServerResourceRecord -Zonename $line -InputObject $record -Force Add-DnsServerResourceRecordCName -Zonename $line -Name $hostname -TimeToLive $ttl -HostNameAlias $target これは私を投げます: Add-DnsServerResourceRecordCName:サーバーNS01のゾーンzone.tldにリソースレコード@を作成できませんでした。C:\ admin \ updatettl.ps1:56 char:4 + Add-DnsServerResourceRecordCName -Zonename $ line -Name $ hostname> -TimeToLive ... + ~~~~~~~~~~~~~~~~~ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ ~~~~~~~~~~~~~~~~~~~ + CategoryInfo:ResourceExists:(@:root / Microsoft / ... urceRecordCName)> [Add-DnsServerResourceRecordCName]、CimException + FullyQualifiedErrorId:WIN32 9709、 Add-DnsServerResourceRecordCName 何か案は?ありがとう

2
数日間オフラインのドメインコントローラー
私のプライマリドメインコントローラーは週末に亡くなり、そのマザーボードは明日交換されます。 新しいマザーボードをインストールすると、サーバーのMACアドレスが変わる可能性があると言われています。 ネットワークに接続する前に、どのような問題を心配する必要がありますか?ADは問題なく同期するだけですか? DHCPについてはどうですか?死ぬ前はdhcpサーバーでしたが、ネットワーク上の別の場所にインストールする必要がありました。電源を入れ直すと、dhcpサーバーの競合が発生します。

2
Nagiosを使用してサービスが利用できないことを確認することは妥当ですか?
プライベートインターフェイスとパブリックインターフェイスを備えたサーバーがあるとします。パブリックにはHTTP(S)サーバーなどがあり、プライベートにはMySQLとSSHがあります。 明らかにNagiosは、サービスがそれぞれのインターフェースで実行されていることを確認するのに役立ちます。しかし、MySQLおよびSSHポートがパブリックインターフェイスで開いていないことを明示的にテストするチェックを構築することは良い考えですか?このアイデアは、プライベートである必要のあるサービスを開いた不注意による設定ミスをキャッチし、適切に警告することです。 私の一部は、これはひどくうまくスケールしないだろうという考えを持っています-たとえば、iptables DROPルールがあると想像してください。しかし、そのタイムアウトは、ブロックされたサービスを、本当に行き詰まっているオープンなサービスと区別できるように、十分に長くなければなりません。 これは実用的なアイデアですか?Nagiosは適切なツールですか?私は、TCPチェックプラグインからの結果を無効にする可能性を検討していませんが、それが可能であると確信しています...

2
Apache mod_remoteipとアクセスログ
Apache 2.4以降、フロントエンドサーバー(ワニス、イカ、アパッチなど)が提供するx-forwarded-forからクライアントアドレスを書き換えるために、mod_extract_forwardedではなくmod_remoteipを使用し始めました。 これまでのところ、php、cgi、wsgiなどのモジュールですべてが正常に動作します。クライアントアドレスは本来のとおりに表示されますが、アクセスログにクライアントアドレスを書き込むことができませんでした(%a、%h、%{c } a)。運が悪い-私は常に127.0.0.1(localhost forward ex。)を取得しています。 mod_remoteipを使用しているときにクライアントのIPアドレスを記録する方法 更新:IT WORKS O_O-以下の回答を参照してください

8
非特権lxcコンテナを自動起動するにはどうすればよいですか?
Ubuntu 14.04では、手動で開始および停止できる非特権コンテナーを作成しました。 しかし、私はこれをシステムとともに開始および停止したいと思います。 コンテナの構成に以下を追加しました: lxc.start.auto = 1 lxc.start.delay = 5 ただし、システムスクリプトは非特権コンテナを選択するようには見えません。 linuxcontainers.orgにこれに関連するスレッドがありますが、解決策はrootユーザーに制限されているようです。 (rootユーザーの同意を得て)非rootユーザーに対してこれを行うためのクリーンな方法はありますか?

4
MySQL接続はlocalhostでは機能しますが、127.0.0.1では機能しません
Debian Wheezy(apt-get install mysql-server mysql-client)にはかなり標準的なMySQLインストールがあり、これまで何度も成功しています。 経由localhostで接続しようとすると、すべてが機能します。しかし、経由で接続127.0.0.1するとエラーメッセージが表示されます。 $ mysql -h localhost -P 3306 -u xxx -p -- works $ mysql -h 127.0.0.1 -P 3306 -u xxx -p ERROR 2013 (HY000): Lost connection to MySQL server at 'reading initial communication packet', system error: 0 localhostホスト名として使用しているにもかかわらず、Javaアプリケーションから接続しようとすると、同様のエラーが発生します。 com.mysql.jdbc.exceptions.jdbc4.CommunicationsException: Communications link failure. The last packet …
9 mysql 

1
有効なレプリカのないホットスペアをZFSに強制的に切り離すとどうなりますか?
6つのRAIDZで構成されたZFSプールがあります。2つのディスクが故障する前に最初の故障からZFSが回復できなかった単一のRAIDZ内の2つのディスクを失うことにより、RAIDZの1つが劣化しました。再起動直後の「zpool status」の出力は次のとおりです。 pool: pod2 state: DEGRADED status: One or more devices has experienced an error resulting in data corruption. Applications may be affected. action: Restore the file in question if possible. Otherwise restore the entire pool from backup. see: http://www.sun.com/msg/ZFS-8000-8A scrub: resilver in progress for 0h6m, 0.05% done, 237h17m to …
9 linux  zfs  zfs-fuse 

1
ZFSヘッドノードをデータベースサーバーとして使用していますか?
ここに示すように、Nexentaの推奨アーキテクチャに基づいて、高可用性クラスタ共有ストレージにデュアルヘッドZFS-backed NASを使用しています。 1 JBODのディスクは単一の4 TB Postgresデータベースのデータベースファイルを保存し、他のJBODのディスクは20 TBの大きな未加工バイナリフラットファイル(大きな恒星オブジェクトの衝突シミュレーションのクラスター結果)を保存します。つまり、PostgresファイルをバッキングするJBODは主にランダムなワークロードを処理し、シミュレーション結果をバッキングするJBODは主にシリアルワークロードを処理します。どちらのヘッドノードにも256 GBのメモリと16コアがあります。クラスターには約200のコアがあり、それぞれがPostgresセッションを維持しているため、約200の同時セッションが予想されます。 ZFSヘッドノードをクラスターのミラーリングされたPostgresデータベースサーバーのペアとして同時に機能させることが、セットアップで賢明かどうか知りたいのですが。私が見ることができる唯一の欠点は次のとおりです。 インフラストラクチャのスケーリングの柔軟性が低下します。 冗長性のレベルがわずかに低くなります。 PostgresのメモリとCPUリソースが制限されています。 ただし、私が理解している利点は、ZFSは自動フェールオーバーにかなりとんでもないことであり、ヘッドと一緒に失敗するため、ヘッドノードが失敗したかどうかを各Postgresデータベースサーバーに理解させるために多くの作業を費やす必要はありません。ノード。

2
PowershellがPKI証明書をリモートで削除する
最近PKIを再構築しましたが、ネットワーク上のすべてのクライアントマシンに発行された証明書を削除したいと思います。Powershellの仕事のように聞こえます!そのため、このスクリプトはGPOによって配布され、SysVolから実行され、起動時にクライアントマシンでトリガーされるように記述しました。 set-location cert:\LocalMachine\My $certname = $env:COMPUTERNAME + ".domain.com" get-item * | %{ if($_.issuer -like "CN=IssuingCA*" -and $_.DnsNameList.unicode -like $certname) { remove-item .\$_.Thumbprint -Force } } 管理者特権のコマンドプロンプトから: Ranの場合、スクリプトは何も出力しません(単に新しい端末行)。エラーは返されず、証明書は削除されません。 スクリプト-WhatIfのRemove-Itemコマンドに引数を追加しても、エラーは発生せず、証明書は削除されません。 Remove-Item。\ CERTIFICATE-THUMBPRINT -Forceが実行されると、証明書が削除されます。 これは権限の問題ですか?これを行うためのよりスマートで簡単な方法はありますか? ありがとう!

8
Centos 7はnpmをyumインストールできません
CentOS 7にnodejsとnpmをインストールしようとしています したがって、最初にrpm -i http://dl.fedoraproject.org/pub/epel/beta/7/x86_64/epel-release-7-0.2.noarch.rpm を実行してepelリポジトリを取得しました 次に、yum install nodejsを試しました。うまくいった。次に、yum install npmを試しました。Yumは「npmパッケージが見つかりません」で戻ります npmを手動でビルドする必要がありますか?そして、どうすればいいですか?
9 centos  node.js  npm 

3
ESXcliコマンドが30分でタイムアウトする
私はpowercliスクリプトに取り組んでおり、環境内の各データストアをループして、シンプロビジョニングされたLUNのスペースを再利用しています。環境内のすべてのLUNはDell Equal Logicです。 vCenterバージョン: 5.5.0_1750787 ESXiバージョン: Dell 5.5-1331820(A01) 私が遭遇している問題は、スクリプトでunmapコマンドを実行してからちょうど30分後に次のエラーが発生することです。 PowerCLIから: Message: An error occurred while communicating with the remote host: InnerText: At \\SOMEIP\Share\folder\vmware_unmap_datastore.ps1:96 char:9 + $RETVAL = $ESXCLI.storage.vmfs.unmap(200, $ds.Name, $null) + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ + CatagoryInfo : OperationsStopped: (:) [], HostCommunication + FullyQualifiedErrorId : VMware.VimAutomation.ViCore.Types.V1.ErrorHandling.HostCommunication From:ESXi Host vpxa.log: ==> vpxa.log <== 2014-06-30T14:39:51.907Z …

1
Vagrantは実行するPuppetマニフェストのディレクトリを指すことができますか?
私はVagrantを使用していくつかの初期Puppet構成をジャンプスタートし、追加マニフェストをモジュールに作成してそのように含めることなく、複数のマニフェスト(site.pp以外)をパペット実行ワークフローに含める/実行する方法について混乱しています。 Vagrantがポイントするパペットマニフェストディレクトリ(以下を参照)には、実行したいマニフェストが2つあります:site.ppとhierasetup.pp。 config.vm.provision "puppet" do |puppet| puppet.manifests_path = "puppet_files/manifests" puppet.module_path = "puppet_files/modules" puppet.manifest_file = "site.pp" puppet.options = "--verbose --debug" end 現在、site.ppをhierasetup.ppを呼び出すマニフェストにしています。私のsite.ppは次のようになります: File { owner => 'root', group => 'root', mode => '0644', } import "hierasetup.pp" include jboss しかし、「インポート」の廃止について次のエラーが表示されます。 警告:「インポート」の使用は、/ tmp / vagrant-puppet-1 / manifests / site.pp:33で廃止されました。http://links.puppetlabs.com/puppet-import-deprecationを参照してください (grammar.ra:610:in `_reduce_190 'にあります) 「代わりに試すこと」の下で参照されているURLによると、「ノード定義を個別のファイルに保持するには、メインマニフェストとしてディレクトリを指定してください」とあります。 …
9 puppet  vagrant 

1
Linuxミント(ライブCD)をcifsを使用してpxebootするとネットワークが正しく初期化されませんが、nfsで動作します
192.168.26.1にTFTP / DHCP / NFS / SMBサーバー(Ubuntuサーバー12.04 LTS)があります。pxelinuxを使用して、Windowsの起動オプションとインストールオプション、Ubuntuネットワークインストーラー、およびLinux Mint 17 MATEライブCDを含むメニューを表示します。このように実行することはすでに厄介であり、私は蒸気を使い果たしています... Linux Mintには、NFSとCIFSの2つのネットブートオプションを用意しました。私はそれをNFSで完全に動作させました:ユーザーはブートメニューでそれを選択でき、しばらくするとLinux MintライブCDデスクトップに移動します。しかし、CIFSでは、ネットワーキングが適切に初期化されません。Linux Mintが起動すると、ネットワークは120秒間ハングします。その後、デスクトップから起動し続けますが、ネットnetwork-managerは起動していません(起動していません)。DHCPサーバーが応答しないことが問題であると考えましたが、DHCPサーバーのログでDHCP要求と正常な応答を確認できます。 Linux Mintデスクトップに入るifconfigと、DHCPによって割り当てられたIPアドレスが報告され、サーバーへのpingが機能します。 私のpxelinux構成は次のとおりです(すべてAPPENDが1行で、このサイトでは読みやすくするために分割しています): NFS: LABEL linuxmint17 MENU LABEL Linux Mint 17 KERNEL linux-mint-17/image/casper/vmlinuz APPEND root=/dev/nfs boot=casper netboot=nfs nfsroot=192.168.26.1:/var/lib/tftpboot/linux-mint-17/image initrd=/linux-mint-17/image/casper/initrd.lz CIFS: LABEL linuxmint17smb MENU LABEL Linux Mint 17 (SMB) KERNEL linux-mint-17/image/casper/vmlinuz APPEND root=/dev/cifs boot=casper netboot=cifs nfsroot=//192.168.26.1/tftpshare/linux-mint-17/image …

5
Windows 2012 R2が自己署名証明書を信頼しないのはなぜですか?
テスト環境で、私は現在、すぐに展開する必要があるいくつかのテスト(実際には既にですが、締め切りがどうなるかを知っています...)をためらっています。これは、Windowsが、隔離されたテスト環境。「実際の」証明書といくつかのDNSトリックを使用して問題を回避することはできますが、セキュリティ/コンパートメント化の理由から、証明書は示していません。 Zimbraと呼ばれるLinuxベースの電子メールサーバーに接続しようとしています。自動生成された自己署名OpenSSL証明書を使用しています。Googleが明らかにしたページは、IIS自己署名証明書を備えたIIS Webサイトを特に参照していますが、それを生成する方法は実際には重要ではないと思います。 こことここで見つけた手順によると、これは証明書をローカルコンピュータの信頼されたルート証明機関ストアにインストールするという簡単な問題です。証明書を手動でコピーし、MMCスナップインを介して直接インポートするだけでなく、これを行いました。ログアウトと再起動は何も変更しません。 ここに私が毎回得る証明書エラーがあります: そして、これが認定パスです(ネタバレ:証明書そのものです): 最後に、ここにある証明書は、ローカルコンピュータの証明書ストアに安全に格納されています。 Linuxベースのサーバーに接続するServer 2012 R2を使用している間、これらの手順は特にVista(2番目はOSについては触れていません)とIISを参照しています。インポートウィザードにはいくつかの違いがあります(私の場合、現在のユーザーまたはローカルシステム用にインポートするオプションがありますが、両方試してみました)。信頼できると既に言った証明書を本当に本当に信頼できるようにするために変更する必要がある、私が見つけていない場所の設定ですか? Windows Server 2012 R2に自己署名証明書を信頼させる正しい方法は何ですか?

1
UnixマシンからWindows AD Kerberosキータブをリモートで生成する方法は?
ktpassWindows Server側のユーティリティを使用せずにクライアントマシンから直接キータブファイルを作成できるかどうかを知りたいのですが。 これが必要な主な理由は、いくつかのシェルスクリプトを使用して、LinuxマシンのWindows Active DirectoryからのKerberos認証の統合を自動的に有効にするためです。 ありがとう

弊社のサイトを使用することにより、あなたは弊社のクッキーポリシーおよびプライバシーポリシーを読み、理解したものとみなされます。
Licensed under cc by-sa 3.0 with attribution required.