サーバー管理者

システムおよびネットワーク管理者向けのQ&A

5
物理パーティションシステムをLVMに変更する方法
すべてのディスクをカバーする3つの物理パーティションを持つ、Debianを搭載したサーバーがあります。ブート、ルート、スワップです。次に、そのパーティションをLVMパーティションに置き換えます。最初はLVMでDebianをインストールする方法を知っていますが、この場合、プロバイダーがリモートアクセスを備えたサーバーとこの方法でインストールされたシステムを取得するため、最初にシステムをインストールできません。 ssh接続のみを使用してパーティションを変更し、一時データを配置する他のリモートサーバーを変更するにはどうすればよいですか?
10 linux  lvm 

2
Nginx ssl-SSL:エラー:0906D06C:PEMルーチン:PEM_read_bio:開始行なし
123-regからの証明書を使用してサーバーでSSLを有効にしようとしていますが、次のエラーが発生します。 nginx: [emerg] SSL_CTX_use_certificate_chain_file("/opt/nginx/conf/cleantechlms.crt") failed (SSL: error:0906D06C:PEM routines:PEM_read_bio:no start line error:140DC009:SSL routines:SSL_CTX_use_certificate_chain_file:PEM lib) これは私のnginx設定です: server { listen 443; server_name a-fake-url.com; root /file/path/public; passenger_enabled on; ssl on; ssl_certificate /opt/nginx/conf/cleantechlms.crt; ssl_certificate_key /opt/nginx/conf/cleantechlms.key; } crtとkeyを完全なファイル権限に設定しようとしましたが、違いはありません。 私のcrtファイルは、発行されたcrtとca crtを連結したものです。 更新 私はsperateファイルに両方のキーをコピーしてから「cat mykey.crt >> ca.cert」を実行しようとしました また、キーを同じファイルに手動でコピーしてみました。 何か案は?
10 nginx  ssl 


3
特定のソースIPを使用するプロキシとしてのnginx
私はnginxを使用して静的ファイルを提供し、他のリクエストを一部のTomcatインスタンスにプロキシしています。問題は、Tomcatへの接続にnginxが使用するIPアドレスを選択する方法がわからないことです。 各Tomcatインスタンスは、特定のIPアドレスからのHTTP接続のみを受け入れます。私のサーバーにはこれらすべてのIPがあります。nginxが使用するものを選択できません。 これは私の設定ファイルです: proxy_set_header Host $host; proxy_set_header X-Real-IP $remote_addr; proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for; proxy_set_header X-Forwarded-Proto $scheme; location /integracao/ { proxy_pass http://X.X.X.X:9080/integracao/; } location /solr/ { proxy_pass http://Y.Y.Y.Y:8080/solr/; } 私のサーバーには、AとBの2つのIPアドレスを持つ1つのインターフェースがあります。最初のTomcatに接続するにはIP A、Solrに接続するにはIP Bを使用する必要があります。 誰でもそれを行う方法を知っていますか?
10 nginx  proxy  ip  ip-address 



4
Linux(centos)でGUIを使用しないFortinet SSL VPNクライアントのセットアップ
Centosで実行されているVPSにフォーティネットSSL VPNクライアントをインストールしてセットアップするにはどうすればよいですか?私が持っているすべてのガイドは、リソースを節約するためにVPSにインストールされていないGUIをすべて使用しているため、問題を抱えています。(例:http : //dbssolutions.freshdesk.com/solution/categories/1513/folders/3047/articles/1791-how-to-install-the-linux-fortinet-ssl-vpn-client) 私はすでにVPNクライアントのLinuxバージョンを持っていますが、ターミナルを使用してそれをインストールおよび構成する方法がわかりません。

3
HAproxyのACLリストでワイルドカードホストを照合するにはどうすればよいですか?
haproxy.confに次の行があります。 acl valid_domains hdr(Host) -i mysite.com images.mysite.com docs.mysite.com admin.mysite.com redirect location http://mysite.com/invalid_domain if !valid_domains サブドメインを一致させるにはどうすればよいですか? 私は試した: acl valid_domains hdr(Host) -i *.mysite.com そして: acl valid_domains hdr(Host) -i [a-z]+.mysite.com ...しかし、どちらも機能しませんでした。 ありがとう

3
より頻繁に時刻を同期するようにntpdを構成するにはどうすればよいですか?
可能な限り頻繁に時刻を同期するようにntpdを設定する必要があります。その方法を教えてください。 UPDサーバーをポーリングするのではなく、ntpdにシステムクロックをより頻繁に調整させる必要があります。仮想PCのシステムクロックのずれが大きすぎるため、必要 です。maxpollは何も変更しないようです。minpoll/ maxpollを4と5に設定しているため、時間の調整は数分に1回しか行われないようです。
10 linux  ntp  ntpd 


3
nginxが外部IPアドレスへのリクエストを処理しない
ポート81でnginxを実行しています。Telnetを使用できtelnet 127.0.0.1 81、すべて問題ありません。 しかし、Mac(外部IPアドレス)から自分のマシンにTelnet接続しようとすると、次のエラーが発生します。 telnet: connect to address 109.123.x.x: Connection refused telnet: Unable to connect to remote host これが私の/ etc / nginx / sites-available / defaultファイルです: server { listen 81; ## listen for ipv4; this line is default and implied #listen [::]:80 default ipv6only=on; ## listen for ipv6 root /usr/share/nginx/www; …
10 nginx  ip  ip-address 

8
MySQL my.cnfパスはどこにありますか?
MySQLのインストールディレクトリを見つけました。 /usr/local/mysql/ my.cnfサーバーを構成する場所を知るためのパスはどこにありますか?/etc/my.cnf(以下に示すように)を作成してみましたが、影響はありませんでした [mysqld] #charset collation_server=utf8_general_ci character_set_server=utf8 default_character_set=utf8
10 mysql  my.cnf 

3
Apache virtualhostをipv6で動作するように設定するにはどうすればよいですか?
1つのipv4アドレスといくつかのipv6アドレスを持つサーバーを持っています。1つのドメインがipv4にリダイレクトされます。次のように、apache ports.confを設定したレコード: Listen ip.v4.address:80 NameVirtualHost ip.v4.address:80 およびvirtualhostファイル: <VirtualHost ip.v4.address:80> DocumentRoot /var/www/first/ ServerName first.domain ServerAlias www.first.domain ErrorLog ... CustomLog ... </VirtualHost> そして、すべてが正常に動作します。 次に、2番目のIPを使用して2番目のドメインの新しい仮想ホストを作成します。2番目のドメインをipv6 AAAAレコードにリダイレクトし、ports.confに追加します。 Listen [ip.v6.address]:80 NameVirtualHost [ip.v6.address]:80 新しい仮想ホストファイルを作成します。 <VirtualHost [ip.v6.address]:80> DocumentRoot /var/www/second/ ServerName second.domain ServerAlias www.second.domain ErrorLog ... CustomLog ... </VirtualHost> Apacheを再起動します。サーバーの起動時にエラーはありませんでしたが、機能しません。ブラウザに2番目のドメインを入力すると、サーバーが見つかりません。[ip.v6.address]サイトに入ると表示されます。 何か助けは?

2
.htaccessでphp_valueとphp_flagの使用を許可
モジュールとしてPHP5を使用してApache Webサーバーを実行しています(注意:CGIではなくApacheモジュールとして!)。 私の.htaccessファイル(gallery3ソフトウェアが付属しています1の一部ではhttp://gallery.menalto.com/)、はphp_valueとのphp_flagの文があります。 そのフォルダー内のファイルにアクセスしようとすると、500サーバーエラーが発生します。そこで、apache2.confを編集して、次の行を追加しました。 <Directory /my/gallery/folder> AllowOverride All </Directory> 私は何か間違ったことをしましたか?オーバーライドを許可し、ApacheモジュールとしてPHPを実行します。なぜerror.logが教えてくれるのphp_value not allowed hereですか?


弊社のサイトを使用することにより、あなたは弊社のクッキーポリシーおよびプライバシーポリシーを読み、理解したものとみなされます。
Licensed under cc by-sa 3.0 with attribution required.