サーバー管理者

システムおよびネットワーク管理者向けのQ&A

4
DCにログオンせずにADのすべてのユーザーとグループを表示する方法
ツリービュータイプの構造を使用して、グループを検索し、AD内のメンバーを確認したいと思います。DCへのRDCアクセス権がないため、ログインしてActive Directoryユーザーとコンピュータースナップインを使用できません。 これを行う別の方法はありますか?DCではないドメイン上の別のサーバーからですか?

5
PuTTYの致命的なエラー:サーバーがシェル/コマンドの開始を拒否しました
SSH経由でサーバーにアクセスするために、常にPuTTY(win32)を使用しました。昨日、サーバーのOpenSSHを4.3から5.8にアップグレードしましたが、PuTTYが動作しなくなったようです。パスワードを要求し、パスワードが正しいことを確認して、致命的なエラーを表示しますServer refused to start a shell/command。 cygwinのOpenSSHでログオンしようとすると、何の問題もありません。
10 ssh  putty 

4
独自のdomain.comリクエストをwww.domain.comにリダイレクトするサービスはありますか?[閉まっている]
閉まっている。この質問はトピックから外れています。現在、回答を受け付けていません。 この質問を改善してみませんか? サーバー障害のトピックになるように質問を更新します。 4年前休業。 これはapache構成で301リダイレクトを使用すると簡単ですが、これを安価または無料で実行できるサードパーティのサービスを探しています。これを使用して、www以外のトラフィックを、Amazon Elastic Load Balancerホスト名にCNAMEしたwwwレコードにリダイレクトします。

1
通常のユーザーがPostgreSQLでスキーマを作成できるようにするには何が必要ですか?
新しいデータベースtestを作成し、次のコマンドでユーザー 'eonil'を作成しました。 CREATE ROLE eonil LOGIN ENCRYPTED PASSWORD 'password' NOINHERIT VALID UNTIL 'infinity'; 私のPostgreSQLで。走るpsql -U eonil test。新しいスキーマを作成しようとすると、エラーが表示されます。 test=> CREATE SCHEMA new_schema AUTHORIZATION eonil; ERROR: permission denied for database test test=> なぜこれがエラーになるのですか?何が必要ですか?

4
`tail -f`で更新が停止することがあり、ファイルは移動していません
最近tail -f <logfile>、画面への更新が停止する場合があることに気付きました。 ただし、Ctrl>- Cを実行し、tail作業を再開すると問題ありません。そして、ログファイルが途中でローテーションされていないことを確認しました(tail気が散る可能性があります)。 何が原因でしょうか?RHEL 5.2 x64を実行しています。
10 logging  rhel5  tail 

1
FreeBSDでデフォルトのシェルを変更する方法は?
FreeBSDのデフォルトのシェルはsh、私には本当に我慢できません。オートコンプリートは非常に制限されており、rehashコマンドは私を殺します。私は一人の武装した男と一人の脚の男のように感じます... シェルをグローバルに、zshまたはbashrootと現在および将来のすべてのユーザーに変更するにはどうすればよいですか?
10 bash  shell  freebsd  zsh  sh 

2
wgetの進行状況がどうなったのか:メガはもうそれを切りませんか?
大きなファイルをキューにダウンロードするスクリプトがあります。まともなログがあれば、本当に感謝しています。-oor -aオプションの指定は明らかにそのために特別に作られていますが、現時点では、この「非常に大きなファイル」を書いている時点では、マンページに記載されているように、サイズが50mではなくギガバイトになっています。--progress=dot:mega3GBファイルの場合のみ、1000行の出力を生成します(明らかに3000 * 80ドット( '。')になります)。だから私は疑問に思っています:実際にログ機能を利用できるように、進行スタイルの設定をカスタマイズする方法はありますか?

3
fstabおよびcifsマウント、fstabの外部に認証情報を保存することは可能ですか?
現在、cifsを使用して(認証が必要な)ネットワーク共有を/ etc / fstabにマウントしています。それはうまく機能しますが、認証の詳細(ユーザー名/パス)をfstabの外に移動して、600にchmodできるようにしたいと思います(許可を変更するとfstabで問題が発生する可能性があるため)。これが可能かどうか疑問に思っていました(多くのユーザーのシステムで、これらのアクセス許可をすべてのユーザーが表示できるようにしたくない)。 から: //server/foo/bar /mnt/bar cifs username=user,password=pass,r 0 0 に: //server/foo/bar /mnt/bar cifs <link to permissions>,r 0 0 (またはこれに類似した何か)。ありがとう。

8
Linuxで非表示のプロセスを検出する方法は?
仕事で根付いていると思われる箱があります。問題は、それをどのように見つけるかです。私はシステム管理者ではありませんが、状況を解決するためにチームに連れて行かれました。問題など、探すのに適した場所がどこにあるのか知りたいです。 これが疑われる理由は、高い(ランダムに見える)ポートからのマシンでのネットワーク使用率が通常より高いことに気付いたためです。 問題のある子供を見つけるには何ができるでしょうか?将来これから保護するために何ができるでしょうか?将来これを認識させるために実行できる監視はありますか?(ネットワーク監視とは別に、私たちはすでにより注意深く監視するために取り組んでいます。) よろしくお願いします。必要に応じて詳細をお知らせします。あなたの時間を感謝します。

4
なぜ一部のSSHセッションはオートコンプリートを提供し、一部は提供しないのですか?
非常に初心者の質問! 同じAmazon AWSクラスターに属している2つの異なるサーバーに接続しています。彼らは私が運営しているのではありません。 1つのsshセッションで、ターミナルはオートコンプリートを許可します。他のセッションでは、そうではありません。 これはなぜですか-サーバー管理者が設定するオプションですか? そして、私はそれについて何ができますか? ありがとう!
10 ssh  terminal 



3
IISリセットは、キャッシュされたアイテムを強制的に再送信しますか?
サイトのアップデートをリリースするときに、キャッシュされたJavaScriptファイル、CSS、画像などを処理する戦略を開発しようとしています。JavaScriptファイルにバージョン番号を実装する前に、リリースごとにIISをリセットすると、キャッシュされたファイルが効果的に再送信されるかどうか疑問に思いました。
10 iis-7  asp.net  cache 

2
奇妙な問題:ピアによる接続のリセット
CentOSを実行しているLinuxサーバーでSSHに問題があります。Windows cmdからPuTTYまたはsshを使用してサーバーに正常に接続できます。セキュアFTPを使用する場合も同様です。サーバーに接続してファイルのリストを取得でき、すべて問題ありません。問題は、ネットワークを介して任意の量のデータを送信しようとすると発生します。 特定のしきい値を超えて何かを転送しようとすると、接続は失敗し、「ピアによって接続がリセットされました」というメッセージが表示されます。ホームディレクトリに約3 MBのsqlファイルがあります。FTPで転送しようとすると、転送が開始され、約48kが転送された後に終了します。次に、新しい接続を開始し、さらに48kを転送します。PuTTYを使用してセッションを開くと、接続してログインできます。cat file.sql再試行すると、接続が終了し、「ピアによって接続がリセットされました」というメッセージが表示されます。ローカルワークステーションからサーバーに移動する場合も同じ状況です。サーバーでホストされているsvnリポジトリにコミットする必要があるソースコードがかなりありますが、同じ「ピアによる接続リセット」メッセージが表示されます。 私は問題が私のローカルワークステーションにあることを知っています。私は妻のMacbookとサーバーへのSSHを問題なく使用できるからです。友人のLinuxボックスにssh(同じパテインストールを使用)し、サーバーからサーバーにsftpしてファイルをダウンロードし、ボックスからサーバーに別のsshセッションを開いて、ファイルをcatします。だから、何かが起こっていますが、私は何がわかりません。誰かアイデアはありますか? 更新 私はこれをもう少し理解しようとしました、そして私が単一のsshセッションで転送できるデータの量のハード制限があるようです。そうした場合はすぐにヒットしcat file.sqlますがls -l、一貫した回数を入力し続けることもでき、「ピアによる接続リセット」メッセージも表示されます。私はもう試した: 新しいSSHキーの生成 ルーターを再起動する コンピュータを再起動する リモートサーバーの再起動 私はリモートサーバーにtcpdumpを書きましたが、私にとってはTCPがあまり理解できないほど詳細なレベルでは理解できません。私はsshでデバッグをオンにしており、接続がリセットされるまでのログの一部を次に示します。 Jul 24 23:10:56 server sshd[4507]: debug1: permanently_set_uid: 500/503 Jul 24 23:10:56 server sshd[4507]: debug1: Entering interactive session for SSH2. Jul 24 23:10:56 server sshd[4507]: debug1: server_init_dispatch_20 Jul 24 23:10:56 server sshd[4507]: debug1: server_input_channel_open: ctype session …
10 ssh  centos  putty 

3
WindowsでLinuxホスト名を解決する
私はWindows 7マシンとLinuxマシン(Fedora 12と13)のシンプルなホームネットワークを持っています。Linuxマシン名をWindowsマシンから解決できるようにしたいのですが。例えば: -Windows 7のping mylinuxmachine 現在、これは解決しません。何か案は?

弊社のサイトを使用することにより、あなたは弊社のクッキーポリシーおよびプライバシーポリシーを読み、理解したものとみなされます。
Licensed under cc by-sa 3.0 with attribution required.