サーバー管理者

システムおよびネットワーク管理者向けのQ&A

4
Linuxでスワップサイズが常に増加し、スワップスペースが再利用されていないのですか?
4 GBのTomcatサーバーが実行されている8GB RAMのLinuxボックスがあります。それらの1つは3000MBメモリー(jvm -Xmsおよび-Xmx設定)に設定され、その他は1500MBに設定されます。スワップパーティションも8ギガに設定されています。これらのサーバーを起動すると、スワップファイルの使用率が低くなります。ただし、1日のうちの1つまたはすべてのサーバーがピーク状態にある特定の時間帯に、スワップの使用量が増加し始めます。次に、典型的なsar -r出力を示します。 kbmemfree kbmemused%memused kbbuffers kbcached kbswpfree kbswpused %swpused kbswpcad 48260 8125832 99.41 196440 2761852 7197688 1190912 14.20 316044 75504 8098588 99.08 198032 2399460 7197688 1190912 14.20 316032 現在使用されている14.2%のスワップを示しています。面白いことに、この%は決して減少しません。それは増加し続け、最大30-40%に達します。サーバーは毎週再起動します。 %swpusedは、ピークアクティビティの期間中に増加し、アクティビティの少ない期間中に減少すると想定します。または、少なくとも一定のままです。これは、スワップスペースがOSによって再利用されることはないようです。 freeの出力:free -mキャッシュされた使用済みの共有バッファの合計Mem:7982 7937 45 0 32 2088-/ + buffers / cache:5816 2166 Swap:8191 1163 7028 つまり、少なくとも2gの無料のRAMがあります。それで問題は、なぜスワップ領域が増え続け、OSによって解放されないのかということです。またはこれをデバッグして何が起こっているかを理解する方法..

2
_default_ VirtualHost overport on port 80
以下のように2つの仮想ホストをapache2 confファイルに追加しました。 <VirtualHost *:80> DocumentRoot /var/www/html/site1 ServerName www.site1.com ServerAlias site1.com </VirtualHost> <VirtualHost *:80> DocumentRoot /var/www/html/site2 ServerName www.site2.com ServerAlias site2.com </VirtualHost> 次に、Apacheを再起動した後にエラーが発生しました: [警告] デフォルトの VirtualHostがポート80で重複しています。最初のものが優先されます グーグルを検索し、彼らは下の行のコメントを外すと言ったので、私はしました: NameVirtualHost *:80 再起動すると、エラーは発生しませんが、両方のサイトが最初のサイトに移動します。 Centos5を実行しています。この問題を解決するにはどうすればよいですか?

4
Apache 2:SetEnvIf「IP範囲」
私のApache構成で、訪問者が特定のIP範囲から来ていることがわかった場合は、環境変数を設定します。現在私はこのようにしています: SetEnvIfNoCase Remote_Addr "^194\.8\.7[45]\." banned=spammer-ip SetEnvIfNoCase Remote_Addr "^212\.156\.170\." banned=spammer-ip 私が好むのは次のようなものです: SetEnvIfIpRange 194.8.74.0/23 banned=spammer-ip SetEnvIfIpRange 212.156.170.0/24 banned=spammer-ip ... IPアドレスを文字列に変換してから正規表現を実行することは、リソースを無駄にすることになると思います。 私はできる Deny From 194.8.74.0/23 ...しかし、403エラーページで確認できる変数が得られません-アクセスが拒否された理由を見つけるために。 私が見逃す可能性のある提案はありますか?「IPアドレス範囲」に基づいて環境変数を設定できるApache2 MODはありますか?

6
/ etc / bind / zones /または/ var / cache / bind /を使用する必要がありますか?
各チュートリアルは、これについて異なる意見を持っているようです。ISC BINDゾーンでは、/etc/bind/zones/またはを使用する必要がありますか/var/cache/bind/?前回のインストールで使用しました/var/cache/bind/が、使用するように指示されたためです。ただし、この新しいDebianインストール用のpidファイルを見つけただけなので、「作業ディレクトリ」を使用してゾーンファイルを保存することは、おそらく最善のアイデアではないと考えました。多くの管理者がこれを使用しているため、新しいゾーンを宣言するときに完全なパスを入力する必要はありません。 例えば: file "/etc/bind/zones/db.foobar.com"; の代わりに: file "db.foobar.com"; 明らかにタイプする方が簡単ですが、それは良い練習ですか、悪い練習ですか? 作業ディレクトリを/etc/bind/zones次のように設定するよう提案する人もいます。 options { // directory "/var/cache/bind"; directory "/etc/bind/zones"; } ...しかし、pidファイルがそこに作成されるので、これは良い習慣ではないと私に思います(/var/cache/bind偶然ではない限り)。 マンページを確認しましたが、ディレクトリオプションの目的や、それが設計された正確なアイデアは表示されていませんでしたか?
10 bind  named-conf 

2
同じワイルドカードSSL証明書を別のIPアドレスやボックスで使用できますか?
ロックされています。この質問とトピックへの回答はロックされています。質問はトピックから外れていますが、歴史的に重要です。現在、新しい回答や相互作用を受け入れていません。 例: 2つの異なるボックスにインストールされた* .example.comのワイルドカードSSL証明書。 hostEU.example.com A 60.70.80.90 hostUS.example.com A 200.210.220.240 これは完全に有効なシナリオであり、実際のホスト名が同じIP(または同じ意味で同じボックス)に存在しないと思います。 私の仮定は正しいですか?

2
サービスが失敗したときに実行する回復アクションを設定する
私はWindowsボックスに多くのカスタム作成サービスをインストールしました(XP、Server、Vistaのどちらでもかまいません)。1回目、2回目、およびそれ以降の失敗時に常に「サービスを再起動する」ように設定します。しかし、私はこの作品を見たことがありません。サービスは単に停止しますが(エラーまたはコード内の何かが原因で)、再起動しません。 「エラーのあるストップのアクションを有効にする」チェックボックスに気づきました。エラーが原因で障害が発生した場合にリカバリを有効にするには、これを確認する必要がありますか? ありがとう、マーク。
10 windows 

2
sshでsu -cを実行します。
SSHを介してサーバーのBIOSバージョンを確認しようとしています。これはroot権限が必要なコマンドです。 ssh remote-server su -c dmidecode しかし、これはもちろんエラーで失敗します: 標準入力はttyでなければなりません これを機能させるにはどうすればよいですか?sudoを使用できません。root@ remote-serverとしてログインしようとすると、suコマンドで使用するパスワードが受け入れられません。RedHat Enterprise Linux 4を使用しています。
10 ssh  unix  su 


1
「本当に」Hyper-Vリモートアクセス用にLANアダプターを予約する必要がありますか?
最近、Windows Server 2008 R2システムにHyper-Vの役割をインストールしました。役割をインストールして構成すると、使用を許可するネットワークアダプターが尋ねられます。インストールされているアダプターは1つだけなので、1つだけのボックスをオンにする必要がありました。 セットアッププロセスでは、リモートアクセス用にネットワークアダプターを予約することをお勧めしました。これは、VM専用のアダプターを使用し、リモートデスクトップをまったく使用できないためだと思っていました。 私の仮想マシンは問題なく動作し、問題なくHyper-Vホストにリモート接続できることがわかりました。それで、それらは保守的で、Hyper-Vがリモートデスクトップセッションをサポートするようにすることで、(VMが使用している可能性がある)帯域幅を無駄にしないように提案していましたか?少なくとも、インストールしたアダプタはギガビットです。 私はデュアルポートIntel Gigabit Lanアダプターを持っています。未使用のサーバーから盗んで入れ替えることができます。しかし、私の「エンタープライズ」は趣味サイズ(1日あたり40回の匿名のWebアクセス)で、VMは通常、電子メール、Webの顧客テストにのみ使用されますアプリ、開発)。だから私はそれが問題になるとは思いません。また、Hyper-Vホストのネットワークカードを交換するのは面倒ですか。 どう思いますか?Hyper-Vが推奨するようにネットワークアダプターを予約しないことは重要なことですか?

5
共有に割り当てられたセキュリティグループにいるとき、Windows共有にアクセスできない
私はこれに少し困惑しています。 ADに「特別なデータユーザー」と呼ばれるセキュリティグループを作成し、自分に追加しました。 次に、サーバー上に共有を作成し、そのADセキュリティグループに共有へのフルアクセスを付与しました。 共有にアクセスしようとすると、アクセス拒否のエラーが表示されません。 ユーザーアカウントを直接共有に追加したり、何年も前から使用されている別のセキュリティグループを追加したりすると、そのメンバーは正常に機能します。 この新しいグループが機能しない理由を探すためのヒントや提案をいただければ幸いです。私は高低を調べましたが、作成された新しいセキュリティグループが機能しない理由を理解できません... ありがとう!

10
1台のコンピューターで複数の画面を監視するにはどうすればよいですか?(教室で言って?)[終了しました]
閉まっている。この質問はトピックから外れています。現在、回答を受け付けていません。 この質問を改善してみませんか? サーバー障害のトピックになるように質問を更新します。 6年前休業。 私は小さなコンピュータベースのクラスの教師です。キッドは若いので、各コンピュータの後ろに立って、Itunesやソリティアになっていないことを確認することはできません。 私のコンピューター画面から、小さなボックスで画面のライブフィードを取得する方法があります(画像と画像を考えてください)。これにより、誰が作業していないのか、誰が作業しているのかをすばやく確認できますか?


4
単一のコマンドで中間マシンを介してSSH接続をトンネリングする
1つのコマンドで、コンピューターAからコンピューターBを経由してコンピューターCにssh接続を確立し、コンピューターCのシェルにアクセスできるようにする方法はありますか? しわ(-Lオプションを使用してssh接続を転送することを除外しているように見える)は、コンピューターBのアカウントへのパスワードがあり、コンピューターBのアカウントがコンピューターCのアカウントへの接続を許可されているが、コンピューターCのアカウントのパスワードがありません。
10 ssh  tunneling 

8
使用されているPHPを判別する方法は?
使用されているPHPを判別する方法は? 例えば、存在する場合/usr/local/bin/phpやusr/local/bin/php5、どのように私は1つが私のPHPスクリプトで使用されている知っているのですか?
10 php 

7
ルーターにはIPアドレスがありますか?
ルーターにはIPアドレスがありますか?LANに接続している場合、ルーターのIPアドレスを取得するにはどうすればよいですか? 私によると、IPアドレスは1つしか持てないため、複数のアドレスは持てません。私が間違っている場合は修正してください、または複数のアドレスを持つ可能性がある状況はありますか? ありがとう。
10 networking 

弊社のサイトを使用することにより、あなたは弊社のクッキーポリシーおよびプライバシーポリシーを読み、理解したものとみなされます。
Licensed under cc by-sa 3.0 with attribution required.