サーバー管理者

システムおよびネットワーク管理者向けのQ&A

3
PowerShellでCredSSP認証を機能させることができない
リモート処理を使用してPowerShellスクリプトを作成しようとすると、ダブルホップの問題だと私が思いました。その記事では、Perrimanが問題の簡潔な説明と問題を解決するための具体的な手順を示しています(コマンドを知っていればほとんど簡単ですが、私のようなあまり知られていない人にとっては、その情報は非常に貴重です!)。 私は走ったEnable-WSManCredSSP Server事件のない私のWin7のサーバー上ではなく、実行しようとEnable-WSManCredSSP Client –DelegateComputer <FQDN of the server>、このエラーが発生し、私のWin7のクライアント上で: Enable-WSManCredSSP : The client cannot connect to the destination specified in the request. Verify that the service on the destination is running and is accepting requests. Consult the logs and documentation for the WS-Management service running on the destination, most commonly …

1
mdadmおよび4kセクター(高度なフォーマット)
Serverfaultには4kセクターのディスクの調整について多くの質問がありますが、1つだけはまだはっきりしていません。 RAID1 + LVMの調整に成功しました。私がしたことの1つは、mdadmスーパーブロックバージョン1.0(スーパーブロックをディスクの最後に格納する)を使用することでした。 マンページはこれを言っています: 異なるサブバージョンは、デバイスの異なる場所にスーパーブロックを格納します。末尾(1.0の場合)、先頭(1.1の場合)、または先頭から4K(1.2の場合)のいずれかです。「1」は「1.0」と同等です。「デフォルト」は「1.2」と同等です。 デフォルトである1.2バージョンは4kセクタードライブ用に作られていますか?最初から4k +スーパーブロックの長さは4kの倍数ではないため(私が正しく覚えていれば、スーパーブロックの長さは約200バイトです)、私が見る方法ではそうではありません。 これについての洞察は大歓迎です。 編集: mdadmスーパーブロック1.1および1.2は4kアライメント用であると、以下に回答しました。私はデバイス全体のレイドを作成しました: mdadm --create /dev/md4 -l 1 -n 2 /dev/sdb /dev/sdd 次に、それに論理ボリュームを追加しました。 vgcreate universe2 /dev/md4 アレイは16 MB /秒で同期しています。 md4 : active raid1 sdd[1] sdb[0] 1465137424 blocks super 1.2 [2/2] [UU] [>....................] resync = 0.8% (13100352/1465137424) finish=1471.6min speed=16443K/sec だから私はそれが正しく調整されているとは思いません。 (ディスクは1.5 TB WD …

3
EVERYONEへの書き込みアクセスは機能し、IUSR、IIS_IUSRS、DefaultAppPoolは機能しません。どうして?
OK。ここでは、Windows Server 2008 R2のIIS 7.5でクラシックASP Webサイトをセットアップしようとしています。Webサイトのルートの下にdbcという名前のフォルダーがあり、すべてのページの処理中に特定の情報の読み取りと書き込みに使用されるファイルがあります。 問題は、IUSR書き込み権限、IIS_IUSRS書き込み権限、またはDefaultAppPool書き込み権限を付与すると、「パス「E:... \ websiteroot \ dbc \ filename.txt」へのアクセスが拒否されます」 しかし、そのdbcフォルダーに対するすべてのユーザーに書き込みアクセスを許可した場合、エラーは発生しませんが、すべてが完璧に見えます。 詳細情報:Webサイトはクラシックパイプラインモードで実行され、匿名認証が有効になっています(おそらく唯一の認証が有効になっています)。そして、IUSRアカウントとアプリケーションプールIDを使用して匿名認証を試しました。私の場合、ApplicationPoolIdentityはWebサイトの認証のIDです。ファイルI / OにはCOM +を使用します。クラシックASP Server.CreateObjectを使用して、オブジェクトをインスタンス化します。COM +はネットワークサービスとして実行されます。 考え?すべての人に書き込み権限を付与したくない。何か不足していますか? 解決しよう:これが私がしたことです。 CipherDemoという名前のWebサイトは、IIS 7.5のAppPoolIdentityの下で実行されていました。これは、Identity IIS AppPool \ CipherDemoによって見つけることができました。ICACLSを使用して、そのフォルダーにRWアクセス許可を与えました。 そして、実際にファイルI / Oを実行していたCOM +は、ネットワークサービスIDで実行されていました。プロセスモニターを使用してアクセス拒否エラーをトレースしていたところ、ネットワークサービスにはそのフォルダーに対する読み取りアクセス許可しかありませんでした。 ICACLS "フォルダ名" / grant:r "NT AUTHORITY \ NETWORKSERVICE" :( OI)(CI)RXW / Tを使用して、そのフォルダへの書き込みアクセスを許可しました。 そしてそれを解決しました。 私はWebサイトがCipherDemo Identityとして実行されるため、これがCOM +経由でファイルにアクセスするために使用されるアカウントになると考えていました。しかし、COM +が独自のID境界で機能することを確認するのは恥ずかしいことです。

3
IIS 7.5は静的HTMLページをロードしません
専用サーバーに新しくインストールされたIIS 7.5があります。ASP.NET 4.0 Webアプリがそのフォルダーにコピーされ、新しいWebサイトがポスト80の独自のIPで作成され、IIS_IUSRおよびIUSRアカウントがサイトのフォルダーに対する読み取り/実行権限を持ち、サイトが4.0 .NETの独自の統合アプリプールに割り当てられます(同じ結果でクラシックプールを試しました)。 問題:このWebサイトにアクセスしようとすると、ブラウザーはaspxページ、.axdファイルなどの.NETリソースによって生成されたコンテンツのみをロードします。静的画像、静的js、css、htmlファイルはページソースにありますが、IISはそうしませんそれらを提供しないでください。すべてのブラウザーの開発ツールは、これらすべての静的リソースが間違ったコンテンツタイプ(画像、スタイルなどではなくプレーンテキスト)でサーバーから送信されたと報告しています。何が悪いのでしょうか?

3
sshサーバーを実行しているLiveCD
sshデーモンが実行されているLiveCDを探しています。放棄されたサーバーに接続してバックアップを作成したいので、それが必要です。サーバーにはモニターがありません。 提案?
10 live-cd 

2
ランダム化されたSlappasswd出力
slappasswd固定ハッシュを生成することを期待していましたが、同じ入力パスワードに対して同じ出力を取得することはないため、出力はランダム化されているようです。 $ slappasswd -s secret {SSHA}mCXsPZkfgQYZr2mKHpy5Iav+2S2XlVU3 $ slappasswd -s secret {SSHA}62oXsalJBuopYfHhi6hGp6AESuWNIVnd $ slappasswd -s secret {SSHA}0Ulc8+ugMi3NbTtWnclOFW1LKCqRdsT8 認証中に、slapdは提供されたパスワードのハッシュを同じようにランダム化して、そもそも最初に定義されたパスワードと一致できるようにする方法を知っていますか?
10 openldap 

3
高負荷平均、低CPU
サーバーが遅くなり、その理由がわかりません。 上から印刷: top - 14:32:50 up 639 days, 6:30, 1 user, load average: 67.93, 70.63, 79.85 Tasks: 245 total, 1 running, 244 sleeping, 0 stopped, 0 zombie Cpu(s): 3.9% us, 0.5% sy, 0.0% ni, 94.5% id, 1.0% wa, 0.0% hi, 0.0% si Mem: 1034784k total, 1021256k used, 13528k free, 4360k …

3
rootパスワードを設定した後、MYSQLでパスワードなしでログインできるのはなぜですか?
rootパスワードを設定した後も、MYSQLでコマンドラインからパスワードなしでログインできるのはなぜですか?ルートunixプロンプトで「mysql」と入力すると、パスワードを要求されず、ルートアクセスが許可されます。「mysql -u root」がアカウントに設定したパスワードを要求しないのはなぜですか。 また、リモートマシンからmysqlに「root」としてログインできません。以下で正しく設定していませんか?「ホスト...はこのMySQLサーバーへの接続を許可されていません。 '%'を構成しませんでしたか? これが私のユーザーテーブルです: mysql> select host,user,password from user; +-----------+------+-------------------------------------------+ | host | user | password | +-----------+------+-------------------------------------------+ | localhost | root | *2470C0C06DEE42FD1618BB99005ADCA2EC9D1E19 | | % | root | | | 127.0.0.1 | root | | | ::1 | root | | | localhost | | | …

5
特定のWebサイトのクライアントブラウザキャッシュをオフにする方法はありますか?
これはブラウザにとらわれない質問ですが、IE9でテストしています。 ユーザーがアクセスするWebアプリの1つがランダムにキャッシュされており、必要なときに変更が表示されません。他のサイトではこの問題は発生しておらず、他のサイトでは発生しないと主張しているベンダーと協力してきました。開発者ツールバーを使用して「サーバーから強制的に更新」を選択すると、すべてが正しく更新されます。 この問題を実際に解決する代わりに、この特定のサイトのキャッシュを無効にすることで問題を回避することが考えられます。ただし、その方法はわかりません。

4
Maildirから重複メッセージを削除する
IMAPサーバーのMaildirに重複したメッセージがたくさんあります。それらを削除する最良の方法は何ですか? 関連するポイント: 共有メッセージIDは通常、複製の十分な定義です。重複するメッセージの1つを除くすべてを削除する小さなスクリプトが機能します。 共有メッセージ本文に基づいて重複を見つける必要がある場合があります。ここで共有の合理的な定義は何ですか?ビット単位で同等ですか?行の折り返し、エスケープ、文字エンコーディングの奇妙な違いはどうですか? 「重複」メッセージには、意味のある違いがある場合があります。「重複」メッセージのセットの違いを確認する最良の方法は何ですか?差分?
10 maildir 

4
/ var / log / messagesでの過剰なDHCPリクエスト:DHCPINFORM、DHCPACK、DHCPREQUESTが繰り返される
複数のサブネットでDHCPを実行しているCentOS 5システムがあります。/ var / log / messagesに、一定のDHCPINFORM、DHCPACK、およびDHCPREQUESTメッセージが表示されます。これらのリクエストが他のインストールよりも頻繁に発生する理由がわかりません。メッセージは数秒ごとにバースト的に送信されるため、非常に大きなログファイルが生成されます。 ここでのデバイスの大部分は、ワイヤレスハンドヘルドデバイスです(Windows CE TCPスタックを使用)。絶え間ないメッセージを鎮めることについての洞察をいただければ幸いです。 /etc/dhcpd.conf default-lease-time 28800; authoritative; allow bootp; ddns-update-style none; option subnet-mask 255.255.255.0; option domain-name-servers 10.1.1.3; option domain-name "xxxinc.com"; option tftp-server-name "10.1.1.3"; option ntp-servers 17.151.16.21; subnet 10.1.1.0 netmask 255.255.255.0 { range dynamic-bootp 10.1.1.120 10.1.1.211; option tftp-server-name "10.1.1.3"; next-server 10.1.1.3; filename "/dsl/pxelinux.0"; option …
10 linux  centos  dhcp 

4
nginxでフォールバックエラーページを設定する方法
現在、nginxがいくつかのエラーページと他の「デフォルト」メディアファイル(favicon.icoやrobots.txtなど)を処理するように構成しています。 。 基本的に、私がやろうとしていることは、そのサーバーのルートの下にあるサーバーに特定のファイルを提供することです(例:/var/www/someserver.com/robots.txt)。そのファイルが存在しない場合は、nginxを「デフォルト」、つまり/var/www/default/robots.txtに移動します。これは、(正常に)構成した方法の基本的な要点です。 server { ... root /var/www/someserver.com; location ~* ^/(robots\.txt)$ { error_page 404 = @default; } location @default { root /var/www/default; } } それはうまくいきます。 エラーページに対しても同じことを実行しようとしていますが、それを実行することはできません。 server { ... root /var/www/someserver.com; error_page 404 /404.html; location ~* ^/(404\.html)$ { error_page 404 = @default; } location @default { root /var/www/default; } } …
10 nginx 

2
非表示の( `.`)ファイルを表示するようにApacheを構成する方法
Apacheのディレクトリ一覧に./ hiddenファイルを表示するにはどうすればよいですか?両方試しました <Directory /var/www/*> Options Indexes FollowSymLinks MultiViews AllowOverride None Order allow,deny allow from all </Directory> そして <Directory /var/www/> Options Indexes FollowSymLinks MultiViews AllowOverride None Order allow,deny allow from all </Directory> しかし、どちらも隠しファイルを表示しません

4
SELinuxはRedhatをより安全にしますか?
SELinuxはRedhatをより安全にしますか? SELinuxを無効にした回数を思い出せません。これは、物事を実行する能力に苛立ち続けたためです。多くの場合、物事がうまくいかなかった明確な理由はありませんでした。その理由を見つけるために、Googleに問い合わせる必要がありました。 エンタープライズユーザーであるRedhatの深刻なユーザーを除いて、ほとんどのカジュアルユーザーが邪魔になると思われる場合にセキュリティを無効にするか弱めますが、SELinuxは本当に便利ですか? PS。すべてのアプリケーションにわたってSELinuxの問題を記録、追跡、管理するのに役立つツールはありますか?
10 centos  redhat  selinux 

4
単位のサフィックスが付いた数値の解析に便利ですか?
の出力など、人間が読める形式の数量のデータがありdu -h、それらの数値をさらに操作したいとします。そのデータのサブセットの合計を行うために、grepを介してデータをパイプしたいとします。これまでに見たことのない多くのシステムでこのアドホックを実行し、最小限のユーティリティしかありません。すべての標準10 ^ nサフィックスのサフィックス変換が必要です。 パイプライン内で接尾辞付きの数値を実数に変換するgnu-linuxユーティリティが存在しますか?これを行うために作成されたbash関数、または正規表現の置換やいくつかのsedステップの代わりに覚えやすいかもしれないperlがありますか? 38M /var/crazyface/courses/200909-90147 2.7M /var/crazyface/courses/200909-90157 1.1M /var/crazyface/courses/200909-90159 385M /var/crazyface/courses/200909-90161 1.3M /var/crazyface/courses/200909-90169 376M /var/crazyface/courses/200907-90171 8.0K /var/crazyface/courses/200907-90173 668K /var/crazyface/courses/200907-90175 564M /var/crazyface/courses/200907-90178 4.0K /var/crazyface/courses/200907-90179 | grep 200907 | <amazing suffix conversion> | awk '{s+=$1} END {print s}' 関連参照: サイズでdu -h出力を並べ替える方法 /programming/2557649/convert-memory-size-human-readable-into-actual-number-bytes-in-perl

弊社のサイトを使用することにより、あなたは弊社のクッキーポリシーおよびプライバシーポリシーを読み、理解したものとみなされます。
Licensed under cc by-sa 3.0 with attribution required.