サーバー管理者

システムおよびネットワーク管理者向けのQ&A

3
Apacheのグレースフルリスタートとユーザーエクスペリエンスの影響
運用gracefulサーバーでApacheの再起動を実行しても安全ですか?グレースフルリスタートはどのような影響を及ぼし、どのような影響がありますか(ある場合)?有害な影響はありますか(例:短時間であっても、ダウンタイム)? 私は以下のリソースを検討しましたが、ユーザーへの影響がどのようになるかはまだ不明です。 「apache2」の稼働時間を見つける http://httpd.apache.org/docs/2.2/stopping.html#graceful http://www.cyberciti.biz/faq/apache-making-changes-config-file-without-restarting/

1
IPTables:発信MySQL接続を許可しますが、着信接続は許可しません
外部ソースからmysqlへの接続を許可しないサーバーがあります。私のデータベースと接続はすべてlocalhostで行われます。iptablesのデフォルトポリシーは、指定していないポートの接続をドロップすることです(現在、iptableルールでポート3306が指定されていないため、このポートへのすべての接続がドロップされます)。 それで問題ありませんが、今度はAmazon RDSの外部にあるmysqlデータベースに接続したいと思います。 ポート3306は、次のように外部に開放できます。 iptables -t filter -A INPUT -p tcp --sport 3306 -j ACCEPT iptables -t filter -A OUTPUT -p tcp --dport 3306 -j ACCEPT これにより、Amazon RDS上のデータベースに接続できますが、サーバー上のデータベースへのリモート接続も可能になります。 サーバーがAmazonのデータベースに接続できるようにするが、サーバー上のデータベースへの外部接続を制限するにはどうすればよいですか? また、Amazon RDSインスタンスのIPアドレスは定期的に変更される可能性があることにも注意してください。
10 iptables 


2
Tomcat 8 org.apache.catalina.webresources.Cache.getResource
7.0.52から8.0.14にアップグレードしました。 多くの静的画像ファイルでこれを取得しています: org.apache.catalina.webresources.Cache.getResource [/base/1325/WA6144-150x112.jpg]にあるリソースをキャッシュに追加できません。期限切れのキャッシュエントリを削除した後、利用可能な空き容量が不足していたため、最大サイズを増やすことを検討してくださいキャッシュの 特定のリソース設定を指定していないため、7.0.52でこれを取得できませんでした。 起動時にこの問題が発生したことについては、修正されたと思われるバグレポートで発見しました。私にとって、これは起動時ではなく、リソースが要求されたときに常に起こります。 他に誰かがこの問題を抱えていますか? ありがとう。 少なくともキャッシュを無効にしようとしていますが、キャッシュを使用しないように指定する方法の例が見つかりません。属性は8のコンテキストから削除されました。リソースを追加しようとしましたが、構成を正しく取得できません。 <Resource name="file" cachingAllowed="false" className="org.apache.catalina.webresources.FileResourceSet" />

4
OS XコマンドラインIPv4インターフェースのリセット
ジュニパーのネットワークコネクトVPNクライアントは、OS Xネットワークインターフェイスが正常に切断されない場合、OS Xネットワークインターフェイスを使用できない状態のままにするようです。 編集:「正常に切断する」とは、ソフトウェアクライアントの「サインアウト」ボタンをクリックする以外の理由でVPNがドロップした場合を指します。これは、WiFiがVPNをドロップするのに十分な長さでドロップアウトした場合、またはおそらく切断を忘れてラップトップ画面を閉じた場合などに発生します。 端末から単純なpingを実行すると、次の結果が得られます。 ping: sendto: Cannot allocate memory 再起動すると問題は解決しますが、それは不便です。 ifconfigを使用してインターフェースをリセットしても機能しません。 ifconfig en0 down ifconfig en0 up どちらもルートテーブルをフラッシュしません。 route -n flush DNSキャッシュのリセットも試みました(まったく関係ありませんが、とにかく試してみると思いました)。それは明らかにうまくいきませんでした。 launchctl unload /System/Library/LaunchDaemons/com.apple.mDNSResponder.plist launchctl load /System/Library/LaunchDaemons/com.apple.mDNSResponder.plist 最終的に確実に機能したのは、IPv4をオフにしてから、次の手順を使用してオンに戻すことでした。 システム設定を開く ネットワークアイコンをクリックします 壊れたインターフェースをクリックします。 [詳細]ボタンをクリックします。 TCP / IPを選択します IPv4の設定で「オフ」を選択します。 「OK」を選択 「適用」を選択します。 手順4〜8を再度実行しますが、6を目的のIP構成方法に置き換えます。 だから私の質問に...コマンドラインから上記のステップ1から9と同じことを達成する方法はありますか?理想的には、bashスクリプトを呼び出してリセットを実行できるようにしたいと考えています。 注:これはOS X Mountain LionとOS X Yosemiteでテストされています。OS X Mavericksをスキップしたので、その特定のタグを省略したのはそのためです。これがマーベリックスにも当てはまるすべての理由がありますが、それを証明することはできません。

1
Nginxはsslで古いドメインから新しいドメインにリダイレクトします
私はから私のサイトのドメイン名を変更しようとしていますhttps://www.myolddomain.se/へhttps://www.mynewdomain.se/ 問題は、私の古いドメインの場合、すべてのページでSSLを強制したため、googleおよび他のサイトのすべてのリンクがhttpsにリンクされていることです。httpsリンクから古いドメインにアクセスしようとすると、証明書エラーが発生します。だから私の質問は、httpsにリンクされているすべてのページを、このエラーが発生することなく、nginxの別のhttpsで保護されたドメインにリダイレクトするにはどうすればよいですか? 私はいくつかの調査を行ったところ、Webページをリダイレクトするためのこのソリューションを見つけました。これは現在、私の構成ファイルに挿入されています。それでも証明書エラーが発生します! server { server_name .myolddomain.se; return 301 https://www.mynewdomain.se$request_uri; } しかし、私はそれを機能させることができません!誰かが答えを思い付くことができれば私は非常に感謝します

2
AWS認証情報を個人のマシンに安全に保存する
AWS認証情報を個人のマシンに安全に保存するにはどうすればよいですか? 詳細に: 私たちのチームの誰もが、管理タスクを実行するためにAWSセキュリティ認証情報を必要とします(認証情報はロールによって分離されます)。これらの資格情報は通常、ディスク上のいくつかの構成ファイルにプレーンテキストで格納されます。これは非常に安全ではないと思います。特に、資格情報がチームメンバーに分散され、最終的にバックアップなどに使用されることを考えると、 私はこれらの資格情報を暗号化された形式で保存することを強く望みます(たとえば、sshキーに似ています)。自動化する方法はありますか?または、たとえばopensslを使用してデータを暗号化するbashスクリプトをハッキングする必要がありますか? EC2インスタンスの資格情報を保護する方法については、Webに多くの情報があります。このAmazon IAMロールの機能さえありますが、EC2にのみ適用されます。

2
Ubuntuでの低遅延TCP設定
私のラボには、Ubuntuで実行する測定用のサーバーがあります。また、TCP接続を介してデータを受信し、できるだけ早く応答を送信するCプログラムがあります。 構成 CPU:2プロセッサx 4コア-Intel(R)Xeon(R)CPU E5345 @ 2.33GHz RAM:12 GB NIC:Intel Corporation 80003ES2LAN Gigabit Ethernet Controller / 82546EB Gigabit Ethernet Controller ネットワークスイッチ:Cisco Catalyst 2960 データ情報:データブロックは約です。各10ミリ秒。データブロックサイズは約です。1000バイト。 パケット受信時のネットワーク遅延は非常に重要です(数十マイクロ秒が重要です)。プログラムを最大限に最適化しましたが、Ubuntuを調整した経験がありません。 パケットの処理/送信のローカル遅延を減らすためにUbuntuで何を設定できますか?

10
パブリックIP経由でEC2インスタンスのサイトにアクセスできません
私はウィンドウ2008サーバーを備えたAmazon EC2マイクロインスタンスを所有しており、Javaを使用してTomcat 7サーバーにデプロイされたサンプルWebアプリケーションをそこにデプロイしました。インスタンスでローカルにアクセスできますが、AWSインスタンスの外部でアクセスしようとしたときに、AWSパブリックDNS /パブリックIPアドレス/インスタンスのElastic IPアドレスを使用して自宅のコンピューターから言うと、「Webページは利用不可"。 私はこのフォーラムで非常に多くの同様の質問をしました、そして私は彼らが求めているすべての設定を完了しましたが、それでも成功していません。 これが私が行った/確認したことです。 1. localhostが機能するため、アプリケーションはポート80でリッスンします。 2.インスタンスが使用しているセキュリティグループの下のすべてのユーザーに対して、ポート80のHTTPの受信ルールを追加しました。 3. Windowsインスタンスのファイアウォール設定を確認し、ポート80がブロックされていないことを確認しました。 4.ファイアウォールをオフにしても試しましたが、成功しませんでした。 誰かが私を助けてくれると本当にありがたいです。 ありがとう、NS

2
crontabがfopenで結果を一覧表示または編集する:権限が拒否されました
最近、ユーザーのcrontabから実行するように構成されたジョブが実行を停止しました。ユーザーのcrontabをリストまたは編集しようとすると、結果は次のようになります。 user@host:~$ crontab -l crontabs/user/: fopen: Permission denied user@host:~$ crontab -e crontabs/user/: fdopen: Permission denied 明らかにアクセス許可に関連していますが、アクセス許可がどのように変更されたかはわかりません。さらに重要なのは、アクセス許可を何に設定するかです。 / usr / bin / crontabの権限: $ ll /usr/bin/crontab -rwxr-sr-x 1 root libuuid 35896 Aug 24 2010 /usr/bin/crontab* / var / spool / cron / crontabディレクトリの権限: # ll /var/spool/cron/ total 12 drwxr-xr-x 3 root …

1
Internet Explorerを使用して長期実行データAPIのPHP / CURLを呼び出すと、Apache 2サーバーがフリーズして再起動が必要になる
Microsoft Internet Explorerブラウザーによって呼び出されない限り問題なく動作するPHPプログラムを実行しています。その後、以下のプロセスが起動され、Apache 2がロックされ、Webサーバーの再起動が必要になります(Ubuntu 12.04 LTS上)。 bob@drools:/etc/php5/apache2# ps auxwww | grep apache2 root 8737 0.1 2.5 369164 25800 ? Ssl 12:41 0:00 /usr/sbin/apache2 -k start www-data 8743 0.0 3.2 393748 33268 ? Sl 12:41 0:00 /usr/sbin/apache2 -k start www-data 8755 0.1 3.3 393856 33904 ? Sl 12:41 0:00 /usr/sbin/apache2 -k …

2
「ソースファイルが見つかりませんでした」というWindows機能のインストールが失敗する
Media FoundationRDSセッションホストとして使用する準備として、Windows 2012 R2ボックスに機能をインストールしようとしています。 ただし、インストールの試みはすべて失敗します。 Installation of one or more roles, role services, or features failed. The source files could not be found. Use the "Source" option to specify the location of the files that are required to restore the feature. For more information on specifying a source location, see …

2
SSHパスフレーズプロンプトを停止する方法 [閉まっている]
閉まっている。この質問はトピックから外れています。現在、回答を受け付けていません。 この質問を改善してみませんか? サーバー障害のトピックになるように質問を更新します。 5年前休業。 開いたばかりのサーバーがあります。としてnt_deployersshを実行すると、sshパスフレーズを要求されます。 Nets-Mac-Pro:mysite emai$ ssh nt_deployer@mysite-staging.nettheory.com Enter passphrase for key '/Users/emai/.ssh/id_rsa': nt_deployer@mysite-staging.nettheory.com's password: Welcome to Ubuntu 14.04 LTS (GNU/Linux 3.13.0-29-generic x86_64) しかし、私がとしてsshするときemai、それは尋ねません: Nets-Mac-Pro:mysite emai$ ssh emai@mysite-staging.nettheory.com emai@mysite-staging.nettheory.com's password: Welcome to Ubuntu 14.04 LTS (GNU/Linux 3.13.0-29-generic x86_64) パスフレーズプロンプトが表示されないようにする方法を教えてもらえますかnt_deployer?
10 ssh 

1
Supermicro IPMIがプレーンテキストの管理者パスワードでWebを介して侵害されているかどうかを確認するにはどうすればよいですか?
私はいくつかのSupermicroサーバーでIPMIを実行しています。このブログ(http://blog.cari.net/carisirt-yet-another-bmc-vulnerability-and-some-added-extras)で説明されているように、重大な脆弱性があります。リモートの場所からプレーンテキストの管理者パスワードを取得します。 サーバーのマザーボードが侵害されているかどうかを確認するにはどうすればよいですか?

1
監視構成の再読み込み-監視対象サービスを再起動するはずですか?
UbuntuサーバーでMonit 5.4を実行します。を使用するとmonit reload、監視対象サービス(この状況ではTomcat 7)が再起動されるようです。予想される動作ですか?ドキュメンテーションは言う: reload-実行中のMonitデーモンを再初期化します。デーモンは構成を再読み取りし、ログファイルを閉じて再度開きます。 サービスを再起動せず、設定のみをリロードすることを期待しています。このようにして、電子メールアラートやその他のものを変更できます。 これはの出力です monit status The Monit daemon 5.4 uptime: 15h 0m Process 'tomcat7' status Running monitoring status Monitored pid 38842 parent pid 1 uptime 14h 30m children 0 memory kilobytes 3445964 memory kilobytes total 3445964 memory percent 10.4% memory percent total 10.4% cpu percent 14.8% …
10 ubuntu  service  monit  daemon 

弊社のサイトを使用することにより、あなたは弊社のクッキーポリシーおよびプライバシーポリシーを読み、理解したものとみなされます。
Licensed under cc by-sa 3.0 with attribution required.