サーバー管理者

システムおよびネットワーク管理者向けのQ&A

5
apt-get updateがapt-get updateを実行するように指示するのはなぜですか?
だから私はこれを続けています: # apt-get update Get:1 http://ftp.us.debian.org etch Release.gpg [1032B] Hit http://ftp.us.debian.org etch Release (...bunch more of this elided...) Hit http://ftp.us.debian.org etch/contrib Sources Fetched 68.8kB in 1s (37.4kB/s) Reading package lists... Done W: There is no public key available for the following key IDs: 9AA38DCD55BE302B W: GPG error: http://ftp.us.debian.org etch Release: …
10 linux  debian  apt  gpg 

4
.bashrcがcygwinで読み取られないのはなぜですか?
私の.bashrcは次のようになります。 alias name@server="ssh server sname" echo "bashrc read" このechoステートメントは、読み取られたかどうかを確認するためのものです。しかし、エコーは何もしません。より高速なsshのエイリアスを、リモートボックスで機能するエイリアスである特定のコマンドを実行するボックスに設定したい。
10 bash  cygwin  bashrc 

8
これはファイルサーバーのアクセス許可に推奨される/有効な方法ですか?
ファイルサーバーはIT業界では当たり前のことであり、グループを作成してクライアント上の共有フォルダーへのクライアントアクセスを管理するためのアクセス許可を適用する方法について、一般に受け入れられている慣行(ここでは「ベスト」という言葉を使うのをためらいます)があるかどうか知りたいです。ファイルサーバー。 私の現在の仕事では、ACLの数十のグループから個々のユーザーを直接ファイルシステムに置くだけに至るまで、これを行うためのさまざまな方法をかなり混乱させてしまいました。私の仕事は、混乱を解消し、会社全体でこれに対処するためのある種の標準化された方法(大規模な環境、15万人の従業員、9万人のクライアントコンピューター、数百のファイルサーバー)を考案することでした。 この問題についての私の理解から、保護されたリソースごとに必要なアクセスレベルごとに少なくとも1つのグループが必要であるようです。このモデルは、別のアクセスレベルをサポートする必要がない限り、ファイルシステムのアクセス許可に再度触れる必要がないという点で、最も柔軟性が高いようです。欠点は、複数の共有リソースで同じグループを再利用するよりも多くのグループを作成することです。 ここに私が何を意味するかを示す例があります: FILE01という名前のファイルサーバーに "Test Results"という共有があり、読み取り専用アクセス、読み取り/書き込みアクセス、およびフルコントロールが必要なユーザーがいます。1つの保護されたリソース* 3つのアクセスレベル= 3つのセキュリティグループ。AD環境では、これらをユニバーサルグループとして作成するため、フォレスト内の任意のドメインからユーザー/グループを簡単に追加できます。各グループは共有フォルダとアクセスレベルを一意に参照するため、グループ名にはこれらの「主要な」データが組み込まれ、権限は次のようになります。 "FILE01-Test Results-FC" -- Full Control "FILE01-Test Results-RW" -- Read & Write "FILE01-Test Results-RO" -- Read Only 通常、ビルトインSYSTEMアカウントと、フルコントロールアクセス権を持つビルトインAdministratorsも含まれます。この共有へのアクセス権を実際に誰が取得するかに対する変更は、ACLに触れる必要なく、グループメンバーシップを使用して処理できるようになりました(マネージャー、技術者、QAアナリストなどの特定のビジネスロールを表す「ロール」グループを追加するか、または個人のみ) 1回限りのアクセスのユーザー)。 2つの質問: 1)これは実際にアクセス許可を処理するための推奨または有効なアプローチですか、それともより単純でエレガントなソリューションが欠けていますか?私は特に、継承を使用するソリューションに興味がありますが、物事が変わったときにファイルシステムの大部分を再ACLする必要がないという柔軟性を保持しています。 2)環境内でファイルサーバーのアクセス許可とグループ構造をどのように処理していますか?大規模な環境でも作業している人にはボーナスポイント。

5
Sambaを使用してWindows共有に接続すると「NT_STATUS_DUPLICATE_NAME」が返される
Windowsマシンに共有ディレクトリを設定し、username @ workgroupにフルコントロールのアクセス許可を与えました。 Linuxでsmbclientを使用してWindowsマシンに接続しようとすると、エラーが発生しますNT_STATUS_DUPLICATE_NAME。これが筆記録です: $ smbclient -U username -W workgroup -L //windows-machine Enter username's password: Domain=[workgroup] OS=[Windows 5.1] Server=[Windows 2000 LAN Manager] tree connect failed: NT_STATUS_DUPLICATE_NAME 意図的に間違ったユーザー名、パスワード、またはワークグループを入力すると、別のエラーが発生しますNT_STATUS_LOGON_FAILURE。だから私は他の情報を正しく取得しているようです。 windows-machineIPアドレスを指すエントリを/ etc / hostsに配置しました。WindowsマシンのNetBIOS名は異なります。 このエラーの意味を誰かが知っていますか?

7
IPv6に適したIPアドレス管理ソリューションには何がありますか?[閉まっている]
閉まっている。この質問は、オフトピック。現在、回答を受け付けていません。 この質問を改善してみませんか? サーバー障害のトピックになるように質問を更新します。 8年前休業。 IPv4アドレス管理に使用できるオープンソースのIPAMツールは多数あります。ただし、IPv6で使用できるアクティブに更新されるツールが明らかに不足しているようです。 FreeIPdb(コードはもう保守されていません)またはRIPEデータベース(エンタープライズ/ ISP IPAMを可能にするRIPEdbのカスタマイズをいくつか見ましたが、おそらく/ 32相当のスペースしか処理しないシステムにとってはやり過ぎのようです)以外。 他に欠けているオプションはありますか? (データベースのみ。viをフラットテキストIPAMに使用できることを知っています。それが、現時点で/ 32を処理している方法ですが、それよりもずっと長くスケーリングすることはありません) オープンソースである必要はありませんが、デュアルスタック環境でIPv6を管理するために何をしているのですか
10 networking  ipv6  ipam 

11
スワップパーティションはどのくらいの大きさにする必要がありますか?
数年前から、RAMの2倍のスペースを持つスワップパーティションを作成することをお勧めします。それは今日も当てはまりますか?またはこれはもう必要ありませんか? 8 GiBのRAMを搭載したサーバーがあり、スワップパーティションを作成する必要があります。16GiBが多すぎるのではないかと思っていました。
10 linux  memory  partition  swap 

3
WPAとWPA2のセキュリティに関する考慮事項
複数のオフィスにまたがる既存のWEPインフラストラクチャを置き換えるため、WPAからWPA2(両方のPSK)へのアップグレードの価値を比較検討しています。WPA2をサポートしないデバイスにはいくつかの種類があるため、そのプロトコルに移行すると追加のコストがかかります。 私が知りたいのは、WPA-PSKワイヤレスネットワークに対する脅威は何ですか?その情報により、アップグレードのコストとセキュリティの脅威のバランスをとることができます。
10 security  wifi  wpa 


7
無料のWindowsサーバーのウイルス対策プログラムとファイアウォールプログラム?
ロックされています。この質問とトピックへの回答はロックされています。質問はトピックから外れていますが、歴史的に重要です。現在、新しい回答や相互作用を受け入れていません。 Windows Server 2003にインストールできる無料のWindowsサーバーウイルス対策およびファイアウォールプログラムにはどのようなものがありますか? 私のサーバーの主なサービスは、PHP WebサイトといくつかのVB.NETソケットサーバーをホストすることです。

6
名前解決の一時的な失敗:ホスト名の検索の失敗
PHPで何ヶ月も問題なく動作しているスクリプトがあります。最近は機能しなくなりました。 このスクリプトはGmailに接続して、顧客にメールを送信します。 最近、スクリプトを実行するとこのエラーが発生し始めました。 The SMTP connection failed to start [tls://smtp.gmail.com:465]: fsockopen returned Error Number 0 and Error String 'php_network_getaddresses: getaddrinfo failed: Temporary failure in name resolution' 覚えておいてください、これはコード変更なしでした。 私は私のresolv.confを見ました、そしてそれは大丈夫であるように見えます: nameserver 208.67.222.222 私はgmail.comにpingできます: # ping smtp.gmail.com PING gmail-smtp-msa.l.google.com (74.125.93.111) 56(84) bytes of data. 64 bytes from qw-in-f111.google.com (74.125.93.111): icmp_seq=1 ttl=247 time=26.7 ms …

1
MySQLサーバーへのリモート接続に非常に時間がかかる
LinuxノートブックでMySQL 5.0.75サーバーを実行しており、ローカルネットワークの別のマシンから接続したい。 この接続には5〜6秒かかります。 mysql -h 172.22.65.101 -u myuser -p123 MySQLホストへのping: PING 172.22.65.101 (172.22.65.101) 56(84) bytes of data. 64 bytes from 172.22.65.101: icmp_seq=1 ttl=64 time=0.799 ms 64 bytes from 172.22.65.101: icmp_seq=2 ttl=64 time=0.000 ms 64 bytes from 172.22.65.101: icmp_seq=3 ttl=64 time=6.43 ms 64 bytes from 172.22.65.101: icmp_seq=4 ttl=64 time=0.000 ms 64 …


18
大量のRAMを備えたサーバーを構築する費用対効果の高い方法
ロックされています。この質問とトピックへの回答はロックされています。質問はトピックから外れていますが、歴史的に重要です。現在、新しい回答や相互作用を受け入れていません。 スケーラビリティが主にRAMによって制限されているJavaアプリケーションがあり、それをデータセンターの1つ以上のサーバーで実行したいと考えています。100GB-512GB以上のRAMに対応できるサーバーハードウェアはどこで探すべきですか?私はそのような問題の専門家ではないので、どこから始めればいいのか本当にわかりません。 これはスーパーコンピュータの領域(6桁以上)に入っているのですか、それとも5桁の低価格でそのようなサーバーを入手できますか? 以下のいくつかの質問に基づくいくつかのメモ: はい、私はこのスケーラビリティ要件を削除する方法を考えようと懸命に努力してきましたが、それは実際には選択肢ではありません。アプリケーションは基本的に、非常に大量のデータへの非常に高速なランダムアクセスを必要とするため、(おそらくデータベースを介して)ハードディスクに保存してもデータを削減できません。 少なくとも理論的には、JVMはそれまでスケールアップできると確信しています。目立った問題なしに、Sun 1.6 JVMに10GBを割り当ててコードを定期的に実行しています。
10 memory  hardware 

17
Windows用の安価なネットワーク監視ツール
ロックされています。この質問とトピックへの回答はロックされています。質問はトピックから外れていますが、歴史的に重要です。現在、新しい回答や相互作用を受け入れていません。 小規模ネットワーク向けの無料または安価なWindowsベースのネットワーク監視ツールを探しています。私はNagiosに精通していますが、私たちはWindowsのみのショップを運営しており、1台の奇妙なLinuxマシンについて心配したくありません。どのようなオプションがありますか? (注:私はこの質問を読みましたが、特にWindowsソフトウェアを探しています)

6
人形のホスト名の問題
オンラインで検索したところ、他の数人が他のリスト/ボードでこの問題を抱えていることがわかりました。マスターサーバーで証明書に署名した後、2回目にsudo puppetd ​​--waitforcert 60 --testを実行すると、このエラーが発生します- notice: Got signed certificate warning: Certificate validation failed; considering using the certname configuration option err: /File[/var/lib/puppet/lib]: Failed to generate additional resources during transaction: Certificates were not trusted: hostname was not match with the server certificate どのような問題があり、どのように修正するかを理解できません。だから私は尋ねる理由です。 LAN上の2台のサーバーにパペットを設定しています。puppetmasterは「puppet」、その他のサーバーは「puppetclient」という名前です。私はpuppetclientの/ etc / hostsにパペットを入れました。 hostname -fを実行すると、それぞれのサーバー上のpuppetとpupperclientが表示されます。他に何を試したらよいかわかりません。誰か洞察力がありますか?

弊社のサイトを使用することにより、あなたは弊社のクッキーポリシーおよびプライバシーポリシーを読み、理解したものとみなされます。
Licensed under cc by-sa 3.0 with attribution required.