サーバー管理者

システムおよびネットワーク管理者向けのQ&A

2
断片化されたTCPフラグメントがTCPサーバーに保持される期間
特定のTCPフラグメントが2つのIPデータグラムにフラグメント化され、最初のデータグラムはTCPサーバーに到着するが、2番目のデータグラムは到着しないと仮定します。 一定時間後、TCPサーバーはキープアライブを送信し、クライアントが生きていると判断します。次に、TCPサーバーはこの最初のデータグラムをどのように処理しますか?2番目のデータグラムの到着を待つのですか、それとも最初のデータグラムを破棄しますか?
10 ip  tcp 

4
HP ProliantサーバーおよびUbuntu 12.04のディスク/ RAIDモニタリング
Ubuntu 12.04を使用して、HP ProliantサーバーのハードディスクとRAIDのステータスを監視するにはどうすればよいですか。Ubuntu 10.04では、cciss-vol-statusを使用してRAIDステータスを定期的に照会できましたが、cciss-vol0-statusは12.04では機能しなくなりました。12.04では、/ proc / driver / ccissまたは/ dev / ccissディレクトリはありません。

2
SNIは私のWebサイト訪問者のプライバシーの問題を表しますか?
まず、英語が下手でごめんなさい。私はまだそれを学んでいます。ここに行く: IPアドレスごとに1つのWebサイトをホストする場合、「純粋な」SSL(SNIなし)を使用でき、ユーザーが取得したいホスト名とパスをユーザーに通知する前にキー交換が発生します。鍵交換後、すべてのデータを安全に交換できます。とはいえ、誰かが偶然ネットワークを盗聴したとしても、機密情報は漏洩しません*(脚注を参照)。 一方、IPアドレスごとに複数のWebサイトをホストする場合は、おそらくSNIを使用するため、Webサイトの訪問者は、適切な証明書を提供する前に、ターゲットホスト名を通知する必要があります。この場合、自分のネットワークを盗聴した誰かが、自分がアクセスしているすべてのWebサイトドメインを追跡できます。 私の仮定に誤りはありますか?そうでない場合、ユーザーが暗号化されたDNSも使用していることを前提として、これはプライバシーの問題を表していませんか? 脚注:スニファーがIPアドレスを逆引きして、どのWebサイトにアクセスしたかを確認できることも理解していますが、ネットワークケーブルを介してプレーンテキストで移動するホスト名は、検閲当局にとってキーワードベースのドメインブロッキングを容易にするようです。
10 ssl  https  privacy  sni 

1
SmartOSにエクスポートすると、SMFマニフェストが構成データを失うのはなぜですか?
JoyentのBase64 1.8.1 SmartOSイメージのSMF(サーバー管理機能)でサーバープロセスを実行しています。 SmartOSを使用していない場合は、KVMを使用したIllumOSのクラウドベースのディストリビューションです。しかし、本質的にはSolarisのようなもので、OpenSolarisを継承しています。SmartOSを使用していない場合でも、ServerFaultに関するSolarisの知識を活用したいと思っています。 私の問題は、権限のないユーザーに、所有しているサービスの再起動を許可することです。私は、RBACを使用し、承認を/etc/security/auth_attrユーザーに追加して、その承認をユーザーに関連付けることで、その方法を考え出しました。 次に、サービスのSMFマニフェストに以下を追加しました。 <property_group name='general' type='framework'> <!-- Allow to be restarted--> <propval name='action_authorization' type='astring' value='solaris.smf.manage.my-server-process' /> <!-- Allow to be started and stopped --> <propval name='value_authorization' type='astring' value='solaris.smf.manage.my-server-process' /> </property_group> そして、これはインポート時にうまく機能します。権限のないユーザーが、独自のサーバープロセスを再起動、開始、および停止することを許可されています(これは自動コード展開用です)。 ただし、SMFマニフェストをエクスポートすると、この構成データは失われます...そのセクションに表示されるのはこれだけです。 <property_group name='general' type='framework'> <property name='action_authorization' type='astring'/> <property name='value_authorization' type='astring'/> </property_group> なぜこれが起こっているのか誰か知っていますか?構文が間違っていますか、それとも単にSMFを誤って使用していますか?

4
すべてを人形にするかどうか?
注意:理論的な質問がたくさんあります。 最近、私はPuppet(および同様のシステム)について読んでいます。これは、私が信じているように、私の作業を非常に簡単にすることができます。しかし、私が「操り人形」にできるすべてのことを理解しようと試みますが、残念ながらできません。「クラウド」またはHAクラスターを想像できます。ここで、より多くのサーバー上の同じ構成です。しかし、ワークステーションはどうですか?1台のPC(centosとkvm)、1台のノートブック(fedora)、およびパーソナルサーバーを持っていますが、パペット化できますか(またはすべきですか)。(不利な点)とは何ですか?または、私たちの会社には何百ものサーバー(主にセントーソ)がありますが、それぞれのサーバーは少し異なります。1つの場所に多くの構成を配置する方が良いかどうかを判断できません。このトピックに関するあなたの意見やリンクを喜んで提供します。
10 linux  centos  puppet  cms 

7
Windows Serverバックアップを使用した複数のUSBバックアップターゲット
Windows Server 2012バックアップスケジュールに複数のUSB外部ディスクターゲットを追加しようとしています。 追加のターゲットを追加するためにGUIの手順を実行した後、プロセスはエラーで失敗しますThe system cannot find the path specified。 私はこの記事の手順に従いました: オプション1は初心者ではありません。リムーバブルディスクが12枚以上あり、USBハブがいっぱい入った箱を購入して、これらすべてのディスクをサーバーラックの背面にぶら下げたくありません。したがって、この例では、記事はステップ3に進むことを提案しています。 オプション2は、明らかな理由により、オプションではなくバックアップスケジュールから古いディスクを削除します。 オプション3はコマンドの実行を提案しWBADMIN ENABLE BACKUP -addtarget:{DISKGUID}ますが、これはエラーメッセージで失敗しますERROR - The specified backup location could not be found or is not a supported backup storage location。 オプション3で成功したと報告しているスレッドがたくさんありますが、私のような他のスレッドではまったく同じ問題があります。 イベントログとディレクトリ内のファイルを確認しましC:\Windows\Logs\WindowsServerBackupたが、役に立ちませんでした。また、ディスク上のボリュームを削除してプロセスを繰り返し、ディスク上にNTFSボリュームを事前に作成してみました。 関連性がある場合は、フォーマットされていない容量が2 TB(フォーマットされた1.82 TB)の一連のUSBディスクを使用しています。 他に誰かがこの問題を抱えて、なんとか解決しましたか? アップデート1 答えこの質問は、 GUIDなどの前後に引用符を置くことを示唆しましたWBADMIN ENABLE BACKUP -addtarget:"{DISKGUID}"。これは、デバイスをフォーマットするかどうかを尋ねるので、さらに一歩進みますが、フォーマット後、エラーで失敗しますThe system cannot find the …

4
Windows Server 2012で劣化した仮想ディスクを解決する方法
Windows Server 2012の新しい記憶域スペース機能を使用しています。次のディスクがあります。 FriendlyName CanPool OperationalStatus HealthStatus Usage Size ------------ ------- ----------------- ------------ ----- ---- PhysicalDisk2 False OK Healthy Auto-Select 2.73 TB PhysicalDisk3 False OK Healthy Auto-Select 2.73 TB PhysicalDisk4 False OK Healthy Auto-Select 2.73 TB PhysicalDisk5 False OK Healthy Auto-Select 2.73 TB 別のOSディスクもあります。上記のディスクは、単一のストレージプールの一部です。 FriendlyName OperationalStatus HealthStatus IsPrimordial IsReadOnly ------------ …

4
LinuxへのPHP拡張機能のインストール
我慢してください。私はサーバー管理者ではなく開発者です。私の会社はMagentoの使用を検討しています。ApacheとPHPがインストールされた事前構成済みのLinuxサーバーを渡されましたが、Magentoセットアップを実行しようとすると、ロードする必要があるPHP拡張機能があることがわかります。私はphp.iniファイルを編集できますが、拡張機能をどこで入手するか、またはどのようにインストールするかがわかりません。 誰か私に手を貸してくれませんか?PDO_MySQL、mcrypt、GD拡張機能が必要です。ターミナルからのダウンロードとコードのコンパイルについて話しているサイトを検索して見つけましたが、それは私の頭の中にあります。これを行う簡単な方法はありますか?
10 php  linux 

3
本番環境で自己署名証明書の代わりにcacert SSL証明書を使用することは良い考えですか?
職場では、プレーンなhttpまたは自己署名証明書(ロードバランサー管理インターフェイス、内部wiki、サボテンなど)を使用する多数のWebインターフェイスがあります。 特定のVLAN /ネットワークの外部から到達できるものはありません。 自宅で使用する場合は、cacert SSL証明書を使用します。 私は雇用主に自己署名証明書とプレーンhttpの代わりにcacert SSL証明書を使用するように勧めるべきかどうか疑問に思っていました。誰でも本番環境でcacert sslを使用していますか?賛否両論は何ですか?セキュリティは向上しますか?管理は簡単ですか?予期しないことはありますか?品質スキャンに影響はありますか?どうすればそれらを納得させることができますか? もちろん、公開ウェブサイトの有料証明書は変更されません。 編集: (好奇心旺盛)企業からの無料のssl証明書はクラス3ではないようです。パスポートを提示し、物理的に立ち会ってcacertsからクラス3を取得する必要がありました。各クラス1のブラウザーに警告はありませんか? とにかく、私は無料のCAについて同じ質問をします。自己署名されたプレーンなhttpを使用するよりも良いですか、そしてなぜですか? 管理を容易にするために、サーバー側で行います。見逃したことはありますか? 免責事項:私はCacert Associationのメンバーではなく、Assurerでもなく、通常のハッピーユーザーです。
10 security  ssl 

1
トンネルインターフェイスでのIOS QOSサービスポリシーパススルー
1つのネットワーク上にIPIPトンネルを経由してサーバーに到達するSIP電話がいくつかあります。 次のように、適切なVOIPトラフィックを監視するQOSルールを設定しました。 class-map match-any class-voice description Voice match dscp af11 match dscp cs4 match dscp cs3 ! policy-map qos-out class class-voice priority 100 ! interface Tunnel1 description Tunnel to VOIP Server ip address 10.10.0.2 255.255.255.252 tunnel source FastEthernet0/1 tunnel destination 172.16.100.100 tunnel mode ipip ! interface FastEthernet0/1 description Internet bandwidth …
10 ios  qos 

1
Active Directory:コンピュータのログオンプロセスとユーザーのログオンプロセスの違いは何ですか?
ユーザーとコンピューターは、Active Directoryに関して同等の原則として扱われると言って間違いありません。ユーザーとコンピューターの両方にパスワードがあり、ユーザーとコンピューターの両方がドメインに個別にログオンする必要があります。 自動的に起動するNetLogonサービスが、起動時にコンピューターをドメインにログオンする責任があることを理解しています。そのとき、NetLogonはDNSルックアップを介してドメインコントローラロケータロジックを使用して、ドメインコントローラを見つけます。 コンピュータが以前にドメインにログオンしたことがあり、それがどのサイトに属しているかがわかっている場合は、サイト固有のDNSクエリから開始してDCを特定し、必要に応じてより一般的なDCにフェイルバックできます。 これまでの私の仮定に誤りがある場合は、修正してください。 それでは、ユーザーはコンピューターにログインするときに、コンピューターにログオンするときに別のDCロケータープロセスを持っているのでしょうか。または、ユーザーがログオンしたときにコンピューターがすでに思いついたものを使用しますか?コンピューターとそのコンピューターにログオンしているユーザーが異なる認証DCを持つことは可能ですか?

2
スクリプトでGNU画面内から実行されているかどうかを確認することはできますか?
リモートサーバーで長時間実行されるプロセスがあり、手動で開始される場合があります。残念ながら、インターネット接続が停止し、カーネルがパニックに陥り、ジョブの接続と開始に使用されるsshセッションが他の多くの課題に直面する可能性があります。 画面は、プロセスが中断されないようにするための完璧な方法のようです。ただし、画面を開始することを常に覚えてからスクリプトを実行してプロセスを開始することを人に頼ることは、発生するのを待つ問題です。スクリプトが画面内から呼び出されているかどうかを確認できるスクリプトからの方法はありますか?そうである場合、プロセスは続行します。それ以外の場合、スクリプトはユーザーに最初に画面を実行するように指示するメッセージで終了します。
10 gnu-screen 



1
デバイスに空き容量はありません—ですが空き容量があります
奇妙な問題があるVMware仮想化環境でUbuntu 12.04.1サーバーを実行しています。今度は2回、一見ランダムな時間に、十分な空き容量があるように見えても、マシンが突然ルートパーティションに書き込むことができなくなりました。私は何が悪いのかを理解しようとして途方に暮れています。 「df -h」は、40%以上の空き容量があるすべてのマウントされたボリュームを表示します。どちらの場合もこれが発生し、再起動すると数分間解決し、その後「デバイスに空き容量がありません」というメッセージに戻りました。スナップショットからの復元はそれをより長く修正するように見えますが、これが再び起こったので、それをどうするかわかりません。 問題がなければ、マシンはCUPS 1.5.3およびSamba 3.6.3を実行しているネットワークプリントサーバーです。

弊社のサイトを使用することにより、あなたは弊社のクッキーポリシーおよびプライバシーポリシーを読み、理解したものとみなされます。
Licensed under cc by-sa 3.0 with attribution required.