サーバー管理者

システムおよびネットワーク管理者向けのQ&A

4
リストが空のときにforeachループを保護する
Powershell v2.0を使用して、X日より古いファイルを削除します。 $backups = Get-ChildItem -Path $Backuppath | Where-Object {($_.lastwritetime -lt (Get-Date).addDays(-$DaysKeep)) -and (-not $_.PSIsContainer) -and ($_.Name -like "backup*")} foreach ($file in $backups) { Remove-Item $file.FullName; } ただし、$ backupsが空の場合、次のようになります。 Remove-Item : Cannot bind argument to parameter 'Path' because it is null. 私はもう試した: foreachを保護する if (!$backups) Remove-Itemの保護 if (Test-Path $file -PathType …
10 powershell 

1
マルチドメインフォレストで、インフラストラクチャマスターのすべてではなく一部がグローバルカタログにある場合、どうなりますか?
TechNetの記事の多くは次のようにありますが、この1かについての深さで多くの情報がないとそれはインフラストラクチャマスタはまた、グローバルカタログである場合にはファントムオブジェクトは更新されませんことを言うが、以外に、実際にこの中で起こるが、構成。 次のような構成を想像してください。 |--------------| | example.com | | | | dedicated IM | |--------------| | | | |-------------------| | child.example.com | | | | IM on a GC | |-------------------| にchildは、両方がグローバルカタログである2つのDCがあります。つまり、インフラストラクチャマスターの役割はGCにあります。また、GC exampleではない DC上にインフラストラクチャマスターの役割を持つ3つのDCがあります。 私は通常、すべてをGCにすることが最善であり、この種のことを心配する必要はないことを理解していますが、そうではないと仮定すると、このような設定から予想される正確なエラー動作と、どのドメイン( s)この動作は現れるのでしょうか?子供か親か?

4
/var/log/auth.logが失敗したSSH試行をログに記録しない
サーバーで失敗しました(ユーザー名、パスワード、またはその両方が正しくありません)。 / etc / ssh / sshd_configを # Logging SyslogFacility AUTH LogLevel INFO に # Logging SyslogFacility AUTH LogLevel VERBOSE 以来、ランダムなパスワードを使用して既存のユーザーと存在しないユーザーの両方で複数のssh試行を試みたため失敗しました。/var/log/auth.logを確認しても何も表示されず、完全に空白です。 何が欠けていますか?他のプロセスもシステムにインストールして実行する必要がありますか?Ubuntuを実行しています。 この問題に関するヘルプやガイダンスは大歓迎です。 ありがとう

1
Kerberos認証、サービスホスト、およびKDCへのアクセス
Webアプリケーション(ホスト名:service.domain.com)があり、Kerberos認証を使用して、Windowsドメインにログインしているユーザーを識別したいと考えています。Microsoft AD(Windows Server 2008 R2)はKerberosサービスを提供しています。 このサービスは、Spring Security Kerberos拡張ライブラリを使用してSPNEGO / Kerberosプロトコルを実装するJava Webアプリケーションです。ADでkeytabファイルを作成しました。これには、Webアプリケーションを使用してクライアントブラウザーから送信されるKerberosチケットを認証するのに十分な共有シークレットが含まれています。 私の質問は、サービスホスト(service.domain.com)がKDC(kdc.domain.com)へのファイアウォールアクセス(TCP / UDP 88)を持っている必要があるか、またはサービスホストがKerberosチケットと認証を提供しますか?



3
vsftpdはMD5で暗号化されたパスワードを受け入れません
仮想ユーザーが自分のスペースにアクセスできるようにvsftpdでサーバーを設定しています。現在は完全に機能していますが、CRYPTパスワードでのみ機能します。そう sudo htpasswd -c /etc/vsftpd/ftpd.passwd phpmyadmin ログインできませんが、 sudo htpasswd -c -d /etc/vsftpd/ftpd.passwd phpmyadmin 意志。 /etc/vsftpd.conf listen=YES anonymous_enable=NO local_enable=YES write_enable=YES local_umask=022 nopriv_user=vsftpd virtual_use_local_privs=YES guest_enable=YES user_sub_token=$USER local_root=/var/www/vhosts/$USER.universe.local chroot_local_user=YES hide_ids=YES guest_username=vsftpd /etc/pam.d/vsftpd auth required pam_pwdfile.so pwdfile /etc/vsftpd/ftpd.passwd crypt=2 account required pam_permit.so crypt=2 ソースとPHPからapache2.4.3をインストールしました。 私が試したこと: グーグルたくさん crypt = 2を設定 友人に尋ねる SHAを使用(どちらも機能しない) htpasswdとvsftpdを更新 私はこれに1週間も苦労してきました。
10 ftp  pam  vsftpd  md5 

3
特定のサービスのWindowsイベントログを無効にできますか?
AzureのWindows Server 2008 VMで実行されているレガシーアプリケーションがあり、Windowsイベントログを毎分スパムしている。イベントログに書き込んでいるコードのソースにはアクセスできません。dllファイルのみです。それは私がやりたいほど巨大なソフトウェアであるため、私はそれを書き直すこともできません。 だから私の質問は... とにかく私が特定のメッセージのイベントソースをブロックすることはありますか?イベントソース全体がログに記録されるのをブロックしたくないのは明らかです。問題が発生したときに役立つ情報がログに記録されるためです。これは、この1つの特定のメッセージがサーバーログを詰まらせて非常に煩わしくなっているためです。

2
「レイヤー2隣接」の意味を誰かに教えてもらえますか?
新しいデータセンターのロールアウトの論理トポロジの設計に取り組んでいます。「Cisco Data Center Infrastructure 2.5 Design Guide」を読んでいて、多層設計を進めています。この設計には、ループレイヤー2やループフリーなど、複数のオプションがあります。 ループ設計の利点は、それを必要とするサーバーのレイヤー2隣接性であると述べています。ループのないトポロジでは、レイヤ2の隣接関係が「1組のアクセススイッチ」に限定されているようです。 これの意味がよくわかりません。私はそれがサーバーから別のレイヤー2の「ホップ」の数を参照していると思いますが、どちらの場合も、VLANを通過するには、トラフィックがアグリゲーションレイヤー(L2 / L3スイッチを想定)までのトリップを必要とするようです。同じVLANについて話している場合、同じVLAN上のサーバーは通信するためにaggレイヤーまでトラバースする必要があるため、ループのない例では接続されたスイッチへの直接のトリップのように見えるため、ループがさらに悪化しているように見えます。 誰かが私の誤解に光を当てることができますか?

2
NginxからPHPにカスタムパラメータを渡す方法は?
パスとNginx 1.2.4組み合わせて使用してPHP-FPM 5.4.8おり、fastcgiカスタムパラメータをに渡そうとしていますPHP。これまでに見つけたオプションは次のとおりです。 envディレクティブを使用して環境変数を設定し、nginxで、getenv()または$_ENVからフェッチしPHPます。問題はenv、mainコンテキストでのみパラメーターを設定する必要があるのに対し、コンテキストでのみ動作するserverことです。 fastcgi_paramそのために設計されたディレクティブを使用します。 を使用して一部のパラメーターの値を変更しようとしましfastcgi_paramたが、失敗しました: nginx: fastcgi_param PATH_INFO "/var/tmp"; PHP: 私は見つけることができるすべての事前定義された配列をチェックしました: echo '<pre>'; echo "\n".'$GLOBALS'."\n"; var_dump($GLOBALS); echo "\n".'$_SERVER'."\n"; var_dump($_SERVER); echo "\n".'$_GET'."\n"; var_dump($_GET); echo "\n".'$_POST'."\n"; var_dump($_POST); echo "\n".'$_FILES'."\n"; var_dump($_FILES); echo "\n".'$_REQUEST'."\n"; var_dump($_REQUEST); echo "\n".'$_SESSION'."\n"; var_dump($_SESSION); echo "\n".'$_ENV'."\n"; var_dump($_ENV); echo "\n".'$_COOKIE'."\n"; var_dump($_COOKIE); echo "\n".'$php_errormsg'."\n"; var_dump($php_errormsg); echo "\n".'$HTTP_RAW_POST_DATA'."\n"; var_dump($HTTP_RAW_POST_DATA); echo "\n".'$http_response_header'."\n"; var_dump($http_response_header); …
10 php  nginx  fastcgi  php-fpm 

5
1台のコンピューターの1人のユーザーにのみGPOを適用する
ユーザーに適用する必要があるGPOがありますが、ユーザーDOMAIN\DumbGuyがログオンしたときのみDOMAIN\DumbGuysComputer$です。ときDOMAIN\NiceReceptionistにログオンするDOMAIN\DumbGuysComputer$には、適用しないでください。ときDOMAIN\DumbGuyにログオンするDOMAIN\ReceptionstsComputer$には、適用しないでください。 1台のコンピューターで1人のユーザーにのみ適用する必要があります。 GPOをユーザーオブジェクトに適用すると、彼のすべてのコンピューターに適用されます。GPOをコンピューターオブジェクトに適用すると、そのコンピューター上のすべてのユーザーに適用されます。両方に当てはめればさらに広がります。 1台のコンピューター上の1人のユーザーにGPOを適用するにはどうすればよいですか?

2
Icinga Webにホスト/サービスが表示されない
icinga 1.8とicinga webを新しくインストールした後、いくつかのホスト/サービスを追加して、icingaサービスを再起動しました。次に、画面上部の[管理]をクリックしてキャッシュをクリアすることにより、Webインターフェイスを介してicinga webのキャッシュをクリアしました。次に、icinga-webインターフェースをリロードしましたが、新しく追加されたホスト/サービスは表示されませんでした。 icingaのログに問題は/etc/init.d/icinga showerrors表示されません。実行してもエラーや警告は表示されません。 私はあらゆる場所で解決策を探し、icingaからすべてのドキュメントを読みましたが、この問題への言及はどこにも見つかりませんでした。
10 icinga 

1
MCEメッセージを解釈するにはどうすればよいですか?
最近/var/log/messages、私たちのサーバーの1つ(以下)で発生した多くのエラーに気づきました。ただし、mceクライアントは、syslog内のデコードされたエントリよりもエラーの原因を特定できていないようです。MCE出力を解釈するために使用するある種のキーはありますか? Nov 12 04:19:19 areion kernel: [14698753.176035] Machine check events logged Nov 12 04:19:19 areion mcelog: HARDWARE ERROR. This is *NOT* a software problem! Nov 12 04:19:19 areion mcelog: Please contact your hardware vendor Nov 12 04:19:19 areion mcelog: MCE 0 Nov 12 04:19:19 areion mcelog: CPU 0 BANK 8 …
10 debian  linux 

3
*ユーザーログを保存するためのnix規則?
ユーザーに代わって実行されるプロセスの従来のログの場所は何ですか? ~/.foo/logs/ —私の一番の選択ですが、それほど素晴らしいものではありません /var/log/foo.uid/ —非システムユーザーはここではディレクトリを作成できません。最初に作成するには協力が必要です。 の共通ファイル/var/log/(例:/var/log/foo.log)—非公開ではありません 等
10 linux  unix  logging 


弊社のサイトを使用することにより、あなたは弊社のクッキーポリシーおよびプライバシーポリシーを読み、理解したものとみなされます。
Licensed under cc by-sa 3.0 with attribution required.