サーバー管理者

システムおよびネットワーク管理者向けのQ&A

1
ADフォレスト間認証-PACにグループがありません
2つのフォレストで構成されるActive Directoryセットアップがあります。 1つのフォレストルートドメインと2つの直接の子ドメインを持つ1つのマルチドメインフォレスト DMZ発行のための1つの単一ドメインフォレスト DMZドメインに3つの発信信頼、1つはフォレストルートドメインに対する推移的なフォレスト信頼、2つは外部の非推移的な信頼(ショートカット信頼)を作成しました。 4つのドメインすべてのDCはすべてグローバルカタログサーバーです。 以下でそれを視覚化しようとしました: さて、ここに問題があります。ドメインのdmzRoot.tldセキュリティグループへのリソースへのアクセスを許可すると、セキュリティグループのメンバーであるユーザーには機能しますが、のセキュリティグループのメンバーであっても、ドメインのユーザーには機能しません。childAchildAchildBchildA たとえば、ローカル管理者にメンバーサーバーへのアクセスを許可するとしますdmzRoot.tld。childA.ForestRoot.tld\dmzAdministratorsメンバーサーバーのローカルのビルトインAdministratorsグループに追加します。 childA.ForestRoot.tld\dmzAdministrators 次のメンバーがいます: childA \ dmzAdmin childB \ superUser 私はとして認証した場合さて、childA\dmzAdmin私は、ローカル管理者としてメンバサーバーにログオンすることができ、私はからの出力を見ている場合whoami /groups、childA.ForestRoot.tld\dmzAdministratorsグループが明確に記載されています。 childB\superUserただし、認証を行うと、アカウントにリモートログオンが許可されていないというメッセージが表示されます。アカウントを確認whoami /groupsしたところchildB\superUser、childA.ForestRoot.tld\dmzAdministratorsグループが表示されていません。 ほとんどのように思えるchildAグループSIDの認証時にPACに含まれていません飽きないchildBすべてのDCのは、GCのであっても、ユーザーを。 テストしたdmzRoot.tldのマシンでPAC検証を無効にしましたが、これは役に立ちませんでした。 これを効果的にトラブルシューティングする方法に関する提案はありますか?認証の証跡をたどって、失敗した場所を特定するにはどうすればよいですか?

5
NginxはチャンクコンテンツのContent-Lengthヘッダーを削除します
nginx 1.2.3を使用してスクリプトにプロキシします。 proxy_set_header Host $host; proxy_pass http://127.0.0.1:8880; proxy_buffering off; proxy_read_timeout 300s; gzip off; スクリプトはTransfer-encoding: chunkedとの両方を送信しますContent-Length: 251。 HTTP/1.0 307 Temporary Redirect Content-length: 251 Pragma: no-cache Location: /... Cache-control: no-cache Transfer-encoding: chunked 私は両方が必要ですが、nginxは自動的に削除しContent-Lengthます: HTTP/1.1 302 Found Server: nginx/1.2.3 Content-Type: application/json; charset=utf-8 Content-Length: 58 Connection: keep-alive Location: /... その結果、クライアントはチャンクが送信されるのを待ちません。これは以前のバージョンのnginxで機能していました。
10 nginx 

2
インスタンス作成時の.pemファイルがない場合、Amazon EC2サーバーインスタンスにSSHで接続できますか?
稼働中のいくつかのAmazon EC2サーバーで作業しており、サーバーにSSH接続する必要があります。サーバーが最初にセットアップされたときに生成されたキーはありません(他の誰かがここに来る前に作成しました)。キーファイルがなくてもサーバーにアクセスできますか? FWIWこれまでに、EC2ダッシュボードで新しいキーペアを生成するなど、SSHを使用してさまざまなことをボックスに試しましたが、何も機能していないようです。このAmazon AWSサポートの投稿とこの回答は、現在のサーバーのAMIを作成し、それを使用してまったく新しいEC2サーバーインスタンスをインスタンス化する(.pemファイルを生成するためだけに)場合を除き、運が悪いことを示しているようです当時)。これが、現時点でボックスに入る唯一の方法ですか?

1
「ip addr change」および「ip addr replace」コマンドについて
現在、eth0インターフェースに関連付けられている次のIPv4アドレスがあります。 T60:~ # ip -V ip utility, iproute2-ss110629 T60:~ # ip addr show dev eth0 2: eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN qlen 1000 link/ether 00:15:58:2a:84:3e brd ff:ff:ff:ff:ff:ff inet 10.11.12.2/24 scope global eth0 inet 10.11.12.3/24 scope global secondary eth0 inet 10.11.12.4/24 scope global secondary eth0 inet6 fe80::215:58ff:fe2a:843e/64 scope …
10 linux  ip 

4
arp --deleteはエントリを削除しません。エントリを「不完全」としてマークするだけです
$ sudo arp -avn ? (10.10.7.30) at 00:cc:cc:bb:dd:86 [ether] on eth0 ... $ sudo arp --delete 10.10.7.30 $ sudo arp -avn ? (10.10.7.30) at <incomplete> [ether] on eth0 の後に--delete私はエントリを期待していませんでした10.10.7.30。予期せず、エントリが残り、マークが付けられ<incomplete>ます。 Ubuntu 10.04の使用。
10 linux  arp 

3
パスワードサーバー2012を忘れた
それで、私は本当にバカなことをしました。MSServer 2012を実行しているサーバーの管理者パスワードを忘れました。サーバーが24時間年中無休で稼働しているため、電源が切れて再度ログインしなければならなかったので、シャットダウンしてログインする必要はほとんどありません。パスワードを思い出せませんでした。ルーキーのミスのため、ほとんどの場合このサーバーで実行されているすべてのサービスが原因で、OS全体を再インストールする必要がないようにしています。私はかなりの数の試用版「回復ツール」をダウンロードしましたが、これらはパスワードのリセット以外のすべてを行うようです。特定のアプリケーションが機能し、支払う価値があることを誰かが保証できれば、さまざまなサービスをすべて再インストールして再構成する日々を節約するために何かお金を払って喜んで喜んでいます。だから私の質問は、

2
開いていて常に書き込まれているファイルをローテーションする
ロギング情報をログファイルに継続的に書き込むLinuxアプリケーションがあります。/var/log/application.log。アプリケーションがファイルを自動的にローテーションしないため、このログファイルは数週間でギガバイトのサイズに達する可能性があるため、このファイルを適切にローテーションできるようにしたい ここでの主な懸念は、アプリケーションによって常に開かれているファイルをローテーションするには、おそらく次のことを行う必要があるということです。 ファイルを回転された形式に移動します /var/log/application.log -> /var/log/application.log.2013-01-28 空のを作成します/var/log/application.log。Obs:この時点で、申請プロセスはまだ書き込み中です/var/log/application.log.2013-01-28 アプリケーションプロセスのファイル記述子を変更して、再びポイントするようにします。 /var/log/application.log それで、私は正しいですか?もしそうなら、どうすればこれを行うことができますか?(主にファイル記述子部分の変更) そうでない場合、正しい方法とその方法を教えてください。

3
ログインに何度も失敗した後、IPアドレスを自動的にブロックする
Windows 2008サーバーで多くの失敗したログイン試行(1秒あたり1回)を受信して​​います。ログイン試行回数が多すぎると、アカウントを自動的にロックするようにローカルセキュリティポリシーをすでに設定していますが、IPアドレスを自動的に含める方法はありますか? Windowsファイアウォールが一時的に(たとえば30分間)ブロックされるようにしますか?
10 windows  firewall 

2
サーバーの移行:最も効率的な方法
サーバー(2つの異なるホスト)間でサイトの1つを移行する必要があります。どちらの環境もLinuxです。 サイトはビデオをストリーミングするため、サーバーには現在メディアファイル(画像とビデオ)が入っています。私が最初に思ったのは、rsycncを使用してすべてを転送することですが、できるだけ効率的に、できるだけ早くすべてを実行したいと考えています。プロセスを高速化する方法について、またはrsyncがここでの正しい選択であるかどうかについて、いくつかのアドバイスがあると思いました。 前もって感謝します。システム管理者に関する私の限られた知識についての謝罪... 編集:基本的なLAMPスタック(centos)で実行しており、ラックスペースの赤い帽子に移動しています)。
10 linux  rsync  migration 

4
sshトンネルエラー「ssh_exchange_identification:接続がリモートホストによって閉じられました」
オフィスマシンからホームマシンへのsshトンネルを使用しようとしていますが、使用しようとするとエラーが発生します。 私がやっていることは次のように1つのシェルを開始することです: ssh -gL 12345:my.home.domain:22 my.home.domain これは私に適切なシェルを与えています、問題ありません。私が通常行うことは、次のように、このオフィスマシンを介してホームマシンにSSHで接続することです。 ssh -p 12345 127.0.0.1 これは、先週まで、ホームマシンに新しいシステムをセットアップする(UbuntuからDebianに切り替える)まで、私にとっては常にうまくいきました。エラーが発生します。私はまだ最初のssh接続を開くことができますが、そのトンネルを使用しようとすると、(オフィスマシンで)次のエラーが発生します。 ssh_exchange_identification: Connection closed by remote host また、それが発生すると、私がトンネリングを設定したオープンシェルが次の行を生成します。 channel 3: open failed: connect failed: Connection timed out その時点で、私は途方に暮れています。さらに情報が必要な場合は、投稿させていただきます。 =============それにさらに============== さらにいじくり回した後、さまざまなポートでTelnetを実行しようとすると、サーバー(私のホームマシン)から別の応答が返されることがわかりました。私が試した場合: telnet my.home.domain 22 私はこれを取り戻します: Trying <my ip address>... Connected to <my domain>. Escape character is '^]'. SSH-2.0-OpenSSH_5.5p1 Debian-6+squeeze2 これは私が期待することです。トンネルをセットアップしてからtelnet接続すると、次のような応答が表示されます。 …
10 ssh-tunnel 


3
RedHat:RPMをビルドするために一種のモック環境にパッケージをインストールすることは可能ですか
RPM .specの依存関係を隔離された環境にインストールできるツールはありますか?このような依存関係をシステムにグローバルにインストールすることはありません。ルート権限がないため、インストールできません。 理由 新しいバージョンのBに依存するパッケージAをビルドしたい(システムにグローバルにインストールできない)。 私は、新しいバージョンの構築したいBを、ビルド・ツールをインストールしましょうBは「S -develのビルドに必要なすべてのファイルを提供するために、隔離された環境にそれをA。 ソリューション これを行うためのツールはありますか? そうでなければ、言うことでこれを行おうとするとき、私は何に注意すべきchrootですか? これは悪い習慣でしょうか?
10 linux  chroot  rhel6  rpm 


4
PostgreSQLは64コアまで拡張できますか?
このComputer World記事では、PostgreSQLが64のコア制限まで拡張できることを指定しています。これは、64コアの1つのマルチコアプロセッサを意味しますか?それともコアの少ないマルチプロセッサですか? 私が尋ねる理由は、PostgreSQLがスケールアップできるプロセッサの数を見つけようとしているためですが、もちろんそれはプロセッサのタイプに限定される可能性があります。ただし、他のデータベースで他の統計情報(つまり、ここでは Microsoft SQL Server が最大320の論理プロセッサに拡張できることを示す)を見つけており、コアの数を指定していません。これは非常にあいまいな統計ですか? どんな考えでも大歓迎です。ありがとう!

1
Apache 2.2.xでSSL / TLS圧縮を無効にする
mod_sslを使用するときにApache 2.2.xでSSL / TLS圧縮を無効にする方法はありますか? そうでない場合、古いブラウザでのCRIME / BEASTの影響を軽減するために人々は何をしていますか? 関連リンク: https://issues.apache.org/bugzilla/show_bug.cgi?id=53219 https://threatpost.com/en_us/blogs/new-attack-uses-ssltls-information-leak-hijack-https-sessions-090512 /security/19911/crime-how-to-beat-the-beast-successor

弊社のサイトを使用することにより、あなたは弊社のクッキーポリシーおよびプライバシーポリシーを読み、理解したものとみなされます。
Licensed under cc by-sa 3.0 with attribution required.