サーバー管理者

システムおよびネットワーク管理者向けのQ&A

1
autosshはリンクダウン時にsshを強制終了しません
autosshを30秒のポーリング時間で開始しました。 AUTOSSH_POLL=30 AUTOSSH_LOGLEVEL=7 autossh -M 0 -f -S none -f -N -L localhost:34567:localhost:6543 user1@server1 そしてそれはうまくいきます: Sep 5 12:26:44 serverA autossh[20935]: check on child 23084 Sep 5 12:26:44 serverA autossh[20935]: set alarm for 30 secs しかし、ネットワークケーブルを物理的に取り外した場合、つまりトンネルが機能しなくなった場合、autosshはsshデーモンを強制終了しません。どうして?リンクがダウンしている場合、autosshは何もできないことを理解していますが、私の意見では、次のことを実行する必要があります。 子sshプロセスを確認します(check on child ...) 遠端を確認してください!!! (トンネルを介したpingのような操作) トンネルがダウンしていることを認識する sshプロセスを停止します もう一度トンネルを作成してみてください それが機能しないことを認識し、(指数関数的に増加する?)タイマーを設定してすぐにもう一度チェックする それが私がautosshを実行している理由です:トンネルに何かが起こった場合(ソフトウェアまたはハードウェアの問題である場合)、トンネルを再起動する必要があります。代わりに、sshプロセスが終了するのを待っています。接続を再確立する見込みがない場合でも、再起動しようとしているのではないですか? autosshはどのようなチェックを行っていますか?sshが稼働していることを確認してください。遠端のチェックを行っていませんか? 編集する 要求に応じて、ssh構成の関連部分を追加します。 # …
10 networking  ssh 

2
エンドユーザーへのプロンプトなしでBitLockerを有効にする方法
すべてのオプションが設定され、回復キーがActive Directoryに格納されるように、グループポリシーでBitLockerとTPMの設定を構成しました。すべてのマシンでWindows 7を標準の企業イメージで実行しており、TPMチップが有効になっていてBIOSでアクティブになっています。 私の目標は、ユーザーがしなければならないすべてが[BitLockerを有効にする]をクリックするだけで済むようにすることです。マイクロソフトは、スクリプトを介して展開できる自動化サンプルも提供しています。しかし、これをスムーズなプロセスにするための小さな問題があります。 GUIでは、ユーザーがBitLockerを有効にすると、自動的に生成される所有者パスワードでTPMを初期化する必要があります。ただし、回復パスワードはユーザーに表示され、テキストファイルに保存するように求められます。このダイアログを抑制できないようで、ステップをスキップできません。キーがADに正常にバックアップされるため、これは不要な(そして不要な)プロンプトです。 展開をスクリプト化する場合、TPMを初期化するときにスクリプトで所有者パスワードを指定する必要があり、GUIのようにランダムに生成されるようにします。 BitLockerの展開を本当に希望どおりにゼロタッチする方法はありますか?

2
ESXiおよびWindows Server CPUパーキング
知らない人のために、CPUパーキングは最近のWindows Serverリリースの機能で、WindowsはCPUコアをほとんど使用せず、何も使用しないようにすることができます。節電対策として導入されました。他の場所の中で、ここでそれについての詳細があります。 しかし、私が興味を持っているのは、この問題が仮想化ゲストの問題なのか、または物理CPUがWindowsではなくESXiによって管理されており、駐車されたCPUがCPUをパーク解除するのに十分な作業があるとスケジューラが判断しない限り、トラフィックを処理しますか? 私はこれについて何も見つけていません-それは与えられたワークロードに非常に基づいていると思いますが、ハイパースレッドが効果があるかどうかとは異なり、定期的に議論されているようです)。「ワークロードを使用したテスト」は理解していますが、見逃したアドバイスやガイドラインはないかと思いました。


3
CentOS 7(Docker上)に言語サポートを追加するにはどうすればよいですか?
ロケールを日本語に設定しようとしていますが、DockerのCentOSイメージに言語サポートが含まれていません。 bash-4.2# yum groupinstall -y "Japanese Support" Loaded plugins: fastestmirror Loading mirror speeds from cached hostfile * base: mirrors.btte.net * extras: centos.mirror.secureax.com * updates: centos.mirror.secureax.com Warning: group Japanese Support does not exist. Maybe run: yum groups mark install (see man yum) No packages in any requested group available to install …
10 centos  yum  docker 

4
Dockerコンテナーにどのような名前を付けますか?
Ubuntu 12.04.4にDocker 1.1.2をインストールしました。私は使用して画像IDを設定するさまざまな試みを試みました: sudo docker run -i -t --name=container1 ubuntu date しかし、私の試みは失敗したようです。私が行うたびにdocker ps -a、イメージIDはランダム化されています。追加すればホスト名を設定できますが-h container1、イメージIDを設定したいと思います。ここで何が欠けていますか?ありがとう!

1
FreeBSDリンク集約は単一リンクよりも速くありません
我々は、4ポート置くインテルI340-T4のFreeBSD 9.3サーバにNICを1とするために構成されたリンクアグリゲーションでLACPモード -2-にマスタ・ファイル・サーバからのデータの16のTiBにはミラー8に要する時間を短縮しようとして並行して4つのクローン。最大で4ギガビット/秒の総帯域幅が得られると期待していましたが、何を試しても、1ギガビット/秒の総帯域幅より速くなることはありません。2 iperf3静止LANでこれをテストするために使用しています。3最初のインスタンスは予想どおりほぼギガビットに達しますが、2番目のインスタンスを並行して開始すると、2つのクライアントの速度が約½ギガビット/秒に低下します。3番目のクライアントを追加すると、3つすべてのクライアントの速度が〜⅓Gbit /秒に低下します。 iperf34つのテストクライアントすべてからのトラフィックが、異なるポートの中央スイッチに入るようにテストを設定しました。 各テストマシンにはラックスイッチへの独立したパスがあり、ファイルサーバー、そのNIC、およびスイッチにはすべて、lagg0グループを分割してそれぞれに個別のIPアドレスを割り当てることでこれを実現する帯域幅があることを確認しましたこのIntelネットワークカードの4つのインターフェイスのうち。その構成では、4ギガビット/秒の総帯域幅を実現しました。 この道を歩み始めたとき、私たちは古いSMC8024L2管理スイッチでこれを行っていました。(PDFデータシート、1.3 MB。)それは当時の最高のスイッチではありませんでしたが、これを行うことができるはずです。スイッチは古くなっているため故障しているのではないかと考えましたが、はるかに高性能なHP 2530-24Gにアップグレードしても症状は変わりませんでした。 HP 2530-24Gスイッチは、問題の4つのポートが実際に動的LACPトランクとして構成されていると主張しています。 # show trunks Load Balancing Method: L3-based (default) Port | Name Type | Group Type ---- + -------------------------------- --------- + ----- -------- 1 | Bart trunk 1 100/1000T | Dyn1 LACP 3 | Bart trunk 2 100/1000T | …

1
yumインデックスが破損するのはなぜですか?
時々、yumのキャッシュが破損し、次のようなエラーが表示されます。 error: db3 error(-30974) from dbenv->failchk: DB_RUNRECOVERY: Fatal error, run database recovery error: cannot open Packages index using db3 - (-30974) error: cannot open Packages database in /var/lib/rpm 回避策はrm -f /var/lib/rpm/__db*次の「yum」コマンドでデータを再生成します。 私の質問は、これを引き起こしている可能性が高いのは何ですか?ロックを無視する、またはこれを引き起こす他の問題がある一般的なタスクはありますか? 私たちは何百ものCentOSマシンを使用しており、この問題が発生するパターンはありません。これは「100万分の1」の問題である可能性があり、大規模に見られることがよくあります。 注:私はこれが非常に「自由回答」の質問であることを理解していますが、回答が原因を見つけた場合は、戻って特定の問題に直接関連するより標準的なものに質問を変えます。

5
リクエストがないにもかかわらずIISアプリケーションプールのCPU使用率が高い
最近、Windows Server 2008 R2 / IIS 7.5サーバーのセットを、Windows Server 2012 / IIS 8を実行する新しいサーバーに移行しました。 IISからの奇妙な動作が発生しています。2つの同一のサーバーがあり、各サーバーは2つのWebサイトを実行しており、それぞれが独自のアプリプールで実行しています。各Webサイトのコードは同じです。(文字通り...同じdllとすべて、わずかに異なる構成)。 アプリプールは24時間ごとのスケジュールでリサイクルするように設定されていますが、その24時間の間、w3wpワーカープロセスのCPU使用率は12.5%ずつ増加します(サーバーには8つのプロセッサがあるため、そうではないと思います)偶然)。 CPU使用率が上昇すると、アプリがリサイクルするまで、CPU使用率は下がりません。私の知る限り、このアプリは何もせず、現時点ではリクエストを処理していません。サーバーへのすべてのトラフィックをブロックでき、CPU使用率はそのままです。Webサイトを再起動することもできますが、CPU使用率は変わりません。CPU使用率をリセットする唯一の方法は、それが実行されているアプリプールをリサイクルまたは再起動することです。 この問題が私のコードとは何の関係もないと確信していますが、ハードウェア構成などでうまく機能していないIIS構成の変更やIIS 8の変更の一部ですか? それが重要かどうかはわかりませんが、これらはRackspace Performance Cloudサーバーです。 以下のスクリーンショットは、これらのサーバーのCPU負荷の経時変化を示しています(緑色の矢印は、アプリプールがリサイクルする時間を示しています。各プラトーが12.5%の整数倍であることがわかります。 誰かがこの動作を観察しましたか?2009年にIIS 6で同じ問題が発生しているように見える人がいるこの質問を見つけました。 トラフィックのない高CPUを使用するIIS w3wp どんな助けでも大歓迎です
10 iis  cpu-usage  iis-8 

2
VMWare ESXi 5.5、シンプロビジョニングは依然としてディスク上の全容量を割り当てます
VMWare ESXiでのシンプロビジョニングに関する多くの質問と回答が表示されますが、私が直面しているものとは異なります。新しいVMを作成し、100 GBのシンプロビジョニングされたハードディスクを指定しています。私が読んだすべてから、vmdkファイルの物理サイズは100GB未満であると予想しています。ただし、それでも100GBのxxx-flat.vmdkを作成しています。 以前にVMWare Workstationで行ったように、簡単にコピーしてカスタマイズできる基本システムをセットアップしようとしています。非常に簡単!コピーの電源を入れると、VMWareはコピーしたかどうかを尋ねてきます。「はい」と答えると、電源を切って実行します。ただし、ESXi 5.5のバグのように見えるので、100GB以上をコピーします。つまり、新しいインスタンスが必要になるたびに、OSを再インストールするのと同じくらいの速さで済みます。 誰かこれを経験しましたか?

4
RDPを使用してサーバーにファイルをコピーするときの「貼り付け情報の準備」
RDP接続を介して1つのサーバーフォルダーから別のサーバーフォルダーにファイルをコピーしようとしています。ファイルをコピーするためにCTRL + Cを押すと、このウィンドウがポップアップ表示されます。 276個のファイルと49個のフォルダーにコピーされているのは12.5 MBだけで、非常に高速ですが、RDPクリップボード共有を使用しているようです。約60〜128 kbのネットワークアクティビティが表示され、右クリックしてコンテンツを宛先にドラッグすると、すばやく動作します。クリップボードの共有を無効にすると、CTRL + Cでコピーすることもできます。 気付いたサーバーは1つだけで、過去2か月の間に発生しました。Windowsの更新によって変更された可能性のある構成設定はありますか? 私ができることは、以前の動作に戻ることです。 クリップボードの共有が有効になっているため、クライアントとサーバー間でテキストをクリップボードにコピーして貼り付けることができます 共有ドライブが有効になっているため、サーバーセッションでクライアントのローカルドライブにアクセスできます サーバー上のローカルディレクトリ間でファイルをコピーしても、rdpclip.exeを使用して(CTRL + Cまたは右クリックコピーを使用して)ファイルの内容がクライアントのクリップボードにコピーされない クライアント上の共有フォルダーからファイルをコピー\\tsclient\xxxしても、ネットワークを介してデータがコピーされますが、クリップボードは必要ありません(90%これは以前の動作と同じです。ファイルを貼り付けるまで、ウィンドウポップアップは表示されませんでした)サーバー)

1
fstabのCIFSマウントはIPで成功し、/ etc / hostsに書き込まれたホスト名で失敗する
Ubuntu Server 14.04 LTSでfstabからのホスト名の解決に問題があるのはなぜですか。次のエントリをマウントしようとしました: //NAS-5h2-20/backuppc/ /mnt/backuppc cifs auto,user=THEUSER,password=THEPASSWORD,cifsacl,uid=109 0 0 マウントはエラーで失敗します mount: wrong fs type, bad option, bad superblock on //NAS-5h1-15/backuppc, missing codepage or helper program, or other error (for several filesystems (e.g. nfs, cifs) you might need a /sbin/mount.<type> helper program) In some cases useful info is found in …

2
RAID1の読み取りアクセスが書き込みアクセスより遅いのはなぜですか?
いくつかの簡単なパフォーマンステストを実行しましたが、RAID1からの読み取りは書き込みよりも遅いようです。 root@dss0:~# for i in 1 2 3; do dd if=/dev/zero of=/dev/sda bs=1048576 count=131072; done 137438953472 bytes (137 GB) copied, 192.349 s, 715 MB/s 137438953472 bytes (137 GB) copied, 192.851 s, 713 MB/s 137438953472 bytes (137 GB) copied, 193.026 s, 712 MB/s root@dss0:~# for i in 1 2 3; do …

2
どのようにしてバックアップ/セカンダリMXサーバーをテストできますか?
Postfixを使用してセカンダリMXサーバーをセットアップしたいのですが、運用に移行する前に(MXエントリを追加して)これをテストする最善の方法は何ですか? 考えられる1つの方法は、まったく異なるドメイン名でテストすることです。つまり、「fake-test-domain.com」のようなドメインを購入し、このバックアップMXサーバーのみでDNSゾーンを設定します。 DNSにリストされる前に、メールサーバーにこのサーバーにメッセージを送信させる簡単な方法はありますか? MXレコードをエミュレートしないため、送信側のシステムでhostsファイルを使用できないと思います。

1
Munin Postgresプラグイン:DBD :: Pgが見つかりません
Munin用のいくつかのPostgresqlプラグインをアクティブ化しようとしています。実行するmunin-node-configure --suggest | grep postgresと、次の出力が得られます。 postgres_bgwriter | no | no [DBD::Pg not found, and cannot do psql yet] postgres_cache_ | no | no [DBD::Pg not found, and cannot do psql yet] postgres_checkpoints | no | no [DBD::Pg not found, and cannot do psql yet] postgres_connections_ | no | no [DBD::Pg …

弊社のサイトを使用することにより、あなたは弊社のクッキーポリシーおよびプライバシーポリシーを読み、理解したものとみなされます。
Licensed under cc by-sa 3.0 with attribution required.