サーバー管理者

システムおよびネットワーク管理者向けのQ&A

3
Docker-ルートのcrontabなし
私のDockerfileは正しくビルドされているように見えます(そのように指示されています)。コンテナを実行すると、次のエラーメッセージが表示されます。CMDサービスのディレクトリを使用して、または使用せずにコマンド()を実行してみました。 crontab.sh基本的には、cronスケジュールをテキストファイル(cron.jobs)に書き込み、そのテキストファイルをcrontabにインポートします。 Dockerfile: FROM node:0.10 MAINTAINER Tom VOLUME /var/log/ RUN mkdir /pulse ADD . /pulse WORKDIR /pulse RUN apt-get update && apt-get install -y cron ADD *.sh /pulse/ RUN chmod 750 /pulse/crontab.sh && chmod 750 /pulse/ RUN chmod 644 /etc/crontab CMD cron -f CMD touch /var/log/cron.log && sh /pulse/crontab.sh && …
10 cron  docker 

3
システムクラッシュの原因を特定する方法
私のサーバーは約1週間に1回クラッシュし、何が原因であるかについての手掛かりを残していません。チェック/var/log/messagesしたところ、ある時点で記録が停止し、ハードリブートを実行するとコンピューターの投稿情報から開始します。 原因を特定できる、確認できるものやインストールできるソフトウェアはありますか? CentOS 7を実行しています。 これが私の唯一のエラー/問題です/var/log/dmesg:https://paste.netcoding.net/cosisiloji.log [ 3.606936] md: Waiting for all devices to be available before autodetect [ 3.606984] md: If you don't use raid, use raid=noautodetect [ 3.607085] md: Autodetecting RAID arrays. [ 3.608309] md: Scanned 6 and added 6 devices. [ 3.608362] md: autorun ... [ 3.608412] md: …

3
sudoでfindを安全に使用する
Linuxサーバーでは、ユーザーのグループからroot権限を削除する必要があります。ただし、これらのユーザーには、「検索」ユーティリティを使用して、ファイル名、変更日、およびその他のメタデータに基づいてファイルを検索できる正当な理由があります。 サーバーでは、ファイル名は機密ではありませんが、ファイルの内容は機密である可能性があります。 ユーザーがサーバー上の任意の場所でファイルを検索できるように、sudoを使用したいと思います。「検索」ユーティリティは素晴らしいですが、「-exec」を使用して任意のコマンドを生成するなど、あらゆる種類の副作用を許可します。 find制限を使用して作業できますか?
10 linux  sudo  find 

1
SSO vCenterのLDAPサービスをセットアップする
フレッシュインストールvCenterサーバー サーバー2008 r2 ADセットアップユーザーをインストールし、vCenterで「IDソースを追加」しようとすると、「テスト接続」を押すとエラーが発生します。 「vCenter Single Sign-onサーバーは、指定されたURLのサービスへの接続または認証に失敗しました」 「IDソースの追加」構成: 「LDAPサーバーとしてのActive Directory」の使用 名前:domain.local ユーザーのベースDN:cu = users、dc = domain、dc = local ドメイン名:domain.local ドメインエイリアス: グループのベースDN:cu = users、dc = domain、dc = local プライマリサーバーのURL:ldap://ad.domain.local セカンダリサーバーのURL: ユーザー名:administrator@vsphere.local パスワード:PASSWORD LDAPサービスの設定方法がわかりません。 私はAD LDSをインストールしてインスタンスを作成しましたが、これで正しい方向に進んでいるかどうかはわかりませんが、インスタンスをセットアップするとき、すべてのデフォルトが受け入れるものを受け入れました: はい、アプリケーションディレクトリパーティションを作成します パーティション名:cu = users、dc = domain、dc = local ファイアウォールを無効にしました AD LDSインスタンスが実行されていることを確認しましたが、まだエラーが発生します。 誰かが私が間違っていることを教えてもらえますか?

2
Windows Server 2016で記憶域スペースダイレクトをテストするためにSCVMMが必要ですか?
私はラボの3つのWindows Server 2016 Datacenterエディションにインストールしました。各サーバーには5つのSASドライブがあり、サーバー用に数台のSSDを購入します。現在、インフラストラクチャをテストしており、Windows Server 2016の記憶域スペースを調べています。問題は、SCVMMを使用して記憶域スペースダイレクトを展開できるかどうかです。また、実際にSCVMMが必要ですか?

2
Amazon LinuxへのPostgresサーバー9.6のインストール
ソースからビルドせずにAmazon Linuxにpostgres-server 9.6をインストールする最良の方法は何ですか?私が実行しているしようとしたrpm -i https://download.postgresql.org/pub/repos/yum/9.6/redhat/rhel-6-x86_64/pgdg-ami201503-96-9.6-2.noarch.rpm上で記載されているバージョンをインストールするhttps://yum.postgresql.org/repopackages.phpを、そしてそれがエラーなしでインストールしたのですが、私はまだ持っていないservice postgresql、またはpsql、またはpostgresユーザー。私は何を取りこぼしたか?

7
スイッチはVLANルーティングを実行できますか?[閉まっている]
休業。この質問には詳細または明確さが必要です。現在、回答を受け付けていません。 この質問を改善してみませんか?詳細を追加し、この投稿を編集して問題を明確にしてください。 3年前休業。 私はVLANについて学習しており、2つのVLAN間の通信にスイッチを使用できるかどうか疑問に思っています。 スイッチはトランクリンクをサポートし、フレームの宛先/送信元(VID)を既に知っているので、あるVLANから別のVLANにフレームを送信するために使用できますか? たとえば、上記のこの画像では、このスイッチがすでに各VLANのVIDを受信して​​いるのに、なぜルーターが必要なのかと思っていました。フレームを転送先のVLANに切り替えられないのに、ルーターがそれを行う必要があるため、フレームのルーターへの転送時間とルーターへの転送時間が長くなるのはなぜですか?
10 routing  switch  vlan 

1
URLを呼び出すタスクをスケジュールする方法
MVCアプリがあります。呼び出されたときにバックグラウンドプロセスを実行してActive Directoryをクエリし、データベースを更新するコントローラーがあります。 http:// myapp / BackgroundTask / Run これを、ブラウザーを開かずにスケジュール(毎日)で実行したい。サードパーティのソリューションがたくさんあるようですが、何かが組み込まれていますか?

1
PostfixとDovecotはOCSPステープリングをサポートしていますか?
私はSSL証明書に「必須」属性を設定したいので、すべてのサービスがOCSPステープリングをサポートしているかどうかを調べるために調査を行っていました。これまでのところ、SSLLabs.comを使用して確認できるApacheが実行していることがわかりました。 しかし、それとは別に、他の2つのサービス(SMTPとIMAP)もOCSPステープリングをサポートしているかどうかは確認できませんでした。今私の質問は、PostfixとDovecotもそれをサポートしていますか? PS:メールトランスポートに関しては、証明書は重要ではないようですが、属性を追加すると、クライアントがそのために作業を拒否する可能性がある場合、問題が発生するのを避けたいと思います。それから利益を得る。
10 ssl  postfix  dovecot  ocsp 

1
サーバーをRDライセンスサーバーにリンクする
現在約20台のサーバーが稼働しており、120日間のRDP猶予期間で稼働しています。 これで、ライセンスサーバーおよび接続ブローカーとして機能するサーバーがセットアップされました。 これらのサーバーはすべて同じドメイン上にあります。 リモートデスクトップに使用する各サーバーをライセンスサーバーにリンクする方法を知りたいのですが。 すべてのサーバーで2012R2を使用しています。

1
OSX上のMonoのXSP4は、.aspxまたは.aspファイルに対してAccess Forbidden(エラー500)を示します。
テストのために古いASPベースのサイトのコピーをローカルでホストしようとしているMacを使用しています。Apacheには(まだ)mod_monoを使用せず、基本的なスタンドアロンXSPサーバーのみを使用します。少なくともlocalhostからASP.NETエラーページを表示できるようになるまでは、十分な試練でした。 .htmまたは.htmlファイルを指定すると、文句なしに表示されます。しかし、私が試みるすべてのASPファイルは「アクセス禁止」エラーを出します。 これは、.htaccessファイルやweb.configファイルなど、XSPの構成ファイルが必要であり、これらの拡張機能を提供するものとしてホワイトリストに登録する必要があることを意味していると思います。(静的HTMLファイルをホストするためだけにMonoとXSPをインストールする必要があるのはなぜでしょうか?) xsp4 --helpはヘルプではなかったし、man xspでもなかったので、ここにいる。 Application Exception System.Web.HttpException Access to file '/anysite/whateverpage.asp' is forbidden. Description: HTTP 500.Error processing request. Details: Error processing request. Exception stack trace: at System.Web.DefaultHttpHandler.BeginProcessRequest (System.Web.HttpContext context, System.AsyncCallback callback, System.Object state) [0x0005e] in <79d7580b4e46487286a5f8386a98413d>:0 at System.Web.HttpApplication+<Pipeline>c__Iterator1.MoveNext () [0x00d9c] in <79d7580b4e46487286a5f8386a98413d>:0 at System.Web.HttpApplication.Tick () [0x00000] in <79d7580b4e46487286a5f8386a98413d>:0 …

2
Windowsサーバーでパスワードの最大長を無効にする[終了]
閉まっている。この質問はトピックから外れています。現在、回答を受け付けていません。 この質問を改善してみませんか? サーバー障害のトピックになるように質問を更新します。 3年前休業。 Windows 2012サーバーで16文字より長いパスワードを作成しようとすると、パスワードが長すぎるために拒否されます。「パスワードの最大長」と呼ばれるGPOを探してみました-見つかりません。問題は、PwdFiltまたはPCNSFLTにある可能性があります。私も見たregeditのスクリーンショット。1 問題は、暗号化を行うためにインストールするSQL 2014サーバーに36文字のパスワードが必要なことです。 助言がありますか?

4
スペース不足のUbuntuルートドライブ、duまたはlsofでソースが見つからない
Ubuntu 15.10マシンのルートドライブの空き容量はほとんどありませんが、ソースが見つかりません。容量が不足しているドライブはsdb2、51Gの313Mです。ファイルシステムはext4です。 ここでsudo du -h / --max-depth=1出力は: Filesystem Size Used Avail Use% Mounted on udev 3.9G 0 3.9G 0% /dev tmpfs 789M 9.4M 780M 2% /run /dev/sdb2 51G 48G 313M 100% / tmpfs 3.9G 12K 3.9G 1% /dev/shm tmpfs 5.0M 4.0K 5.0M 1% /run/lock tmpfs 3.9G 0 3.9G 0% /sys/fs/cgroup …

2
サーバーがロードバランサーを使い果たしたときにアラートを出す
私たちは多くの環境に多くのサイトを持っています。環境の多くは、2つのWebサーバー(場合によっては2つのアプリサーバー)で負荷分散されます。過去2か月に2回、サーバーが誤ってロードバランサーから取り出されたという状況に遭遇しました。これは、2日後に2台目のサーバーが取り外され、サイトが完全にダウンしたときに私たちを噛みました。どちらの場合も問題は迅速に発見および修正されましたが、サーバーがロードバランサーの外にある場合はアラートが必要であると思います。サーバーのWebサイトが稼働中で応答していたため、通常のアラートはここでは機能しませんが、LBにはありませんでした。 ロードバランサー自体でアラートを設定することは可能かもしれませんが、それらは私たちのホスティングプロバイダーによって管理されており、それらに対処するのは面倒な場合があります。 私の考えは、15分ごとにサーバーログをスキャンし、1時間あたりのユニークユーザー数が特定のしきい値を下回ったときにメールを送信するアプリを用意することです。書くのはそれほど難しいように聞こえませんが、すでにこれらの線に沿って何かを行う標準のサードパーティツールがすでにあるようです。 必要であれば、Windows、ASP.NET、IISを使用します。 Webサイトがヒットしない場合に警告するツールの推奨事項は?

10
不足しているpyopensslモジュールをletsencryptするためのcertbot
LetsEncrypt用のCertBotの設定についてサポートが必要です CentOS 7とPython 2.7を実行しています certbotを実行すると、次のエラーが発生します。 [root@li86-193 frappe-bench]#certbot certonly --manual Traceback (most recent call last): File "/usr/bin/certbot", line 7, in <module> from certbot.main import main File "/usr/lib/python2.7/site-packages/certbot/main.py", line 21, in <module> from certbot import client File "/usr/lib/python2.7/site-packages/certbot/client.py", line 10, in <module> from acme import client as acme_client File "/usr/lib/python2.7/site-packages/acme/client.py", line 31, …
10 centos7  certbot 

弊社のサイトを使用することにより、あなたは弊社のクッキーポリシーおよびプライバシーポリシーを読み、理解したものとみなされます。
Licensed under cc by-sa 3.0 with attribution required.