サーバー管理者

システムおよびネットワーク管理者向けのQ&A

4
サイトのIPアドレスを変更する最善の方法-エンドユーザーの観点から?
私は関連するQ / Aの束をここで読みましたが、最良の答えが何であるかはまだわかりません。 いくつかのサイトをIPアドレス「1.abc」から「2.def」に移動しています。現在、既存のDNSですべてのTTLを300秒に設定し、新しいDNSゾーンを(AWS Route 53で)使用する準備ができています。新しいネームサーバーとすべてのTTLは60秒です。DNSの観点からは、準備ができていると思います。移動後、数日後、Route 53でTTLをより適切な数値に設定します。 私はすべてのユーザーに移動について警告し、移動の時間帯を定義しました。移動が完了して24時間経過しても古い(ロックされた)サイトが表示される場合は、コンピューターを再起動してローカルDNSキャッシュを強制的にフラッシュする必要があることを伝えました。 ユーザーのブラウザ(キャッシュ)がこれにどのように影響するかわかりません。ローカルホストファイル(Win7)を使った私自身の実験では、古いIPアドレスを許可していないブラウザーについて何かがあることがわかりました - 新しいサイトの場所を表示するには、履歴に移動してすべてをクリアする必要がありました。アップ、後もipconfig /flushdns (編集)-私は古いサーバーへのrootアクセス権を持っていないため、この質問に対する承認済みの回答を実装できません。 質問: ユーザーにそれを処理してほしくないので、すべてのブラウザーを強制的に再キャッシュするためにできることはありますか?もしそうなら、それをオンにしておく時間はどれくらいですか? ありがとう...

1
CentOSにTomcatをデプロイするときのファイアウォールの問題
CentOS環境にTomcatサーバーをデプロイしようとしていますが、リクエストを受信して​​いません。 startup.shを実行すると正常に動作し、ログにtomcatが実行されていることが示されます 16-Dec-2016 13:36:58.440 INFO [main] org.apache.coyote.AbstractProtocol.start Starting ProtocolHandler [http-nio-8080] 16-Dec-2016 13:36:58.444 INFO [main] org.apache.coyote.AbstractProtocol.start Starting ProtocolHandler [ajp-nio-8009] 16-Dec-2016 13:36:58.445 INFO [main] org.apache.catalina.startup.Catalina.start Server startup in 14803 ms netstatを実行してリスニングポートを確認すると、listenと表示される $netstat -atnp|grep LISTEN tcp 0 0 0.0.0.0:8080 0.0.0.0:* LISTEN 3321/java ファイアウォールをスキップするために、iptablesにカスタムルールを追加しました。 $iptables -nL Chain INPUT (policy ACCEPT) target prot opt source …

2
ワイルドカードでファイルをチェックし、バッチファイルに変数として保存します[終了]
閉まっている。この質問はトピックから外れています。現在、回答を受け付けていません。 この質問を改善してみませんか? サーバー障害のトピックになるように質問を更新します。 3年前休業。 指定したフォルダーにファイルがあるかどうかを確認する方法を探しています。完全なファイル名は取得できないため、ワイルドカードを使用する必要があります。ファイルを見つけたら、ファイル名を変数として保存します。
10 batch-file 

2
イーサネットパッチパネルを介してスイッチのコンソールポートに接続する
私たちのオフィスビルには、Cisco SRW2048スイッチがあります。背面には、コンソール接続用のシリアルポートがあります。このコンソールポートを自分の部屋のコンピューターに接続したいのですが。 スイッチは、他のすべての部屋につながるイーサネットパッチパネルの隣のネットワークルームにあります。そのパッチパネルを使用してスイッチのコンソールポートに接続できるかどうか疑問に思いました。 2本のロールオーバーケーブルを使用すれば機能しますか?たとえば、1つをスイッチからパッチパネルに接続し、もう1つを部屋のイーサネットポートからコンピュータのシリアルポートに接続した場合、 そうでない場合、床に沿ってネットワークルームから私の部屋まで超長いシリアルケーブルを使用せずにスイッチに接続する別の方法はありますか? 更新:はい、私telnetはスイッチにアクセスするためにWebインターフェイス(または)を使用する必要があることを知っています。学習課題として、または単に楽しみのために、コンソールポートに接続したいだけです。 学校のラボでは、ルーター/スイッチのコンソールポートとしてRJ45コネクタがあり、ロールオーバーケーブルを使用して接続しているため、使用するケーブル/アダプターがわからないだけです。このスイッチには、コンソールポートとしてRS232(シリアル)コネクタがあり、イーサネットパッチパネルを介してどのように接続するかがわかりませんでした。 更新2:一端にロールオーバーケーブルを使用し、もう一端に「ヌルモデム」アダプターを使用できますか?
10 cisco  switch  console  serial 

1
IISをネットワークから隠す[終了]
休業。この質問には詳細または明確さが必要です。現在、回答を受け付けていません。 この質問を改善してみませんか?詳細を追加し、この投稿を編集して問題を明確にしてください。 3年前休業。 テストWebサイトをホストするためにWindowsにiisをインストールしましたが、ネットワーク上のすべてのユーザーに共有されています。これを無効にして他のコンピュータと共有しないようにする方法はありますか?
10 iis 

1
Windows Serverログ履歴[終了]
閉まっている。この質問はトピックから外れています。現在、回答を受け付けていません。 この質問を改善してみませんか? サーバー障害のトピックになるように質問を更新します。 3年前休業。 私が休暇中に誰かが私のデスクトップにログインしたことを確認しました。これは管理者からサーバーを介して行われたと思いますが、方法はわかりません。私はITフレンドリーではありませんが、サーバーに対する管理者特権を持っているため、デスクトップにアクセスするためにITを責める前に、彼が非稼働時間と同じ時間にサーバーにログオンしているかどうかを確認しました。サーバー2008で以前のログインを表示する方法について、誰かが段階的なプロセスを教えてもらえますか

1
内部DNSは内部サーバーをポイントしていますが、サイトはパブリックサイトに解決されますか?
ウェブサイトがwebsite.test.company.comあり、内部DNS(サーバー2012 r2)には10.0.0.21があります。これは内部的にサーバーアドレスです。しかし、それを入力するwww.website.test.company.comとwebsite.com、テストサーバーではなくライブページに解決されて表示されますか?なぜこれが誰かに方向付けられてしまうのか、考えられません。私の頭の中で、httpパスはゲートウェイの外に出てはいけません。

1
Windowsサーバーを監視する最良の方法?[閉まっている]
閉まっている。この質問はトピックから外れています。現在、回答を受け付けていません。 この質問を改善してみませんか? サーバー障害のトピックになるように質問を更新します。 3年前休業。 私は、中小企業のクライアントにITサポートを提供する会社で働いています。私のタスクの1つは、サービスビューアーを実行することです。これには、重大なエラー/警告、およびDHCPとDNS管理コンソールのイベントビューアーのチェックが含まれます。クライアントのワークステーションのイベントビューアもチェックされますが、定期的ではありません。 これらのすべてのログの表示を一元化できる既存のソリューションはありますか?そのため、各サーバーにリモートでアクセスし、各クライアントに対して同じことを何度も繰り返す必要がありません。 各クライアントには、2003年から2012 R2までのWindowsサーバーのいくつかのバージョンがあります。

3
ドメインへのVMの追加
この記事で言及されている手順に従って、AzureでSPファームを構成しようとしています -https://technet.microsoft.com/en-us/library/mt723354( v= office.16).aspxしかし、SQL VM( 'sqlVM')、これをADドメインに追加できません。 ドメインに接続しようとすると、以下のエラーメッセージが表示されます。 PS C:\ Users \ anuvya> Add-Computer -DomainName "corp.contoso.com" コマンドパイプラインポジション1のコマンドレットAdd-Computer次のパラメーターに値を指定します:Add-Computer:コンピューター 'sqlVM'は、次のエラーメッセージで現在のワークグループ 'WORKGROUP'からドメイン 'corp.contoso.com'に参加できませんでした:指定されたドメイン存在しないか、接続できませんでした。行:1文字:1 + Add-Computer -DomainName "corp.contoso.com" + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ ~~~~~~~~~~~~~~ + CategoryInfo:OperationStopped:(sqlVM:String)[Add-Computer]、InvalidOperationException + FullyQualifiedErrorId:FailToJoinDomainFromWorkgroup、Microsoft.PowerShell.Commands.AddComputerComman 任意の入力をいただければ幸いです。 おかげで、 ====================

2
ASP.NET 4.5へのアップグレード後に404エラーが発生する
最近、Webアプリを.NET 4.5にアップグレードしました。コードをテスト環境にプッシュした後、「404-ファイルまたはディレクトリが見つかりません」と表示されます。エラー。コードはVS2013デスクトップから正常に実行されます。WebサーバーはW2K08 R2でIIS 7.5を実行しています。サイトで.aspまたは.htmページを表示できますが、最も単純な.aspxページを表示しようとすると、このエラーが発生します。それは私のweb.configの構成の問題だと思います。

3
Apache2サーバーでHTTPSを有効にした後-すべてのリクエストで404エラーが発生する[終了]
閉まっている。この質問はトピックから外れています。現在、回答を受け付けていません。 この質問を改善してみませんか? サーバー障害のトピックになるように質問を更新します。 3年前休業。 さて、私はこれまでSSL / HTTPSの経験がありませんでした。標準のHTTPしか扱っていません。最近、SSLが必要なサイトで作業を開始しました。もちろん、私は外に出て、その方法を調査し、始めました。SSL証明書を正常にインストールする段階に到達しました-緑の南京錠が表示され、サーバーがポート443でHTTPSリクエストに応答します。 SSL、ただし、それらはポート80 / HTTPで正常に見えました(HTTPをHTTPSにリダイレクトするまで)。 簡単に言うと、HTTPSサイトに完全にアクセスできますが、ページは送信されず、リクエストごとに404が送信されます。 /etc/apache2/sites-available/[name].conf <VirtualHost *:80> ServerName [serverName] RewriteEngine On RewriteCond %{HTTP:X-Forwarded-Proto} !https RewriteRule ^ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=302] </VirtualHost> <VirtualHost *:443> ServerName [serverName] ServerAdmin [email] DocumentRoot [docRoot] # I know the following SSL cert stuff is correct SSLEngine On SSLCertificateFile [...]/[domain].crt SSLCertificateKeyFile [...]/[certificate].key …

1
Firewalld for VMを使用して1:1 Natを構成する
私はサーバー内に2つの仮想マシンをセットアップし、CentOS 7のファイアウォールで1:1 NATをセットアップしようとしています。現在、両方の仮想マシンは仮想ブリッジ(virbr0、vnet0、vnet1)の背後にあり、コピーを作成しました使用する各IPのNICの数。私はそれを次のように設定したいと思います: eth0:0(パブリックIP)-----> vnet0(内部IP); eth0:1(パブリックIP)-----> vnet1(内部IP) それを理解する方法は、1:1 NATを探していることですが、それを設定する方法がわかりません。私は元々すべてをブリッジで構成していましたが、ホスティングプロバイダーはネットワーク上のブリッジを許可していません。仮想NICの架空のMACがすべてをネットワークから開始します。 いくつかのことを試しましたが、firewalldにはまだ慣れていません。

3
Windowsネットワークプロファイルを「DomainAuthenticated」からパブリックに変更する
OpenVPN 2.3.13クライアントソフトウェアがインストールされたドメインに参加しているWindows Server 2012 R2ボックスがあります。VPN接続がアクティブな場合、「イーサネット2」(TAPインターフェイス)接続は、NLAによってメインLAN NICと共にドメインネットワークカテゴリに配置されます。理想的には、VPNインターフェイスをパブリックカテゴリに割り当てることができるようにしたいと考えています。私はPowerShellを試してみましたが、このエラーが常に発生します: 次のいずれかの理由により、NetworkCategoryを設定できません。PowerShellを昇格させていない。NetworkCategoryを「DomainAuthenticated」から変更することはできません。ユーザーが開始したNetworkCategoryへの変更は、グループポリシー設定 'Network List Manager Policies'が原因で防止されています。行:1 char:1 + Set-NetConnectionProfile -InterfaceIndex 15 -NetworkCategory Public + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ + CategoryInfo:PermissionDenied:(MSFT_NetConnect ... 72AADA665483} "): root / StandardCi ... nnectionProfile)[Set-NetConnectionProfile]、CimException + FullyQualifiedErrorId:MI RESULT 2、Set-NetConnectionProfile 15は「Ethernet 2」のインターフェース番号 注目に値するのは、このコマンドを管理者特権のPowerShellセッションで実行していて、使用可能なすべてのGPOポリシーを試してみましたが、エラーが常にスローされます。NLAに関するほとんどの情報は、プライベートとパブリックの切り替えが機能することを示唆していますが、DomainAuthenicatedは少し異なるようです。 レジストリメソッドにはイーサネット2の実際のプロファイルがないため、そのように変更することもできません。 とにかくTAPアダプターを強制的にパブリックにする方法はありますか?OpenVPN接続自体は、メインNICのデフォルトゲートウェイを上書きせず、10.0.0.0 / 8サブネットを使用します。route-nopullルートを使用してオーバーライドするという事実は、NLAがネットワークを検出する方法の問題の一部である可能性があります。 Ethernet adapter Ethernet 2: Connection-specific DNS Suffix . …

2
MySQLは非常に単純なSELECTクエリで非常に遅い
InnoDBエンジンを備えたMySQL 5.5データベースにデータを保存する仮想マシンで実行されている単純なWebアプリケーションがあります。約3年間はすべて問題なく動作しましたが、突然、非常に遅くなりました。 たとえば、住所を保持する非常に単純なテーブルがあります。 CREATE TABLE `addresses` ( `address_id` int(11) NOT NULL AUTO_INCREMENT, `name` varchar(64) CHARACTER SET latin1 NOT NULL, `firstname` varchar(64) CHARACTER SET latin1 NOT NULL, `street` varchar(64) CHARACTER SET latin1 NOT NULL, `housenumber` varchar(16) CHARACTER SET latin1 NOT NULL, `zip` varchar(5) CHARACTER SET latin1 NOT NULL, `city` varchar(64) CHARACTER …
10 linux  mysql  performance  io 

3
Robocopyを使用したIISレプリケーション上のWordPress
4つのIISサーバーにワードプレス環境をセットアップしました。robocopyスクリプトをトリガーするスケジュールされたタスクを使用して、5分ごとにwordpressディレクトリを複製することを検討しています。 そのようなアプローチについての意見は何ですか?誰かがこれまたは類似のものを使用したことがありますか?

弊社のサイトを使用することにより、あなたは弊社のクッキーポリシーおよびプライバシーポリシーを読み、理解したものとみなされます。
Licensed under cc by-sa 3.0 with attribution required.