サーバー管理者

システムおよびネットワーク管理者向けのQ&A

1
NSレコードの値をIPアドレスにすることはできますか?
今日まで、私はそれができないと信じていました。このページから 名前フィールドは次のいずれかです。 完全修飾ドメイン名(FQDN)(例:example.com)。(ドットで終わる) 修飾されていない名前(ドットで終わらない) '@'($ ORIGINの現在の値を置き換えます) 「スペース」または「空白」(タブ)-これは、名前フィールドの以前の値で置き換えられます。 今、次のクエリを見てください $ dig top-immotunisie.com NS ; <<>> DiG 9.6.0-APPLE-P2 <<>> top-immotunisie.com NS ;; global options: +cmd ;; Got answer: ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 44156 ;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 0 ;; QUESTION SECTION: …

5
バックアップ用の一時的なSSHトンネル
リモートサーバー上のいくつかのMySQLスキーマのコンテンツを自動的にバックアップするシェルスクリプト(現在はbashを使用)を記述したいと思います。リモートサーバーはSSHアクセスのみを許可するようにロックダウンされているためmysqldump、さまざまなスキーマに対して実行する前にSSHトンネルを作成する必要があります。 問題なくトンネルを作成できますが、データベースのダンプが完了した後で自動的にトンネルを閉じたいと思います。 現在、私のスクリプトはこれを行っています: /usr/bin/ssh -T -f -L 4444:127.0.0.1:3306 -l remoteuser 208.77.188.166 sleep 600 /usr/bin/mysqldump --compress -h 127.0.0.1 -P 4444 -u user -ppassword db1 | gzip > /root/backups/snapshot/db1.sql.gz /usr/bin/mysqldump --compress -h 127.0.0.1 -P 4444 -u user -ppassword db2 | gzip > /root/backups/snapshot/db2.sql.gz /usr/bin/mysqldump --compress -h 127.0.0.1 -P 4444 -u user -ppassword …


2
DNS解決エラーのデバッグ
auth.otc.t-systems.comCloudflareのサーバーでドメインのDNS解決エラーをデバッグしていますが、行き詰まりました。奇妙なことに、クエリを実行するマシンによっては検索が成功または失敗しますが、構成がどこで異なるのかわかりません。 失敗は常に次のメッセージで発生します。 server can't find auth.otc.t-systems.com: SERVFAIL 1.1.1.1 CloudflareのDNSです。 これまでに試したこと: nslookup auth.otc.t-systems.com 1.1.1.1さまざまなマシンで実行: 仕事用と自宅用のインターネットがある私のマシンでは失敗します(ただし、どちらの場合もGoogleのDNSで成功します)。 仕事用のインターネットを備えた同僚のマシンでは失敗します。 リモートサーバーへのsshセッションで成功します。 今、私は私たちの仕事のインターネットにいくつかの奇妙な設定があり、それが検索を失敗させると仮定します。しかし、何を探すべきかわからず、失敗するオンラインnslookupサービスもいくつか見つかりました。 失敗:https : //network-tools.com/nslook/Default.asp? domain=auth.otc.t-systems.com &type=1& server=1.1.1.1 &class=1& port=53 & timeout=5000 & go.x=21 &go.y=13 作品:http : //www.kloth.net/services/nslookup.php これをさらにデバッグするためのヒントはありますか?

2
ホストを解決できませんでした:mirrorlist.centos.org Centos 7
最新のcentos 7を新しくインストールしました [root@localhost ~]# cat /etc/centos-release CentOS Linux release 7.4.1708 (Core) [root@localhost ~]# 何かをインストールしたいのにwgetがインストールされなかったので、wgetをインストールしようとすると、yumがエラーを出しているのがわかりました。 インターネットでこの問題に関するすべてのトピックを見たかもしれませんが、解決策を見つけることができませんでした。 [root@localhost ~]# yum update Loaded plugins: fastestmirror Could not retrieve mirrorlist http://mirrorlist.centos.org/?release=7&arch=x86_64&repo=os&infra=stock error was 14: curl#6 - "Could not resolve host: mirrorlist.centos.org; Unknown error" http://mirror.centos.org/centos/7/os/x86_64/repodata/repomd.xml: [Errno 14] curl#6 - "Could not resolve host: mirror.centos.org; Unknown …
11 centos7 

7
DHCPネットワークのマシンに固定IPアドレスを割り当てる
ローカルコンピューターが常にアクセスできるように、サーバーに固定プライベートIPアドレスを割り当てたいです。 現在、サーバーのDHCPアドレスはのようなものです192.168.1.66。 DHCPで使用できるIPからこのIPを除外するように、サーバーに固定と同じIPを割り当て、ルーターを構成するだけですか?または、従来静的アドレス用に予約されているIPの範囲はありますか? 私の初心者の質問は、コマンドに関するものではなく、一般原則と優良慣行に関するものです。 実用的なケース (1/2の編集) 多くの良い答え、特にリアムからの非常に詳細な答えをありがとう。 ルーターの設定にアクセスできました。 Routers's overview panel: ========================= Connectivity type is set to DHCP and PPoE. (...) Network panel ============= IPv4 address distribution (DHCP) -------------------------------- Enable DHCP on LAN : Off DHCP range starts at IP address : 192.168.1.33 DHCP range ends at IP address : …
11 dhcp  ip-address 

2
GoogleクラウドDNSでMXレコードを作成する
ASPMX.L.GOOGLE.COMMXレコードとして追加しようとしていますが、追加できません。エラーはinvalid data recordです。誰でもそれを修正する方法を知っていますか? Google Cloud DNSでGoogle Cloud Platformを使用しています。メールにはGoogle Suiteを使用しています。私のサイトは正常に動作します。

2
ニスデーモンが構成されたポートで待機していない
私はubuntu 16.04にワニスをインストールしようとしています、 私はいくつかの記事を読みましたが、どれも機能していません。私が読んだことから、ubuntu 15.04以降、(systemdのため)ワニスの構成方法が変更されました。 今私は実際の混乱を持っていますがうまくいきません: / etc / default / varnish: DAEMON_OPTS="-a :80 \ -T localhost:6082 \ -f /etc/varnish/default.vcl \ -S /etc/varnish/secret \ -s malloc,256m" /etc/varnish/default.vcl(通常、127.0.0とポート8080を指すホストを指しますが、デバッグ目的で外部ドメインに変更しました)vcl 4.0; # Default backend definition. Set this to point to your content server. backend default { .host = "www.varnish-cache.org"; .port = "80"; } /etc/apache2/ports.conf …

1
kern.logおよびsys.logからUFWブロックを削除します
Nginx、Wordpress、およびUbuntu 16。 私は常にこれらのメッセージで爆撃されています kern.log , syslog and ufw.log Nov 28 21:02:28 kernel: [246817.450026] [UFW BLOCK] IN=eth0 OUT= MAC=xx.xx SRC=122.3.133.77 DST=xx.xx LEN=60 TOS=0x00 PREC=0x00 TTL=53 ID=22334 DF PROTO=TCP SPT=45750 DPT=23 WINDOW=5808 RES=0x00 SYN URGP=0 Nov 28 21:02:31 kernel: [246820.443191] [UFW BLOCK] IN=eth0 OUT= MAC=xx.xx SRC=122.3.133.77 DST=xx.xx LEN=60 TOS=0x00 PREC=0x00 TTL=53 ID=22335 …
11 logging  syslog  ufw 

1
「レジストラ登録の有効期限」と実際の有効期限の関係
ドメインのwhoisクエリのExpiration関連の出力を理解するのに苦労してい.comます。特にRegistrar Registration Expiration Dateフィールドの意味がわかりません。 次に例を示します(短縮): $ whois example.com Whois Server Version 2.0 Domain names in the .com and .net domains can now be registered with many different competing registrars. Go to http://www.internic.net for detailed information. Domain Name: example.com Registrar: CRONON AG Sponsoring Registrar IANA ID: 141 Whois Server: whois.cronon.net Referral …

1
Dockerコンテナーがホストトンネルインターフェース上のOpenVPNクライアントに接続することを許可する
私は次の設定をしています: Dockerサービスを実行しているCentOSホスト ユーザー定義のドッカーブリッジネットワーク そのユーザー定義のブリッジネットワークに接続された2つのDockerコンテナー OpenVPNインストール(現在ホスト上で実行されています。Dockerコンテナーでも実行できます) OpenVPNに接続されている一部のクライアント docker bridgeネットワーク上のdockerコンテナーがtun0ネットワーク上のopenvpnクライアントと通信できるようにするにはどうすればよいですか? docker1(10.10.0.3)とvpn(172.19.0.xの範囲)に接続されたクライアントとの間のtcpベースの通信を透過的に行えるようにしたいと思います。 docker(networking / iptables / ...)側とホスト(iptables?)で何をセットアップする必要がありますか?
11 openvpn  docker 

4
RAMがECCモードで実行されているかどうかを確認するにはどうすればよいですか?
プロセッサを交換してからこの投稿を更新しましたが、私の質問の核心(そして残念ながら結果も)は同じです。 最初のFreeNASボックスを構築し、重要なデータを保存したいので、ECC RAMを使用したいと思いました。私は予算が足りないので、ECC RAMをサポートする最も手頃なソリューションを求めていました。 調査したところ、マザーボード、メモリ、ECCをサポートするCPUが必要であることがわかりました。私が選んだマザーボードは、C232チップセット、DDR4、LGA1151ソケットを備えた「ギガバイトX150M-Pro ECC」です。 また、モデル番号「KVR21E15S8K2 / 8」のキングストン製の2枚のDIMMのキットも購入しました(スペックシート)。ギガバイトはテスト済みのメモリモジュールのリストを公開し、私のモジュールは動作中のECCでサポートされているようです(サポートされているモジュールのリスト)。 予算が足りないので、ECCをサポートする手頃な価格のSkylake CPUが必要でした。Intelによれば、Celeron G3900はECCをサポートしているので、ECCを使用しました。 コンピュータを構築した後、システムが本当にECCメモリで実行されており、マザーボードのBIOSに入っていることを確認したいと思いました。さまざまなインターネットサイトから、一部のマザーボードにECCが機能しているかどうかを通知する特別なセクションがあることを発見しましたが、私のマザーボードにはそれがないようです。すべてのメニューを確認したところ、類似のセクションが見つかりませんでした。 さらに調査を行ったところ、UnixとLinuxのスタック交換に関する投稿が見つかりましたが、私の問題は解決しませんでした。memtest86+「ECC」という値すらわからない最新のものを試してみました。ピュージェットのシステムで使用されていた「ECC:オフ」を示す古い4.20バージョンを試しました。ただし、前述の投稿を読んだ後、それが真実を物語っているとは思えません(たぶん、そのため機能が削除されましたか?)。どちらのバージョンも、DIMMの正しい速度と遅延を読み取れなかったため、への疑問が深まりmemtest86+ます。 もう一つの一般的な方法は、ECCが動作している場合、発行することだった、調べるにはdmidecode -t memory、コマンドをし、読み出しTotal WidthとData Width。私の結果は以下の通りであった128 Bitsと64 Bits、それぞれ。出力の一部には、キーと値のペアがであるメモリ配列に関する詳細が表示されましたError Correction Type: Single-bit ECC。 を期待し72 bitsていたTotal Widthので、デュアルチャネルに関連している可能性があると考え、メモリモジュールを2つの隣接するスロットに移動しました。これにより、デュアルチャネルが使用できなくなりましたが、結果は同じでした。これはの完全な出力ですdmidecode -t memory。 私はピュージェットシステムが公開した興味深いCプログラムを試してみましたが、結果はであり0、ECCサポートがないことを示しています。 今、私はIntel自身のウェブサイト上のデータが正しいことと私のCPUが実際にECCをサポートしていないことに疑問を感じ始めています。メモリとマザーボードの両方に「ECC」という特別なブランドが付いているので、それらを除外できます。 BIOSバージョンがECCを有効にするために更新が必要(現在は何もない)か、ECCが実際に既に機能していて、確認できなかった可能性はありますか?または、ECCメモリを実行したいのにIntelのWebサイトが間違っている、または誤解を招く場合、CPUの選択は間違っていますか? 私のCPUが間違った選択であることが判明した場合、「予算ECC CPU」の次の最良の選択は何でしょうか? 更新:私のシステムがECCを有効にして実行されている可能性があり、ツールが奇妙なデータを報告するだけであるという新しい兆候を見ましたdmidecode。FreeNASフォーラムでは、ユーザーDusanがサーバーグレードのハードウェア(SuperMicro MB、Xeon CPU、Kingston DIMM)を使用しており、と同様の出力が得られ128 Bitsます。しかし、彼はそれが実際に機能するかどうか、自分自身はわからないことを書いた。 更新2: yagmoth555 がこの質問への回答で述べたように、私のマザーボードはXeonプロセッサを備えたECCのみをサポートしているようですが、メモは以前のマニュアルからコピーされたものだと思いました。Xeonプロセッサを調べる必要があることを意味していると思います。:-/ 更新3: Xeon E3-1220v5を購入しました。もちろん、ECCをサポートしており、マニュアルの要件を満たす必要があります。すべてのテストを再度実行してECC機能を確認しましたが、結果は基本的に同じです。 Puget Systemsのコメントから、このecc_check.cプログラムはXeonおよびCore i7プロセッサーでは動作しないようです。:-/ memtest86+今回はさらにチェックアウトしましたが、間違った速度とタイミングだけでなく、インストールされているDDR4の代わりにDDR3も報告するため、DDR4またはC232チップセットをまったくサポートしていないことは間違いありません。ただし、プロセッサは問題なく検出されましたが、の両方のバージョンで同じ最終結果が得られましたmemtest86+。 …

1
bashからのものを除くすべてのpythonプロセスを強制終了する方法
1つのpythonスクリプトを除くすべてのpythonプロセスをbashから強制終了するにはどうすればよいですか。(名前は知っていますが、pidは変更されることがあります)。 私は一種の必要がありますpkill -f "python"が、Python固有のスクリプトを除外しています。 お知らせ下さい。
11 bash 

1
`zfs list`と` zpool list`がraidz2プールの非常に異なるサイズを報告するのはなぜですか?
8つのzpoolを持つZFSサーバーがあります。各プールは、10 + 2 RAIDZ構成の12個の6TBディスクです。したがって、各プールには、12 * 6 = 72 TBのrawストレージスペースと10 * 6 = 60 TBの使用可能スペースがあります。私はそれが使用してクエリを実行する場合しかし、私は別の結果を参照してくださいzfs list使用して対をzpool list以下のように: # zfs list NAME USED AVAIL REFER MOUNTPOINT intp1 631K 48.0T 219K /intp1 intp2 631K 48.0T 219K /intp2 intp3 631K 48.0T 219K /intp3 jbodp4 631K 48.0T 219K /jbodp4 # zpool list NAME SIZE ALLOC …
11 zfs  zfsonlinux 

1
DockerコンテナーからのIPv6接続なし
dockerでIPv6を有効にすると深刻な問題が発生します。 環境 ホストはDebian Jessieを実行しています。 これは仮想サーバー(KVM)です。 eth0は、w:xy:z :: / 64のようなネットワークで静的に構成されたアドレスw:x:y:z :: 1を持っています。これは、私のホスティング会社によってmyに割り当てられています。 私のホストはIPv6を問題なく使用できます。外界へのpingは機能し、コンテナー(ホストにバインドされたポート80)で実行されているWebサイトはipv6を介してアクセスできます。 問題 しかし、コンテナの中から外の世界にアクセスすることはできません!以下のパラメーターでdockerを再起動した後、私のdocker0ブリッジにIPv6アドレスがありません。ルートもゲートウェイもありません(ipv6アドレスがなければ意味がありません)。 私のDockerセットアップ:DockerはDOCKER_OPTSのこれらのパラメーターで開始されます DOCKER_OPTS="--dns 8.8.8.8 --dns 8.8.4.4 --ipv6 --fixed-cidr-v6=w:x:y:z:a::/80" 一部のipv6ホスト構成パラメーター: net.ipv6.conf.all.forwarding = 1 net.ipv6.conf.default.forwarding = 1 これが私が自分で作成したネットワークの1つです。 root@wopr:~# docker network inspect wopr6 [ { "Name": "wopr6", "Id": "ddc192d4af2a8edc809975e84cf3e4cb82c24d4cfe970dd8e3fc7d6ff31e20ee", "Scope": "local", "Driver": "bridge", "EnableIPv6": true, "IPAM": { "Driver": "default", …

弊社のサイトを使用することにより、あなたは弊社のクッキーポリシーおよびプライバシーポリシーを読み、理解したものとみなされます。
Licensed under cc by-sa 3.0 with attribution required.