サーバー管理者

システムおよびネットワーク管理者向けのQ&A


7
なぜストレートイーサネットケーブルですか?
私は友人にストレートケーブルとクロスオーバーケーブルの違いを説明していましたが、なぜ初期の設計者はなぜ2つの異なるケーブルタイプを使用するのが良い考えだと思ったのでしょうか? auto mdi / xが普及するまで続く奇妙な歴史的遺物なのか、それともストレートケーブルが存在する技術的な理由があるのか​​? 編集:指定するには、現在、ストレートケーブルはコンピューターとスイッチ/ハブ間でのみ必要です。スイッチ/ハブが最初からクロスオーバーケーブルを使用するように設計されていないのはなぜですか?
11 ethernet  cable 


4
スクリプトから(GNU)画面を実行
スクリーンセッション内でスクリプトからアプリケーションを起動したいと思います。 スクリプトがなければ、画面を起動し、crtl-acでN個のウィンドウを開き、各ウィンドウでプログラムを実行します。 私は次を試しました screen -d -m -S test screen -S test -X exec tail -f /var/log/messages screen -S test -X screen screen -S test -X exec tail -f /var/log/xinetd.log しかし、セッションテールをアタッチすると実行されません。直後にセッションを接続し、別の端末からscreen -d -m -S startup実行するscreen -S startup -X exec tail -f /var/log/messagesと機能します。 私は何か見落としてますか ? AlexDの回答後に編集します。 半分動作するソリューションは screen -d -m -S test …
11 gnu-screen 

5
fail2banは安全ですか?sshキーを使用する方が良いですか?
SSHにログインするときにキー認証を使用するのか、単にfail2ban + ssh(rootログインが無効)を使用するのかは疑問です。 fail2banは安全ですか?それとも、sshに接続する必要のあるすべてのクライアントマシンでキーを生成して設定するだけで本当に良いですか?
11 ssh  fail2ban 

5
RemoteAppではなくRemoteAppのみを許可する
同様の前提で次の質問を見つけましたが、質問に対する答えは声明として言い換えられた質問でした! RemoteAppは、ユーザーがリモートデスクトップを実行できないようにします RemoteAppを許可し、リモートデスクトップを禁止するにはどうすればよいですか?リモートアプリを許可するには、ユーザーを「リモートデスクトップユーザー」グループに追加する必要があるようです。これにより、リモートデスクトップが可能になります。 「TS Web Access Computers」グループを使用してみましたが、これは彼らにRemoteAppを実行する権限を与えません。 RemoteApp機能をそのままにして、リモートデスクトップを無効にする構成はどこにありますか?

3
IIS7に存在しないAsp.net 4.0ハンドラーマッピング
asp.net 4.0アプリを実行している2つのWindows 2008 R2サーバーがあります。問題が発生しているサーバーは実際にはasp.netページを正常にロードしますが、ajax呼び出しがあると機能しません。他のサーバーのようなこのサーバーのIISには、.net 4.0固有のハンドラーマッピングがないことに気付きました。 文字通り、すべての.net 4.0マッピング(.axd、.soap、.cshtm、.ashx、さらには.aspx)が欠落しています。「aspnet_regiis -ir」を実行しようとしましたが、それは役に立ちませんでした。.net 4.0フレームワークを再インストールする必要がありますか?これらの欠落しているマッピングをすべて手動で追加しますか?他に何か起こっていますか? 私がやりたくないのは、大量のハンドラーをweb.configに追加することです。それらは動作するサーバーには必要ないので、壊れたサーバーには必要ないはずです。

13
サーバーの平均寿命は?
私は、サーバーの寿命が何であるか、または何ができるかを本当に知りたいです。PCの世界に寿命のようなものはありますか?24時間年中無休で稼働していると仮定すると、何時間/日/年/などを使用できますか?

7
LinuxでバックグラウンドでJarを実行する
私は永遠に実行するjarファイルを持っています(ソケットリスニングスレッドで無限ループ)、それを常にバックグラウンドで実行する必要があります。例は次のとおりです。「java -jar test.jar」これを行うにはどうすればよいですか?前もって感謝します!
11 linux  java 

4
無人インストール後のOffice 2010サイレントアクティベーション
OCTを使用して、Office 2010の無人インストールを作成しました。KMSではなくMAKを使用しています(私の決定ではありません)。インストール後にOffice 2010をライセンス認証する方法はありますか?キーはインストール中に設定されますが、アクティブにはなりません。 これはラボ環境で行われるため、ユーザーにライセンス認証を求めるメッセージは表示されません。

5
nmapを使用してIPとMAC​​アドレスを検出できますか?
ロックされています。この質問とその回答はロックされています。なぜなら、質問はトピックから外れていますが、歴史的に重要だからです。現在、新しい回答やインタラクションを受け入れていません。 WindowsシステムでMACアドレスによってデバイスのIPを見つける必要がある場合、通常、radmin.comのAdvanced IP Scannerを使用してネットワークをスキャンし、arp -aを使用してMACアドレスをリストします。 nmapを使用してLinuxおよびWindowsで同じ機能を実行することは可能ですか?スキャンにnmapして、IPとMAC​​アドレスの両方を生成できますか? Linuxでarp -aを試しましたが、Windowsほど速く動作しないようであるか、使用入力が必要なようです。 / vfclists

1
.screenrc-起動時に複数の領域
私はそれが可能であることを知っていますが、私は人生を分割領域モードで1つのウィンドウで画面を起動する方法を理解することはできませんか? 例:起動時に複数のウィンドウを開くように画面を設定していますが、ウィンドウ0を2つの領域に分割して、各領域でアプリケーションを実行したい
11 gnu-screen 

10
システム管理者のドレスコード[非公開]
閉じた。この質問は意見に基づいています。現在、回答を受け付けていません。 5年前に閉鎖されました。 ロックされています。この質問とその回答はロックされています。なぜなら、質問はトピックから外れていますが、歴史的に重要だからです。現在、新しい回答やインタラクションを受け入れていません。 システム管理者としてどのような服装規定を持っていますか? ビジネスカジュアル、カジュアル、カジュアル、フォーマル?「それはすべて、予定している日の種類に依存します」と言っても安全です-しかし、Cレベルの担当者と話す必要がある場合はどうなりますか?予備の服はありますか?
11 untagged 

5
nginxエラーログは巨大だったので、削除して新しいものを作成しましたが、nginxは起動しません
/var/log/nginx/error.logファイルを削除し、次を使用して新しいファイルを作成しました。 sudo nano error.log やってls -laいることを示しているのはerror.logとのaccess.logが同じ権限を持っています。 nginxを起動しようとすると、エラーが発生します。 アラート:エラーログファイルを開くことができませんでした:open() "/var/log/nginx/error.log"許可が拒否されました。 更新 nginxを起動しようとすると、私も見ています: emerg:/var/run/nginx.pidが失敗しました13:許可が拒否されました。

6
送信メールのみを送信するためのsendmailの最小セットアップ?
リモートで管理する単純なサーバーを実行し、エラーが発生するたびに個人のメールアドレスにメールを送信できるようにする必要があります。Ubuntuのデフォルト設定では、sendmailはローカルに送信される電子メールを/ var / spool / mailに蓄積するだけですが、外部の電子メールに送信する必要があります。 私が見つけたチュートリアルはすべて、postfix / sendmailを本格的な電子メールサーバーとして設定することについて説明していますが、送信のみが必要で、外部ログインは必要ありません。これを行う簡単な方法はありますか?

弊社のサイトを使用することにより、あなたは弊社のクッキーポリシーおよびプライバシーポリシーを読み、理解したものとみなされます。
Licensed under cc by-sa 3.0 with attribution required.