サーバー管理者

システムおよびネットワーク管理者向けのQ&A

4
すべての内部サーバーをクラウドに移動する
バックグラウンド 私のクライアントの1人は、約50席のIT依存型のワークフロー主導の法律事務所です。クライアント(FSA規制の住宅ローン業者)の1人によって監査されており、単一サイトはビジネス継続性への脅威であると言われています。私は彼らのビジネスを2つのビットに分割することを提案しました: クライアント側-PC、モニター、椅子、机、LANスイッチ、ルーター、ファイアウォール サーバー側-Active Directory、Exchange、SQL、SharePoint、およびその他の基幹業務アプリ、「ロボット」ワーカーマシン、リモートデスクトップサービスを実行する仮想マシン(合計で約14のVM) アイデアは、機器を保管し、少なくとも別の場所で少なくとも容量の少ないクライアント側環境を迅速に再現するための準備を整えたり、必要に応じてユーザーに自宅から接続させることです。 サーバー側には、より大きな課題があります。これには、(現在はADSLで、すぐに100 Mbpsファイバーになります)IP接続から発行されるサービスと、バックアップを含まない約3 TBのデータが含まれます。サーバー側の環境全体を、現在の自己ホスト型のオンサイトサーバールームからホスト型施設に移動することを提案しました。私はまだ同じレベルのプライバシーを望んでいます。これは、公開されている少数のサービスを除き、インターネットからファイアウォールで保護する必要があり、DMZのWebサーバーVMから最適に提供されます。 現在、2つのサーバールームがあり、それぞれに複製されたSANの1つのノードと1つのHyper-Vクラスターホストが含まれています。冗長ファイバチャネルとイーサネットリンクを組み合わせることにより、サーバールーム全体が失われた場合でもシステムが稼働し続けます。ホストされたサーバー側の環境が、単一のデータセンターの損失に対して同様に回復力があることを望みます。 基本的に、ローカルセルフホスティングから得られるセキュリティ、可用性、制御が必要ですが、クラウドでは、少なくとも30 kmの地理的多様性があります。また、キットを購入して自分でラックに入れたり、ハードウェアの寿命や交換、バックアップなどを心配したりすることはあまり望んでいません。 ご質問 複製するSANおよびHyper-Vクラスターは、データセンターで複製しようとする必要がありますか、または大規模なホスティング事業者とクラウドプロバイダーに可用性を確保する他の方法がありますか? Amazon AWSには必要なすべてのビット(EC2、EBS、S3、VPC、VPNなど)があるように見えますが、EUデータセンターは1つだけです。どのような可用性が期待できますか?たとえば、アイルランドのデータセンターで大規模な停止が発生した場合(たとえば、航空機が着陸することを想像してください)、そこでホストされているサービスはどうなりますか?そして、一般的な信頼性の問題はどうですか? これは、Windows Azure、Rackspace Cloud、または他のクラウドサービスが提供するものを使用して実行できますか? 私の質問を検討してくれてありがとう。

2
とにかくGRUBフェイルセーフをタイムアウトにするには?
すべてのUbuntu 11.04を実行しているランダム(リモート)の場所にインストールされた多数のヘッドレスサーバーを持っています。箱が下がって二度と戻らないこともありますが、最終的に誰かが外に出てGRUB画面に座っていることを確認します。 通常のブートでは、マシンは問題なくGRUBを介して叫びますが、マシンが適切に起動しない場合、次にボックスが起動したときに停止するという「フェールセーフ」が組み込まれているようですGRUB。 これは私の安全のためであると思いますが、マシンのセットアップ方法により、それが起こらないことを望みます(または、少なくとも1、2分後にタイムアウトし、再起動を試みます)。この機能を無効にする方法はありますか?
11 linux  ubuntu  grub 

3
Linuxソフトウェアraidをraid5からraid6に変換します
現在、RAID5アレイに3つの1.5TBディスクを持つファイルサーバーがあります。ほぼ満杯なので、3つの追加ディスク(それぞれ1.5 TB)を入手しました。 6TBのスペースで十分であり、RAID6の安全性を高めたいので、RAID6に切り替えたいと思います。私は完全なバックアップを持っています-つまり、単に新しいアレイを作成してバックアップを復元できます-バックアップを復元せずに切り替えたいと思います。これは可能ですか?

1
503エラーを特にキャッシュしないようにmod_proxyを構成するにはどうすればよいですか?
これは私のmod_proxy設定です: <IfModule mod_proxy.c> <Proxy *> Order deny,allow Allow from all </Proxy> ProxyPass /manage/ http://localhost:9000/manage/ ProxyPassReverse /manage/ http://localhost:9000/manage/ </IfModule> ポート9000にある他のWebサイトが正しく応答しない場合は常に、503エラーが持続することに気付きます。これは、Webサイトが修正された後でも持続します。つまり、503応答はキャッシュされているようです。 どうすれば無効にできますか?自分でキャッシュを有効にしたとは思わない。おそらくこれがデフォルトだろう。

6
SSHが失敗します:PTY割り当て要求はチャネル0で失敗しました
そのため、エラーをグーグルでチェックし、serverfaultをチェックしましたが、解決策は適合しませんでした。ほとんどの結果は/ dev / ptsの問題でしたが、それはマウントされています。他の結果はgitのエラーですが、マシンにはgitがありません。 アカウントはブロックされていませんが、コンソールにログインできます。他のユーザーもこの問題を抱えているので、私の.ssh /にあるものと関係があるとは思わない 私はssh -vvでこの応答を受け取ります: <snip> debug1: Next authentication method: password rogier@server's password: debug2: we sent a password packet, wait for reply debug1: Authentication succeeded (password). debug1: channel 0: new [client-session] debug2: channel 0: send open debug1: Requesting no-more-sessions@openssh.com debug1: Entering interactive session. debug2: callback start debug2: …
11 ssh  debian 

3
Virtualbox CentOS no eth0
新鮮なcentos-minimalをインストールしたばかりで、私はブリッジネットワークを動作させることも、ホストオンリーモードでもないネットワークを取得することはできません。ifconfigを実行すると、eth0のみが存在し、lo / etc / sysconfig / network-scripts / ifcfg-eth0をcatしたときも DEVICE="eth0" HWADDR="08:00:27:FE:D5:10" NM_CONTROLLED="yes" ONBOOT="no"

3
apt-getにインストール後のすべての設定手順をスキップするように依頼するにはどうすればよいですか?
Debian / Ubuntuマシンにいくつかのパッケージ(RabbitMQなど)をインストールする場合、post-installステップはデフォルトでサービスを開始します。 ほとんどの場合これは素晴らしいことですが、場合によっては(たとえば、必要なポートで既にサービスを実行している場合)、これはapt-get失敗し、完全に失敗します。 apt-getこれらのpost-install手順をすべてスキップして、適切にインストールできるようにする方法はありますか? 注これはインストール中の質問に関するものではありません。対話式セッションであっても、post-installステップが失敗すると失敗するため、これらのインストールは失敗します。
11 ubuntu  debian  apt 

7
なぜPEAPの代わりにEAP-TTLSを使用するのですか?
私が理解したように、EAP-TTLSとPEAPは、ワイヤレスネットワークに実装された場合、同じレベルのセキュリティを共有します。どちらも証明書によるサーバー側認証のみを提供します。 EAP-TTLSの欠点は、Microsoft Windowsの非ネイティブサポートであるため、すべてのユーザーが追加のソフトウェアをインストールする必要があります。 EAP-TTLSの利点は、安全性の低い認証メカニズム(PAP、CHAP、MS-CHAP)をサポートできることですが、最新の適切に安全なワイヤレスシステムでそれらが必要な理由は何ですか? あなたはどう思いますか?PEAPの代わりにEAP-TTLSを実装する必要があるのはなぜですか?ほとんどのWindowsユーザー、中程度のLinuxユーザー、そして最も少ないiOS、OSXユーザーがいるとしましょう。
11 security  wifi  radius  peap 

3
ACLを使用してumaskをオーバーライドして、特定のディレクトリで作成されたすべてのファイルを読み取り可能にすることはできますか?
私のumaskが0077であると仮定します。 foo特別な権限を適用したいディレクトリがあります。私が作成するすべてのファイルはfoo誰でも読み取り可能でなければならず、すべてのディレクトリは誰でも読み取りおよび実行可能でなければなりません。 現在、ファイルを作成すると、ファイルは0600になり、ディレクトリは0700になります。 $ cd foo/ $ touch file $ mkdir directory $ ls -l drwx------ 2 nfm nfm 4096 2012-01-12 16:16 directory -rw------- 1 nfm nfm 0 2012-01-12 16:15 file umaskに関係なく、ファイルを0644、ディレクトリ0755にします。 drwxr-xr-x 2 nfm nfm 4096 2012-01-12 16:16 directory -rw-r--r-- 1 nfm nfm 0 2012-01-12 16:15 file どうすればこれを達成できますか?

3
パスワードとセキュリティのパイピング
私は時々やりますecho "secret" | mysql -u root -p ...。今、私はここでセキュリティについて心配しています:すべてのプロセスをリストする誰かがパスワードを見ることができますか? 確認するには、「ps aux」の出力にecho "test" | sleep 1000秘密のechoコマンドが表示されていませんでした。だから私はそれが安全だと思います-しかし、セキュリティの専門家はそれを確認できますか?:)
11 security  shell 

2
「このプログラムは動作を停止しました」などのダイアログを完全に無効にします
Windows 2008の自動化プロセスでコマンドラインプログラムを実行し、Windows 2008を閉じるときに、[閉じる]ボタンを使用して "このプログラムは動作を停止しました"ダイアログを表示する場合があります。完全に無効にする方法は?すべてのユーザーのエラー報告をオフにしようとしましたが、それで問題は変わりません。

11
多くのサーバーのシステム更新
私たちには多くのサーバーがあり、それらをすべて更新したいと考えています。実際の方法は、システム管理者のいずれかがサーバーからサーバーに移動し、aptitude update && aptitude upgradeそれを作成することです-それはまだクールではありません。 私は今でも優れたソリューションを探しています。人形はこの仕事をすることができますか?どうやってやるの?


4
自動Linuxアップデートのベストプラクティス
RHEL / RHELベースのサーバーの自動更新を実行する方法に取り組んでいます。 最初のアイデア: Puppetを使用して、デフォルトのリポジトリを無効にし、独自のリポジトリを指定します。次に、ensure => latest自動的に更新するパッケージに使用します。 問題:更新後に一部のサービスが再起動することがわかりました(当たり前)。 質問: Linuxの更新を自動化する方法や、サービスの自動再起動を緩和するための戦略に関するアドバイスはありますか?Puppetを含むソリューションをお勧めしますが、別のサービスを使用する必要がある場合、それは契約違反ではありません。 編集 考えられる解決策: @ voretaq7と@ewwhiteが提案したものの多くを実装する解決策を提出しました。これが私が当分の間行っているルートであるようです。他に提案がある場合は、コメントするか回答を送信してください。


弊社のサイトを使用することにより、あなたは弊社のクッキーポリシーおよびプライバシーポリシーを読み、理解したものとみなされます。
Licensed under cc by-sa 3.0 with attribution required.