サーバー管理者

システムおよびネットワーク管理者向けのQ&A

2
iptablesはチェーンを1つだけ表示します
tldr:iptablesで1つのチェーンだけを表示するにはどうすればよいですか? iptablesでテーブルを1つだけ表示できますが、テーブルは複数のチェーンで構成されています。チェーン内のどこでINPUTが最後のルールであるかを見つける必要があります(通常、常にではありませんが、すべてのルールを拒否します)。 私はawkといくつかのgrepを試しましたが、それらのスキルは衰えているに違いありません。私はawkを使用して1つの段落だけを取得しようとしましたが、iptables --line-numbers -n -L -t filterおそらくそれらの空白行が実際には空白ではないため、の出力では機能しないようです。 CentOS 6の最小環境にインストールされる通常のgnuツールを使用したソリューションを探しています。
12 iptables  firewall  awk 

1
robocopyはサーバー間のファイルのドラッグ/ドロップより20倍遅い
2つのサーバー間で20 TBのファイルを移行しています。どちらのシステムもWindows 2012R2で、最新のアップデートがインストールされています。どちらもギガビットネットワークを使用しています。 コマンドラインで新しいサーバーでrobocopyを使用する robocopy /S /ZB /MOVE /J /DCOPY:A /V /FP \\oldserver\shared\folder X:\folder それは約5-10MB / sでコピーします。 エクスプローラーを使用してサーバー間でファイルをドラッグアンドドロップすると、約110MB / sになります。これは私が期待した速度です。 ファイル共有とネットワークの速度が明らかに速いのに、なぜrobocopyの速度が遅いのか理解できません。 私が試したこと: スイッチの問題を排除するために、サーバーをイーサネットケーブルで直接接続します。変化なし。 /MT値が1、4、8、16 のスイッチ。すべてほぼ同じ速度でコピーされます。 ファイルを移動する代わりにコピーします。変化なし。 画面に出力する代わりにログファイルを使用する。変化なし。 古いサーバーからのファイルのプッシュと新しいサーバーからのプル。変化なし。 何か案は?
12 robocopy 

2
rsync(chown chmod)で宛先のアクセス許可を設定するにはどうすればよいですか
マウントポイントからローカルフォルダーまで、ローカルrsyncを実行しようとしています。所有者、グループ、およびアクセス許可を特定の設定に設定する必要があります。これが私が使っているものです: rsync -rtlv --chown=process:sambausers --chmod=D770,F770 /mnt/owncloud_mnt/Engineering/ /Drive_D/docs/Engineering_test 私はディレクトリとファイルの両方で760のパーミッションを取得し、所有権のroot:rootを取得します(rsyncはrootとして実行されます)。 何が悪いのですか? TIA
12 linux  rsync  fedora 

1
「tlsv1 alert unknown ca」とはどういう意味ですか?
私はそのようなクライアント証明書を使用してカールリクエストをしようとしています: curl -E my.pem https://some.site そして、私は次のエラーメッセージを受け取ります: curl: (35) error:14094418:SSL routines:SSL3_READ_BYTES:tlsv1 alert unknown ca これは何を意味するのでしょうか? この苦情は、私が接続しているサーバー、または私のcurlクライアントからのものですか? (どのように判断しますか)このコンテキストのCAは何ですか? caがわかるようにするにはどうすればよいですか?

4
リダイレクトにはSSL証明書が必要ですか?
現在、サイトの「HTTPリダイレクト」機能にある永続的なリダイレクトを使用して、IIS 8.5で新しいアドレスにリダイレクトするように設定されたWebサイト(クライアントはドメイン名を変更しましたが、古いドメインから新しいサイトにユーザーを送信することを望んでいます)があります。 古いドメインのSSL証明書が更新されるようになりました。更新が必要かどうかについては、技術部門に未解決の問題があります。 IISでHTTPリダイレクトを設定した場合、サイトにはSSL証明書が必要ですか?または、訪問者はそのようなものがチェックされる前にリダイレクトされますか?

3
Nginxでsendfileのオン/オフを使用する場合と使用しない場合
この設定はnginx.confかなり前からあります。 sendfile on; たとえばファイルを更新し、/js/main.jsブラウザーhttps://test.com/js/main.js?newrandomtimestampからアクセスした場合、ブラウザーから完全な更新(キャッシュのクリア)を行わない限り、古いバージョンがロードされます。 しかし、sendfileから設定を変更すると、sendfileをオフにします。ブラウザーは、更新されたファイルの正しいバージョンをロードします。 実稼働Webサーバーでは、sendfileをオンに使用する必要があります。またはsendfile off ;? sendfileがオンの場合; 上記の問題を解決するにはどうすればよいですか(キャッシュが改善されたためか、パフォーマンスが向上したかなど)。 以下はnginx.conf本番サーバーので、バージョン1.7.5を使用しています。 user nginx; worker_processes 2; error_log /var/log/nginx/error.log warn; pid /var/run/nginx.pid; worker_rlimit_nofile 51200; events { use epoll; worker_connections 51200; } http { include /etc/nginx/mime.types; default_type application/octet-stream; log_format main '$remote_addr - $remote_user [$time_local] "$request" ' '$status $body_bytes_sent "$http_referer" ' '"$http_user_agent" "$http_x_forwarded_for"'; access_log …
12 nginx  cache 

2
AWS CLIコマンドライン:「--query」を使用して複数のソース行を出力する方法
aws-cliバージョン1.7.8を使用--queryして、複数の行から派生した1つのレコードを作成するための出力を取得しています。この場合、私はから特定の情報を取得しようとしていますdescribe-instances。 ではdescribe-instancesコマンド、我々はを参照してくださいライン/セクションを取得しRESERVATIONS、INSTANCESとTAGS。 新しいAWS CLIコマンドを実行するだけで、3行すべてから個別に情報を取得できます。 予約ライン: aws ec2 describe-instances --instance-ids i-xxxxxxxx --query 'Reservations[*].ReservationId' INSTANCE行: aws ec2 describe-instances --instance-ids i-xxxxxxxx --query 'Reservations[*].[Instances[*].[InstanceId,ImageId]]' タグライン: aws ec2 describe-instances --instance-ids i-xxxxxxxx --query 'Reservations[].Instances[].[Tags[?Key==名前]]' これら3つのコマンドを実行し、結果を連結して1つのレコードを作成できます。 これを3つの異なるコマンドではなく、1つのコマンドとして実行できる方法があるかどうか誰かが知っていますか? PIPEやその他の形式の構文を試しましたが、現時点では良い解決策を見つけることができません。 単一のコマンドからこれら3つのコマンドの同等の出力を取得できますか?

2
404ページのモニターモニターhttpステータス
404または403ページでHTTPステータスを監視しようとしています。ご存じのように、Monitはこれらのページを接続の失敗と見なしますが、どうすればそれを変更できますか。404または403ページが表示されることを監視したいだけです。 可能であれば、この構成で確認する必要があります。 これは私のチェック設定です: check process httpd with pidfile /var/run/httpd.pid start program = "/etc/init.d/httpd start" stop program = "/etc/init.d/httpd stop" if failed host hostname port 80 protocol HTTP request "/" then exec "/bin/bash -c '/bin/echo -e "hostname\thttpd\t3\tFAILED" | /usr/sbin/send_nsca -H nagiosserver -c /etc/send_nsca.cfg; /usr/bin/monit restart nginx;'"
12 http  monit 

1
OpenSSL:genrsa対genpkey?
なぜOpenSSLは2つのユーティリティを提供し、重複が多いのですか genpkey: OpenSSL> genpkey - Usage: genpkey [options] where options may be -out file output file -outform X output format (DER or PEM) -pass arg output file pass phrase source -<cipher> use cipher <cipher> to encrypt the key -engine e use engine e, possibly a hardware device. -paramfile file parameters …
12 openssl 

5
Kerberos事前認証エラーの原因となっているプロセス/プログラムを追跡(コード0x18)
2つのサーバーのうちの1つを介してロックアウトされているドメインアカウントがあります。ビルトイン監査はそれだけを教えてくれます(SERVER1、SERVER2からロックアウト)。 アカウントは5分以内にロックアウトされ、1分あたり約1リクエストのようです。 私は最初に(sysinternalsから)procmonを実行して、アカウントのロックを解除した後に新しいPROCESS STARTが生成されているかどうかを確認しようとしました。疑わしいものは何も出てきません。私のワークステーション上でprocmonのを実行し、UACシェル(conscent.exe)に上昇した後のことがスタックからのように思えるntdll.dllとは、rpct4.dllあなたが(ないように注意してください)ADに対してのauthしようとすると、呼び出されます。 DCへの認証要求を引き起こしているプロセスを絞り込む方法はありますか?これは常に同じDCであるため、そのサイト内のサーバーである必要があります。私はwiresharkでコールを探すこともできますが、それが実際にそれをトリガーしているプロセスを絞り込むことはできません。 そのドメインアカウントを使用しているサービス、ドライブマッピング、またはスケジュールされたタスクもないため、ドメインの資格情報が格納されている必要があります。どのサーバーにも、そのドメインアカウントで開いているRDPセッションはありません(確認しました)。 その他のメモ はい、「成功/失敗」ログオン監査は問題のDCで有効になっています。実際にアカウントがロックアウトされるまで、失敗イベントはログに記録されません。 さらにショー掘りLSASS.exeになりKERBEROS、アカウントのロックが解除されると、問題のDCへの呼び出しを。これは、(一般的には)vpxd.exevCenterプロセスであるJavaによって呼び出されるようです。しかし、他の "server2"を見ると、アカウントのロックアウトが(また)発生する可能性があり、への呼び出しが表示さlsass.exeれず、apacheプロセスのみが生成されています。この2つの関係は、SERVER2がSERVER1のvSphereクラスターの一部である(server1がvSphere OSである)ことだけです。 DCのエラー つまり、ADから言われるのは、認証前のKerberosエラーだということだけです。klist念のため、確認したところチケットはなく、とにかくフラッシュしました。このkerberosエラーの原因はまだわかりません。 Index : 202500597 EntryType : FailureAudit InstanceId : 4771 Message : Kerberos pre-authentication failed. Account Information: Security ID: S-1-5-21-3381590919-2827822839-3002869273-5848 Account Name: USER Service Information: Service Name: krbtgt/DOMAIN Network Information: Client Address: ::ffff:x.x.x.x Client Port: 61450 Additional Information: …

5
LinuxでIPコマンドを使用してIPを削除する
次のように2つのIPを追加すると、 ip addr add 1.1.1.1/24 dev eth2 ip addr add 1.1.1.2/24 dev eth2 そして、私はこのようなものを削除しようとします: ip addr del 1.1.1.2/24 dev eth2 両方のIPが削除され、その処理方法がわかりません。 誰でもそれを解決する方法を知っていますか?

4
ランダムなIPアドレスからの「\ x」で始まるランダムにエンコードされた文字列によるNginx 400エラー
これらはある種のボットだと思いますが、彼らが私のサーバーに対して何をしようとしているのか知りたいのです。 質問のログインは以下であり、IPアドレスは元のアドレスから変更されています。 12.34.56.78 - - [18/Oct/2012:16:48:20 +0100] "\x86L\xED\x0C\xB0\x01|\x80Z\xBF\x7F\xBE\xBE" 400 172 "-" "-" 12.34.56.78 - - [18/Oct/2012:16:50:28 +0100] "\x84K\x1D#Z\x99\xA0\xFA0\xDC\xC8_\xF3\xAB1\xE2\x86%4xZ\x04\xA3)\xBCN\x92r*\xAAN\x5CF\x94S\xE3\xAF\x96r]j\xAA\xC1Y_\xAE\xF0p\xE5\xBAQiz\x14\x9F\x92\x0C\xCC\x8Ed\x17N\x08\x05" 400 172 "-" "-" 12.34.56.78 - - [18/Oct/2012:16:58:32 +0100] "g\x82-\x9A\xB8\xF0\xFA\xF4\xAD8\xBA\x8FP\xAD\x0B0\xD3\xB2\xD2\x1D\xFF=\xAB\xDEC\xD5\xCB\x0B*Z^\x187\x9C\xB6\xA6V\xB8-D_\xFE" 400 172 "-" "-" 12.34.56.78 - - [18/Oct/2012:17:06:59 +0100] "\xA61[\xB5\x02*\xCA\xB6\xC6\xDB\x92#o.\xF4Kj'H\xFD>\x0E\x15\x0E\x90\xDF\xD0R>'\xB8A\xAF\xA3\x13\xB3c\xACI\xA0\xAA\xA7\x9C\xCE\xA3\x92\x85\xDA\xAD1\x08\x07\xFC\xBB\x0B\x95\xA8Z\xCA\xA1\xE0\x88\xAEP" 400 172 "-" "-" 12.34.56.78 - - [18/Oct/2012:17:13:53 +0100] "b\xC4\xA24Z\xA2\x95\xEFc\xAF\xF1\x93\xE8\x81\xFD\xB4\xDEo\x92\xC0v\x1Fe\xD8W\x85\xC7O\x9D\x8C\x89<" 400 172 …
12 nginx  logging  hacking 

3
1時間ごとにOpenVPNサーバーから切断される
OpenVPN構成にかなり奇妙な問題があります。からWindows 7最新の公式OpenVPNクライアントでOpenVPNサーバーに接続しています(OpenVPN 2.1.4 i386-redhat-linux-gnu)。 問題はOpenVPN、1時間後にちょうどサーバーから切断され、どのディレクティブ/オプションがこれを担当するのか理解できないことです。多分それはクライアントの問題ですか?別のWindowsシステムとWindows VPNクライアントを試しました。Linux無切断して期待通りのクライアントが働いています。 この問題のトラブルシューティングを手伝っていただけませんか?私は本を読み、グーグルで試してみましたが、一部の人々が一緒にプレイすることをお勧めkeepaliveしてreneg-secディレクティブ。しかし、それは役に立たないようです。 OpenVPNサーバー設定 port 1194 proto udp dev tun ca ca.crt cert server.crt key server.key dh dh1024.pem server 192.168.2.0 255.255.255.0 ifconfig-pool-persist ipp.txt push "route 10.0.0.0 255.0.0.0" client-config-dir ccd route 192.168.51.0 255.255.255.0 keepalive 60 600 reneg-sec 5000 hand-window 15 tls-auth ta.key 0 comp-lzo max-clients 50 user …
12 openvpn 

3
nmapがpingスキャンで稼働中のホストを見つけられない
nmapを使用してローカルネットワークにpingスキャンを試みましたが、確実に稼働しているマシンを見つけられないようです。pingには応答しますが、pingスキャンには応答します。 pingの結果: $ ping 192.168.0.2 PING 192.168.0.2 (192.168.0.2): 56 data bytes 64 bytes from 192.168.0.2: icmp_seq=0 ttl=64 time=1.585 ms そしてtcpdumpの出力: $ tcpdump -i fxp0 -n host 192.168.0.2 12:43:07.624911 IP 192.168.0.222 > 192.168.0.2: ICMP echo request, id 61023, seq 0, length 64 12:43:07.625029 IP 192.168.0.2 > 192.168.0.222: ICMP echo reply, id …
12 networking  ping  nmap 


弊社のサイトを使用することにより、あなたは弊社のクッキーポリシーおよびプライバシーポリシーを読み、理解したものとみなされます。
Licensed under cc by-sa 3.0 with attribution required.