サーバー管理者

システムおよびネットワーク管理者向けのQ&A

5
nginxをインストールして設定ファイルをインストールする方法
使用してサーバー(Ubuntu 11.04)からnginx 1.0.6を完全にアンインストールしました apt-get remove nginx rm -rf /etc/nginx/ rm -rf /usr/sbin/nginx rm /usr/share/man/man1/nginx.1.gz apt-get remove nginx* もう一度インストールしたいのですが、nginxを起動すると次のようなエラーが表示されます。 nginxの再起動:nginx:[emerg] open() "/etc/nginx/nginx.conf"が失敗しました(2:そのようなファイルまたはディレクトリはありません) 次に、独自のconfファイルを配置すると、新しいエラーが発生します。 nginxの再起動:nginx:[emerg] open() "/etc/nginx/mime.types"が失敗しました(2:そのようなファイルまたはディレクトリはありません)/etc/nginx/nginx.conf:12 今ではそれapt-get install nginxが完全にインストールされていないようです、私はapt-getキャッシュをクリアしましたが、役に立たないようです。apt-getを使用してnginxのフルインストールを取得するにはどうすればよいですか?
12 ubuntu  nginx  apt 


3
同じUbuntuサーバーで複数バージョンのPostgreSQLを実行する
PostgreSQL 8.4と9.0を同じサーバー(Ubuntu Lucid)で実行しています。 両方をapt-getを使用してインストールしました(デフォルトのパッケージソースでは8.4、https: //launchpad.net/~pitti/+archive/postgresqlからppaを追加した後は9.0 )。 コマンドラインから「createdb」などのコマンドを実行するか、「psql」シェルを起動すると、私のシステムではデフォルトでPostgreSQLバージョン8.4が使用されます。 では、これらのコマンドで8.4ではなくPostgreSQL 9.0を使用するように強制するにはどうすればよいですか?

1
厳格、中程度、オープンなNATとは何ですか?
国内ルーターのNATオプションは、多くの場合、厳格に構成されています。これは何を意味するのでしょうか?モデレートまたはオープンは何をしますか?ポートフォワーディング/ DMZアクセスはstrictで正しく機能するので、なぜ他の2つに悩むのでしょうか? ルーターを見ると、これがファイアウォールに影響を与えていることがわかります。Cisco / iptablesを使用してネットワークをセキュリティ保護するために多大な時間を費やす場合、そのような簡潔で説明のつかない答えは腹立たしく、これがファイアウォールにどのような影響を与えるかについての手がかりはありません。 誰かが光を当ててください。
12 router  nat  open 


2
powershellを使用してUSB外付けドライブをマウント解除する
PowerShellを使用して外付けUSBドライブのマウントを解除しようとしていますが、これを正常に実行できません。次のスクリプトは私が使用するものです。 #get the Win32Volume object representing the volume I wish to eject $drive = Get-WmiObject Win32_Volume -filter "DriveLetter = 'F:'" #call dismount on that object there by ejecting drive $drive.Dismount($Force , $Permanent) 次に、コンピューターをチェックして、ドライブがアンマウントされているかどうかを確認しますが、マウントされていません。 ブールパラメータ$ forceと$ permanentは、さまざまな順列を使用して試されたが、役に立たなかった。paramsが切り替えられると、dismountコマンドによって返される終了コードが変わります。 (0,0) = exit code 0 (0,1) = exit code 2 (1,0) = exit code …

3
AWS Application Load BalancerでHTTPをHTTPSにリダイレクトするにはどうすればよいですか?
私たちのウェブサイトはHIPAAに準拠する必要があるため、すべてを暗号化する必要があります。「私は、彼らがに入れたときに、クライアントは、エラーメッセージを取得する必要はありませんHTTP私はHTTPSにHTTPとHTTPS、およびHTTPリダイレクトの両方をサポートする必要があるので、://mysite.com」。私は正しいですか? 私はウェブサーバーでそれを正しく行いました。したがって、Webサーバーに直接接続すると、HTTPは自動的にHTTPSにリダイレクトされます。すべて良い。 しかし、WebサーバーはAWS Application Load Balancerの背後にあります。ELBでHTTPをHTTPSにリダイレクトする方法がわかりません。そのため、クライアントブラウザーは引き続きHTTP経由でELBに接続できます。 AWS Application Load BalancerでHTTP => HTTPSを設定するにはどうすればよいですか? つまり、ELBとWebサーバー間の接続がHTTPSであることは確かですが、クライアントブラウザーとELB間の接続がHTTPSであることを確認するにはどうすればよいですか。

1
[::]:80エラーのNginx重複リッスンオプション
コマンドを実行して構成をテストすると、に複数の重複があるというエラーが表示され[::]:80ます。その前に、複数のデフォルトサーバーの重複に関する問題がありました。 複数のデフォルトサーバーで問題が発生した場合、ファイルは次のようになりました server { listen 80 default_server; listen [::]:80 default_server ipv6only=on; root /usr/share/nginx/html; index index.php index.html index.htm; server_name munki; error_page 404 /404.html; error_page 500 502 503 504 /50x.html; location = /50x.html { root /usr/share/nginx/html; } location /report { try_files $uri $uri/ =404; } location ~ \.php$ { try_files $uri =404; …
12 ubuntu  nginx 

2
Linuxで夏時間(DST)の変更を無効にする
数週間前、DSTは永続的であり、GMT + 3が国内で永久に使用されることが(トルコのエネルギー天然資源省によって)発表されました。 現在、Linuxサーバーのタイムゾーンはヨーロッパ/イスタンブールに設定されています。ただし、tzdataの更新はまだリリースされていません。 更新がないため、2016年10月30日に、zoneinfoファイル(/ usr / share / zoneinfo / Europe / Istanbul)で宣言されているように、タイムゾーンが自動的にGMT + 3からGMT + 2に変更されます。 以下の2016年の詳細を確認できます。 # zdump -v /usr/share/zoneinfo/Europe/Istanbul | grep 2016 /usr/share/zoneinfo/Europe/Istanbul Sun Mar 27 00:59:59 2016 UT = Sun Mar 27 02:59:59 2016 EET isdst=0 gmtoff=7200 /usr/share/zoneinfo/Europe/Istanbul Sun Mar 27 01:00:00 2016 UT = …


2
Apacheが特定の設定をロードしたかどうかを確認しますか?
設定ファイルがたくさんあるので、1つのファイルを作成しましたが、その効果がわかりません。 私の設定が間違っているか、設定ファイルがApacheによって読み込まれていません。 特定の構成ファイルがApacheによってロードされたかどうかを確認するために実行できるコマンドはありますか? apachectl configtest エラーを出力しません。サーバーはエラーなしで再起動します。
12 apache-2.2 


4
PHP:直接リンクを提供せずにファイルをダウンロード用に提供する
ダウンロード用の請求書を提供したい。現在、単純な番号付けスキーム(invoice-01.pdf、invoice-02.pdfなど)を使用しています。代わりにハッシュを使用してデータを不明瞭にすることができることを知っています。 PHPを使用して、ユーザーに直接ポイントさせないで請求書を提供することもできますか?
12 php 

5
SSHを介してWebトラフィックをトンネリングしている間、インタラクティブシェルアクセスを無効にできますか?
外部ユーザーがイントラネット専用のWebアプリケーションにアクセスするための安価なVPNソリューションとして、SSHトンネリングの実装を検討しています。 現在、OpenSSHがインストールされたUbuntu Server 10.04.1 64ビットを使用しています。 WindowsボックスでPuttyを使用して、sshサーバーへのローカルポートにトンネルを作成しています。 start putty -D 9999 mysshserver.com -N 次に、Firefoxにlocalhost:9999でSOCKSプロキシを使用するように指示します。 -Nフラグは、クライアント側からインタラクティブシェルを無効にします。サーバー側でこれを行う方法はありますか? ルートアクセスの無効化、rsaキー認証の使用、およびデフォルトポートの変更。この目的のために私が従うべき他の明らかなセキュリティ慣行はありますか?私の目標は、単にWebトラフィックをトンネリングできるようにすることです。
12 security  ssh  proxy  shell  socks 

2
シグナル11の原因は何ですか?[閉まっている]
ここで何が尋ねられているのかを知るのは難しい。この質問は、あいまいで、あいまいで、不完全で、過度に広い、または修辞的であり、現在の形では合理的に回答することができません。再開できるようにこの質問を明確にするヘルプについては、ヘルプセンターに アクセスしてください。 10年前に閉鎖。 信号11の最も可能性の高い原因は、「セグメンテーション違反」としても知られていますか?
12 linux 

弊社のサイトを使用することにより、あなたは弊社のクッキーポリシーおよびプライバシーポリシーを読み、理解したものとみなされます。
Licensed under cc by-sa 3.0 with attribution required.