サーバー管理者

システムおよびネットワーク管理者向けのQ&A


2
アップストリームに到達できない場合にnginxにサイト構成を無視させる
nginxに複数のサイト構成があり、マシンを再起動したときに、サイトの上流の1つに到達できない場合、nginxはまったく起動せず、結果としてこれらの健全なサイトは起動しません。 nginxはそれらの無効なサイトを無視しますか? http { ## # Basic Settings ## sendfile on; tcp_nopush on; tcp_nodelay on; keepalive_timeout 65; types_hash_max_size 2048; # server_tokens off; # server_names_hash_bucket_size 64; # server_name_in_redirect off; include /etc/nginx/mime.types; default_type application/octet-stream; ## # Logging Settings ## access_log /var/log/nginx/access.log; error_log /var/log/nginx/error.log; ## # Gzip Settings ## gzip on; gzip_disable "msie6"; …
12 nginx 

2
Azure App ServiceのCPU使用率が100%になる原因を特定するにはどうすればよいですか?
私は、Azure App Serviceプランに5つのアプリを持っています。異なるクライアント向けの同じアプリのすべての異なるコピーです。これは、SQLデータベースを備えたASP.NET MVCアプリです。 今朝、目が覚めたのは遅い、応答しないサイトで、503エラーが時々発生しました。App ServiceプランのCPU /メモリメトリックを確認したところ、CPUが100%に固定されていることがわかりました。 また、個々のサイトのCPU時間のグラフは、すべてが同時にオフになっていることを示していますが、他のサイトよりも悪いものもあります。 Advanced Application Restartを実行して問題を解決しようとしましたが、ブレードがロードされませんでした。これは、サーバーが応答できなかった情報を取得しようとしたためと考えられます。 最後に、各サイトを1つずつ停止して、CPUをゼロに戻した後、それらを再び起動しましたが、これで問題は解決されたようですが、今ではいくつかのサイトが上昇を始めています。 私は数週間前に同様の問題を経験し、自分のアプリプランに対して大きくなりすぎていると想定していたため、S1からS2にアップグレードしましたが、今日まで問題ありませんでした。 このCPUに飢えた動作の原因が何であるかを理解する方法について、私は完全に困惑しています。誰かが私にこれを診断し始める方法の正しい方向を教えてもらえますか?

1
セキュリティグループをAWS RDSインスタンスにリンクする方法
RDSにpostgres dbセットアップがあります。それは素晴らしいです。ただし、これを、すべてが単一のに存在するELBの背後にある自動スケーリングされたEC2インスタンスのセットにリンクしたいと思いますEC2 security group。 EC2セキュリティグループをソースとして使用するRDSインスタンスのセキュリティグループにルールを追加することが可能であると言われました。コンソールに移動してRDSセキュリティグループを編集すると、ソース列の下に次のオプションのみが表示されますAnywhere, Custom IP, and My IP。 列の上部にある情報ポップアップには次のように記載されています:To specify a security group in another AWS account (EC2-Classic only), prefix it with the account ID and a forward slash, for example: 111122223333/OtherSecurityGroup.(EC2-Classicにのみ適用できるようです) ソースドロップダウンボックスに入力できません。 RDSセクションの下で、私はそれらが持っていることに気づきますoption groups。ただし、私のpostgresインスタンスに関連付けられているデフォルトのオプショングループは編集できません。 そこで、新しいグループを作ってみました。この時点で、私はpostgresが利用可能としてリストされていないことを発見しましたengine。代わりにmysqlを選択して、オプションを追加できるかどうかを確認しました。mysqlインスタンスにセキュリティグループを追加できるようですが、postgresインスタンスは追加できません。 postgresインスタンスはこの期待されるオプションをサポートしていませんか?

2
ドライブが「E」状態のSynology NASでmdadmアレイを回復するにはどうすればよいですか?
Synologyには、カーネルのrdev-> flags構造に「DriveError」フラグを追加する、カスタマイズされたバージョンのmdドライバーとmdadmツールセットがあります。 正味の影響-アレイの障害(最初のドライブ)が発生し、2番目のドライブのエラーが発生した場合、アレイは、ドライブからの読み取りが機能しているにもかかわらず、アレイを修復または再構築できない状態になります。大丈夫。 この時点では、この質問についてはこの配列についてはあまり心配していません。既にコンテンツを取り出して再構築するつもりなので、将来的にはこの問題の解決方法を知りたくないからです。 、これは2回目なので、フォーラムで他の人が同様の質問をしているのを見たことがあります。 Synologyのサポートはあまり役に立たず(ほとんどの場合無反応)、ボックスのRAIDセットの扱いに関する情報は一切共有されません。 / proc / mdstatの内容: ds1512-ent> cat /proc/mdstat Personalities : [linear] [raid0] [raid1] [raid10] [raid6] [raid5] [raid4] md2 : active raid5 sdb5[1] sda5[5](S) sde5[4](E) sdd5[3] sdc5[2] 11702126592 blocks super 1.2 level 5, 64k chunk, algorithm 2 [5/4] [_UUUE] md1 : active raid1 sdb2[1] sdd2[3] sdc2[2] …

5
USBからのキックスタートインストール—キックスタートの場所
キックスタートファイル(/server/548405/)を追加した後、Fedora ISOを正常に(USBスティック用に)再構築できるようにした後、USBメディアでキックスタートファイルを見つける際に問題が発生しました。 これがCDROMから行われる場合、このパラメーターをブートに追加することにより、単純にキックスタートできます: linux ks=cdrom これによりキックスタートが行われます(キックスタートファイルの名前がks.cfgであり、ディスクのルートにある場合)。 さて、これは明らかにUSBドライブでは異なりますので、私の研究から、この行がうまくいくと思いました: linux ks=hd:sdb1:/ks.cfg 明らかにこれは機能しません。このドライブは既にマウントされており、再マウントできないというエラーメッセージが表示されます。 編集:実際のエラーメッセージ: mount: /dev/sdb1 is already mounted or /run/install/tmpmnt0 busy Warning: Can't get kickstart from /dev/sdb1:/ks.cfg 構文が正しいことをテストするために、私はキックスタートファイルを別のUSBスティックに置き、同じコマンドをロードして新しい場所からks.cfgを取得しました。 linux ks=hd:sdc1:/ks.cfg これは機能します(USBスティックが順番にマウントされている場合、ブート-> sdb1、キックスタート-> sdc1)。インストールはキックスタートし、問題なくインストールを完了します。明らかに、2つのペンドライブを使用する必要があることは、ややイライラして信頼性が低くなります。 これを回避する方法はありますか?
12 linux  fedora  usb  kickstart 

7
Windows Server 2012でRDPを修正する方法
以下は、RDPステータスのスナップショットです。いいね: リモートマシンから接続しようとすると、エラーが発生します。 "This computer can't connect to the remote computer. Try connecting again. If the problem continues..." ポート3389をリモートでテストしましたが、開いています。私はそれをnetstatでテストしました。 TCP 0.0.0.0:3389 hostname:0 LISTENING Windowsファイアウォールなし ネットワークファイアウォールなし 真新しい自己署名証明書 マシンは最近再起動され、その前に機能していました ターミナルサービスが実行されている SSL証明書を検査すると、すべての詳細が表示され、見栄えがよく、2014年に期限が切れます hklm:\ System \ CurrentControlSet \ Control \ Terminal Server \ fDenyTSConnectionsは0です C:\ ProgramData \ Microsoft \ Crypto \ RSA \ MachineKeys管理者はすべての特権を持っています 更新: …

3
JenkinsにGitから取得したスクリプトを実行させるにはどうすればよいですか?
私はJenkinsを使用して、一連のインポートジョブをトリガーおよび管理しています。インポートスクリプトをGithubに配置し、Jenkinsがジョブをビルドするときに、(a)そのバージョン管理されたスクリプトをGithubからプルし、(b)スクリプトを実行する必要があります。 私が実行している問題は、ジョブ内で実行するスクリプトの名前を参照する方法がわからないことです。ソースコードがワークスペースディレクトリにプルされていることを前提としています。その仮定は正しいですか?(ドキュメントがあった場合のみ!) これまでに行ったことは次のとおりです。 WindowsサーバーにJenkins(明らかに)をインストールしました(いいえ、それについて選択の余地はありませんでした) 私のgithubアカウントにリポジトリを作成し、それにコードを入れました https://github.com/mcholl/SARS-Import/で公開されています roottest.pyとomniture-video \ test.pyの2つのスクリプトがあることがわかります。そこにあるコードはAppleの特許下にあります。 私はroottest.pyを実行したいという考えです Githubプラグインをインストールしました 次のようにジョブを作成しました。 プロジェクト名=「Github統合のテスト」 GitHubプロジェクト:https : //github.com/mcholl/SARS-Import.git/ Windowsバッチコマンドを追加します:python roottest.py ジョブを手動で実行する ただし、ファイルが見つからないというエラーメッセージが表示されます。ワークフローは「ソースのローカルコピーを...(Job)/ workspace /ディレクトリにプルし、ワークスペースディレクトリのコンテキストでバッチコマンドを実行する」と想定しているため、これは奇妙です。 これが完全なコンソール出力です: ワークスペースC:\ Program Files(x86)\ Jenkins \ jobs \ Testing Github Integration \ workspace [workspace]のユーザー匿名の構築によって開始されました$ cmd / c C:\ Windows \ TEMP \ hudson1966342425043540895.batを呼び出します C:\ Program Files(x86)\ Jenkins \ …
12 jenkins  github 

4
rsyncが失敗した後のクリーンアップ方法は?
ローカルの「rsync -ah」プロセスを終了しました。 ターゲットディレクトリに「.abc.vmdk.zxivMN」のようなジャンクファイルを残しました。 ジャンクファイルは、「rsync -ah」を連続して実行しても削除されません。 詳細: 同期していた両方のフォルダーでdiffを実行したところ、「/ mnt / archive1 / documents / general:.abc.vmdk.zxivMNのみ」と報告されました。 一時的なrsyncファイルをクリーンアップする最良の方法は何ですか?
12 rsync 

2
Debian 7 IPv6リンクローカルアドレスはどのように設定されますか?
dhclientがeth0で実行されている場合、DHCPサーバーからIPv4アドレスを取得し、eth0に接続されているScope:Link IPv6アドレスを取得しているようです。 inet6 addr: fe80::a00:27ff:fed0:4d41/64 Scope:Link しかし、dhclient-scriptからは、そのアドレスがどのように追加されているのかわかりません。静的IPアドレスを持つ別のインターフェイスで、リンクローカルIPv6アドレスを追加したいのですが、Macを知らずにそれを行うための一般的なコマンドがあるかどうか疑問に思っていました。 編集: 「ip link set dev ethX up」または「ifconfig ethX up」を実行すると、カーネルがリンクローカルアドレスを割り当てるようです。しかし、私の場合、DHCPを使用しているインターフェースにケーブルが接続されていて、静的にセットアップしていたインターフェースにケーブルが接続されていませんでした。月曜日まで確認できませんが、リンクがない場合、カーネルはインターフェイスにリンクローカルアドレスを割り当てないと思います。

2
タグでrsyslogメッセージをフィルタリングする方法
出力をカスタムファイルにリダイレクトしたいアプリケーションとスクリプトがいくつかあります。 私はそれらのアプリケーションを使用して起動します command | logger -t TAG これらのメッセージをタグに基づいてフィルタリングし、別のファイルにリダイレクトしたいと思います。これらのアプリケーションは主に長時間実行されるプロセスであり、適切なログローテーションが必要であるため、bashリダイレクトを使用したくありません。 /etc/rsyslog.d/60-myfilter.confにカスタムフィルターを追加しようとしました。 if $syslogtag == 'giomanager' then /var/log/giomanager.log 何が悪いのですか?タグに基づいてフィルタリングする適切な方法は何ですか、または同様の結果を得るためのより良いオプションはありますか?
12 bash  logging  syslog  rsyslog 

3
nginxリバースプロキシで、Cookieのセキュアフラグを設定するにはどうすればよいですか?
nginxをリバースプロキシとして使用して、httpsのみのサイトにサービスを提供しています。したがって、このサイトのCookieに安全のフラグを付けてください。しかし、バックエンドサーバーはhttpサーバーであるため、cookieにセキュアフラグを設定しません。安全なフラグを追加するための応答としてSet-Cookieヘッダーを変更するにはどうすればよいですか?

2
nginxで常に単一のファイルを返すようにロケーションブロックを構成するにはどうすればよいですか?
私のアプリケーションでは、場所 "/"で静的なindex.htmlファイルを返し、 "/ static"でフォルダーから静的ファイルを提供し、他のすべての要求で404 NOT FOUNDを返します。後で、他のすべての要求をWSGIサーバーにリダイレクトします。 これは現在私の設定です: # Dev server. server { listen 1337; charset UTF-8; location / { rewrite ^ static/index_debug.html break; } location /static { alias /home/tomas/projects/streamcore/static; } } 静的フォルダは完全に機能していますが、「/」は404 NOT FOUNDを返します。私も試しました: alias /home/tomas/projects/streamcore/static/index_debug.html; ロケーションブロックでは、500の内部サーバーエラーが返されます。alias単一のファイルが好きではないようです。さらに私は試しました: try_files static/index_debug.html; ただし、これにより、「try_filesディレクティブの引数の数が無効です」というエラーでサーバーが起動しなくなります。どうやらtry_files実際には複数のファイルを試す必要があるようですが、これは私が探している動作ではありません。 だから私の質問は:どのようにして静的ブロックを常に返すようにロケーションブロックを構成するのですか? 編集:私aliasは実際に単一のファイルを引数として受け入れるはずの他の回答から見たので、私は試しました: location = / { alias /home/tomas/projects/streamcore/static/index_debug.html; } しかし、まだ500の内部サーバーエラーしか発生しません。「/」リクエストのエラーログには次のように記載されています。 …

2
Postfix master.cfとmain.cf
main.cfとmaster.cfの両方で-oプレフィックスを使用して同じ設定を指定できることがよくあります。 私の質問は、一方が他方をオーバーライドするかどうか、そうである場合、両方に同じ設定(異なる値を持つ)が見つかった場合、どちらのファイルが優先されるかです。 たとえば、 smtpd_tls_auth_only=yes main.cfで指定されましたが、 -o smtpd_tls_auth_only=no master.cfで指定されましたが、postfixが注意を払うのはどれですか?

5
Linux ubuntuでPHP CLIを構成してwww-dataとして実行するにはどうすればよいですか?
私のubuntuにsymfony2アプリケーションがあります。symfonyには便利なコンソールコマンドがたくさんあります(php app/console cache:clearまたはなどphp app/console assets:install web)。 問題はroot、それらをユーザーとして実行すると、新しく生成されたファイルにroot:rootユーザー/グループが含まれ、Webサイトにアクセスするとエラーが発生することです(Apacheがこれらのファイルを読み取ったり変更したりできないためですwww-data:www-data。 実行chown www-data:www-dataすると問題は解決しますが、キャッシュをクリアするたびに実行することは解決策ではありません。 常にwww-dataユーザー/グループとして実行するようにPHP CLIを構成するにはどうすればよいですか? または コマンドを別のユーザーとして実行するにはどうすればよいですか(rootになり、www-dataとして実行します)?

弊社のサイトを使用することにより、あなたは弊社のクッキーポリシーおよびプライバシーポリシーを読み、理解したものとみなされます。
Licensed under cc by-sa 3.0 with attribution required.