サーバー管理者

システムおよびネットワーク管理者向けのQ&A

6
mount.nfs:マウント中にサーバーによって拒否されたアクセス
私のUbuntuシステムでは、/ etc / fstabに次の行があります。 myserver:/home/me /mnt/me nfs rsize=8192,wsize=8192,timeo=14,intr 私がする時 sudo mount -a 私は得る: mount.nfs: access denied by server while mounting myserver:/home/me この問題を診断するにはどうすればよいですか?nfsサーバーもUbuntuです。 追加の詳細:同じネットワーク上の他のUbuntuクライアントからこのnfs共有を問題なくマウントできます。ただし、問題のあるクライアントは、WindowsシステムのVirtualBox内で実行されているという点で異なります。問題のあるクライアントから「myserver」に問題なくpingを実行できます。 編集: 「myserver」上の/ etc / exports: /home/me *(rw,all_squash,async,no_subtree_check,anonuid=1000,anongid=1000) 「myserver」上の/etc/hosts.allowと/etc/hosts.denyは両方ともコメントです。また、同じネットワーク上の他のクライアントからうまく接続できることを覚えておいてください。

2
ピアによるdocker swarmデータベース接続のリセット
Docker SwarmでSpring Bootアプリケーションを実行していて、データベースにpostgresを使用しています。両方をドッカーサービスとして実行すると、ログに示されているように、データベース接続が一貫してランダムに失敗します(タイムスタンプで確認できます)。 2017-10-26T 17:14:15 .200415747Z app-db.1.1ayo6h8ro1og@scw-c2964a | ログ:クライアントからデータを受信できませんでした:接続がピアによってリセットされました 2017-10-26T 17:43:36 .481718562Z app-db.1.1ayo6h8ro1og@scw-c2964a | ログ:クライアントからデータを受信できませんでした:接続がピアによってリセットされました 2017-10-26T 17:43:56 .954152654Z app-db.1.1ayo6h8ro1og@scw-c2964a | ログ:クライアントからデータを受信できませんでした:接続がピアによってリセットされました 2017-10-26T 17:44:17 .434171472Z app-db.1.1ayo6h8ro1og@scw-c2964a | ログ:クライアントからデータを受信できませんでした:接続がピアによってリセットされました 2017-10-26T 17:49:04 .154174253Z app-db.1.1ayo6h8ro1og@scw-c2964a | ログ:クライアントからデータを受信できませんでした:接続がピアによってリセットされました その理由が分からなかった。任意のアイデアをいただければ幸いです。 編集: アプリケーションをテストすると、次のようなエラーもスローされることに気付きました。 SQLTransientConnectionException:HikariPool-1-接続を利用できません。リクエストは937517ms後にタイムアウトしました ありがとう。

3
デフォルトのストレージプールをlibvirtから変更するにはどうすればよいですか?
VMの仮想ディスクと、使用しているオペレーティングシステムのISOを保存するために、KVMで別のストレージプールを使用しようとしています。 例:今後/media/work/kvmマウントさ/dev/sda5れるすべての状況のデフォルトのストレージプールとして、にマウントされたディレクトリを使用したい 新しいストレージプールを構成、作成、開始するのはとても簡単ですが、少なくともUbuntuでは、別のストレージプールからISOを選択しているかどうかは関係ありません。VirtualMachine Managerは常にデフォルトのストレージをポイントします/var/cache/libvirtVM(仮想マシン)の仮想ディスクが作成されるストレージとしてのプール()。 どうすればこれを回避できますか?

2
1つのIPと同じポートを持つがホストヘッダーが異なる複数のSSL証明書(IIS 8)
IIS 8(win 2012 r2)サーバーがあり、同じWebサイトを2つの異なるドメインと2つの異なる証明書にバインドしたい。 ドメインが異なるFQDNであるため、ワイルドカードを使用できません。 httpsとポート443に2つのバインディングを追加すると、2つの異なる証明書を選択できません(一方のバインディングを変更すると、もう一方も変更されます)。 異なるポートを使用したり、2つの異なるWebサイトに分割したりせずにこれを解決する方法はありますか? ありがとう!

1
NFSv4ユーザーマッピング
この質問はすでに何度も尋ねられたようですが、他の答えはどういうわけか私には当てはまりませんでした。 基本的に私は新しいNFSv4サーバーをセットアップしただけで、サーバーとクライアント間でUIDとGIDが一致しないという典型的な問題に直面しています。ただし、私のシナリオでは、/ etc / passwdと/ etc / groupを同期することはできません。両方のマシンで同じユーザーがいることに注意してください(この質問とは異なります)。 したがって、私はidmapを調査していました:一部のソースによると、NFSv4はユーザー名を送信するようであり(UID / GIDを送信するNFSv3の動作とは対照的)、idmapの役割はこれらのユーザー名をサーバーのUID / GIDに変換することです。 しかし、これは私の場合にはうまくいかないようです(以下のセットアップの詳細)。これは非常に標準的(かなり多くの場合、リポジトリからNFSのみをインストールする)と考えています。 何か不足していますか?LDAPまたはKerberosを設定せずにこれを機能させる方法はありますか? サーバーのセットアップ サーバーがUbuntu 16.04インストールされ、2人のユーザーがいます。 user1@server:~$ id user1 uid=1000(user1) gid=1000(user1) groups=1000(user1),27(sudo) user1@server:~$ id user2 uid=1001(user2) gid=1001(user2) groups=1001(user2) NFSがリポジトリからインストールされ、テストフォルダーをエクスポートするように構成されました。 user1@server:~$ sudo apt-get install nfs-kernel-server user1@server:~$ sudo cat /proc/fs/nfsd/versions +2 +3 +4 +4.1 +4.2 user1@server:~$ ls -ld /srv/nfs/test/ drwxrwxrwx …
12 ubuntu  nfs 

2
systemdユニットのExecStartをデバッグする方法
完全に拡張されたExecStart/ExecStopコマンドラインを出力できるかどうか知りたいです。次の例を検討してください。 ExecStart=/usr/bin/java $OPTS_COMMON $OPTS $OPTS_LOG $OPTS_DEBUG some.class.Start --param1 ${PARAM1} --param2 ${PARAM2} 多くの環境変数が含まれるかなり長いコマンドラインがあります。変数の一部が(たとえば、ドロップイン構成によって)正しくなくなった場合、サービスがまったく開始されない可能性があります。ただし、envが置換された完全に展開された行はどこにも表示されず、何が問題なのかを見つけるのに苦労しています。 私はこれをグーグルで操作することができず、今のところ私が見つけた唯一の可能性は/usr/bin/echo、サービス自体の代わりに実行するようにユニットファイルを変更することです。しかし、それは少し面倒です。またはさらに厄介な解決策-すべての環境変数を1つずつ確認してください。 実際に実行しようとしているものをsystemdに強制的に表示させる方法はありますか?
12 systemd 

2
リロード時にデーモンを強制終了して再起動するようにsystemdを設定するにはどうすればよいですか?
systemdを使用して制御したい旧式のデーモンがあります。構成ファイルが変更された場合は、強制終了して再起動する必要があります。つまり、設定ファイルを編集した後systemctl reload MYSERVICE、プロセスを終了して再起動する必要があります。 試行1:デフォルトを試します。これは、デーモンを開始する方法をsystemdに通知しますが、再ロードする方法は通知しません。 [Service] ExecStart=/usr/bin/MYSERVICE Type=simple その結果、startそしてrestart仕事が、reloadこのエラーを与えます: # systemctl reload MYSERVICE Failed to reload MYSERVICE.service: Job type reload is not applicable for unit MYSERVICE.service. 試み2:プロセスを強制終了する方法を教えてください。これによりプロセスは強制終了されますが、systemdはプロセスを再起動しません。 [Service] ExecStart=/usr/bin/MYSERVICE Type=simple ExecReload=/bin/kill -HUP $MAINPID ...に続く... # systemctl daemon-reload # systemctl reload MYSERVICE ...プロセスを強制終了しますが、自動的に再起動されません。 試行3:ExecReloadを使用してプロセスも再起動します。これはいくつかの理由で失敗します: ExecReload=/bin/kill -HUP $MAINPID ; /usr/bin/MYSERVICE ...私が得るエラーメッセージ...: # systemctl …
12 systemd 



3
dig応答のすべてのフラグは何ですか?
dig 応答はコメントセクションでフラグを返します。 $ dig example.com +noall +comments ; <<>> DiG 9.8.3-P1 <<>> example.com +noall +comments ;; global options: +cmd ;; Got answer: ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 29045 ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0 ここの最後の行にはフラグがあります: flags: qr rd ra; 発掘するすべての可能なフラグは何ですか? これが私がこれまでに見つけたもののリストです: …

5
動的IPを使用するAmazon EC2セキュリティグループの受信ルール
EC2セキュリティグループの潜在的な問題であると私が考えるものの明確化を探しています。 Linuxインスタンスに接続するためのセキュリティグループを設定しています。HTTPおよびHTTPSアクセス用の「どこでも」ルールを作成しました。 SSHルールの場合、Amazonチュートリアルでは、パブリックIPアドレスへの受信アクセスを制限する必要があると述べています。 取得できないのは、パブリックIPアドレスが動的である場合、どのように安全または機能するかです。 IPアドレスは動的なので、ISPがパブリックIPを変更し、インスタンスにSSH接続できなくなった場合はどうなりますか? 使用しているセットアップガイドへのリンク:http : //docs.aws.amazon.com/AWSEC2/latest/UserGuide/get-set-up-for-amazon-ec2.html(「セキュリティグループの作成」のステップ7 'は私に問題があるようです)

2
しばらくすると最初のリクエストが常に遅くなる-ASP.NET MVC / IIS 8.5 / Windows Server 2012 R2 VPS
Windows Server 2012 R2 / IIS 8.5と1 GBのRAMを備えたVPSで、トラフィックの少ないASP.NET MVC 5アプリケーションをホストしています。 私の問題は、Chrome Dev Toolsによると、何のリクエストもない状態での最初のリクエストの応答が常に遅くなるということです-約1.5秒。後続の更新要求/応答には、約45ミリ秒しかかかりません。 アプリケーションプールでStart ModeをAlwaysRunningに設定し、WebサイトレベルでPreload EnabledをTrueに設定しましたが、まったく効果がありませんでした。変更やアップロードがまったくない場合でも、しばらくすると、次のリクエストで応答を取得するのに1.5秒かかります。

2
Dockerイメージサイズを縮小する方法
GlassFishを実行しているコンテナがあります。画像をコミットしてみると14GBになりました。その後、/tmp/10GBのコンテナーで削除してイメージをコミットしようとしましたが、それでもイメージは14GBです。コンテナからファイルを削除しても画像サイズには反映されないようです。この問題を解決するにはどうすればよいですか?
12 docker 

4
Kubernetesは常に503サービスを提供しますが、複数のTLS Ingressでは一時的に利用できません
Amazon Web Servicesでkopsによってkubernetesクラスターをセットアップしています 2つのサイトを設定しています。1つはSSL / TLS / httpsで保護され、もう1つはhttpのみです。どちらもWordpressサイトです。サイトIDを保護するためにドメインが変更されました 入力構成: apiVersion: extensions/v1beta1 kind: Ingress metadata: name: my-rules spec: tls: - hosts: - site1.com secretName: site1-tls-secret - hosts: - www.site1.com secretName: site1-tls-secret rules: - host: site1.com http: paths: - path: / backend: serviceName: site1 servicePort: 80 - host: www.site1.com http: paths: - …

2
mount.nfs:正しくないマウントオプションが指定されました
CentOS 7.2サーバーにNFSボリュームをマウントしようとしています。 NFS共有ポイントをマウントしようとすると、次の応答が返されます。 [root@web1:~] #mount -t nfs nfs1.example.com:/var/nfs/home /home mount.nfs: an incorrect mount option was specified チェックしてnfs-utils-1.3.0-0.21.el7.x86_64、両方のマシンにインストールしました。NFSクライアントとNFSサーバーのOSはどちらもCentos 7.2です これをトラブルシューティングするために、NFSサーバーの/ etc / exportsファイルのリストを次のように減らしました。 /var/nfs/home web1.example.com(rw,sync,no_root_squash,no_all_squash) 私が行う場合showmount、私は上のNFS共有をマウントしようとしているサーバーから、これは私が見たものです。 [root@web1:~] #showmount -e nfs1.example.com Export list for nfs1.example.com: /var/nfs/home web1.example.com 私が行う場合、mount -vこれは私が得るものです: [root@web1:~] #mount -v -t nfs nfs1.example.com:/var/nfs/home /home mount.nfs: timeout set for Fri Jan …
12 nfs 

弊社のサイトを使用することにより、あなたは弊社のクッキーポリシーおよびプライバシーポリシーを読み、理解したものとみなされます。
Licensed under cc by-sa 3.0 with attribution required.