タグ付けされた質問 「python」

Pythonは、標準のmacOSインストールに含まれているプログラミング言語です。Pythonに関するプログラミングの質問がある場合は、Stack Overflowで質問してください。

12
OS X El Capitanのアップグレード後にpipを使用する方法は?
El Capitanの更新後、pip installを実行できません。私が得るエラーは、pipがインストール中に新しいフォルダーを作成しようとすると「操作は許可されません」ということです。 creating /System/Library/Frameworks/Python.framework/Versions/2.7/share error: could not create '/System/Library/Frameworks/Python.framework/Versions/2.7/share': Operation not permitted 実際、一般的にこれらのフォルダーにフォルダーなどを作成することはできません。役に立たないsudoを使用してみました。また、私はやった sudo chflags nouchg /System/Library/Frameworks/Python.framework/Versions/2.7/ 上記も助けにはなりませんでした。Pythonライブラリを再びスムーズにインストールできるようにするにはどうすればよいですか?

6
Homebrew:Python 3.7からPython 3.6.5.xへのロールバック?
brew upgrade私のシステムのPythonは、Python 3.7にアップグレード。残念ながら、Python 3.7は私が使用する必要のある他のソフトウェア(Ansibleを含むがこれに限定されない)を壊します。これらの問題は来週かそこらで解決されると思いますが、その間、Python 3.6.5.xにロールバックしたいと思います。 A brew info pythonは、以前のバージョンがまだインストールされており、パージされていないことを示しています。 ➜ brew info python python: stable 3.7.0 (bottled), HEAD Interpreted, interactive, object-oriented programming language https://www.python.org/ /usr/local/Cellar/python/3.6.5 (4,825 files, 100.8MB) Poured from bottle on 2018-03-31 at 20:21:57 /usr/local/Cellar/python/3.6.5_1 (4,788 files, 99.9MB) Poured from bottle on 2018-06-20 at 16:00:26 /usr/local/Cellar/python/3.7.0 (4,869 files, 103.3MB) ...
73 homebrew  python 


5
ターミナルでシンボリックリンクの完全に解決されたパスを取得する方法は?
私のラップトップにはpythonインストールの混乱があります。で実行可能ファイルを見ていましたが/usr/local/bin、それらはすべてへのシンボリックリンクです../../../Library...... これを取り巻く奇妙な動作がいくつかあります。私がしなければls -lhaG私が見る--->とシンボリックリンクの右への相対パス: lrwxr-xr-x 1 root wheel 69B Dec 7 22:29 python3 -> ../../../Library/Frameworks/Python.framework/Versions/3.1/bin/python3 ただし、そのパスを解決してpython3への実際のパスを表示するコマンドラインツールを入手できないようです。私はpwd -P、findこれを行うためのユーティリティとユーティリティに関するいくつかのちらつきを見つけました。問題は、これらがOS Xでは動作せず、Linuxで動作する(つまり、シンボリックリンクへのフルパスを出力する)と人々が説明しているようには見えないことです。彼らは私のためにシンボリックリンクのパスを印刷するだけです: FantasticMrFox:bin robert$ pwd -P python3 /usr/local/bin FantasticMrFox:bin robert$ find `pwd -P` -name python3 /usr/local/bin/python3 ここで何が起こっているかについてのアイデアはありますか?

3
MacでPythonを削除して再インストールします—これらの古い参照を信頼できますか?
私はMacが初めてで、どうやら間違いを犯したようです。私はPythonをチュートリアルを通して、そしてHomebrew、Pip、XCodeの間で何らかの形で私のバージョンがすべて混ざっています。Pip3はpython2を指しているため、私のpython3トライアルはすべて失敗します... すべてのバージョンを安全に削除し、クリーンインストール(homebrew?)のために撮影する方法を研究していますが、少し緊張しています。 私はいくつかの素晴らしいリンクを見つけました: MacでのPython 3のアンインストール Mac OS X 10.6.4でPython 2.7をアンインストールする方法は? 明らかに、ルート/systemディレクトリにあるものには何も触れず、基本的に他のすべてが削除されます。私を不安にさせているのは、このリンクがかなり古くなっているということです。(6年!+)本当に信頼しているかどうかはわかりません。 誰か最近ここに来たの?上記リンクの投稿を信頼できますか?このPythonバージョンの混乱をクリーンアップするにはどうすればよいですか?注:MacOS Sierra(10.12.5)を使用しています

3
MacでPython 3を最新の状態に保つ
Python 3が必要です(OS Xが提供するpythonをいじりたくありません)。による: https://docs.python.org/3/using/mac.html Python 3を入手して長く生きることができますが、次のDMGを使用してアップグレードする場合に何が起こるかは明確ではありません。例として、OS XのRで何が起こるかを説明します。GUIは/ Applicationにあり、スタッフは/ Library / Frameworksにあります。アップグレードすると、GUIがアップグレードされ、新しいフレームワークが/ Library / Frameworksディレクトリに古いものと並べて配置されます(古いものが無視されるようにする「現在の」シンボリックリンクがあります)。私はいつも古いものを削除して、汚物がたまらないようにします。それだけです。このアプローチはPhytonで機能しますか?
27 python 

2
Macがスリープすると、ターミナルプロセスは停止しますか?
ターミナルを介してPython機械学習プログラムを実行していますが、終了するまでに数時間かかります。コンピューターを放置すると、休止状態になります-画面が消え、パスワードを再度入力する必要があります。 この場合、スクリプトはキャンセル、一時停止、または継続されますか?私のスクリプトが99%完了し、コンピューターがスリープ状態になったために中断されるとは思わないでしょう。

2
`apxs:Error:Command failed with rc = 65536`を修正して、Mountain Lion(Mavericks)でmod_wsgi、mod_fastcgiなどをコンパイルする方法は?
OS X Mountain Lionにアップデートしました。更新により、mod_wsgiを含むすべてのpythonおよびapacheモジュールが削除されました。 今、私はmod_wsgiを再コンパイルしようとしています(Lionでは問題なくコンパイルされています)。 ここからソースコードを使用します:http : //code.google.com/p/modwsgi/wiki/DownloadTheSoftware?tm=2 ./configureは問題なくMakefileを作成します: $ ./configure checking for apxs2... no checking for apxs... /usr/sbin/apxs checking Apache version... 2.2.22 checking for python... /usr/bin/python configure: creating ./config.status config.status: creating Makefile ただし、makeはエラーを返します。 $ make /usr/sbin/apxs -c -I/System/Library/Frameworks/Python.framework/Versions/2.7/include/python2.7 -DENABLE_DTRACE -DMACOSX -DNDEBUG -DNDEBUG -DENABLE_DTRACE -Wc,'-arch x86_64' mod_wsgi.c -Wl,-F/System/Library/Frameworks -framework Python ...

2
iTerm2はcom.googlecode.iterm2.plistを読み取りません
私はiTerm2(1.0.0)ユーザーです。iTerm設定を使用するか、com.googlecode.iterm2.plistファイルを変更して、プロファイルを作成する方法を知っています。 便宜上、ファイル.plistを示すために使用しcom.googlecode.iterm2.plistます。 コマンドを使用して開発サーバーに接続するためのプロファイルが既にいくつかあります。(つまりssh 192.168.1.1)。 プロファイルを変更してiTermに追加します。そこで、これを行うためのPythonスクリプトを作成しました。手順は以下のとおりです。 iTerm2 .plistファイルをに変換します.xml。(つまりplutil -convert xml1) plistlibPython を使用して、このファイルにいくつかのプロファイルを書き込みます。 iTerm2 .plistファイルを元のバイナリ形式に変換します。(つまりplutil -convert binary1) 上記の手順は機能しません。iTerm2は、Pythonスクリプトから作成されたプロファイルをロードしませんでした。 そこで、.plistファイルがないか、iTermがプロファイルをロードする方法を確認しました。 iTerm2プログラムを終了しました。 にある.plistディスクからファイルを削除しました~/Library/Preferences/。 iTerm2プログラムを実行します。 ⌘ Cmd+ を入力してプロファイル設定を開きますO。 .plistファイルを削除してもプロファイルがあることがわかりました。ここで何が起こったのですか?認識できないバックアッププロファイルファイルはありますか?
21 macos  iterm  python  plist 


4
launchctl configの何が問題になっていますか?
ログイン時にSickBeardを自動実行しようとしています python /Applications/Sick-Beard/Sickbeard.py <?xml version="1.0" encoding="UTF-8"?> <!DOCTYPE plist PUBLIC -//Apple Computer//DTD PLIST 1.0//EN http://www.apple.com/DTDs/PropertyList-1.0.dtd > <plist version="1.0"> <dict> <key>Label</key> <string>com.sickbeard.sickbeard</string> <key>ProgramArguments</key> <array> <string>/usr/bin/python</string> <string>/Applications/Sick-Beard/SickBeard.py</string> <string>-q</string> <string>-d</string> </array> <key>RunAtLoad</key> <true/> </dict> </plist> 実行するlaunchctl com.sickbeard.sickbeard.plistと、次のメッセージが表示されます。 launchctl load com.sickbeard.sickbeard.plist launchctl:返されるplistはありません:com.sickbeard.sickbeard.plist launchctl:返されるplistはありません:com.sickbeard.sickbeard.plist
15 macos  python  launchd 

3
PythonパッケージをインストールするためのpipとMacPortsの使用
Macports経由で私のMacにPythonパッケージ(例えば、numpy)をインストールすることができます: port install py-numpy または経由pip: pip install numpy 各アプローチの一般的な長所/短所は何ですか?それぞれのアプローチはいつ使用すべきですか? どちらを優先するべきですか? インストールするパッケージが小さいか大きいnumpyか(例:)は重要ですか? それは私が使用しているpythonのバージョン(2.xvs 3.x、またはApple pythonとMacPortのバージョン)に依存しpythonますか? pythonMacに複数のバージョンがインストールされているかどうかは重要ですか? 同時に使用できますか? 私は、それぞれのアプローチの長所/短所の短いリストと、どちらを選択するかについての議論がある回答を期待しています。

2
OS X 10.8でApplescriptを使用せずにウィンドウを最前面に表示するにはどうすればよいですか
ウィンドウ(QuickTimeなど)をフォーカスせずに最前面に表示したい。Applescriptで次のコードを使用して、OS X 10.7でそれを行うことができます。 tell application "System Events" set visible of process "QuickTime Player" to true end tell これはPythonと同等です。 from ScriptingBridge import * process = SBApplication.applicationWithBundleIdentifier_('com.apple.systemevents').processes().objectWithName_('QuickTime Player') process.setVisible_(True) しかし、OS X 10.8にアップグレードした後は機能しません。それを機能させる方法はありますか?

0
Yosemiteにコマンドライン開発者ツールをインストールする方法 [閉まっている]
閉まっている。この質問はトピックから外れています。現在、回答を受け付けていません。 この質問を改善してみませんか? 質問を更新することがありますので、上のトピック別の掲載について。 5年前休業。 次のコマンドでxcode開発者ツールをインストールしようとしています: xcode-select --install そして私はこのエラーを持っています: 「このソフトウェアは現在Software Update Serverから入手できないため、インストールできません」 Pillow Pythonモジュールを使用できるように、開発者ツールをインストールしようとしています。何か案は?ありがとう。

3
端末経由でVPN接続を作成する方法
マーベリックスを搭載したMacBook Proを使用しています。端末でVPNネットワークに接続する方法を探しています。 これを行う理由は、30台のサーバーの中から最速のVPNサーバーを自動的に検出する小さなプログラムをPythonで記述したいからです。これは自発的な練習プロジェクトなので、Python言語に固執すると思います。だから私はタスクを分解し、プログラムが最初にサーバーの1つに接続する必要があるかもしれないと思い、その後速度テストを実行します。 そのため、Pythonで事前に作成されたVPNモジュールが見つからないため、VPN接続の確立がシステムレベルの下にあるように見えるので、この最初のステップで立ち往生しています。つまり、システムシェルにVPNサーバーに接続するように指示するようにPythonに指示するようなものになると思います。 私がぶらぶらしていて、と入力してコマンドを見つけましたapropos vpn。と呼ばれていvpnagentます。しかしman vpnagent、有用な情報を提供せずwhich vpnagent、ユーティリティがMacにインストールされていないことを知らせません。私が見つけたもう1つの興味深いことはpppd、設定ファイルの設定が非常にイライラすることでした。なんとかできませんでした。 端末を使用してVPNに接続する方法はありますか?また、プログラミングは初めてなので、私のプロジェクトに関するコメントも歓迎します。前もって感謝します。

弊社のサイトを使用することにより、あなたは弊社のクッキーポリシーおよびプライバシーポリシーを読み、理解したものとみなされます。
Licensed under cc by-sa 3.0 with attribution required.