タグ付けされた質問 「php」

PHPは、動的Webページの構築に使用されるサーバー側のスクリプト言語です。

2
自作でcomposerをインストールする方法
MacOSは初めてなので、簡単な質問かもしれません。 デフォルトのPHP 7.1がインストールされたHigh Sierraを使用しています。PHP7.2もインストールして実行しています。 curl -s http://php-osx.liip.ch/install.sh | bash -s 7.2 私が走ると: brew install composer 私は得ています: Error: No available formula with the name "composer" ==> Searching for a previously deleted formula... Warning: homebrew/core is shallow clone. To get complete history run: git -C "$(brew --repo homebrew/core)" fetch --unshallow Error: No ...
14 install  homebrew  php 


3
MacのネイティブWeb共有およびダウンロードしたMySQLよりもMAMPスタックを使用する利点
Macでネイティブに提供されているWeb共有と、MySQLを手動でダウンロードしてインストールする代わりに、MAMPスタックを使用する利点は何ですか? MAMPがapache / mysql / phpの最新/他のバージョンをどのように持つことができるかを見ることができますが、他の利点はありますか? 私のMCBには、Apache 2.2.15とPHP 5.3.3を搭載したSnow Leopard 10.6.6が付属していました。非常に最近の(ただし最新ではない)バージョンです。 両方ともインストールされているので、同じ機能を持つものを入手する理由はほとんどありませんでした。 MySQLのインストールも非常に簡単だったため、その理由はありません。
11 mysql  apache  php 

1
PHPのコンパイル時オプションはどのように決定できますか?
PHPのインストールをカスタマイズしようとしていますが、プログラムを最初からコンパイルするのはあまり慣れていません。どのコンパイル時オプションがphpに使用されたかを判断するにはどうすればよいですか?具体的には、--with-readlineオプションが指定されたかどうかを確認しようとしています。ありがとう!
11 terminal  php 

1
sudoを使用しても/ usrに書き込めない
これが私の問題です: sudo php -d detect_unicode=0 go-pear.phar ...ルートとして実行して/usr&/usr/shareディレクトリを変更する必要がありますが、これは次のようになります。 Below is a suggested file layout for your new PEAR installation. To change individual locations, type the number in front of the directory. Type 'all' to change all of them or simply press Enter to accept these locations. 1. Installation base ($prefix) : ...

1
コマンドラインに表示されるPHPバージョンは、phpinfo()とは異なります。localhost:8000で
次のように入力して、OS X PHPテストサーバーを開始しました php -S localhost:8000 OS XのPHPを5.6に更新し、コマンドラインで次のように入力してバージョンを確認しました。 php -v 「PHP 5.6.5」があることを教えてくれます PHPテストサーバーを起動し、phpinfo();機能を持つindex.phpファイルを見ると、OS Xに付属するバージョン5.5.14がまだあることがわかります。 その変更を反映するためにlocalhost:8000でPHPバージョンを取得するにはどうすればよいですか?
8 macos  php 

4
Yosemiteへのアップグレード後のphpMyAdmin 403 Forbidden Error
MacをMac OS X Yosemiteにアップグレードしました。 Homebrew経由でMavericksにAMPスタックをインストールしましたが、正常に機能しました。 Yosemiteにアップグレードすると、次の問題が発生します。 phpMyAdminをロードしようとするとhttp://localhost/phpmyadmin、次のエラーが表示されます。 禁じられた このサーバーの/ phpmyadminにアクセスする権限がありません。 エラーログには以下が表示されます。 [Mon Oct 20 11:34:17.235518 2014] [authz_core:error] [pid 70303] [client ::1:50374] AH01630: client denied by server configuration: /usr/local/share/phpmyadmin ローカルホストをロードしようとすると、空白のページが表示されます。エラーログには、それに関連するエントリはありません。 私はdnsmasqをセットアップしましたが、今では機能しません。 * .dev構造の下でドメイン名をpingしようとすると、応答しません。タイムアウトすらしません。まったく応答がなく、pingを終了するにはctrl-Cを押す必要があります。ただし、試してみるとdig、次のような応答が返されます。 ➜ dig cs.dev ; <<>> DiG 9.8.3-P1 <<>> cs.dev ;; global options: +cmd ;; Got answer: ;; ->>HEADER<<- ...

1
localhostでapacheを使用したWebサイトにアクセスできません[複製]
この質問にはすでに答えがあります: MacOS Sierra上のApache:AH00557:httpd:Macbook-Pro.localでapr_sockaddr_info_get()が失敗しましたAH00558:httpd:確実に判断できませんでした… 5つの回答 yosemiteを実行しているMacbook Proでphp、mysql、apacheを有効にしようとしていました。このガイドに従いまし たが、実行されません。助けてくださいOS X上のローカルWebサーバーを設定する際に間違って何.....私はというエラーを取得します。http:// localhostの/は使用できません。 Abhimanyus-MacBook-Pro:~ abhimanyuaryan$ cat /etc/hosts ## # Host Database # # localhost is used to configure the loopback interface # when the system is booting. Do not change this entry. ## 127.0.0.1 localhost 255.255.255.255 broadcasthost #::1 localhost Abhimanyus-MacBook-Pro:~ abhimanyuaryan$ ls -lad /Library/WebServer/Documents ...


0
MacPortsでphp5の代わりにphp56をロードする際の問題
私はMacOS X Mavericksを実行しています、そこで私は手動でインストールによってMAMPスタックを作成しました mysql5-server、 php5など、MacPortsの下で。私は最近この設定をにアップグレードすることを余儀なくされました mysql56-server そして php56 (WordPressのCherry Frameworkのインストールによる)私は以下のリンクで提供された指示に従うことによってそうしました。 https://trac.macports.org/wiki/howto/MAMP 私はまだ私の古いMAMP設定を保存していることに注意してください。つまり、私は mysql5-server、 php5など、MacPortsの下で、しかし、代わりにApache2とMySQLサーバを起動するために「古い」コマンドを使う代わりに、私は今次のコマンドを使います。 sudo port load apache2 sudo port load mysql56-server 先週のデフォルトパラメータのいくつかを変更した後まで、すべてが新しい設定で問題なく動作していました。 /opt/local/etc/php56/php.ini ファイル、私は私のデータベースへの接続を失いました。変更したパラメータは < max_time_input = 60 ; (from) > max_time_input = -1 ; (to) < upload_max_filesize = 2M ; (from) > upload_max_filesize = 8M ; (to) N.B.のデフォルトのソケット値 ...
1 macports  apache  mysql  php 

1
$ PATHはどのように作成されますか?
私はまだMac OSの動作に比較的慣れていませんが、Linuxの広範な知識を持っています。php_osxを使用してMavericksでphpを更新し、export PATH=/usr/local/php5/bin:$PATH新しいphpバージョンを使用するために使用するように指示されています。 phpを更新しようとして、次のファイルへの参照が見つかりました。 .bash_profile -このファイルが見つかりません。 .bashrc パス path_helper 誰かがMavericksで$ PATHがどのように作成されているかを簡単に理解し、exportコマンドがエディションをパスに配置する場所と、必要に応じて削除する方法を理解するのに役立ちますか?

3
MojaveでローカルのPHPフルディスクアクセスを許可する
私はPHPウェブページをローカルのapacheインストールで実行しています。このページでは、shell_execを使用してsqlite3経由でmessages / chat.dbにアクセスしています。 shell_exec("sudo -u ben sqlite3 ~/Library/messages/chat.db \"SELECT ... Mojaveの前に私は正しく応答を得ました、しかしMojaveにアップデートしてから私は得ます: unable to open database ターミナルで直接実行すると、これと同じ問題が発生し、システム環境設定の「フルディスクアクセス」パネルにターミナルを追加することで解決します。 PHPページに追加する必要があるものがわかりません。 sqlite3、apachectl、php-fpmなど、見つけられるものはすべて試しましたが、うまくいきませんでした。 何を追加する必要がありますか? 参考:benはsudoersファイルにあります

1
macOSを10.14 Mojaveにアップグレードしてから、PHPは非常に遅いですか?
私のMacをMojave 10.14にアップグレードしてから、PHPが非常に遅いことに気付きました。 私が端末からこれをすると: php -v バージョン番号を表示するまでに約4〜5秒かかります。 PHP 7.1.13 (cli) (built: Feb 1 2018 13:38:42) ( NTS ) これを修正する方法はありますか?そして、たぶん最新のPHP(現在は7.2)にアップグレードしますか?

1
デフォルトのPHPバージョンへのすべてのリンクを削除するにはどうすればよいですか?
macOS Sierraを実行しています。 デフォルトでインストールされているPHPバージョンへのすべてのリンクを完全に削除するにはどうすればよいですか?homebrewを使用してPHP 7をインストールしましたが、プログラムで外部CLIアプリケーションを呼び出すスクリプトを実行すると、インストールされているデフォルトのPHPバージョンであるPHP 5.6.25を使用しているようです。 このPHPバージョンとのすべての関係を打破するにはどうすればよいですか? 私はphp -v、phpinfo()インストールした適切なPHP7バージョンを既に表示しています。どういうわけか、一部のスクリプトは依然としてデフォルトバージョンを検索しようとします。 私はすでにあなたがそれを単に削除することはできないことを読んだ。 さらに情報が必要な場合はお知らせください。
弊社のサイトを使用することにより、あなたは弊社のクッキーポリシーおよびプライバシーポリシーを読み、理解したものとみなされます。
Licensed under cc by-sa 3.0 with attribution required.