Ubuntu

Ubuntuユーザーと開発者のためのQ&A

3
単一のオーディオチャネルを別のデバイスにリダイレクトする方法
Bluetoothステレオスピーカーを購入したばかりで、次のようなアイデアがありました。 Bluetoothスピーカーをリアスピーカーとして使用し、2つの通常のケーブルステレオスピーカー(または別のペアのBluetoothスピーカー)をフロントとして使用して、4.0オーディオシステムを構築することはできますか?どのプログラムを使用する必要がありますか? 一般的に:4.0または5.1信号を単一のチャネルに分割して複数のデバイスに送信することは可能ですか?


3
Ralink RT2800で定期的に接続が切断される
問題の原因がわからないのですが、Ubuntu 12.04.1 LTSにアップグレードした後、通常のワイヤレス切断が発生し始めました。 システムプロファイラとベンチマークユーティリティを使用して、すべてのドライバが意図したとおりに機能しているかどうかを確認しました。この観点からは問題ないようです。 そこで、WICDネットワークマネージャーを使用して一時的な解決策を講じることにしました。一部の個人は、ワイヤレス接続を安定させていると述べています。-しかし、私の場合ではありません。 さらに、DHCPを使用する代わりに、IPv4の手動設定を使用してみました。(IPv6も無効)。sudo /etc/init.d/networking restartを実行しました(一時的な修正)... また、私はバックポートソリューションとndiswrapperソリューションを試しました-何も機能していません。 参考のためにいくつかの情報を含める: ハードウェア情報:lshw -C network *-ネットワークの説明:イーサネットインターフェイス 製品:RTL8111 / 8168B PCI Express Gigabit Ethernetコントローラー ベンダー:Realtek Semiconductor Co.、Ltd. 物理ID:0 バス情報:pci @ 0000:04:00.0 論理名:eth0 バージョン:01 シリアル:00:1a:4d:52:ee:1d サイズ:10Mbit / s 容量:1ギガビット/秒 幅:64ビット クロック:33MHz 機能:pm vpd msi pciexpress bus_master cap_list romイーサネット物理tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt …

2
apparmorプロファイルのエラーにより、mysqlが更新されない
アップデート後にmysqlエラーが発生しました。 これがログです。 (Leyendo la base de datos ... 559752 ficheros o directorios instalados actualmente.) Desinstalando mysql-server ... Configurando mysql-server-5.5 (5.5.24-0ubuntu0.12.04.1) ... Error del analizador AppArmor para /etc/apparmor.d/usr.sbin.mysqld in /etc/apparmor.d/usr.sbin.mysqld en la l?nea 40: syntax error, unexpected TOK_END_OF_RULE, expecting TOK_MODE start: Job failed to start invoke-rc.d: initscript mysql, action "start" failed. …
9 12.04  mysql 


2
プロセス「/ usr / bin / X:0 -auth / var / run / lightdm / root /:0 -nolisten tcp vt7 -novtswitch -background none」とは何ですか?
Ubuntu 12.04セットアップで深刻なパフォーマンスの問題が発生しているためhtop、通常のタスクと一緒に実行して原因を探しています。 クロム、コンピス、コンキーなどの通常の容疑者は別として、私はこのプロセスに気づきました: /usr/bin/X :0 -auth /var/run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch -background none これは常に実行されているだけでなく、CPU使用量とメモリ消費量の両方に関して、プロセスリストの主要なリソースソースの1つでもあります。それはだだけフラッシュプレーヤーなどのような、特にressourceに飢えたタスクによって随時トッピング、最も時間のナンバーワンのパフォーマンスイーター。 名前からすると、私はそれが何をするのか全くわかりません。XとlightdmはGUIとの関係を示しているようですが、tcpはネットワークに関係しているようです。 私の質問:このプロセスは常に実行されるはずですか?それはそれが使用することを合法的である。このくらいの ressourcesを?実行するにはそれが必要ですか、それとも殺しても安全ですか? 参考:私のシステムは完全に最新です。最新のnvidiaドライバーとcompiz-packagesにxorg-edgers ppaを使用しています(特定のバグ関連の理由により)。 任意の提案は非常にいただければ幸いです。

3
トップパネルのSpotifyインジケーターを無効にする方法は?
Spotifyインジケーターアイコンは、ネイティブのUnityテーマと競合し、サウンドインジケーターメニューに既に表示されているため、冗長です。Spotifyインジケーターを削除または無効にする方法はありますか?または、少なくともアイコンを変更します(私のファイルシステムでそれをgrepできませんでした)。12.04でSpotifyの「プレビュー」を使用しています。ありがとう!

4
アップデート後にMySQLサーバーを起動できません
今日、システムを更新しましたが、mysqlサーバーを起動できません。 次のエラーが発生します。 Aug 14 14:32:09 VULTURUS kernel: [ 1996.413190] init: mysql main process (14122) terminated with status 1 Aug 14 14:32:09 VULTURUS kernel: [ 1996.413262] init: mysql main process ended, respawning Aug 14 14:32:10 VULTURUS kernel: [ 1997.373479] init: mysql post-start process (14123) terminated with status 1 Aug 14 14:32:10 …
9 mysql  apparmor 

2
rmコマンドと削除ボタンの違いは何ですか?
本を読んだところ、コマンドではファイルではなくrmが削除されinodeます。つまり、rmコマンドで削除すると、復元できません。 私はUbuntu環境に非常に慣れていません。今私の疑問は、Delキーはどのように機能するのですか?inode私のTrashフォルダから復元できるので、私が懸念している限りでは、は削除されていません。だから私は、Del キーがフォルダに変更を加えずにmvコマンドを実行していると言ってもいいですか?または、ここで何か不足していますか?Trashinode
9 delete  rm 

1
マウント操作を拒否するAppArmor
この操作を許可するようにapparmorを説得するにはどうすればよいですか? [28763.284171] type=1400 audit(1344273461.387:192): apparmor="DENIED" operation="mount" info="failed type match" error=-13 parent=7101 profile="lxc-container-with-nesting" name="/" pid=7112 comm="su" flags="ro, remount, bind" 基本的に、ルートファイルシステムを読み取り専用で再マウントしようとしています(LXCコンテナーにネストされたマウント名前空間に)。セットアップは、次で終わる場所の周りのいくつかのバインドマウントです。 mount --rbind / / mount -o remount,ro / 私は次のすべての組み合わせを試しました: mount options=(ro, remount, bind) / -> /, と思いました。ルールaudit mount,を追加すると、他のすべてのマウントが表示されますが、/で動作しているマウントは表示されません。私が得ることができる最も近いものはmount -> /,、私見が緩すぎるということです。mount / -> /,再マウントも拒否します(最初のバインドマウントは許可されます)。
9 server  apparmor  lxc 

2
スクリプトを使用してFTPサーバーへのファイルの送信を自動化するにはどうすればよいですか?
特定のログファイルを/var/log/取得し、簡単に取得できる場所(ほとんどの場合、アクセスできるWebサーバーまたはFTPサーバー)に配置するスクリプトを作成する必要があります。メールで送りたいとは思わない。Webdavはオプションかもしれません。ユーザーとのやり取りなしで機能する必要があり、かなり速くて痛みもありません。助言がありますか?(基本的にパスワードは必要ありません)

4
数秒ごとにApacheのaccess.logグルービングを停止する方法は?
から、新しいUbuntu 12.04サーバー+ ZendサーバーCE(MySQL / PHPmyadmin)をインストールしましたdeb http://repos.zend.com/zend-server/5.6.0_ubuntu1204/deb server non-free Repository。 私のapache2 / access.logは次のようになり、数秒ごとにグルービングします。 ::1 - - [06/Aug/2012:13:27:59 +0200] "OPTIONS * HTTP/1.0" 200 126 "-" "Apache/2.2.22 (Ubuntu) (internal dummy connection)" ::1 - - [06/Aug/2012:13:27:59 +0200] "OPTIONS * HTTP/1.0" 200 126 "-" "Apache/2.2.22 (Ubuntu) (internal dummy connection)" ::1 - - [06/Aug/2012:13:27:59 +0200] "OPTIONS …
9 apache2  zend 

6
より良いワークスペーススイッチャー?
UnityのデフォルトインストールでUbuntu 12.04を実行しています。 ワークスペーススイッチャーのアイコンが改善された可能性があります。それが行う機能は、キーストロークによって実現されます。他のデスクトップにウィンドウがあるかどうかにかかわらず、アイコンは同じままです(デスクトップ1の2つのウィンドウ)。 より優れたワークスペーススイッチャーはありますか-デスクトップ上のウィンドウをリアルタイムで表すスイッチャーですか? または、ワークスペーススイッチャーのアイコンをオフにするにはどうすればよいですか?

2
スタートアップからサービスを削除する
開発マシン(ラップトップ)にmysqlが(リポジトリから)インストールされており、起動するたびにデーモンを実行する必要はありません。/etc/init/mysql.confを/etc/init/mysql.conf.oldにコピーし、 "start on"行以降のすべてを削除しました。ただし、再起動すると、upstartでmysqldを起動できなくなります。 $ sudo service mysql start start: Unknown job: mysql これも失敗します(この時点で何かを試みます): $ sudo service mysql restart stop: Unknown job: mysql start: Unknown job: mysql これは私の起動スクリプトです: # /etc/init/mysql.conf .... start on stop on starting rc RUNLEVEL=[016] これはデフォルトのスクリプトです: # /etc/init/mysql.conf.old .... start on runlevel [2345] stop on starting rc RUNLEVEL=[016] …
9 upstart 

2
ログイン画面からのみゲストセッションを無効にする方法は?
したい: 誰かが私のコンピューターを使用する必要がある場合に備えて、私の管理者アカウントにログインしているときにユーザーメニューからゲストセッションを選択できるようにするため。 欲しくない コンピューターの電源を入れてゲストセッションにログインできる人 私が/etc/lightdm/lightdm.confインクルードするために編集する方法を聞いたことがありますallow-guest=false(そしてlightdmを再起動します) この方法の問題は、ゲストアカウントを完全に無効にしたくないことです。(管理者アカウントにログインしている間)ゲストセッションを手動で開始する機能を維持しながら、ログインメニューからのアクセスを無効にしたいだけです。 そのような修正はありますか?私は検索エンジンを介してそれを見つけることができないようです(そして検索のために言葉を言うのは非常に難しいです) 編集:はい。Ubuntu 12.04 LTS(デスクトップ)、最新リリース。 そして、それが機能する方法のため、ゲストアカウントである必要があります。他のユーザーがゲストアカウントを使用できるようにしたいのですが、それがどのように機能するか(パスワードがなく、セッションが終了するとそのすべてが削除されるため)公開されたパスワードなしでメインアカウントから簡単に起動できます。私のコンピュータをオンにした人なら誰でも利用できる無料のアカウント。 標準の制限付きアカウントでこれを達成できたとしても、ほとんどのソフトウェアの設定を変更して何も保存しないようにできるので、問題はありません。メインアカウントにログインしている間は、パスワードなしでユーザーリストからアクセスできる必要がありますが、メインログイン画面からは非表示/アクセスできません。 これが私が言及したコードです。ご覧のとおり、構造は非常に似ていますが、いくつかの重要な違いがあります。ありませんauto required pam_unix.so。リンクには「行」という行を追加するように書かれauth optional pam_permit.soていますがauth required pam_permit.so、すでに他の小さな違いがあります。 #%PAM-1.0 auth requisite pam_nologin.so auth required pam_env.so readenv=1 auth required pam_env.so readenv=1 envfile=/etc/default/locale auth required pam_permit.so @include common-account session [success=ok ignore=ignore module_unknown=ignore default=bad] pam_selinux.so close session required pam_limits.so @include common-session session …

弊社のサイトを使用することにより、あなたは弊社のクッキーポリシーおよびプライバシーポリシーを読み、理解したものとみなされます。
Licensed under cc by-sa 3.0 with attribution required.