それは好みの問題です。各パラメーターを文書化する複雑な関数呼び出しの場合、または変数がかなり長く、それらの多くが存在する場合、これは適切です。
例えば:
do_complex_op(
0, //Starting state, always 0, ask Joe why
X, //X-coord of thingy
y, //Y-coord of thingy
73, //in this case, we don't want to use Z but want constant
dlogMessageTitle, //message for dialogue title
dlogMessageText, //message for dialogue contents, don't care about this.
SomethingIP, //IP of something-or-other server, can be NULL, won't crash.
someObject.childObject.getValue(key1).HVAL, //very long path to HVAL
someObject.childObject.getValue(key1).LVAL, //very long path to LVAL
this.parentWindow.owner.mainTextBox.text.value.trim, //get the trimmed text, untrimmed text causes weird output
pvrMainSettingForLongBlahs.getObjectByPath(somePath),
pvrMainSettingForLongBlahs.K_TCA_UPPER_LIMIT,
pvrMainSettingForLongBlahs.K_ENDPOINT_COMPLIANCE_LEVEL,
);
名前付きパラメーターを許可する言語では、パラメーター名を使用する場合にこれがより一般的です(PL / SQLの例)。
PKG_SOME_TEST_CODE.FN_DO_SOMETHING( in_text => 'test text',
in_id => v_id,
in_ref_id => v_ref_id,
out_array_for_storage => v_bArray);
しかし、関数呼び出しが単純でパラメーターが多すぎない場合、次のような迷惑になる可能性があることに同意します。
setColour (
r,
g,
b
);
読みやすいと思う
setColour(r,g,b);
@ammoQの場合:
rc=a(b,c(d,e(f)))
rc=a(
b,
c(
d,
e(
f
)
)
)