getSomething
vsで始まる特定のメソッドに名前を付ける必要があるかどうかを判断するのは常に困難findSomething
です。
問題は、設計が不十分なAPIのヘルパーを作成することにあります。これは通常、オブジェクトからデータを取得するときに発生し、オブジェクトをパラメーターとして必要とします。以下に簡単な例を示します。
public String getRevision(Item item) {
service.load(item, "revision");
// there is usually more work to do before getting the data..
try {
return item.get_revision();
}
catch(NotLoadedException exception) {
log.error("Property named 'property_name' was not loaded", exception);
}
return null;
}
このメソッドの名前をgetRevision()
orにするfindRevision()
かどうか、どのように決めるのですか