サーバー管理者

システムおよびネットワーク管理者向けのQ&A

6
SMBは「遅い」と主張した
私たちの会社のネットワーク(サーバー2008で実行されているWindowsドメインであると私は信じています)は非常に遅いです。これの主な例は、SMBを介してファイルをコピーすることです。リストには数分かかり、適度なサイズのファイルをコピーする場合でもさらに時間がかかります。この問題について近づくと、ITマネージャー(他のメリットがあるにもかかわらず、非常に頑固で技術的な担当者ではありません)は手を挙げて、非常に防御的になり、耳を傾けようとする代わりに言い訳をします。問題の根本原因を解明します。 さて、この問題の人間的要素が解決するのにいくらかの時間と努力が必要であることを認識して、私は彼の言い訳を技術的に反論する方法をまったく知らないままにされています。この場合、彼はSMBが問題であり、「遅い」プロトコルであると主張しています。この声明の証拠はありますか(私は逸話的な反証しかありません)?この議論で前進するための最良の方法は何ですか?

7
MediaWikiのインストールを高速化(パフォーマンス)するためのヒントはありますか?
MediaWikiのインストールがあり、速度が遅くなっているという苦情が寄せられています。どのようにして速度/パフォーマンスを向上させることができますか? ヒントが1つあります(以下で追加します)が、もっと聞きたいと思っています。回答ごとに1つのヒントを入力してください。

5
perlルートキットを削除する痛み
そこで、オフィスでジオサービスウェブサーバーをホストしています。 誰かがおそらくこのボックスに侵入し(おそらくftpまたはsshを介して)、何らかの種類のirc管理のルートキットを置いたようです。 今私はすべてを整理しようとしています、ircを介して接続しようとするプロセスpidを見つけましたが、呼び出しプロセスが誰であるのかわかりません(すでにps、pstree、lsofで調べられました)プロセスはperlですスクリプトはwwwユーザーが所有していますが、ps aux | grepは最後の列に偽のファイルパスを表示します。 そのpidを追跡して呼び出し元をキャッチする別の方法はありますか? 言及するのを忘れました:カーネルは2.6.23です。これはrootになるために悪用可能ですが、このマシンにはあまり触れられないため、カーネルをアップグレードできません。 編集:lsofは役立つかもしれません: lsof -p 9481 コマンドPIDユーザーFDタイプデバイスサイズノード名ss perl 9481 www cwd DIR 8,2 608 2 / ss perl 9481 www rtd DIR 8,2 608 2 / ss perl 9481 www txt REG 8,2 1168928 38385 / usr / bin / perl5.8.8ss perl 9481 www …

2
/ etc / network / interfacesファイルを更新して、ボックスにIPv6自己割り当てアドレスのみが表示されるようにするにはどうすればよいですか?
私はこの露骨な初心者向けの質問をお詫び申し上げますが、これが「正しい方法」で行われるようにして、うまくいくように思わずにいじるだけでなく、私が持っているドキュメンテーションはこのケースに対処していないようです。 現在、私が使用しているDebian Linuxボックスには、次の/ etc / network / interfacesファイルがあります。 auto lo iface lo inet loopback auto bond0 iface bond0 inet dhcp pre-up modprobe bonding mode=active-backup miimon=100 primary=eth0 pre-up ip link set bond0 up pre-up /sbin/ifenslave bond0 eth0 pre-up /sbin/ifenslave bond0 eth1 上記は正常に動作し、ほとんどの場合私が望むことを実行します-起動時にボックスが起動し、2つのイーサネットジャックがフェイルオーバー/冗長性に使用されます(つまり、ボックスが機能している場合、最初のジャックを通信に使用します。それ以外の場合は、セカンドジャック)。 ただし、私の目的では、IPv4やDHCPを使用したくありません。私は、ボックスのIPv6自己割り当てアドレス(つまり、fe80 :: whatever:it:is)のみを使用して他のIPアドレスを使用しないで(bond ... これを指定する適切な方法は何ですか?「iface bond0 inet dhcp」を「iface bond0 …


8
Linuxネットワーキングのクラッシュ:原因を見つけるための最良の手順は?
昨夜、Linux(CentOS)サーバーの1つに到達できませんでした。 リモートコンソール以外の方法でサーバーに到達できませんでした。リモートコンソールでログインした後、外部ホストにもpingできないことがわかりました。 簡単なことでservice network restart問題は解決しましたが、何が原因なのかまだ疑問です。私のログファイルにはエラーがまったくないようです(ネットワーク接続を必要とし、ネットワーク障害の後に失敗したさまざまなデーモンを除く)。 この問題の原因を見つけるために実行できる追加の手順はありますか? 編集:これはちょうど再び起こった。ネットワークサービスの再起動を発行するまで、サーバーは完全に応答しませんでした。どんなアドバイスでも大歓迎です。これは、ハードウェアコンポーネントの不良が原因である可能性がありますか? Madhattersのリクエストに従って、当時のログからの抜粋をいくつか示します(ネットワークは20:13にクラッシュしました)。 / var / log / messages: Dec 2 20:01:05 graviton kernel: Firewall: *TCP_IN Blocked* IN=eth0 OUT= MAC=<stripped> SRC=<stripped> DST=<stripped> LEN=40 TOS=0x00 PREC=0x00 TTL=101 ID=256 PROTO=TCP SPT=6000 DPT=3306 WINDOW=16384 RES=0x00 SYN URGP=0 Dec 2 20:01:05 graviton kernel: Firewall: *TCP_IN Blocked* IN=eth0 OUT= MAC=<stripped> …


3
Linuxのpsコマンドの出力をユーザーのANDコマンドでフィルタリングできますか?
その所有者とそのコマンドを与えられたプロセスのpidが必要です。ユーザーごとのプロセスを「ps -u xxx」とそのコマンドで「ps -C yyy」でフィルタリングできますが、「ps -u xxx -C yyy」を試すと、ORロジックを使用して結合されます。ANDロジックが必要です。どうすればこれを達成できますか?

2
kslowdの目的は何ですか?
私はUbuntu 10.10を実行しています: uname -a Linux mt-xps 2.6.35-22-generic #35-Ubuntu SMP Sat Oct 16 20:45:36 UTC 2010 x86_64 GNU/Linux topを実行すると、「kslowd000」または同様のプロセスが上位のCPU使用率リストにポップアップ表示されることがあります。私はkslowdをグーグルで試しましたが、それが何であるかについての説明は見つかりませんでした。マンページも役に立ちません。 それは何をするためのものか ?そして、どうやって自分を見つけますか?
8 ubuntu  unix  daemon 

3
ブリッジされたワイヤレスのvirt-managerを使用してtap0を設定します
3日後、ようやくkvmゲストがワイヤレス経由でネットワークで作業できるようになりました(下のリンク-ありがとう!): 私のネットワークは192.168.1.0/24です ホスト上: sudo sh -c "echo 1 > /proc/sys/net/ipv4/ip_forward" sudo tunctl -t tap0 sudo ip link set tap0 up sudo ip addr add 192.168.1.25/24 dev tap0 sudo route add -host 192.168.1.30 dev tap0 sudo parprouted wlan0 tap0 ゲスト上: auto eth0 iface eth0 inet static address 192.168.1.30 netmask 255.255.255.0 network …

1
insserv:起動するとサービスfooとbarの間にループがあります…aptitudeを壊します
LinuxパッケージのCyber​​power powerpanelで発生するこれらの初期化エラーを解決する方法を誰かが知っていますか? 参照:http : //www.cyberpowersystems.com/products/management-software/ppl.html - 代わりにナットを使用してみましたが、問題があります。つまり、syslogを効果的に無効にするDebianバグ354429があるため、ナットは選択できません。 参照:http : //bugs.debian.org/cgi-bin/bugreport.cgi?bug=354429 出力: root@host:~# aptitude install foo The following NEW packages will be installed: foo python-central{a} The following packages are RECOMMENDED but will NOT be installed: whois 0 packages upgraded, 2 newly installed, 0 to remove and 1 not upgraded. Need to …
8 init.d 


2
nginxリバースプロキシ、キャッシュとストアを使用する場合
プロジェクトのWebスタックを次のように再構築している最中です:nginx-> haproxy->多くの(apache / passenger rails)インスタンス 目標のいくつかは次のとおりです。 ページキャッシュの単一の場所(現在、各Apacheマシンのレールを介して行われています) より高速な静的コンテンツ 内部パイプラインからSSLを削除する ip logging(以前はtcpモードでhaproxyを実行したために失われました) 画像/スタイルシート/ JavaScriptアセットは、適切なヘッダーとともにキャッシュキャッシュされます。ページキャッシングは内部パラメーターに基づいており、一般的なキャッシュコントロールに応答するべきではありません。これらの目的を達成するために、構成は次のようになります。 server { ... location /really_slow_dynamic_content/ { root /var/www/tmp; error_page 404 = @fetch; } location @fetch { internal; proxy_pass haproxy_ip; proxy_store /var/www/tmp${uri}_cache.html; proxy_store_access user:rw group:rw all:r; } location /assets/ { proxy_pass haproxy_ip; proxy_cache assets; } location / { …
8 nginx 

2
rootユーザーはどのようにして自分自身に書き込みできないファイル/ディレクトリを作成できますか?
通常のユーザーは、chmodファイルにアクセスしてアクセスできないようにすることができます evgeniy@ubuntu:~$ touch test evgeniy@ubuntu:~$ chmod 444 test evgeniy@ubuntu:~$ echo 'test' > test bash: test: Permission denied このようなものをrootユーザーに対してシミュレートできますか?

3
これはerror_logで何ですか?リクエスト\ x16 \ x03 \ x01の無効なメソッド
私はこの行を見つけました Invalid method in request \x16\x03\x01 on error_log file 、そして他のいくつかの同様の行: [Wed Oct 27 23:16:37 2010] [error] [client 187.117.240.164] Invalid URI in request x\xb2\xa1:SMl\xcc{\xfd"\xd1\x91\x84!d\x0e~\xf6:\xfbVu\xdf\xc3\xdb[\xa9\xfe\xd3lpz\x92\xbf\x9f5\xa3\xbbvF\xbc\xee\x1a\xb1\xb0\xf8K\xecE\xbc\xe8r\xacx=\xc7>\xb5\xbd\xa3\xda\xe9\xf09\x95"fd\x1c\x05\x1c\xd5\xf3#:\x91\xe6WE\xdb\xadN;k14;\xdcr\xad\x9e\xa8\xde\x95\xc3\xebw\xa0\xb1N\x8c~\xf1\xcfSY\xd5zX\xd7\x0f\vH\xe4\xb5(\xcf,3\xc98\x19\xefYq@\xd2I\x96\xfb\xc7\xa9\xae._{S\xd1\x9c\xad\x17\xdci\x9b\xca\x93\xafSM\xb8\x99\xd9|\xc2\xd8\xc9\xe7\xe9O\x99\xad\x19\xc3V]\xcc\xddR\xf7$\xaa\xb8\x18\xe0f\xb8\xff Apacheは最初のエラーの数秒後に正常に再起動しました...

弊社のサイトを使用することにより、あなたは弊社のクッキーポリシーおよびプライバシーポリシーを読み、理解したものとみなされます。
Licensed under cc by-sa 3.0 with attribution required.