サーバー管理者

システムおよびネットワーク管理者向けのQ&A

3
scp-実行中にファイルをスキップする
scpを実行してリモートサーバーからフォルダーをコピーしています。-rlを使用して実行しているので、ファイルがコピーされているのがわかります。現在のファイルをスキップすることはできますか?
8 scp 

8
ジュニパーネットワーククライアントにスプリットルーティングを使用させる
OSX用ジュニパークライアント(「ネットワークコネクト」)を使用してクライアントのVPNにアクセスしています。クライアントは分割ルーティングを使用しないように構成されているようです。クライアントのVPNホストは、分割ルーティングを有効にする用意がありません。 この構成を上書きしたり、ワークステーションでクライアント以外のネットワークトラフィックにVPNをバイパスさせたりする方法はありますか?これは大した問題ではありませんが、私のストリーミングラジオ局(XMなど)はVPNに接続されません。 用語の誤りについての謝罪。 **編集** Juniperクライアントは、システムのresolve.confファイルを次のように変更します。 nameserver 192.168.0.1 に: search XXX.com [redacted] nameserver 10.30.16.140 nameserver 10.30.8.140 優先DNSエントリをファイルに復元しようとしました $ sudo echo "nameserver 192.168.0.1" >> /etc/resolv.conf ただし、これにより次のエラーが発生します。 -bash: /etc/resolv.conf: Permission denied スーパーユーザーアカウントがこのファイルにアクセスできないのはなぜですか?Juniperクライアントがこのファイルを変更できないようにする方法はありますか?

8
httpdは停止していますが、サブシステムはロックされています
今日php.iniのmax_execution_timeを変更しました。サーバーを再起動すると、次のエラーが発生します。 Stopping httpd: [FAILED] Starting httpd: (98)Address already in use: make_sock: could not bind to address [::]:80 (98)Address already in use: make_sock: could not bind to address 0.0.0.0:80 no listening sockets available, shutting down Unable to open logs httpd proc:killall httpdを強制終了し、正常に起動しましたが、サーバー上のWebサイトを開くことができません。 サービスhttpdステータスOUTPUT: httpd dead but subsys locked / var / …

2
リバースSSHトンネル
一部のAPI統合(トロポ、ペイパルなど)をテストするために、リモートサーバーからローカルマシンにWebトラフィックを転送しようとしています。基本的に、私はtunnlr.comが提供するものと同様のものをセットアップしようとしています。 コマンドでsshトンネルを開始しました $ssh –nNT –R :7777:localhost:5000 user@server 次に、サーバーがポート7777でリッスンしていることがわかります。 user@server:$netstat -ant | grep 7777 tcp 0 0 127.0.0.1:7777 0.0.0.0:* LISTEN tcp6 0 0 ::1:7777 :::* LISTEN $user@server:curl localhost:7777 Hello from local machine これでうまくいきます。curlリクエストは実際にはローカルマシンから提供されます。 では、server.com:8888をそのトンネル経由でルーティングできるようにするにはどうすればよいですか? 私はnginxを次のように使ってみました: upstream tunnel { server 0.0.0.0:7777; } server { listen 8888; server_name server.com; location / { access_log …

4
X-YMailISGヘッダーとは正確には何ですか?
最後に...私たちのメールはYahoo! もはやジャンクではありません。ばんざーい! ただし、Yahoo!MTAを受信すると、X-YMailISGヘッダーが追加されます。非常に大きい... 2 ** 10ビット? メールヘッダーの作成に目覚めた人生のかなりの部分を費やしたので、X-YMailISGヘッダーが何であるかを知りたいと思います。誰か教えてもらえますか?セキュリティ/信頼性の問題が発生しますか?Googleの結果からはほとんどわかりません。 バックグラウンド: 私たちのドメインのSPFとDKIMのDNSゾーンファイルのTXTレコードを何度も調整した後、Yahoo!のDrupalサイトからのメールの生成にようやく成功しました。 X-YahooFilteredBulk としてマークされなくなり、優れたサービスcheck-auth@verifier.port25.comは、SPF、DKIM、およびSender-IDチェックを通過し、SpamAssassinにハムとして表示される電子メールを示す結果を返します。Yahoo! さらに、Received-SPF:パスヘッダーを追加します。 役立つリンク: http : //www.goldfisch.at/knowwiki/howtos/dkim-filter http://old.openspf.org/wizard.html

3
ESXi仮想マシンのデフォルトのBIOSオプション
ESX1(4.1)で仮想マシンのデフォルトのBIOSオプションを設定する方法を知っている人はいますか?新しいVMを作成するたびに、BIOSに移動してBIOSにNum Lockを設定する必要があります。OSに関係なく、VMを作成するたびにnumロックがオンになるようにしたいと思っていました。 ESXiがデフォルトのBIOSオプションをどこから取得し、それを変更する方法を知っている人はいますか? 事前にありがとう、リッチ

2
メールのカスタムヘッダーが失われましたか?
カスタムメールヘッダーについて質問がある 誰かが宛先に送信されるときにプロプライエタリ/カスタムヘッダーを削除するメールサーバーを知っていますか? 正確にこのヘッダーを持つメッセージに返信を送信するときにメールクライアントが特定のヘッダーを返すように強制するために設定できるヘッダーはありますか? カスタムヘッダーは常にで始まりX-ますか?他の人を使用しても安全ですか? 通常、カスタムヘッダーを使用することはお勧めしませんか?身体に属さず、ユーザーが直接見るべきではない情報を他にどのように送信できますか? PS:同様の質問があることは知っていますが、これはこの質問に対する完全な回答ではありません。 よろしくお願いします
8 smtp  email 

1
FreeBSDの `freebsd-update`自動化?
freebsd-updateコマンドは、ダウンロード後に更新エントリを出力します。しかし、それはで示していmoreます。だから私は続けるためにいくつかのスペースを押す必要があります。この動作を回避する方法はありますか?完全自動更新を実行したい。

6
将来の成長のためのラックレイアウト
新しいコロコロ施設に移動する準備が整いました。ラックレイアウトを設計しています。フルラックですが、現時点では12U相当のハードウェアしかありません。 1x 1Uスイッチ 7台の1Uサーバー 1U 2Uサーバー 1U 2Uディスクシェルフ コロコロ施設では、スイッチをフロントマウントして1Uブラシストリップを使用する必要があるため、合計13Uのスペースを使用します。 成長に関しては、中期的にはサーバーにさらに4U、1〜2Uのネットワーク機器、2〜4Uのストレージを追加することになると確信しています。私が助けを求めている具体的な質問: スイッチはどこにマウントすればよいですか?LEDは上にあります... 新しいマシンを追加するためのスペースで機能ごとにサーバーをグループ化する必要がありますか? 別の方法として、サーバーが運用かステージングかに基づいてサーバーをグループ化する必要がありますか? ラックのどこから始めればよいですか?途中で?頂点で?底に?等間隔に? これは私が今考えていることの愚かな小さなASCII図です。私のデザインをばらばらにして自由に感じてください。私が何をしているのか本当にわかりません:)どんなアドバイスでも大歓迎です。 編集:明確にするために、コロはUPSと発電機で冗長電力を提供しているので、図に示していない0U PDUを除いて、計画には電源装置がありません。 42 | -スイッチ---------------------- 41 | -ブラシストリップ----------------- 40 | ~~ 2番目のスイッチ用に予約~~ 39 | ~~ファイアウォール用に予約済み~~~~~~~ 38 | 37 | -admin01 --------------------- 36 | 35 | -vm01 ------------------------ 34 | -vm02 ------------------------ 33 | ~~ vm03用に予約済み~~~~~~~~~~~ …

4
誰がrootアクセスを取得しますか?
一部の機密データを処理するWebアプリケーションに取り組んでいます。セキュリティがかなり厳しくなり、マシンへのアクセスをロックダウンして、技術監査目的ですべてをログに記録するためのポリシーをレイアウトしています。 私たちが繰り返し返してくる質問は、これです。 サーバーインスタンスにはrootユーザーがいます。そのrootユーザーにはパスワードがあります。誰がこれにアクセスできますか?それは機械持つことが可能/望ましい誰もが rootアクセスを持つことができますか? この件についてご意見をお聞かせください。
8 root  security 

2
スラブは使用可能な128Gbのうち88Gbを使用します。何が原因でしょうか?
128 Gbのサーバーでdebian 2.6.26-2-amd64 x86_64 GNU / Linuxを実行しています。最近、利用可能なメモリがかなり少なくなりました。/ proc / meminfoを見ると、スラブが88Gbを使用していることがわかりました。 これは問題ですか?必要なときにメモリが解放されると思いますが、それが望ましくない副作用を引き起こす可能性があるかどうかはわかりません。 なぜスラブはそれほど多くのメモリを必要とするのでしょうか?その明確な原因はありますか? これが将来起こるのを避けることができますか? このメモリをどのように解放できますか? 前もって感謝します > cat /proc/meminfo MemTotal: 132304500 kB MemFree: 26669388 kB Buffers: 237504 kB Cached: 11881136 kB SwapCached: 48 kB Active: 5244640 kB Inactive: 11714308 kB SwapTotal: 5751228 kB SwapFree: 5750436 kB Dirty: 24 kB Writeback: 0 …
8 debian  memory 

2
Muninグラフのサイズ
Muninグラフは非常に小さいです。それは私にとっていくつかのmultigrpahを役に立たなくします。グラフ画像のサイズを大きくすることは可能ですか?
8 munin  graph 

2
ファイアウォールがポート53をブロックしていますが、他にリストされていますか?
bashスクリプトから読み込まれた実質的に同じiptablesルールを持つ3つのノードがありますが、特定の1つのノードがポート53でトラフィックをブロックしていますが、それを受け入れています。 $ iptables --list -v チェーン入力(ポリシーDROP 8886パケット、657Kバイト) pktsバイトターゲットプロトオプトインソース宛先 0 0すべて受け入れ-どこでもどこでもlo 2 122 ACCEPT icmp-どこでもどこでもicmp echo-r​​equest 20738 5600Kすべてを受け入れる-どこでも、どこでも、状態関連、確立 0 0 ACCEPT tcp-eth1任意の場所node1.comマルチポートdports http、smtp 0 0 ACCEPT udp-eth1任意の場所ns.node1.com udp dpt:domain 0 0 ACCEPT tcp-eth1任意の場所ns.node1.com tcp dpt:domain 0 0すべて受け入れ-eth0任意のnode2.backendをどこでも 21 1260 ACCEPT all-eth0 any node3.backend wherewhere 0 0すべて受け入れ-eth0任意のnode4.backendどこでも チェーンフォワード(ポリシーDROP 0パケット、0バイト) pktsバイトターゲットプロトオプトインソース宛先 チェーン出力(ポリシーACCEPT 15804パケット、26Mバイト) …


1
IIS7が中間SSL証明書を送信しない
ドメインのGlobalSignドメイン証明書があります。証明書をIISにインストールし、GlobalSign Domain Intermediate証明書をローカルコンピューターの中間証明機関に追加しました IISが中間証明書(Firefoxでエラーの原因)を送信せず、ドメイン証明書のみを送信しているようです。私はこれをOpenSSLとGlobalSign自身のヘルスチェッカーを含むさまざまなウェブサイトで検証しました。 IISを見ると、チェーン全体をたどることができ、各証明書は "ok"ですが、インストール済みであることを示すオプションがなくても、証明書は既に問題ありません。 何が悪いのかについてのアイデアはありますか?
8 iis  ssl  certificate 

弊社のサイトを使用することにより、あなたは弊社のクッキーポリシーおよびプライバシーポリシーを読み、理解したものとみなされます。
Licensed under cc by-sa 3.0 with attribution required.