サーバー管理者

システムおよびネットワーク管理者向けのQ&A

4
URLがTomcatインスタンスを指すようにする方法は?
この質問が意味をなさない場合は申し訳ありません(ここにはエキスパートがいません)が、tomcatがポート8080をリッスンし、そのURLが通常80にアドレス指定されていることを理解しています。URLが8080を指すようにDNSに指示する方法はありますか?または、どうすればこの問題を解決できますか?

1
実行中のLinuxマシンでスワップファイルを作成する
ホスティング会社は完全に信頼性の低い共有ホスティングサーバーの廃止を計画しているため、当社のWebサイトは共有ホストからVDSに移行されました。 VDSには256 MBのRAMしかなく、いくつかのサイトをホストします。そのうちの1つを除くすべてが数ページの非常にシンプルな静的サイトであり、1日あたりの訪問者数は20〜30人未満です。 OSCommerceのややカスタマイズされたバージョンを実行している私たちのプライマリサイトも低トラフィックです(まれに10人以上の同時ユーザー)が、MySQLを必要とします。残念ながら、メモリ不足のために移動mysqldがクラッシュし続けるため。負荷を軽減するために(スレッドの数を減らすために)Apacheの構成を少し編集しましたが、それは実際の問題を回避するだけです。 サーバーにはスワップ領域はありませんが、必要以上にかなりのディスク領域があるので、その領域の一部をスワップに使用することを考えています。それがパフォーマンスに正確に役立つわけではないことは知っていますが、私たちはそれに耐えることができます。 サーバーの実行中にスワップファイルを作成して有効にするにはどうすればよいですか?OSはCentOS 5.5(最終版)であり、Linuxは私の母国語ではありません。 更新: Quantaで説明されているようにスワップファイルを実装するとサーバーが安定しただけでなく、mysqldのクラッシュも発生しないため、結果について疑問に思う人のために、実際には以前よりも高速にページを提供しています。パフォーマンスの向上は私が期待したものとは逆ですが、この場合は間違っていて嬉しいです。
8 centos5  swap  vds 

1
ext3_dx_add_entry:ディレクトリインデックスがいっぱいです
背景:CentOS 5.3でlighttpd 1.4.28-1を実行して、静的アセットを提供しています。 信号:最近、時々遅くなります。カーネルログと以下のエラーが発生しています/var/log/messages: proftpd[5145]: (::ffff:xx[::ffff:xx]) - FTP session opened. proftpd[5145]: (::ffff:xx[::ffff:xx]) - Preparing to chroot to directory 'xx' EXT3-fs warning (device dm-3): ext3_dx_add_entry: Directory index full! Sep 16 15:30:34 xx last message repeated 489 times iノード情報: df -i Filesystem Inodes IUsed IFree IUse% Mounted on /dev/mapper/ddf1_p3 77037568 9996012 67041556 …


4
Debianで「by-uuid」を参照して、ランダムにキーを付けて暗号化されたスワップパーティションを作成する方法は?
復号化されたデータはいつでもクリアテキストでスワップに書き込まれる可能性があるため、GNU / Linuxシステムにブロックデバイス暗号化を実装している場合は、スワップパーティションも暗号化するのが賢明です。 「crypttab」のdebian manページを見ると、起動時にランダムにキー設定されたスワップパーティションを作成する例が表示されます。これにより、起動時にキーがランダムに設定され、システム自体にのみ認識されます。 # Encrypted swap device cswap /dev/sda6 /dev/urandom cipher=aes-cbc-essiv:sha256,hash=ripemd160,size=256,swap この例では、スワップデバイスは従来の開発パスによって参照されます。 /dev/sda6 たとえば、USBドライブが接続されている場合、絶対デバイスパスは変更される可能性があり、起動時に再割り当てされます。/dev/sda6たまたま予想とは異なるパーティションになっていて、その後ランダムスワップデータで上書きされてしまうと、ユーザーは非常に不満になります。 交換、使用UUIDの代わりに、デバイスパス(UUIDは変更されないよう):ソリューションがあるように見えるでしょうだから/dev/sda6と/dev/disk/by-uuid/<whatever the uuid of dev/sda6 is> しかし、ここに問題があります。cryptsetupがブート時に暗号化されたスワップパーティションを再作成するたびに、新しいUUIDが生成されます。どー! したがって、この暗号化されたファイルシステムのUUIDを何らかの方法で保存する必要があります。cryptsetupはその--offsetスイッチでこれを行うことができ、LUKSヘッダー、つまりUUIDを保持できると思います。 私はこのURLを見つけました:https : //wiki.archlinux.org/index.php/System_Encryption_with_LUKS#Using_UUIDs_with_encrypted_swap_partitions Arch Linuxで説明されているソリューションをDebian OSに実装する方法を知っている人はいますか?この文書で言及されているinitスクリプトは、Debian OSには存在しないようです。 ありがとう! 編集 1つは、コマンドを使用して同じ目的(暗号化されたスワップスペース)を達成するためにecryptfsを使用することができます: ecryptfs-setup-swap デバイス暗号化を妨げる問題なし。このAskUbuntuクエリを見てください

3
rootユーザーのulimitを決定する
rootユーザーの最大オープンファイル記述子を増やしたと考えています。これは、次の行を/etc/security/limits.confに追加することで行われました。 * - nofile 2048 アプリケーション(solr-rootによって実行される)が1098ファイルを開いていることがわかるため(ここでは説明しません)、rootユーザーの制限が増加したことを確認しました。ただし、rootユーザーが許可されている開いているファイルの数を確認することはできません。このコマンドが機能することを期待しますが、そうではありません: $ sudo -u root -s "ulimit -Sn" 1024 何か案は?ありがとう!
8 linux  solr  ulimit 

2
サーバーCPU:仮想化に関して、L3キャッシュサイズはどのくらい重要ですか?
パフォーマンスに関して、インテルXeon i7プロセッサーのL3キャッシュサイズは仮想化機能にとってどれほど重要ですか? 私は、Xeon 1366 Nehalem / Westmere CPUを、約4〜5台のVMのローエンド仮想化ホストとなるサーバーに選びました。 4MB L3キャッシュと8MB L3キャッシュの間には価格分割があるようです。8MBから4MBにステップアップすると、どのくらいのパフォーマンスが得られますか?

2
Postfix「smtpd_recipient_restrictions」に設定された最適なパラメータ
私たちは別のISPからDNSを継承しており、今やメールサーバーは毎分約1000通のメールで攻撃されており、これらのメールの99.99%は単なるスパムです。私たちはあまり運が悪い状態でスパムのフィルタリング/拒否を最適化しようとしています。 あなたの意見では、最適なセットはsmtpd_recipient_restrictions何でしょうか? システム構成:Ubuntu + Amavis + Postfix + MySQL + Fail2Ban-Postfix どんなアドバイスでも大歓迎です! UDPATE、2012-08-08 後続としてのposftix構成の変更とPotrgeyサービスの構成で、スパムレベルが10倍に減少しました smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, reject_non_fqdn_hostname, reject_invalid_hostname, reject_non_fqdn_sender, reject_unknown_sender_domain, reject_non_fqdn_recipient, reject_unknown_recipient_domain, check_policy_service inet:127.0.0.1:10023, reject_rbl_client zen.spamhaus.org, check_recipient_access mysql:/etc/postfix/mysql-virtual_recipient.cf, reject_unauth_pipelining, reject_unauth_destination

2
rsync:最上位ディレクトリのみのDotfileを除外する方法は?
バッシュの下でバックアップを実行する場合rsync、私はトップディレクトリ内のすべてのドットファイルおよび隠しディレクトリを除外しようとしましたが、ないそうでない場合は対象ディレクトリのもの。例えば: /copyme.c /.dontcopythisfile /.dontcopythisdirectory/or_its_contents /directory/.butcopymetoo rsync -a --include=".includeme" --exclude=".*" . DESTサブディレクトリで目的のドットファイルをコピーできませんが、などのバリエーション--exclude="./.*"も失敗します。 提案?これには、より単純なものとは対照的にフィルター規則が必要--excludeですか?
8 regex  bash  rsync 


3
「ドメインユーザー」はコンピューターをドメインに参加させることができますか?
それは私には非常にありそうにないように思えますが、念のために言うと、「ドメインユーザー」のメンバーはコンピューターをドメインに参加させることができますか(ローカル管理者アカウントを持っていることが許可されています)? インストラクターはそれを言った、そしてそれは非常に間違って聞こえます。私はそれをテストし、通常のユーザーの資格情報を提供しようとすると「アクセスが拒否されました」というメッセージが表示されました。ここで何か不足していますか? 更新: ADにその名前のコンピューター が既にある場合、アクセスは拒否されます。アカウントを削除すると、ローカルの Administratorアカウントを持つすべてのユーザーがコンピューターに参加し、ADでアカウントを自動作成できます。信じられない。

2
パブリックIPアドレスをpfSenseに渡す
複数のパブリックルーティングされたIPアドレスを持つデータセンターにサーバーがあり、それを管理するためにESXiを実行しています。 以前は、ネットワークを作成するホストの下でいくつかのVMを実行していました。 inet [x.x.x.210] -- Host OS |-- .211 -- VM 1 \-- .212 -- VM 2 ここで、pfSenseとVMwareで次のことを実行したいと思います。 inet lan [x.x.x.210] -- (NAT) -- [192.168.1.1] |-- .211 -- VM1 |-- .2 -- VM3 \-- .212 -- VM2 \-- .3 -- VM4 VM3とVM4がpfSenseによってNAT処理されたプライベートIPを取得している場所、およびVM1とVM2が同じアダプターで引き続き通過している場所で、独自のパブリックIPを取得している場所。 これを行う方法を理解するためにpfSenseのインターフェイスをナビゲートするのに問題があります。できれば、パブリックIPをDHCP経由で引き渡したいので、pfSenseでサポートされたらIPv6トンネルを追加できます。また、ファイアウォールとしてpfSenseを使用できることも最善です(そうでない場合は、一種の目的に反します)。

2
PHP + cURLからの発信httpリクエストをログに記録する方法は?
サイトでアクションが実行されるたびにcURLリクエストを行うPHPスクリプトを設定しています。問題は、アクションが実行されるたびに情報が2回POSTされることです。 これが私の問題(cURLが2回実行されている)であるか、POST先のURLが何かを2回実行している場合は、解決する必要があります。 これを行う最善の方法は、サーバーからの送信HTTP POST要求を表示することだと思います。 これは最良の選択肢ですか?もしそうなら、私はそれについてどうやって行くのですか?
8 linux  ubuntu  php  curl 

7
Linuxユーザーのホームディレクトリをクリアしてデフォルトにリセットする方法を教えてください。
来週、2つのUnixコースを教えるのを手伝っています。ユーザーにはRHEL 5マシンのアカウントが付与されます。その間に、ファイルを/homeフォルダーに追加し、自分.bashrcや他のdotfileを更新し、クリーンアップが必要なその他の一般的な混乱を実行します。 2番目のセッションの学生は、最初のセッションのユーザーのユーザーアカウントを再利用します。アカウントのクリーンアップを自動化して、新しいユーザーが新たに始められるようにしたいと思います。 を実行しsu -u $USER_ID、ホームディレクトリに「元の」適切なファイルのセットを配置し、見つかったものをすべて削除するシェルスクリプトを記述できると確信しています。このクリーン/リセット操作に役立つ他のツールはありますか?Puppet、Chef、その他のツールの経験はありません。彼らはこのようなことをするのに役立ちますか? 問題の範囲を提供するために、約30のユーザーアカウントがあり、すべてのユーザーIDとパスワードを知っています。これらはすべて同じRHELボックスで作成されています。

3
ユーザーがデータを回復するためのスナップショット機能を提供するファイルシステムはどれですか。
私はLinuxを若者に教えるプロジェクトに取り組んでいます。彼らがホームディレクトリ内のアイテムを削除または破損する傾向があることを知っているため、優れたスナップショットオプションを探しています。私たちは、主要なストレージベンダーから入手できる便利なツールにアクセスできなくなり、ファイルシステムレベルでの解決策を見つけたいと考えています。 私はbtrfsについて多くを読みましたが、ほとんど経験がありません。LVMの使用経験はありますが、そのスナップショット機能に慣れていません。ファイルシステムまたは別のいずれかに、オンデマンドまたはスケジュールされたスナップショットを作成するオプションがありますか?次に、これらのスナップショットを、各ホームフォルダーの.snapshotフォルダーのようにrootなしで常に使用できるようにしますか? 考えてみれば、このソリューションにより、ユーザーは必要に応じて24時間から48時間以内にバックアップを自己復元できます。システム用の別のバックアッププロセスと、よりグローバルなバックアップがあります。しかし、私たちはこのプロセスが「間違い」をするだけの学生によって使用されることを望んでいません。

弊社のサイトを使用することにより、あなたは弊社のクッキーポリシーおよびプライバシーポリシーを読み、理解したものとみなされます。
Licensed under cc by-sa 3.0 with attribution required.