サーバー管理者

システムおよびネットワーク管理者向けのQ&A

3
htaccessのApache 2.4 mod_proxy_fcgiとRewriteRulesを理解する
最近、Webサーバーの1つをApache 2.4に切り替え、php-fpmおよびmod_proxy_fcgiを介してPHPを実行しました。ほとんどすべてが非常にうまく機能していますが、まだ理解していない問題が1つあります。私たちのサイトの1つはWordPressを実行しています。WordPressは、.htaccessファイルに書き換えルールの優れたリストを提供しています。そして、それらはvhostセットアップのProxyPassディレクティブではうまく機能しないようです。 私たちの仮想ホストには次の設定が含まれています: ProxyPassMatch ^/(.*\.php(/.*)?)$ fcgi://127.0.0.2:9126/<path>/$1 これはほとんどの場合に機能します。 htaccessファイルは、特に次のことを行います。 RewriteCond %{REQUEST_FILENAME} -f [OR] RewriteCond %{REQUEST_FILENAME} -d RewriteRule ^ - [L] RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L] RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L] RewriteRule . index.php [L] サイトはサブディレクトリ内のマルチブログなので、URL /blogname/wp-admin/load-styles.php?xxxxをwp-admin / load-styles.php?xxx(2番目の書き換えルール)に書き換える必要があることを読みました。しかし、mod_proxyログを見ると、実際に渡される要求は/blogname/wp-admin/load-styles.phpです。 優先順位の問題があるため、これを読みました。すべてのRewriteRulesが完了する前に、ProxyPassルールが起動します。 私は困惑しています-原因は何ですか?

5
失敗した要求トレースXMLがInternet Explorer(IIS 7.5)で表示されない
クラシックASPのWebサイトをデバッグするために、トレース機能をインストールし、Webサイトの失敗した要求のトレースを有効にしました。エラーが発生するとXMLログが作成されますが、IEでそれらを開くと、素敵な青色のインターフェースが表示される代わりに、大量のコード/テキストが表示されます。 インターフェースが読み込まれないのはなぜですか、どうすれば修正できますか?

5
Windowsタスクスケジューラが複数のインスタンスを起動しようとするのはなぜですか?
クラスター内にある1つのServer 2008 Webサーバー(R2ではない)で実行されるWindowsスケジュールタスクがいくつかあります。 最近、元のウェブサーバークラスターから新しいウェブサーバークラスター(サーバー2008-R2ではない)に移動しました。 Windowsタスクを実行する(クラスター内の)新しいWebサーバーは、私たちが信じている元のサーバーと同じように設定されています。 しかし、新しいWindowsサーバーでは、Windowsタスクスケジューラが各タスクを3回瞬時に開始したいように見えることがわかりました。 新しいタスクをキューに入れるオプションを設定すると、次のようになります。 イベントID 324タスクスケジューラは、タスク "\ Client Reporting"のインスタンス "{9a1a8411-b042-45ff-8e6b-89874df230d7}"をキューに入れ、インスタンス "{2bcc3df6-ea3b-4453-90c2-75b8b1946388}"が完了するとすぐにインスタンスを起動します。 既存のタスクを停止するオプションを設定すると、次のようになります。 イベントID 323タスクスケジューラは、新しいインスタンス「{4db66265-1f51-4ede-8535-ac7c3cb5c4c1}」を起動するために、タスク「\ Client Reporting」のインスタンス「{e685a910-b32b-414e-85fd-96bbe54314a2}」を停止しました。 チェックされた設定: タスクをオンデマンドで実行できるようにします。 スケジュールされた開始を逃した後、できるだけ早くタスクを実行します。 1時間以上実行している場合は、タスクを停止します。 要求されたときに実行中のタスクが終了しない場合は、強制的に停止します。 コンピューターがAC電源で動作している場合にのみ、タスクを開始します。 コンピューターがバッテリー電源に切り替わった場合は、タスクを停止します。 選択したオプション:タスクが既に実行されている場合-既存のインスタンスを停止します。 注:タスクをクラスター内のあるサーバーから別のサーバーに移動して、選択した特定のサーバーのタスクスケジューラが問題の原因であるかどうかを確認しました。同じ行動。 新しいサーバーの構築に関係があるのでしょうか? 別のサーバークラスターに非常によく似たタスクがセットアップされており、これらすべてを何度も起動しなくても問題なく動作します。これらのタスクをここでのタスクと比較すると、タスクスケジューラ内のオプションを通じて利用できる設定に関して、明らかに異なるものは何もないようです。 トリガー:タスクは毎日1時間に1回トリガーされ、この時間を超えると停止するようにスケジュールされます。 アクション:.batファイルを実行します。 これを引き起こしている可能性のあるもの/タスクがこの方法で複数回開始する原因となっているロジックを確認できる場所はどこですか?

2
IPv4アドレスの最後の部分の数字の分布はどの程度均等ですか?
作成したWebサイトでリダイレクトスクリプトを実行しています。訪問者の1/3をサイトAに、訪問者の1/3をサイトBに、1/3をサイトCに送信します。 ユーザーのIPv4アドレス(0〜255)の最後の部分を3で割ることで機能し、残りに応じてサイトA、B、またはCにリダイレクトされます。これまでのところ、サイトAの訪問者は109人、サイトBの訪問者は85人、サイトCの訪問者は101人です。 IPv4アドレスの最後のセグメントが完全にランダムに割り当てられていると想定しても正しいですか? また、最後のセグメントの数値の分布は等しいですか?
9 ip  ip-address 

3
これらの奇妙なアクセス要求は何ですか?
コンピューターでWAMPServerをテストと開発に使用しています。私はそれを忘れて数日間オンラインに置いたままにしました。自分のIPからでもないランダムな要求がたくさんあることに気付きました。下記は用例です。 77.73.69.127 - - [29/Apr/2012:08:22:20 -0700] "HEAD /manager/html HTTP/1.0" 200 - 58.218.199.250 - - [29/Apr/2012:08:31:54 -0700] "GET http://www.verysurf.com/proxyheader.php HTTP/1.1" 404 213 58.218.199.147 - - [29/Apr/2012:08:35:37 -0700] "GET http://www.travelimgusa.com/ip.php HTTP/1.1" 200 1340 58.218.199.250 - - [29/Apr/2012:10:03:53 -0700] "GET http://61.152.144.145/judge.php HTTP/1.1" 200 1355 58.218.199.227 - - [29/Apr/2012:12:04:07 -0700] "GET http://59.53.91.9/proxy/judge.php HTTP/1.1" 200 …

2
Amazon EC2パブリックDNSが機能しない
この質問について:AmazonのEC2でパブリックDNSにアクセスするにはどうすればよいです か? Windows Webプラットフォームのファイアウォールルールに従ってセキュリティグループを構成した場合、問題はありますか?私がそれをしたとき、私はウェブブラウザのパブリックDNSにアクセスできなかったからです。 私のセキュリティグループはデフォルトで、インバウンドルールはHTTP、RDP、SMTPS、ICMPです。 私のインスタンスタイプは、デフォルトのセキュリティグループを持つt1.micro webmatrixホスティングサーバーです。 私のWindowsファイアウォールは、ドメイン、パブリック、プライベートプロファイルに対してアクティブです。 この点についてはよくわかりません。セキュリティグループに示されているHTTPポート80。 私はAmazon EC2を初めて使用するので、これは非常に緊急です。

2
Debian / Ubuntuでは、/ var / lib / apt / listsと/ var / apt / cacheを削除した後、それらを再初期化することは可能ですか?
/ var / lib / apt / listsと/ var / apt / cacheの機能を、それらを削除するか、いくつかのWAで最小化した後で復元することは可能ですか? Ubuntu VMを最小サイズに縮小しようとしています。システムを更新する必要があるときに復元することを目的として、/ var / lib / apt / listsと/ var / cache / aptを削除することにしました。大きな副作用なしに/ var / cache / aptを実行しました。いくつかのディレクトリを再作成するだけで再び有効になります。/ var / lib / apt / listsは私がよくわからないものです。/ var / cache / aptのように再作成することで、それを削除して機能を復元することはできますか? これを行うと、システム構成に関するaptおよびdpkgの知識が破壊されますか、それとも他の場所に保存されますか?
9 ubuntu  debian  apt  cache  var 

1
ストリームを連結する方法は?
catファイルを連結できることはわかっていますが、ファイルとストリームを組み合わせて連結し、その結果を別のプロセスにパイプする必要があります。 質問をより具体的にするために、と連結cat abc.sqlしてgzip -dc xyz.sql.gz、cat qvf.sqlすべてを単一のストリームとしてにパイプしmysqlます。 これを達成するための最良の方法は何ですか?
9 shell  pipe  cat 

5
高可用性仮想化環境のセットアップ
プロジェクトでは、WebショップとCMSシステムの高可用性セットアップを計画するタスクがあります。ただし、当然のことながら、プロジェクトの予算は限られています。したがって、ハイエンドのソリューションは予算に収まらない可能性があります。 Webサーバー(CMS、ショップ)を実行する2台のマシン、データベースを実行する1台のマシン、およびパートナーに注文を配信するために必要なFAXサーバーを実行する1台のマシンがあります。すべてのシステムでLinuxが実行されています。これらのコンポーネントはすべて高可用性である必要があり、透過的なフェイルオーバーをサポートする必要があります。 ハードウェアコストを削減するために、仮想化環境について考えます。世の中にはたくさんの情報がありますが、何から始めたらよいのか正確にはわかりません。少なくともサーバーが仮想マシンのホストとして必要であることは明らかであり、単一障害点はありません。 高可用性をサポートするための最善の方法はどれですか。 最初の質問は、どの仮想化ソリューションがこの状況で最適かということです。なんらかの管理インターフェースが必要です。実行中の仮想マシンをあるホストから別のホストに移動して、ホストのメンテナンスを行えるようにする方法が必要です。1つのホストに障害が発生した場合でも仮想マシンを引き続き使用できるように、何らかのメカニズムが必要です。ここで有効な解決策についてアドバイスできますか? 共有ファイルストレージは、ほとんどの場合、高可用性の前提条件のようです(VMware vSphereはかなり高価です)。ただし、2台のサーバーをセットアップに追加して冗長なNFSファイルストアを提供するよりも、仮想マシンホストに多くのお金を投入した方がよいでしょう。2つの仮想マシンホストだけでうまくいく可能性はありますか?解決策は、これら2つをNFSホストとして使用することです。これを行うと、パフォーマンスの低下が大きくなりますか? 編集:私は99,9%の可用性を目指しています。ただし、通常の営業時間があるため、24時間年中無休で稼働する必要はありません。これにより、操作にある程度のスペースが確保されます。何らかの形で保証する必要がある可用性の期間は、午前10時から深夜0時までです。

1
CUPSのデフォルトのプリンターエラーポリシーを変更する
多くのマルチユーザーLinuxアプリケーションサーバーでCUPS印刷を実行しています。システムはRHELまたはCentOSバージョン4、5、または6です。EL5を開始すると、CUPSプリントサーバーはデフォルトでエラーポリシーに設定され、エラーまたは中断(USBケーブルの切断、ネットワークエラー、紙詰まりなど)が発生すると、基本的にプリンターが無効になります。 )。これは、ファイルErrorPolicy内のプリンターのスタンザ内のディレクティブ/etc/cups/printers.confです。 <Printer backupZ4> Info backupZ4 DeviceURI socket://backupZ4:9100 State Idle Accepting Yes Shared Yes JobSheets none none QuotaPeriod 0 PageLimit 0 KLimit 0 OpPolicy default ErrorPolicy stop-printer </Printer> 私は通常、このフィールドをErrorPolicy retry-job設定ファイルで手動で変更するか、コマンドラインでプリンターを作成するときに変更します。 lpadmin -p backupZ4 -v socket://backupZ4:9100 -o printer-error-policy=retry-job -E 他のユーザーまたはベンダーが印刷システムを管理するとき、彼らはこの変更を忘れることがよくあります。その結果、紙詰まりまたはで修正する必要がある他のメッセージに続いて、プリンターが完全に無効になりますcupsenable。 retry-jobCUPSとではなく、デフォルトのErrorPolicy を作成する方法を教えてくださいstop-printer。

5
CPANおよびPerlモジュールのサイレントおよびスクリプトによるインストール?
Scientific Linux(RHEL)インストールスクリプトにCPANといくつかのPerlモジュールを自動的にインストールする必要があります。残念ながら、私が見た限りでは、必要な特定のモジュール(少なくとも1つ)がRPM:として見つかりません。 したがって、CPANをインストールし、それを自動的に(または構成ファイルを使用して)構成してから、必要なモジュール(依存関係を含む)も自動的にインストールする必要があります。 これは非常に珍しい要件のようには思えませんが、これに関する本当に優れたドキュメントは見たことがありません。問題は、CPANが初めて起動されるときはいつでも、対話型構成が実行されることです。これは何とかスキップできますか?また、モジュールインストールをコマンドラインから直接起動するにはどうすればよいですか?


8
ボンディングデバイスにもかかわらず、/ procまたはどこかにMACアドレスを見つけますか?
eth0とeth1の元のMACアドレスを取得する方法はありますか? サーバーの大規模な配列には、バックアップスイッチ接続を管理するボンディングインターフェイスがあり、1つは誤動作しています。bond0がアクティブの場合、両方のMACアドレスが置き換えられ、ifconfigによってまったく同じように報告されます。 シスコデバイスで見つけたMACアドレスをサーバーアレイで検索したいのですが。 私はdmesg(1)または/ var / log / messagesを使用しますが、ほとんどのアレイで何百日もロールオーバーされました。
9 linux  centos  redhat 

4
Dovecotの仮想ユーザーパスワードを変更するにはどうすればよいですか?
1つのWebベースのコントロールパネルを使用して、Dovecotの仮想ユーザーを作成しました。そのコントロールパネルは機能しなくなったので、手動で行う必要があります。 dovecot.passwdファイルにリストされている1人の(仮想)ユーザーのパスワードをリセットする必要があります。ファイルはCRYPTスキーマを使用します。パスワードをリセットするにはどうすればよいですか? つまり、質問は次のようになりCRYPTます。プレーンテキストのパスワードを暗号化された形式に変換するために何を使用できるのでしょうか。
9 centos  dovecot 

1
Apache mod_status出力で完全なURLを表示するにはどうすればよいですか?
とにかくmod_status出力ページに完全なURLを表示する方法はありますか?現時点では、リクエストは64文字で切り捨てられています。 HEAD /w3c-validator/check?uri=http%3A%2F%2Fwww.domain.com%2Fans ?auto、?notableなどのクエリ文字列オプションがたくさんあることは知っていますが、完全なURL(表示されている)は表示されません。

弊社のサイトを使用することにより、あなたは弊社のクッキーポリシーおよびプライバシーポリシーを読み、理解したものとみなされます。
Licensed under cc by-sa 3.0 with attribution required.