サーバー管理者

システムおよびネットワーク管理者向けのQ&A

1
空の応答を返すuWSGI
uWSGIを介してサーバーに接続しようとしているDjangoサイトがあります。私はそのようにサーバーを起動しました: uwsgi --emperor . Ctrl+Z bg 1 (それぞれ9001と9002で機能する、サイトのテストバージョンと本番バージョンを指す2つの.iniファイルがあります) 次に、自分のサイトを取得しようとします。 curl http://localhost:9002 そうすると、その船は忠実ですが実際の反応はないというメッセージが表示されます。uwsgi.logには、次のものが含まれます。 [pid: 5071|app: 0|req: 2/2] 127.0.0.1 () {26 vars in 357 bytes} [Tue Jul 23 13:20:21 2013] GET / => generated 0 bytes in 1 msecs (HTTP/1.1 302) 2 headers in 96 bytes (1 switches on core 1) エラーは記録されません。 …
9 django  uwsgi 

1
ps -auxで100%を超えるCPU%
ps -auxを使用して、TomcatプロセスがCPU使用率が高くなる時期を検出します。その場合、アラートをグループに送信します。ただし、%CPUが100を超える場合もありますが、アプリケーションは正常に動作しています。それは悪い兆候ですか、それとも私たちの理解が正しいかどうかは、プロセスのCPU使用率に影響します これが出力ですコマンドを実行すると USER PID %CPU %MEM VSZ RSS TTY STAT START TIME COMMAND root 16228 106 24.0 2399428 1840576 ? Sl 07:11 171:35 /usr/bin/java -Djava.util.logging.config.file=/opt/tomcat-rc-core-v1-inst01/conf/logging.properties -Dj
9 linux  cpu-usage  ps 

3
iptablesがIPアドレスをブロックしないのはなぜですか?
取得している悪意のあるトラフィックの特定のパターンを監視し、関連付けられているIPアドレスを禁止するようにfail2banを構成しました。 すべてがうまく機能しているようです-正規表現はパターンに適切に一致しており、問題のあるIPアドレスがiptablesに追加されています。 ただし、Apacheのログを確認すると、禁止されているIPアドレスからのヒットがまだあります。iptablesがまったく実行されていないようです。 したがって、すべてが正しく構成されていることを確認するために、いくつかの詳細を共有します。 まず、iptablesルールをクリアしてリロードします。 $ sudo iptables -F $ cat /etc/iptables.firewall.rules *filter # Allow all loopback (lo0) traffic and drop all traffic to 127/8 that doesn't use lo0 -A INPUT -i lo -j ACCEPT -A INPUT -d 127.0.0.0/8 -j REJECT # Accept all established inbound connections -A INPUT -m …

5
btrfsはファイルの最適化も行いますか?
を実行するとbtrfs filesystem balance、これは暗黙的にファイルを最適化しますか?既存の断片化を維持しながら、バランスが各ファイルエクステントを個別に再割り当てするだけだと想像できます。 FAQエントリは、ある「『バランス』は何をしますか?」、これはこの点では不明確です: btrfsファイルシステムバランスは、ファイルシステム上のすべてのデータとメタデータを取得し、ディスク上の別の場所に再書き込みして、途中でアロケータアルゴリズムに渡します。もともとマルチデバイスファイルシステム用に設計され、デバイス間でデータをより均等に分散します(つまり、使用量を「分散」するため)。これは、ほぼ完全なファイルシステムに新しいデバイスを追加するときに特に役立ちます。 バランスが機能する方法により、いくつかの有用な副作用があります。 割り当てられているが使用されていないデータまたはメタデータのチャンクがたくさんある場合、バランスがその割り当てられたスペースの一部を取り戻す可能性があります。これが、単一デバイスのファイルシステムでバランスを実行する主な理由です。 レプリケーションが破損しているファイルシステム(たとえば、停止していてディスクが削除されたRAID-1 FS)では、FSは現在アクティブなデバイスの1つで失われたデータのコピーを再構築し、RAID-1の機能を復元します。ファイルシステム。
9 btrfs 

2
Windows Server 2012でICACLSを使用してグループ権限を割り当てることができない
権限を追加するためにicaclsでグループを受け入れることができません。次のコマンドで昇格した電源シェルを使用しています。 icacls 'C:/foo' /grant:r 'Group Foo':f 次のエラーが発生します。 Invalid parameter "Group Foo" 私もSUIDを使用してみましたが、それも失敗します。「Domain \ Group Foo」も試しました グループが使用できるようにしようとしているファイルがたくさんあります。Windows Server 2012で大量のアクセス許可を追加する適切な方法は何ですか? -編集- E:\> icacls "E:/Contact Numbers.xlsx" /grant:r "Users":f Invalid parameter "Users"

2
クライアントアプリケーションでサポートされている暗号スイートがサーバーでサポートされていない
サーバーのWindowsイベントログに次のエラーが表示されます。 TLS 1.0接続要求がリモートクライアントアプリケーションから受信されましたが、クライアントアプリケーションでサポートされている暗号スイートがサーバーでサポートされていません。SSL接続要求が失敗しました。 Windows Server 2003ボックスからWindows 7ボックスのWebサービスに接続しようとすると、 他がサポートする暗号スイートに暗号スイートを追加するにはどうすればよいですか? (クライアントを修正することは理想的ですが、サーバーソリューションで問題がないことに失敗しました-関連するすべてのボックスにアクセスできます。プライバシーのためにクライアント間の基本的な暗号化が必要です)。 何時間ものグーグルと読書に加えて、私は試しました: サーバーウィンドウのイベントビューアを確認しました(暗号スイートエラーが見つかりました) http://support.microsoft.com/kb/948963からtest1に暗号スイートを追加しました(助けにはなりませんでした) サーバーのWindowsレジストリの暗号スイートのプロトコルにTLS 1.0を追加(変更なし) Schannelにプロトコルを追加することを期待してIISツールをインストールします(そうではありません)。 クライアントの証明書をエクスポートしますが、秘密鍵が含まれています(変更なし) インストールされた暗号スイートがサーバーとクライアントで一致することを確認します(win2k3がそれらをリストする場所を見つけることができません) TLS_RSA_WITH_AES_256_CBC_SHA(上記の修正プログラムによってインストールされます)をサーバーの暗号スイートに追加します(いいえ、すでにそこにあります)

1
「dmcrypt luksFormat」にパスフレーズを非対話的に提供する方法は?
テスト環境の仮想マシンを自動的にセットアップするスクリプトを書いています。このスクリプトは、特定のパスフレーズを使用して、自動的にdmcrypt + LUKSパーティションをフォーマットします。これはローカルテスト環境なので、パスフレーズのセキュリティは気にしません。VMセットアッププロセス全体を自動化して非対話型にするだけです。 「dmcrypt luksFormat」にパスフレーズを非対話的に提供するにはどうすればよいですか?キーではなくパスフレーズを使用したいのは、本番環境ではLUKSにもパスフレーズを使用するためです。
9 luks  dmcrypt 


2
プロキシの宛先が利用できない場合のNginxローカルフォールバックエラーページ
Nginxサーバーを介してローカルサービスにリクエストを転送しています。私が今やろうとしているのは、サービスが利用できなくなった場合に備えてローカルのエラーページにフォールバックすることです。 私の現在の構成は server { listen 80; server_name ""; location / { proxy_pass http://127.0.0.1:9080; proxy_set_header Host $host; proxy_set_header X-Real-IP $remote_addr; proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for; proxy_connect_timeout 1; proxy_next_upstream error timeout http_500 http_502 http_503 http_504 http_404; proxy_intercept_errors on; } error_page 501 502 503 @maintenance; location @maintenance { root /locust/www/fallback/htdocs; index index.html index.htm; } } …
9 nginx  proxy 

2
nginx:なぜプロキシ句をif句の中に入れられないのですか?
この構成では: server { listen 8080; location / { if ($http_cookie ~* "mycookie") { proxy_set_header X-Request $request; proxy_pass http://localhost:8081; } } } nginxサービスをリロードすると、このエラーが発生します。 Reloading nginx configuration: nginx: [emerg] "proxy_set_header" directive is not allowed here in /etc/nginx/conf.d/check_cookie.conf:5 nginx: configuration file /etc/nginx/nginx.conf test failed この構成は正常に動作しますが、私が望むことは行いません: server { listen 8080; location / { proxy_set_header …

4
OpenWrtのタグ付きおよびタグなしVLANの同じポートでの構成
OpenWrtをMikroTikルーターボードRB750UP(AR9330スイッチ内蔵のAR7240 CPU)にインストールしました。以下に詳細を記載しましたが、私の質問は次のとおりです。 タグなしとタグ付きのVLANを同じポートに構成するにはどうすればよいですか? タグなしのVLANとタグ付きのVLANを個別に正常に構成しましたが、同じポートでは構成できません。これを行う理由は、無線LAN(タグなしフレームが必要)を提供するポートにUbiquiti NanoStation loco M2を接続しているためです。また、ロコの管理(つまり、管理へのアクセス)のためにタグ付きVLANを構成したいのです。タグ付きバンを介したIP)。 詳細は次のとおりです。 ハードウェア MikroTikルーターボードRB750UP Ubiquiti NanoStation loco M2 swconfig 出力: swconfig dev eth0 help switch0: eth0(AR7240/AR9330 built-in switch), ports: 5 (cpu @ 0), vlans: 16 <snip> これは、RB750のAR7240 / AR9330スイッチのレイアウト(私がそうであると信じている)の図へのリンクです。 オペレーティング・システム カスタム構成で構築されたOpenWrt BARRIER BREAKER(Bleeding Edge、r36085) # uname -a Linux OpenWrt 3.8.3 #3 Wed Mar 27 …

2
最小Wifi信号強度の業界標準?
信頼性の高い接続を確立するために必要なWifi信号の強度に関する業界標準はありますか?たとえば、Wifiエンドポイントは、-70db信号に確実に接続する仕様に設計されている可能性があります。 私たちはオフィス用のWifiネットワークを設計しています。dbに信号強度のマップがあります。ユーザーの実際のWifi接続にどのように対応するかを決定しようとしています。 また、プロトコルや頻度によって異なりますか?

5
デプロイキーをvagrantに移動するにはどうすればよいですか?
sshキーをvagrantに移動してに入れ~/.sshたいのですが、最も簡単な方法は何ですか?Vagrantファイルに次のものが含まれています。 config.vm.synced_folder "conf.d", "/svr/conf.d" config.vm.provision :shell, :inline => "ls -l /svr/conf.d/.ssh" 合計4 -rw-r--r-- 1 vagrant vagrant 1670 Mar 26 08:19 id_rsa.mediapop config.vm.provision :shell, :inline => "cp /svr/conf.d/.ssh/id_rsa.mediapop /home/ubuntu/.ssh/id_rsa" config.vm.provision :shell, :inline => "ls -l /home/ubuntu/.ssh" 合計4 -rw ------- 1 ubuntu ubuntu 0 Mar 22 08:56 authorized_keys -rw-r--r-- 1 root root …
9 vagrant 

2
Ubuntu 12.04でのPostgresql 9.2「無効なロケール名」
今日私は、apt.postgresql.orgを介してUbuntuにPostgresql 9.2を正確にインストールしました。 root@ubuntu:/tmp# sudo -u postgres psql -Xc "CREATE DATABASE test TEMPLATE template0 ENCODING 'utf8' LC_CTYPE='it_IT.utf8'" ERROR: invalid locale name: "it_IT.utf8" 私はlocale-gen it_IT.utf8実際に走りました、そして実際には: root@ubuntu:/tmp# locale -a C C.UTF-8 en_GB.utf8 en_US.utf8 it_IT.utf8 POSIX ログに、postgresがit_IT.utf8を認識しない理由に関する意味のある情報がないようです...

3
fail2banはローテーションされたログファイルを監視しますか?
fail2banは引き続きローテーションされたログファイルを監視しますか? たとえば、システムが毎週(7日間)自動的にローテーションする/var/log/fail2ban.logを監視するルールがあります。そのログで禁止されたIPを監視して、過去10日間に5回禁止された繰り返しの違反者を見つけるルールを設定したいと思います。それは可能ですか?

弊社のサイトを使用することにより、あなたは弊社のクッキーポリシーおよびプライバシーポリシーを読み、理解したものとみなされます。
Licensed under cc by-sa 3.0 with attribution required.