サーバー管理者

システムおよびネットワーク管理者向けのQ&A

3
サーバー上のすべてのサイトからユーザーエージェントをブロックするにはどうすればよいですか?
私はもともとこれをwebmasters.stackexchange.comに投稿しましたが、ここでより良いレセプションが得られると言われました。 ここ数日間、私は(おそらく不注意による)DDOS攻撃のように見えるものに苦しんでいます。"Mozilla / 4.0(compatible; ICS)"として識別されるエージェントから、Apacheが利用可能なすべてのメモリを消費するという非常に多くのリクエストを受け取っています。 そのため、このユーザーエージェントを伴うすべてのリクエストをブロックしたいので、httpd.confでこれを試みました。 SetEnvIfNoCase User-Agent "Mozilla/4.0 (compatible; ICS)" bad_user Deny from env=bad_user しかし、Apacheを再起動すると、denyここでの使用について不満があります。locationor directoryブロックでラップする必要がない場合、つまり、サイトごとに新しいブロックを追加する必要がありますが、サーバー全体へのアクセスを拒否する方法はありますか? 更新:私が得るエラー /etc/apache2/httpd.confの4行目のWebサーバーapache2 構文エラーの再起動:ここでは拒否できません[失敗]

3
コマンドラインから中断された.MSIインストールをロールバックする
多数のマシンにJavaインストーラーを展開し、その約半分でフリーズしました。現在、次のメッセージが原因で、後続のデプロイメントが失敗しています。 ユーザー「SYSTEM」は、以前に製品「Java 7 Update 10」のインストールを開始しました。そのユーザーは、その製品を使用する前に、そのインストールを再度実行する必要があります。現在のインストールが続行されます。 に続く: エラー1704。Java7 Update 10のインストールは現在中断されています。続行するには、そのインストールによって行われた変更を取り消す必要があります。これらの変更を元に戻しますか? 対話的にインストールを実行する場合、これで問題ありません。[OK]をクリックしてから[はい]をクリックするだけで、ロールオーバーします。ただし、コマンドラインインストールを実行すると、停止します。コマンドラインから中断されたインストールをキャンセルするにはどうすればよいですか?

1
HAProxyを使用した負荷分散のためのURLパラメーターの使用
Cookieを介して負荷分散を行うシステムがありますが、代わりにURLパラメータを使用したいと考えています。(具体的には、Cookieをサポートしていないフロントエンドアプリがあります)。私の設定は少し複雑です-マルチプレイヤーシステムがあり、このCookieでスティックテーブルを使用して、同じゲームをプレイしている別の人が同じサーバーにアクセスできるようにします。これはうまくいきますが、URLパラメータは何もしないようです。これはすべてhaproxy 1.5dev17で 私の関連するバックエンドは: defaults log global mode http option httplog option dontlognull retries 3 option redispatch option http-server-close maxconn 2000 contimeout 5000 clitimeout 50000 srvtimeout 50000 backend simulate option httpchk OPTIONS /simulate/api/status stick-table type string len 40 size 5M expire 30m stick store-response set-cookie(SIMULATE_STICKY_SESSION) table simulate stick on cookie(SIMULATE_STICKY_SESSION) table …

6
PHP FPMは許可を拒否しますか?
PHP-FPMでアクセスが拒否された理由をいくつか読みましたが、解決できません。 エラーログは次のように読み取ります。 2013/04/20 23:33:28 [crit] 15479#0: *6 open() "/var/lib/nginx/tmp/fastcgi /2/00/0000000002" failed (13: Permission denied) while reading upstream, client: 99.999.999.999, server: example.net, request: "GET /wp-admin/ HTTP/1.1", upstream: "fastcgi://unix:/tmp/php-fpm.sock:", host: "example.net", referrer: "http://example.net/" 私は少しですが失われました: / var / lib / nginx / tmpをec2-userに設定しました(チェックするすべてを+777にしても) /tmp/php-fpm.sockをec2-userに設定しました nginx confファイルはec2-userに設定されています php-confがユーザーおよびグループec2-userに設定されている ps auxはすべてのphp-fpmおよびnginxプロセスでec2-userを提供します 私のNginx構成には多くのファイルが含まれており、基本的な設定は次のとおりです。 user ec2-user ec2-user; …

2
appcmdによるIISの物理パスの変更がアクティブ化されていません
IIS 7.5で問題が発生しました。この問題は、以下で構成される単純な展開システムです。 3つのフォルダーで構成される新しいwebrootのzipファイルを作成します。 Api Site Manager これは新しいフォルダ(「SITE_REV1」と呼ぶとします)に解凍され、以下を呼び出すスクリプトが含まれます(各Webrootに1つ): C:\Windows\system32\inetsrv\appcmd set vdir "www.site.com/" -physicalPath:"SITE_REV1\Site" これは通常、9/10回で機能します。場合によっては、webrootは正しく更新されているように見えますが(IISマネージャーで基本設定を調べた場合、パスは正しいように見えます)、問題の実行中のサイトは実際には古い場所を指しています。「修正」に成功した唯一の方法は、IISリセットを実行することです。問題のアプリケーションプールをリサイクルするだけでは不十分です。 場合によっては、再起動が必要であるように見えることもありますが、正確であるかどうかは100%わかりません(問題を解決するのが自分自身であるとは限りません)。 PowerShellとWeb管理モジュールを使用してスクリプトを書き直し、appcmdに不具合があったことを期待しましたが、同じ問題が発生しました。 Set-ItemProperty "IIS:\Sites\www.site.com" -Name physicalPath -Value "SITE_REV1\Site" 誰かがこのようなことを経験しましたか?誰かが何が起こっているのかについての手がかりはありますか?この問題を防ぐために私が試すことができることは何ですか?IISリセットを実行することは、私たちにとって本当に良いオプションではありません。単一のサイトに変更を展開しようとするたびに、サーバー上のすべてのサイトに影響を与えるからです。 編集:IISマネージャーでの(アプリケーションプールではなく)サイトの開始/停止によってエラーのある物理パスが解決されることを確認しましたが、appcmdを使用してサイトを停止し、物理パスを変更してから開始すると、依然として問題があります同じ問題。私は空白です...

1
レイヤー2またはレイヤー3パケットのどこに機密情報を埋め込むことができますか?
Citrix Netscalerには、ホストに送信されるTCPパケットに情報を埋め込むという興味深い特性があります。このプロパティはNetscalerにエコーバックされ、Netscalerがこれを使用して、仮想サーバー、ホスト、およびルートがこれを使用する必要があるかどうかを判断できます。 専有情報をホストにエコーする機能には、興味深いアプリケーションがあります。 Citrix Netscalerはこれをどのようにして達成し(ビットをどこに詰め込むのか)、Netscaler(または同様のデバイス)は理論的にはデータの他のどの場所にデータを詰め込むことができますか? このカスタムデータをそのまま通過させる(または許可しない)デバイスはどれですか?

2
Exim 4.71は送信メールにDKIM署名を追加しません
ドメインにDKIMを追加しようとしています。キーを作成し、以下をに追加しました/etc/exim4/conf.d/transport/30_exim4_config_remote_smtp。 dkim_domain = mydomain.com dkim_selector = mail1 dkim_private_key = /etc/exim4/dkim.key eximサービスを再起動しましたdpkg-reconfigureが、すべてのメールは署名なしで送信されました。/var/log/exim4/panic.log空です。エラーなどはありません。 何が悪いのですか?Ubuntu 10.04 LTS ### transport/30_exim4-config_remote_smtp ################################# # This transport is used for delivering messages over SMTP connections. remote_smtp: debug_print = "T: remote_smtp for $local_part@$domain" driver = smtp .ifdef REMOTE_SMTP_HOSTS_AVOID_TLS hosts_avoid_tls = REMOTE_SMTP_HOSTS_AVOID_TLS .endif .ifdef REMOTE_SMTP_HEADERS_REWRITE headers_rewrite = REMOTE_SMTP_HEADERS_REWRITE .endif …

4
どのJavaバージョンでJenkinsを実行する必要がありますか?
リファレンス:Jenkinsユーザー:: Windows上のJenkins:Java + JRE(バージョン)の混乱 Jenkinsを実行するJavaのバージョン(Windows)は?Windowsマスターに含まれているJREを使用する必要がありますか?最後の1.6リリースを使用する必要がありますか?現在の1.7バージョンで実行する必要がありますか?(スタンドアロンバージョンを実行していることに注意してください。) Jenkinsのページで私が見つけたのは、Jenkins を実行するために、少なくともJRE 1.5以降が必要です。 余談ですが、私のWindowsサーバーはまだ32ビット2k3ですが、64ビットプラットフォームでJenkinsをどのように実行しますか?32ビットまたは64ビットのJVMですか? この質問は、Jenkinsインスタンスを実行するために使用するJRE(またはJDK)に関するものだけであることに注意してください。Javaプログラムのビルドに使用されるJDKは関係ありません。

3
postfixを使用して特別なフォルダにスパムメールを送信する
私はamavisを実行しているpostfixサーバーとSpamAssassinを使用してスパムのフィルタリングを支援しています。スパムとして検出されたメッセージは、ユーザーのMaildirに配信されると次のようになります。 2013年3月15日01:46:20にtom @ tom-mintから リターンパス:<tom @ tom-mint> X-Original-To:tom@my-server.com 配信先:tom@my-server.com X-Virus-Scanned:my-server.comのDebian amavisd-new X-Spam-Flag:はい X-Spam-Score:6.463 X-Spamレベル:****** X-Spam-Status:はい、スコア= 6.463 tagged_above = 2必須= 6.31 tests = [DRUGS_ERECTILE = 2.221、FH_FROMEML_NOTLD = 0.18、 FSL_HELO_NON_FQDN_1 = 0.001、HELO_NO_DOMAIN = 0.001、RCVD_IN_PBL = 3.558、 RDNS_DYNAMIC = 0.363、TO_NO_BRKTS_DYNIP = 0.139] autolearn = no 日付:金、2013年3月15日01:46:19 -0400 宛先:tom@my-server.com 件名:*** SPAM ***こんにちは User-Agent:家宝mailx 12.5 …
9 linux  email  postfix  spam 

2
誰かが私のパスワードを総当たり攻撃しているのですか?sshd:不明[net]およびsshd:[受け入れ] htopで点滅
私のVPSには約3%のCPU負荷があります。これは、おそらくsshd: unknown [net]、sshd: [accepted]コマンドが毎秒1回表示され、ですぐに表示されなくなるために発生しhtopます。 誰かが私のパスワードをブルートフォースにしようとしているのですか?それについて私は何をしますか?
9 ssh  vps 

2
指定した仮想ホストでのみPhpMyadminへのアクセスを許可する
複数の仮想ホスト環境で作業しています。Mysql Remote Control用のPhpMyadminをインストールしました。 環境は以下のように構成されています。 one.domain.com two.domain.com onlyphpmyadmin.domain.com ここで、3つのドメインのいずれかにアクセスすると http://one.domain.com/phpmyadmin/ http://two.domein.com/phpmyadmin/ http://onlyphpmyadmin.domain.com/phpmyadmin/ 結果は同じで、Phpmyadminへのアクセスが許可されます。 目標は、以下のような状況を取得することです http://one.domain.com/phpmyadmin/ --> access denied http://two.domein.com/phpmyadmin/ --> access denied http://onlyphpmyadmin.domain.com/phpmyadmin/ -->access allowed 同様のハックはありません <?php if($_SERVER['HTTP_HOST'] != 'onlyphpmyadmin.domain.com') die('access denied'); ... ?> 一部のPhpmyadminファイル。 ここに私のPhpmyadmin設定ファイル Alias /phpmyadmin /usr/share/phpmyadmin <Directory /usr/share/phpmyadmin> Options FollowSymLinks DirectoryIndex index.php <IfModule mod_php5.c> AddType application/x-httpd-php .php php_flag …

4
rootフルLinux。空きブロックなし
df -h「/」パーティションが100%使用されていると報告します。du -hs *このパーティションの各ディレクトリで実行すると、まだ多くの領域があることが示されます。 tune2efs空きブロックが1つだけと報告されています。実行fsckされたすべてのブロックも表示されます。 ionodeの使用は、「/」パーティションで14%です。 / var、/ usr、/ dev、/ tmp、/ homeは異なるパーティションにマウントされ、それらに使用可能なスペースがあることに注意してください。 十分なスペースがある場合でも、すべてのブロックが占有され、ディスクレポートがいっぱいになる可能性のある原因を教えてください。

3
PostgreSQLの遅いコミットパフォーマンス
PostgreSQLの設定で問題が発生しています。いくつかのベンチマークの後、非常に単純なクエリには比較的長い時間がかかることがわかりました。詳しく調べたところ、実際のCOMMITコマンドは本当に遅いようです。 次の表を使用して、非常に簡単なテストを実行しました。 CREATE TABLE test ( id serial primary key, foo varchar(16), ); すべてのステートメントのログオンをオンにした後、次のクエリを10000回実行しました。 BEGIN; INSERT INTO test (a) VALUES ('bar'); COMMIT; BEGINとINSERTの完了には1ミリ秒未満かかりますが、COMMITの完了には平均22ミリ秒かかります。 自分のPCで同じベンチマークを実行すると、かなり遅くなりますが、BEGINステートメントとINSERTステートメントの平均は同じになりますが、平均COMMITは約0.4ミリ秒(20倍以上高速)です。 いくつか読んだ後、私はpg_test_fsyncツールを試して問題を突き止めようとしました。サーバーでこれらの結果を取得します。 $ ./pg_test_fsync -o 1024 1024 operations per test O_DIRECT supported on this platform for open_datasync and open_sync. Compare file sync methods using one 8kB write: …

1
コンピューター名ではなくCNAMEを使用してPowershellがサーバーにリモート処理する
コンピューター名ではなくCNAMEを使用して、PowerShellリモート処理でサーバーを操作しようとしています。ローカルマシンとリモートマシンの両方が同じネットワークとドメインにあります。 PowerShellのリモート処理を有効にしましたが、コンピューター名で正常に動作します。TrustedHostsをCNAMEに設定し、CNAMEのSPNを追加しましたが、発行するEnter-PSSession CNAMEと次のようになります。 Enter-PSSession : Connecting to remote server CNAME failed with the following error message : WinRM cannot process the request. The following error occurred while using Kerberos authentication: Cannot find the computer CNAME. Verify that the computer exists on the network and that the name provided is spelled …

3
Windows 7での共有フォルダーの更新が遅い
Windows Server 2012で共有フォルダーに新しいフォルダーを作成すると、Windows 7クライアントで新しいフォルダーが表示されないことがあります。また、いくつかの更新を行っても、新しいフォルダが表示されません。数分後、彼らは現れます。更新時間を変更することは可能ですか? ありがとうございました

弊社のサイトを使用することにより、あなたは弊社のクッキーポリシーおよびプライバシーポリシーを読み、理解したものとみなされます。
Licensed under cc by-sa 3.0 with attribution required.