サーバー管理者

システムおよびネットワーク管理者向けのQ&A

3
非常に低いインバウンドトラフィックと高いアウトバウンドトラフィックの考えられる原因は何ですか?
昨日、Digital Oceanサーバーが攻撃のように見える何かに遭遇しました。アウトバウンドトラフィックは突然700Mbpsに増加しましたが、インバウンドトラフィックは約0.1Mbpsのままで、一度も増加しませんでした。トラフィックは、Digital OceanがDoSを実行していると想定して(これは妥当です)、Digital Oceanがサーバーをネットワークから切断するまで数分間続きました。 私は2つの仮定を持っています。誰かが私たちのサーバーにハッキングした(攻撃の後で同僚がパスワードでSSHログインを有効にしたことに気付いた)か、知らない種類の攻撃があるかです。 誰かがこの状況を解決してくれますか?確かにそのようなトラフィックのようなDoSがある場合は、教えてください。

3
DL380 G5、RAID5、ext3、RAID障害
古いHP DL380G5サーバーがあり、RAID5アレイに5つの300GB SCSI 3.5 ''ディスクがあり、外部ベイに、ext3ファイルシステムで論理ボリュームとしてフォーマットされ、1.2 TBの機密の臨床患者データをホストします。 2つのディスクがhpacucliで予測障害を示したため、最初にそれらの1つを交換し、問題がないことを確認しましたが、「再構築の準備ができました」とも表示されていませんでした。私は2番目のものもまったく不注意に変更しましたが、RAIDが失敗したと表示されます。 古いディスクを元に戻し、サーバーを再起動してみましたが、起動中にリカバリモードになり、論理ボリュームが見つからないと表示されました。 これを復元するために私ができることは何ですか?残念ながらバックアップはありません。どんな助けでも本当に感謝します! 古いドライブを両方とも戻すことを考えていましたが、RAIDが復活する可能性はありますか?
9 raid5  ext3 

1
マシンがシャットダウン/再起動する前に、サービスが正常に終了するのを待ちます
マシンのシャットダウンまたは再起動時に正常にシャットダウンするsystemdサービスをどのように記述しますか?特に、正常に終了するまでマシンのシャットダウンを遅らせます。 シャットダウンに10秒かかるサービスがあります:/usr/local/bin/shutdowntest.sh: #!/bin/bash SHUTDOWN=0 SHUTDOWN_TIME=10 TRAPPED_SIGNAL= function onexit() { TRAPPED_SIGNAL=$1 SHUTDOWN=1 } for SIGNAL in SIGINT SIGTERM SIGHUP SIGPIPE SIGALRM SIGUSR1 SIGUSR2; do trap "onexit $SIGNAL" $SIGNAL done echo >&2 "shutdowntest running" while ((!SHUTDOWN || SHUTDOWN_TIME>0)); do if [[ -n "$TRAPPED_SIGNAL" ]]; then echo >&2 "shutdowntest received signal $TRAPPED_SIGNAL" TRAPPED_SIGNAL= …
9 systemd 

2
ユーザーがZFSデータセットを受信するために欠落しているアクセス許可をどのように判断できますか?
FreeNAS(11.1-U1)とFreeBSD(11.1-RELEASE-p6)マシンを持っています。FreeNASではzfs receive、委任された権限を持つ非ルートユーザーとして再帰的なスナップショットを作りたいです。これはほとんどの子データセットでうまく機能するようです。しかしdata、刑務所にマウントしてそこから管理できるiocageのデータセットは失敗します。 root@freebsd:~> zfs send -RI "dozer@2018-02-21" "dozer@2018-03-08" | ssh -T -i /root/backup_key backupuser@freenas zfs receive -dvuF neo/backups/freebsd receiving incremental stream of dozer@2018-03-03 into neo/backups/freebsd@2018-03-03 received 312B stream in 1 seconds (312B/sec) receiving incremental stream of dozer@2018-03-07 into neo/backups/freebsd@2018-03-07 received 312B stream in 1 seconds (312B/sec) receiving incremental stream of …

4
Windowsプロセスアクティブ化サービスが失敗する-Windows 10
Windowsプロセスアクティブ化サービス(WAS)がWindows 10 PCで起動しなくなりました。その結果、IISは起動しません。いつ起こったのかはよくわかりませんが、先月のことでしょう。 起動時に、システムログに一連の4つのエラーイベントが表示されるようになりました。 WAS 5215:Windowsプロセスアクティブ化サービス(WAS)がオフラインセットアップの初期化を実行できませんでした。データフィールドにはエラー番号が含まれています。[データフィールド:50000780] WAS 5005:エラーが発生したため、Windowsプロセスアクティブ化サービス(WAS)が停止しています。データフィールドにはエラー番号が含まれています。[データフィールド:50000780] サービスコントロールマネージャー7023:WASサービスは次のエラーで終了しました:ファイルが存在します。 Service Control Manager 7001:W3SVCサービスは、次のエラーのために開始できなかったWASサービスに依存しています:ファイルが存在します。 ファイルが存在するというエラーについて、このタイプのエラーへの言及はあまりありません。 (ProcMonを使用して、参照しているファイルを特定しようとしましたが、実行は完全に拒否されます。) 編集...ついにProcMonが機能するようになりました(VS2017を使用して64ビットバージョンを抽出した後)。上記の問題の原因となったファイルは、C:\Windows\System32\inetsrv\Configフォルダー内の「applicationhost.config.tmp」ファイルであることが判明しました。そのファイルを削除すると、プロセスをさらに続行できます。 現在、最初と3番目のエラーは次のとおりです。 WAS 5215:Windowsプロセスアクティブ化サービス(WAS)がオフラインセットアップの初期化を実行できませんでした。データフィールドにはエラー番号が含まれています。[データフィールド:0D000780] サービスコントロールマネージャー7023:Windowsプロセスアクティブ化サービスサービスは次のエラーで終了しました:データが無効です。 Yanbing Shiの回答によると、iis.logファイルの最新の行は次のとおりです。 [01/13/2018 23:10:41] [ ***** IIS 10.0 Component Based Setup ***** ] [01/13/2018 23:10:41] .\inetsrv\iissetup.exe /install SharedLibraries /nano [01/13/2018 23:10:41] Setting Installation Type to Nano [01/13/2018 23:10:41] Successfully added …
9 iis  windows-10 

2
私たちの小規模オフィスには内部DNSサーバーがありますか?
私は小規模オフィス(<50人)を管理しています。オフィスには常に内部DNSサーバーがありました。DNSサーバーはかなり単純明快ですが、過去に問題が発生しました。オフィスでのみ、または外部でVPNを介して利用できるオフィスリソースがいくつかあり、パブリックアドレスとレコードを持つオフィスリソースもいくつかあります。現在、これらのリソースは同じDNS名を持っていますが、これは必ずしも要件ではなく、以前よりもはるかに少なくなっています。 社内オフィスの名前空間も既に所有しているので、パブリックDNSに社内オフィスリソースのすべてのプライベートIPアドレスを入力して、内部DNSの使用を完全に停止することが考えられます。 これは良い考えですか?私は社内DNSのない場所で働いたことはありません。それを維持する必要がある理由は何ですか?それはかつて重要でしたが、今でも便利ですが、私たちが遭遇した問題はもはや便利だと感じさせていません。 維持すべき現在の理由: スプリットDNSにより、内部でホストされているが外部からも利用可能なリソースに同じホスト名を使用できます 購入する必要のないテストドメインがいくつかありますが、それらを取り除くと必要になります。 ??? 親しみやすくて気持ちいい? それを取り除く理由: 現在、IPv6はサポートされていません 主にVPN構成で、DNSの分割にいくつかの問題がありました 不要かもしれないサーバーのメンテナンス

1
ルートCAが期限切れになると、コード署名証明書はどうなりますか?
これまでのところ明確です:コード署名証明書自体の有効期限が切れると、タイムスタンプで署名された場合に備えて、署名されたコードが検証/受け入れられます。そうでない場合、署名されたコードも期限切れになります。 しかし、私のCA自体が期限切れになるとどうなりますか(ルートCA、つまり発行CA)。 タイムスタンプが付けられていても、コードは受け入れられますか? 期限切れのルート証明書と発行CA証明書がまだ存在している必要がありますか(信頼されたルートCA証明書ストアなど)?これは私の仮定ですが、CAが降格されても、署名されたものを実行するクライアントはCAを信頼する必要がありますか?そうでなければ、信頼チェーンは壊れますよね? CRLまたはAIAの欠如は問題を引き起こしますか?

2
HP Proliant DL380 Gen9はハリケーンIrmaの間に濡れましたが、ハードドライブはまだ良好です。新しい同一のサーバーに接続するだけでよいですか
HP Proliant DL380 Gen9はハリケーンIrmaの間に濡れましたが、RAID 1(ミラーリング)として構成された2台のハードドライブはまだ良好です。交換品を注文済みで、古いものと同じ仕様です。2台のハードドライブを同じサーバーに接続するだけで、新しいサーバーは古いハードドライブで起動しますか?


1
OpenBSDは、同じIPを持つが異なるインターフェースを持つ異なるゲートウェイを経由します
同じゲートウェイIPを使用する複数のVPN接続があります(自分の制御外のため、これを変更することはできません)。これらのVPNはすべて異なるネットワークへのアクセスを提供し、ネットワークは少なくとも1ホップまたは2ホップアップストリームであるため、すべての場合にゲートウェイIPが必要です。Linuxを使用すると、ネットワークにルーティングするために、次のことを簡単に実行できます。 ip route add $destination_1 via $gateway_ip dev $interface_1 ip route add $destination_2 via $gateway_ip dev $interface_2 ip route add $destination_3 via $gateway_ip dev $interface_3 等 Linuxは、各宛先ネットワークのトラフィックを正しいゲートウェイに向かう正しいインターフェースに配置するため、ゲートウェイIPが各インターフェースで同じであることは問題ではありません。 私の質問は、どうすればOpenBSDでこれを実現できるでしょうか?私は試し、失敗しました。私の発見によると、特定の目的地では、次のいずれかを行うことができます。 インターフェースを指定する(宛先にそのリンク上で直接到達可能である場合-私の場合はそうではありません) 宛先がリンク上に直接ないため、ゲートウェイIPを指定します しかし、両方を指定する方法がわかりません。

3
DebianストレッチにMongoDB 3.4をインストールできません
mongodb repoをソースリストに追加しました: deb http://repo.mongodb.org/apt/debian jessie/mongodb-org/3.4 main その後apt-get update。 インストールしようとすると、次のようmongodb-orgになります。 root@ns:~# aptitude install mongodb-org The following NEW packages will be installed: mongodb-org mongodb-org-mongos{ab} mongodb-org-server{ab} mongodb-org-shell{ab} mongodb-org-tools{ab} 0 packages upgraded, 5 newly installed, 0 to remove and 0 not upgraded. Need to get 66.7 MB of archives. After unpacking 269 MB will …

3
ドメインコンピュータが互いに通信することを許可しない
私たちのドメインは約60台のコンピューターで構成されています。私はWindows 10ワークステーションが互いに通信できないようにすることを任されています。私のマネージャーは、コンピューターがネットワークプリンター、ファイルサーバー、DCとのみ通信し、インターネットにアクセスできるように、静的ルートを作成するように依頼しました。 これらのコンピューターはすべて同じネットワーク上にあるため、静的ルートがこれらのコンピューターの相互参照を妨げるとは思いません。ドメイン上のコンピューターがネットワークリソースを使用できるが、互いに直接通信できないようにするための最良の方法は何ですか?

7
サーバーの腐食、空調、温度管理
残念ながら、社内のサーバールームにあるサーバーが錆びていることを発見しました。これは、最初の1つが失敗した後に明らかになりました。 明らかな候補の1つはACユニットで、湿度調整に問題があることが考えられます。そこで、温度と湿度をプロットしました。言うことはたくさんありますが、これは私の質問をうまく説明しています: 比較的密閉された部屋(1.5 x 2.5メートル程度)では、各サーモスタットサイクルの後で湿度が非常に高いままであるという事実が疑われます。また、ACをオフにすると、湿度のピークが明らかに抑制されました。 これは通常のAC動作ですか?湿度がいつもこんなに高いレベルに戻るとは思っていませんでした。グラフの右側でも、低いままではなく、かなり高い位置で安定したいと思っています。 私はまた、腐食を引き起こす硫黄を含む微細な粒子状物質など、他の問題についても調べましたが、実際には、それはもっと抽象的な考えのほうです。それをどのように測定および/またはテストするか私にはわかりません。 私もACメンテナンス/空気の質の会社にそれを見てもらいましたが、彼らはオフィスの空気の質の観点から考えているようであり、サーバーが人とは異なる要件を持っているという点で私に完全に従うことができませんでした。一つには、彼らの提案は、新鮮な空気を継続的に部屋に送り込むことでした。私には非論理的なようです。 編集:ズームレベルを高くします。温度の上昇/下降と湿度の上昇/下降の相関関係も確認できます。

1
64KBブロックサイズでXFSからファイルを取得する
私は、RAID 1にあった、完全に機能し、破損しておらず、暗号化されていない2つのNASドライブの1つからファイルを回復する使命を帯びていました。NASはPatriot Javelin S4でした(私の調査でわかったように)Promise FasttrackフェイクRAIDコントローラを使用します。 これに関する情報は非常に少ないため、同じ状況のグーグルにとって、このNASに関するいくつかの事実があります。 RAIDコントローラー:Promise FastTrack(FakeRaid) ボリュームシステム:LVM2 ファイルシステム:64kbブロックサイズ(65536バイト)のXFS Arch:800MHz AMCC PowerPCプロセッサ、256MB RAM(Matthewの研究に感謝) これを行ったとき、私はWindows 10とMacOSコンピュータしか持っていませんでした。LVM2ボリュームにXFSをマウントできるソフトウェアは見つかりませんでした(1つを例外として、以下で詳しく説明します)。私は古いネットブックAcer Aspire Oneを取り出し、それにpuppy linux(具体的にはlxpupフレーバー)をインストールする必要がありました。 子犬のLinuxでは、と呼ばれるツールを使用してこのファイルシステムをマウントできましたdmraid。このツールには、Promise FastTrackのIDであるpdcボリュームをマウントする方法があります。なんとかそれをマウントしているいくつかのフープを飛び越えることができたら、私は実際のXFSファイルシステムにアクセスできるようになり、そして残念なことに、それは64kbのブロックサイズであることがわかりました。 ここで、「read xfs 64kb block size」のようなものをググって始めて、どこにも行きませんでした。「カーネルにパッチを適用しない限り、Linuxは4kbを超えるブロックサイズを読み取ることができません」と答えるのはほんのわずかです。カーネルにパッチを当てる方法がわかりませんし、これを可能にするエミュレーションもないので困惑しています。 Win / Macでこのパーティションを読み取ることができないアプリの1つの例外について言及しました。その例外はufsexplorerでした。100ドルのアプリで、シ​​ームレスにファイルを表示できました。私はそれが機能することを証明するいくつかのファイルをコピーしましたが、試用版では小さなファイルしかコピーできません。 64kbのxfsを読み取るのに役立つような複雑さのレベルにある無料のオープンソースツールはありません。 私の質問は、そのようなツールを誰かが知っていますか?1つ以上のツール、カーネルパッチ、または他の何か(無料)を使用してデータを取得する方法についての具体的な指示があれば、高く評価されます。 もう1つのポイント:これらのドライブのローカルイメージを作成する必要がないことを強く望みます(それが唯一の方法でない限り)。結局のところ、それは2TBのデータであり、私はこれほどのスペースを持っていないかもしれません。 PS 64 kbのxfsを読み取ることができる既知のLinuxがAcerにインストールできる場合、それも実行可能なソリューションです。 更新1:https://www.cgsecurity.org/wiki/TestDiskについて学んだところです。一撃の価値があるかもしれません。試してみる時間があったらまた報告します。 Update 2:TestDiskはXFSパーティションの存在を認識しているようですが、そこに進む方法がわかりません。ファイルを抽出する方法がわからないので、今はそれを放棄し、マシューの答えでqemuアプローチを試しました。

2
Amazon ECSサービスのタスク配置戦略を変更する
5つのEC2インスタンスを持つ単一のECSクラスターで約15のマイクロサービスを実行しています。サービスをセットアップしている間、タスク配置戦略にあまり注意を払わなかったので、今はそれを変更したいと考えていますが、これまでのところ、そうする方法を見つけていません。戦略を定義できるのは、サービスを作成するときだけで、サービスを更新するときではないようです(Amazonのドキュメントでは、更新については触れていませんが、不可能ではないと言っています)。 タスクの配置を変更する方法はありますか、またはすべてのサービスを再作成する必要がありますか?

弊社のサイトを使用することにより、あなたは弊社のクッキーポリシーおよびプライバシーポリシーを読み、理解したものとみなされます。
Licensed under cc by-sa 3.0 with attribution required.