サーバー管理者

システムおよびネットワーク管理者向けのQ&A

2
curl(56)Recv失敗:ピアによる接続のリセット-Dockerコンテナーにヒットしたとき[クローズ]
休業。この質問には詳細または明確さが必要です。現在、回答を受け付けていません。 この質問を改善してみませんか?詳細を追加し、この投稿を編集して問題を明確にしてください。 29日前休業。 AWS ec2インスタンス(実行中docker)から、Docker curlコンテナーでホストされているWebサービスに接続しようとしています。 与えられた: [ec2-user]$ docker ps CONTAINER ID IMAGE COMMAND CREATED STATUS PORTS NAMES b56fa0d76d5c $REGISTRY/$WORK/metrics:v0.1.0 "/bin/sh -c 'sh /root" 3 minutes ago Up 3 minutes 0.0.0.0:80->80/tcp, 0.0.0.0:9000->9000/tcp insane_leakey コンテナー内からWebサービスにアクセスできます。 [ec2-user]$ docker exec -it b56fa0d76d5c bash root@b56fa0d76d5c:/# curl 'http://localhost/health' Request is missing required query parameter 'apiName' …

2
10/20 / 40Gbps nginx大容量ファイルキャッシングウェブサーバー[20Gbpsに達しました]
この質問で、単一のサーバーから40Gbpsを配信するのに最適な構成/ハードウェアを見つけたいと思います。 状況 背後にある低速のストレージサーバーからピークをオフロードするビデオ共有プロキシサーバーがあります。すべてのトラフィックはHTTPのみです。サーバーは、リバースプロキシ(サーバーにキャッシュされないファイル)およびWebサーバー(ローカルドライブに保存されるファイル)として機能します。 現在、100 TB程度のファイルがあり、バックエンドストレージサーバーで増加しています。 キャッシングメカニズムは独立して実装されており、非常にうまく機能するため、この質問はそれ自体をキャッシングすることに関するものではありません。したがって、キャッシュの使用状況は良好です。 ゴール 1台のマシンで40Gbps以上のスループットを実現します。 ハードウェア1 ハードウェア:Supermicro SC825、X11SSL-F、Xeon E3-1230v5(4C/8T@3.4GHz)、16GB DDR4 RAM、2x Supermicro 10G STGN-i1S(LACP L3 + 4) SSD:512G​​B Samsung x 1、500GB Samsung x 2、480GB Intel 535 x 2、240GB Intel S3500 x 1 システム: irqbalancerが停止しました 各インターフェースのset_irq_affinity(ixgbeドライバーtarballのスクリプトを使用) ixgbe-4.3.15 I / Oスケジューラーの期限 iptables空(アンロードされたモジュール) ファイルシステム:XFS Nginx: sendfile off aioスレッド directio 1M …

1
ネストされた仮想化-それは可能ですか?[閉まっている]
閉まっている。この質問はトピックから外れています。現在、回答を受け付けていません。 この質問を改善してみませんか? サーバー障害のトピックになるように質問を更新します。 4年前休業。 VMware ESXi 5.0で作成したサーバーでWin10を使用する必要があります。VMware ESXi 5.0にDebian 6.0をインストールしてから、Win10ゲストオペレーティングシステムでVirtualBox 5.0.14をインストールします。うまくいきますか?

3
ubuntu 15.04でsystemdを使用してdocker-composeを開始する
systemdで制御したいdocker-composeプロジェクトがあります。新興企業では、次のようなスクリプトを使用します。 description "Start/Stop server" author "Jim Cortez" start on filesystem and started docker stop on runlevel [!2345] respawn limit 3 240 pre-start script # wait (if necessary) for our docker context to be accessible while [ ! -f /projects/my_server/docker-compose.yml ] do sleep 1 done /usr/local/bin/docker-compose -f /projects/my_server/docker-compose.yml up -d end …

2
.htaccessファイルの長い行を分割する
.htaccessファイルにContent-Security-Policyヘッダーを設定しています。ヘッダーが非常に長くなり、管理が面倒です。この行をより扱いやすい部分文字列に分割する方法はありますか? 簡単な例として、ヘッダーを次のように設定するとします Header set Content-Security-Policy "deafult-src http://domainA.com; script-src http://domainB.com" 私は(明白な問題を壊すことなく)次のようなもので私の特定のケースを達成できます Header append Content-Security-Policy "default-src http://domainA.com;" Header append Content-Security-Policy "script-src http://domainB.com" しかし、それは文字列にコンマを挿入するので、応答に追加の文字を追加せずに、一般的に適用できるより良い答えがあるかどうか私はまだ興味を持っていました。 文字列を次のように小さな部分に分割するために使用できるいくつかの連結文字がある場合に理想的です Header set Content-Security-Policy "default-src http://domainA.com;" \" script-src http://domainB.com" または Header set Content-Security-Policy "default-src http://domainA.com;"^ " script-src http://domainB.com" または Header set Content-Security-Policy "default-src http://domainA.com;" +" script-src http://domainB.com" あるいは、ある種の変数を設定し、その内容をダンプして次のようなことを行うことができる場合 a="default-src …

3
タグ付けされたDockerイメージをプライベートレジストリから削除する
プライベートDockerレジストリのイメージから誤って追加されたタグを削除するにはどうすればよいですか?オプション-rmiは、Docker 1.9.1のリモートイメージに対しては機能しないようです。 user@ubuntu-user:~$ docker --version Docker version 1.9.1, build a34a1d5 user@ubuntu-user:~$ docker search myregistry:5000/user/image NAME myregistry:5000/user/image:20160119 myregistry:5000/user/image:20160119-20160120 user@ubuntu-user:~$ docker rmi myregistry:5000/user/image:20160119-20160120 Error response from daemon: could not find image: no such id: myregistry:5000/user/image:20160119-20160120 Error: failed to remove images: [myregistry:5000/user/image:20160119-20160120]

2
DKIM署名のあるメールは、SpamAssassinによってT_DKIM_INVALIDフラグを取得します
Debian(jessie)のボックスにpostfixとspamassassinをインストールしました。構成され、すべてが正常に動作します。 DKIM signaturでメールを受信する場合を除きT_DKIM_INVALID、署名が有効であってもフラグが生成されます。以下のログの例を参照してください。 その後、opendkimは署名を検証して通過させます。 Jan 15 14:18:21 localhost spamd[30697]: spamd: connection from localhost [127.0.0.1]:51740 to port 783, fd 5 Jan 15 14:18:21 localhost spamd[30697]: spamd: processing message <id#1234567@mail.gmail.com> for user Jan 15 14:18:21 localhost spamd[30697]: spamd: clean message (-2.0/5.0) for user in 0.2 seconds, 2572 bytes. Jan 15 14:18:21 localhost …

3
リソースの読み込みに失敗しました:net :: ERR_CONNECTION_RESET
リバースプロキシ(Apache2のmod_jk)の背後にあるアプリケーションの使用を開始してから、一部のページが読み込まれないことに気付きました(リバースプロキシ設定がない場合)。 それは、Google Chromeのおかげで見つけるために検査しなければならない微妙なエラーでした:リソースのロードに失敗しました:net :: ERR_CONNECTION_RESET。 単純に、JavaScriptファイルは部分的にロードされます(〜50KBから〜12KBがロードされます)。 Apache2、mod_jk、AJP、またはJettyに問題があると思いました。 しかし、その後、私は調査を行って、さまざまなブラウザーをさまざまなネットワークで使用することを検討しました。 判定: このエラー(ERR_CONNECTION_RESET)は、静的 IPのネットワークを使用している場合にのみ発生します。 1台のルーターでセキュリティレベルを下げましたが、無駄でした。 静的IPを備えたネットワークは、より高いレベルのセキュリティを備えていますか? この問題を克服する方法は? リバースプロキシは主に、セキュリティレベルを高めるためにセールスポイントの静的IPアドレスを利用することを目的としているため、行き詰まりです。

3
find -deleteは問題なく動作しますが、cronでは動作しません
注意してください:私は同様の質問をすべて読みました。cron、パス、環境変数などですが、私の特定の問題の解決策を提供するものは見つかりませんでした。 私はいくつかのMySQLダンプを作成し、次のように古いものを削除するスクリプトを持っています。 /usr/bin/find "/home/bkp/dbdump" -name "*.gz" -mtime +5 -delete (上記のコマンドは、コメントからの提案により、元のコマンドから変更されています) ただし、cronがこのスクリプトを実行しても、ファイルが削除されることはありません。cronユーザーはrootです。 デバッグに関する注意 コマンドが表示されているスクリプトを手動で実行すると、期待どおりにスクリプトが削除されます。 rootとしてコマンドラインから上記のfindコマンドを単独で実行すると、期待どおりに削除されます(-printを使用すると、期待どおりに5日より古いファイルのリストが返されます)。 また、ルートのcrontabに明示的なパスステートメントを追加しましたが 、何も変更されません。 Cronはエラーを送信しません。パイプを使って検索操作をログファイルに送信すると、ログファイルは 空になるか、まったく作成されません。 Ubuntuサーバー14.04.03 LTSを使用しています。
10 cron 

1
ログインしていないユーザーがタスクスケジューラからバッチファイルを実行する
Windows 7でタスクスケジューラからバッチファイルを実行しようとしています。コマンドプロンプトから実行すると、バッチファイルを正常に実行できます。 タスクスケジューラから実行して、ユーザーがログインしているときにのみ実行する場合、タスクは問題なく実行されます。ただし、ユーザーがログインしていないときに実行すると、タスクスケジューラはファイルを実行しているように見えますが、何も起こりません。 バッチファイルの内容が原因ではないことを確認するために、バッチファイルを次の行に変更しようとしました。 echo "success" >> c:\temp\test.log そしてそれは機能しません。何か案は?最高の権限と、バッチファイルとファイルが書き込まれているフォルダーへの完全なアクセス許可を持つ管理者アカウントで実行しています。

2
ZFSプールの遅い順次読み取り
この問題について関連する質問がありますが、複雑すぎて大きすぎたため、問題をNFSとローカルの問題に分割する必要があると判断しました。私はzfs-discussメーリングリストでこれについて尋ねようとしましたが、あまり成功しませんでした。 同じサーバー上のNFS / CIFSディレクトリ間の低速コピー 概要:設定方法と期待される内容 4つのディスクを持つZFSプールがあります。ストライプ化された2つのミラーとして構成された2TB RED(RAID 10)。Linuxでは、zfsonlinux。キャッシュまたはログデバイスはありません。 データはミラー間で分散されます(ZFSにとって重要) 各ディスクは147MB /秒で並列に読み取り(raw w / dd)、合計で588MB /秒のスループットを実現します。 同様の4TB REDディスクのベンチマークに基づいて、各ディスクからのシーケンシャルデータの約115MB /秒の書き込み、138MB /秒の読み取り、および50MB /秒の再書き込みを期待しています。最近はどのディスクでも実行できるため、100MB /秒以上の読み取りまたは書き込みを期待しています。 負荷がかかってシーケンシャルデータの読み取りまたは書き込みを行っているときに、4つのディスクすべてでIO使用率が100%になると思いました。そして、そのディスクは100%の使用率で100MB /秒以上を出力します。 このプールでは、1つのディスクで約2倍の書き込み、2倍の書き換え、4倍の読み取りパフォーマンスが得られると思いました。 NEW同じプールのext4 zvolはZFSとほぼ同じ速度になると思いました 私が実際に得るもの プールの読み取りパフォーマンスが思ったほど高くない 数日前のプールでのbonnie ++ベンチマーク バージョン1.97 ------順次出力-------順次入力--ランダム- 同時実行性1 -Per Chr- --Block-- -Rewrite- -Per Chr- --Block-- --Seeks-- マシンサイズK /秒%CP K /秒%CP K /秒%CP K /秒%CP K …
10 linux  raid  performance  zfs  zpool 

2
SSHキーペアをローカルで廃止する方法
しばらくの間、sshキーを使用しています。私のsshキーペアをより強力な暗号化にアップグレードすることを考えています。キーが登録されているすべてのデバイスを知りません。 それはへかのうである「廃止」私は廃止SSHキーで認証場合、私は警告を受けることを、局部的にそうSSHキー?

2
方法:エラスティックコンテナーサービスでのDockerized MongoDBレプリケーション
Node.jsアプリと、AWS ECSで実行されているMongoDBデータベースがあります。現在取得しているセットアップは、2つのELBと2つのインスタンスで構成されており、それぞれがDockerコンテナーとそれに割り当てられたサービス(node / mongo)を実行しています。 Elastic Load Balancer -> Dockerized Node -> Elastic Load Balancer -> Dockerized MongoDB ここで入手できるMongoDBの公式Dockerイメージを実行しています:https : //registry.hub.docker.com/_/mongo/ DockerとECSを使用してMongoDBのreplicaSetをデプロイするにはどうすればよいですか?各レプリカは異なるインスタンスで実行されていますか?

2
LinuxでZFSを使用してZFSプールが拡張されないのはなぜですか?
Linux上のカーネル2.6.32-431.11.2.el6.x86_64の下に、単一のvdevを持つZFS zpoolがあります。vdevはSANデバイスです。SANのサイズを拡張しました。zpoolがにautoexpand設定されているonにもかかわらず、マシンを再起動し、プールをエクスポート/インポートし、を使用した後でもzpool online -e、プールを拡張できませんでした。vdevがfdisk215GiBから250 GiBに増加したことを示しているので、vdevはより大きくなっています。これが私がしたことのサンプルです: [root@timestandstill ~]# zpool list NAME SIZE ALLOC FREE CAP DEDUP HEALTH ALTROOT dfbackup 214G 207G 7.49G 96% 1.00x ONLINE - [root@timestandstill ~]# zpool import -d /dev/disk/by-id/ pool: dfbackup id: 12129781223864362535 state: ONLINE action: The pool can be imported using its name or numeric identifier. config: …
10 linux  zfs  zfsonlinux 

3
Apache 2.2のサポート終了
サポート終了日がいつApache 2.2.xになるのか、誰か知っていますか?歴史的なパターンから判断すると、2016年か2017年かと思います(1.3と2.0はどちらも11〜12年間で、2005年には2.2が出ました)。 私は、計画的なサポート終了日や最低限のコミットされたサポート終了日などの信頼できるものを見つけたいと思っていました(つまり、Apache Software Foundationは少なくとも20 ##までサポートされることを保証しています)。オンラインでは何も見つかりませんでした。歴史的に起こったこと以外。 過去のリリースとEOLの日付については、https://en.wikipedia.org/? title = Apache_HTTP_Server#Developmentの表を参照してください。
10 apache-2.2 

弊社のサイトを使用することにより、あなたは弊社のクッキーポリシーおよびプライバシーポリシーを読み、理解したものとみなされます。
Licensed under cc by-sa 3.0 with attribution required.