サーバー管理者

システムおよびネットワーク管理者向けのQ&A

1
一部のドメインでrelayhostを無視するようにPostfixを構成するにはどうすればよいですか?
Postfixにを無視する方法はありrelayhostますか? 私のようなものがあります relayhost = [smtp.domain.net]:587 ここで、特定のドメインについては、そのリレーに送信したくないが、そのマシンから送信したいだけです。 それを行うためにどのようにPostfixを構成する必要がありますか?
10 postfix  smtp 

2
MediaWikiで編集したページの保存が遅い
次のLAMPプラットフォームにMediaWiki 1.16.2があります。これは、16 GB RAMデュアルプロセッサマシン上の他のアプリに対して非常に優れています。CentOS5.7(64ビット)Apache 2.2.3 MySQL 5.0.77 PHP 5.1.6 使用しているブラウザにある程度依存しているようですが、編集したページを頻繁に保存するのは遅すぎます。非常に単純な変更のために10秒または20秒待つことも珍しくありません。 ページのレンダリングはかなり高速に動作しますが、編集後の節約でユーザーエクスペリエンスが損なわれます。Operaを実行しているクライアントから編集する際に、Firefox(Fedora Linuxプラットフォーム上)よりもいくつかの改善が見られました。 サーバーをより良くするためにどこを調整できるかに関するヒントはありますか? ところで、マシンで実行されるApacheのベンチマークは印象的です。
10 php  mysql  linux  centos  mediawiki 


1
EBSの使用がボトルネックになるのはどの時点ですか?
EBSボリュームによってサポートされているEC2インスタンスを使用して、Amazonでホストされているサイトがあります。週末には、トラフィックが急上昇し、インスタンスを大きくすることでかなり役立ちます。CPU使用率が100%に急上昇し、サーバーが応答しなくなったことはもうありません。 しかし、ディスクの読み取りも非常に高いことに気づきます(どうしようもない、私は考えていません)。ディスクが維持できないため、どの時点で何らかの障害が発生するのでしょうか。アップ? 添付のスクリーンショットからわかるように、週末は最大80MB /分でした。AWSの経験があり、EBSがボトルネックになるために、どの時点で複数の負荷分散インスタンスに移動する必要があるか知っていますか?

2
OpenSSLを使用してIIS7 SSL更新CSRを確認/読み取る方法
私は毎週最大5つのSSL CSRを処理し、CAに渡してアクションを実行する前にそれらの有効性をチェックする特権があります。UbuntuマシンでOpenSSLを使用してそれらが有効であることを確認し、正しいOU名、適切なCN、2048ビット以上のキーサイズなどをテストします。 先日、IIS7マシンから更新リクエストを受け取りました。OpenSSLを使用してこれを読み取る方法がまったくわかりません。私のCAがそれを受け入れたので、それは有効です... 'file(1)'は「RFC1421セキュリティ証明書署名要求テキスト」であると言います。これは、私がここに持っているCSRの〜50%について言っているものです(残りは「PEM証明書要求」です)。 $ head iis7rcsr -----BEGIN NEW CERTIFICATE REQUEST----- MIIQsQYJKoZIhvcNAQcCoIIQojCCEJ4CAQExCzAJBgUrDgMCGgUAMIIJegYJKoZI hvcNAQcBoIIJawSCCWcwggljMIIIzAIBADCB2zELMAkGA1UEBhMCTloxDTALBgNV BBEMBDkwNTQxDjAMBgNVBAgMBU90YWdvMRAwDgYDVQQHDAdEdW5lZGluMRwwGgYD ... ... openssl req、CSR(PKCS#10)を読み取ると、CSRを理解できません... $ openssl req -in iis7rcsr -text unable to load X509 request 5156:error:0D0680A8:asn1 encoding routines:ASN1_CHECK_TLEN:wrong tag:tasn_dec.c:1316: 5156:error:0D07803A:asn1 encoding routines:ASN1_ITEM_EX_D2I:nested asn1 error:tasn_dec.c:380:Type=X509_REQ_INFO 5156:error:0D08303A:asn1 encoding routines:ASN1_TEMPLATE_NOEXP_D2I:nested asn1 error:tasn_dec.c:748:Field=req_info, Type=X509_REQ 5156:error:0906700D:PEM routines:PEM_ASN1_read_bio:ASN1 lib:pem_oth.c:83: MSDNブログのAndreas Kleinによるこの記事は、IIS7更新CSRがPKCS#7コンテナーであり、CSRと現在の証明書に基づく署名が付いていることを示していますが、それでもまだ読み取ることができません。 $ …

4
LinuxでのSSDの書き込みサイクル数または予想寿命を決定する方法は?
Linux(RHEL 5)サーバーでSSD(Intel X25-M)をしばらく実行してきましたが、過去1年間にどれだけの書き込み負荷がかかっているかを把握するための努力はしていません。Linuxの下で、時間の経過とともにディスクに書き込まれたおおよその量、または(さらに良いことに)ディスクに蓄積された摩耗量を知らせるツールはありますか?それが死に近いかどうかを確認するためのヒントを探しています...
10 linux  ssd 


1
Exchange 2010 SP1パーソナルアーカイブにインポートするためのGFI MailArchiver電子メールのエクスポート
GFI MailArchiver 5の既存のインストールには、アーカイブのデータベースがいくつかあります(おそらく100〜150 GB)。目標は、各ユーザーのアーカイブされた電子メールをエクスポートしてから、Exchange 2010 SP1個人アーカイブにインポートすることです。GFI にはこれを行うためのツールがありますが、それは非常に初歩的なものであり、深刻で率直に言えば実行できない制限があります。電子メールヘッダーに基づいたクエリのみが可能です。複数のヘッダー(To:、Cc :)に表示される可能性のある複数のエイリアスがあるため、これは特定の時点での配布グループのユーザーのメンバーシップをカバーしないという事実は言うまでもなく、このツール十分ではありません。 もう1つのオプションは、ツールを使用せずにGFIデータベースから電子メールを抽出することですが、これを行うには独自のツールを作成してそれらを再構築する必要があり、実際にはその道をたどりません。 私はこの問題にとてもこだわっています。ここで誰かが同様の移行を行ったことがありますか?どうすればこれを最もうまく処理できますか?


7
開発者がエンタープライズ環境で独自のVMサーバーを実行するために必要なもの[終了]
閉まっている。この質問は、オフトピック。現在、回答を受け付けていません。 5年前休業。 ロックされています。この質問とトピックへの回答はロックされています。質問はトピックから外れていますが、歴史的に重要です。現在、新しい回答や相互作用を受け入れていません。 このシナリオもSOに投稿されており、対象ユーザーごとにさまざまな質問がありました。非常に良い回答を受け取ったので、とても嬉しく思います。 私たちは、企業組織内の4人の開発者の小さなチームのために、仮想化を使用した開発環境を実装しようとしています。これにより、個別の開発、テスト、およびステージング環境をセットアップできるほか、評価対象のシステムまたはツールの要件である新しいオペレーティングシステムにアクセスできるようになります。 既存のワークステーションクラスのマシンを再利用し、24 GBのRAMとRAID-10を投入し、マシンをドメインに追加しようとするまで問題なく動作しました。 今、私たちは、当初からすべてのエンタープライズ開発者が戦わなければならなかった戦争、つまり開発とテスト環境のローカル制御のための戦いを始めています。ネットワークおよびIT管理者は、「ESXサーバーはエンタープライズ標準です」から「サーバーはクライアントVLANでは許可されていない」、「[fill-in-the-blank]は現在保有しているスキルセットではない」など、さまざまな懸念を提起しています。ローカルまたはエンタープライズIT組織」。 おそらく本番レベルのハードウェアと正式なITサポートを正当化することができます(必要な場合は必要性を正当化できますが、それには時間がかかり、頭痛の種がたくさんあります)-ITリソースを正式に取得するまでに数か月かかる可能性がありますこれをプロダクションシステムとして扱うことによって割り当てられます。そうしたとしても、必要なローカルコントロールを失う可能性があります。 非実稼働環境を開発者が制御するために、企業内の開発者と同様の苦労があったと思いますので、私の質問は次のとおりです。 一般的に(そして当然のことながら)このタイプの(中央で)管理されていないインフラストラクチャを排除する標準のネットワークおよびセキュリティポリシーが導入されている企業内にこれらのタイプのサイロが存在することを許可するために、開発者はどのような議論をしましたか? これは、開発者が技術的またはビジネス上の正当化を行い、パッチ管理とAVが確実に行われるようにすることですか、それとも制御と所有権をめぐる政治的闘争の問題でしょうか。 選択を前提として、開発者にローカル管理者権限を与えながらハードウェア/ OSの所有権とサポートを取得するか、完全に管理させながら、問題が発生した場合にパッチ管理/ AVを導入して責任を課すことを保証しますか? 開発者がインフラストラクチャの「不正なサーバー」をローカルで制御できないようにブロックできた場合、開発者は当然のことをしましたか、それとも開発者(またはあなた)が開発環境を切断されたVLAN /完全に別のネットワークに移動しましたか? この質問の範囲を制限するためのいくつかの仮定: 繰り返しますが、これは開発環境用です。本番環境の負荷やサポート性は必要ありません。外部からアクセスできるものはありません。 これは、Hyper-VとESXの聖戦ではありません(どちらを使用しても問題ありませんが、Hyper-Vは、これらの目的のためにMSDNで「無料」であるため選択されました[そうです、VMWareにも無料のツールがありますが、優れた管理ツールは一般的には]ではなく、ローカル開発者が "Microsoft Shop"で管理する方が簡単です)。 開発チームはすでに、パッチ管理とウイルス対策の管理、またはITがサポートする場合は既存のエンタープライズシステムとの統合を保証していますが、それを受け入れるかどうかは確かに範囲内です。

3
Puppetによるiptablesの管理
iptablesPuppetでルールを管理するという考えが浮上しました。私はそれaugeasがiptablesレンズを持っているのを見ますが、それは現在実験的です。 これをどのように処理するかについて誰かが何か提案はありますか?理想的には、サーバーのクラスに基づいてチェーンを構築したいと思います。

4
ファイルが物理的にディスク上のどこにあるか(ブロック番号)を確認するにはどうすればよいですか?
これはあいまいな質問だと思います。Linuxボックスでいくつかのディスクのパフォーマンステストを実行しようとしています。同じディスクで同じテストを実行すると、一貫性のない結果が得られます。ディスクのどの部分にアクセスするかによって、ディスクのパフォーマンスが異なることは知っています。特に、データ密度がほぼ一定で回転速度が一定であるため、ディスクの外側への読み取りと書き込みは、ディスクの内側への読み取りと書き込みよりもスループットがはるかに高くなります。 私の不整合が、このジオメトリに起因するスループットの変動に起因する可能性があるかどうかを確認したいと思います。既存のツールを使用して、ディスク上のファイルが配置されている場所を見つけることは可能ですか? そうでない場合は、ファイルシステムをバイパス(および破棄)して、デバイスファイル自体に直接シーク、読み取り、および書き込みを行う何かを書き込むことができると思いますが、それを回避したいと考えています。現在、3.0カーネル(Arch Linux、重要な場合)でext4を使用していますが、他のファイルシステムの手法にも興味があります。

2
再起動せずにプログラムでjenkinsジョブ構成を変更するにはどうすればよいですか?
Jenkinsジョブには、そのジョブの構成を格納するconfig.xmlファイルがあります。 他のジョブの構成を変更する「ジョブマネージャ」ジョブがありますが、Jenkinsを再起動しないと、新しい構成を確認するように見えません。 jenkins-cli.jarコマンドラインツールは、奇妙なことに、このアクションのオプションがないようです。 これは、あるウェブインタフェースを介して編集に設定可能、それは技術的に不可能であろうと思われないので、再起動せずに保存/認めていることがあります。 私の最善の試みは、Webインターフェイスと同じアドレスに投稿してみることでした wget --post-file=config.xml --user=joe.shmoe --password=secret01 \ --no-check-certificate \ https://jenkins.company.com/job/myProject/config.xml ...しかし、有効な認証情報を使用しているにもかかわらず403が表示されます(タイプミスがないようにコピーを貼り付けました) 誰かが何かアイデアを持っているか、私が見逃している単純なことを知っていますか?
10 hudson  jenkins 

1
あるnginxから別のnginxへのリダイレクト
NGINXを備えた2つのサーバー(AとB)があります。サーバーAは古いサイトにサービスを提供し、サーバーBは新しいサイトにサービスを提供しています。DNSを更新しましたが、かなり時間がかかります。私のオフィスでは、古いサイトがまだ表示されています。 subdomain.site.com この特定のサブドメインに対するサーバーAからのすべての要求をサーバーBにリダイレクトするにはどうすればよいですか? これで両方がNGINXでこれで処理されます: server { listen 80; server_name subdomain.site.ru; root /var/www/subdomain/public; passenger_enabled on; }
10 nginx  redirect 


弊社のサイトを使用することにより、あなたは弊社のクッキーポリシーおよびプライバシーポリシーを読み、理解したものとみなされます。
Licensed under cc by-sa 3.0 with attribution required.