サーバー管理者

システムおよびネットワーク管理者向けのQ&A

4
開発サーバーのPostfix、メールを1つのドメインにのみ送信できるようにする
開発サーバーにpostfixがあり、他のドメインではなく自分のドメインにのみメールを送信できるようにして、外部ユーザーが開発サーバーから誤ってメールを受信しないようにします。 私はドキュメントを検索し、いくつかのことを試しましたが、それでもすべてのドメインに送信されています...
11 postfix 

3
バッチファイルでグローバルPATH環境を設定するにはどうすればよいですか?
私たちの環境のグループポリシーは、ログオンするたびにPATH変数を上書きし、「非標準」のコンピューターを実行すると、完全に間違ったものになります(C:\ WindowsとC:\ WINNT、見つからないディレクトリなど)。現在、ログオンするたびに手動で変更していますが、面倒になり始めています。 SETコマンドを使用してバッチファイルのPATH変数を変更すると、ローカルスコープしか持たないため、変更はバッチファイルのコマンドにのみ適用されます。 set PATH=C:\WINNT;C:\WINNT\System32 set PATH このバッチファイルは新しいパスを出力しますが、set PATH後でコマンドラインで実行した場合でも、元のパスのままです。 バッチファイルでグローバル PATH環境を設定するにはどうすればよいですか?または、私が使用できる別のテクニックはありますか?


1
UbuntuのUFWでLAN上のすべてのトラフィックを許可
UbuntuサーバーへのすべてのLANトラフィックを許可します。ドキュメントを読んでコマンドを確認しましたが、IP範囲のコマンドを編集しようとするとエラーが発生します。192.168.15.0-192.168.15.255で始まるすべてのトラフィックを許可するにはどうすればよいですか? sudo ufw allow from 192.168.15.0/255 ERROR:Bad source address 15(3番目の8進数)がエラーの原因であるようです。UFWとほとんど同じように、LANに一意のIPセットがあることを期待していません。 ありがとうございました
11 ubuntu  ufw 

7
起動時にNginxを起動する
nginxとパッセンジャーをインストールして実行できましたが、サーバーを再起動するたびにnginxを起動させることができません。nginxプロセスを開始するには、sudo / opt / nginx / sbin / nginxと入力します。私の理解から、ubuntu hardyで/etc/init.dに入れたものはすべて実行されます。このコマンドライン呼び出しを模倣するコマンドを知っている人はいますか? sudo / opt / nginx / sbin / nginx
11 ubuntu  nginx  startup 

3
無料のTomcat Log Analyserはありますか?[閉まっている]
現在のところ、この質問はQ&A形式には適していません。回答は事実、参考文献、専門知識によって裏付けられると期待していますが、この質問は、議論、議論、投票、または拡張ディスカッションを求める可能性があります。この質問を改善でき、再開できると思われる場合は、ヘルプセンターにアクセスしてください。 6年前休業。 誰かがApache Tomcatログを分析するための優れた無料のプログラムを推奨できますか?リアルタイム分析などは必要ありません。ログがあり、そこからいくつかの使用統計をすばやく簡単に取得したいのですが。統計情報は派手である必要はありません。日、週、月ごとのユニークユーザーの大まかなアイデアが欲しいだけです。 おかげで、 バート。

4
/ usr / sbin / apache2ctl:124:www-browser:見つかりません
ApacheとPassengerでRailsアプリケーションをホストするように新しいVPSを構成しています。数か月前に設定した他のVPSが稼働しています。 新しいものaptitudeでは、最初のものと同じように、Apacheとそのパッケージを経由でインストールしました。最新のVPSで次のコマンドを実行すると、正常な応答が返されます root@www:/etc/apache2# apache2ctl status Apache Server Status for localhost Server Version: Apache/2.2.8 (Ubuntu) Server Built: Jul 10 2009 18:47:48 ... 古いVPSで同じコマンドを実行すると、次のエラーが返されます root@www:/etc/apache2# apache2ctl status /usr/sbin/apache2ctl: 124: www-browser: not found このVPSのApacheには何の問題もありませんが、このエラーの修正方法を知りたいのですが。

8
ファイアウォールの背後にあるLinuxマシンへのリモートアクセス
Linuxマシンを一種のパブリックターミナルとして遠隔地に導入します。メンテナンスのためにSSHを介してリモートでアクセスできるようにしたいのですが、このマシンにアクセスする必要があるまれな場合のために、リモートファイアウォールのポートを開いたままにしたくありません。外部のマシンへのリバースSSHトンネルを作成する簡単なスクリプトについて考えましたが、アクセスする必要があるときにユーザーが何かをする必要はありません。何か案は? 更新:私は、リバースSSHトンネルを作成するスクリプトの元の計画を採用することにしました。ポートノッキングなどの他の推奨される解決策は、私が本当にやりたいことに沿ったものですが、この場合、ユーザーに構成を案内する以外にルーターを構成するためのアクセス権がありません。身震い

3
サービスのStartTypeを自動に設定-遅延
を使用してSet-Service、StartTypeサービスのをの許容値の間で変更できますBoot, System, Automatic, Manual, Disabled。を使用するとservices.msc、一部のサービスをPriorityで起動するように設定できますAutomatic (Delayed Start)。ただし、Get-Serviceこれらの遅延開始サービスは引き続きとして報告されStartType : Automatic、Set-Serviceこれらの値を設定しようとするとエラーになります。 PowerShellを介してこのプロパティを設定できますか?それとも、UI またはGPOに制限されていますか?

2
Ubuntu 16でApacheをプリフォークからイベントに切り替え、PHP 7を動作させる
Apacheは本番環境で実行が遅くなりました。しばらく答えを検索した後、私はようやく#apache IRCチャネルに行き、プロは次のコマンドでapacheモードを確認してもらいました。 sudo apachectl -V そして、サーバーMPMがpreforkであることがわかって驚いた。彼らは、本番サーバーではプリフォークを使用しないでくださいと強調しました。結局のところ、(おそらくDebianから継承された)Ubuntuパッケージは、ApacheでPHPを実行するための推奨される方法が proxy_fcgiとphp-fpmを明確に推奨し、最終的にfcgidを推奨しないという事実にもかかわらず、apacheをpreforkモードで実行することを主張しますプリフォークを使用: なぜprefork mpmでmod_phpを使用すべきではないのか mod_phpは常にすべてのhttpdプロセスにロードされます。httpdが静的/ php以外のコンテンツを提供している場合でも、そのメモリは使用中です。 mod_phpはスレッドセーフではなく、可能な限り最も遅い設定であるprefork mpm(マルチプロセス、スレッドなし)を使用するように強制します。 このページにはPHP-FPMの詳細も含まれていますが、これは少し複雑で不明瞭であり、多くの手動設定が含まれているようです。Ubuntu 16にはfastCGIモードなどのパッケージオプションがないのでがっかりしました。 a2enmodを使用してapacheをイベントモードに切り替えてみましたが、apacheを起動しようとすると、エラーが発生しました。 Apacheはスレッド化されたMPMを実行していますが、PHPモジュールはスレッドセーフになるようにコンパイルされていません。PHPを再コンパイルする必要があります とにかく、パッケージインストーラーにできる限り依存して、 PHP 7.0を搭載したUbuntu 16でfastCGIモードを実行するための最小限の段階的な手順があるかどうか疑問に思いました。私は現在、説明が不十分で曖昧な指示をたくさん見ていますが、私は本番環境を誤った決定で汚してしまうのではないかと心配しています。 また、誰かがタグオプションとしてmpm-eventを追加する必要があります。それが#apache IRCの人たちが推奨したことです。

1
systemd-resolvedサービスは何をし、すべてのインターフェースでリッスンする必要がありますか?[閉まっている]
休業。この質問には、より焦点を当てる必要があります。現在、回答を受け付けていません。 この質問を改善してみませんか?質問を更新して、この投稿を編集するだけで1つの問題に焦点を当てます。 先月休業。 IOTデバイス(現在は非推奨のIntel Galileo)を含むプロジェクトに取り組んでいます。これらのデバイスの強化を検討していsystemd-resolvedますが、サービスがすべてのインターフェイスでリッスンしていることに気付きました(0.0.0.0)。 root@hostname:~# netstat -altnp Active Internet connections (servers and established) Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name tcp 0 0 0.0.0.0:5355 0.0.0.0:* LISTEN 240/systemd-resolve ここでのサービスのfreedesktop.orgの説明を読んだ後、それはそれを述べています、 systemd-resolvedは、ローカルアプリケーションにネットワーク名解決を提供するシステムサービスです。 が実行さpingれているgoogle.com場所まで実行するテストsystemd-resolvedを実行しました。次に、サービスを無効にしてに送信しpingました yahoo.com。どちらのリクエストでもパケット損失はありませんでした。 私の質問は次のとおりです。 このサービスは何をしていますか? ローカルアプリケーションに名前解決を提供している場合、なぜ0.0.0.0インターフェイスでリッスンするのですか? これはセキュリティ上の問題ですか? このサービスを無効にするとどのような影響がありますか? 情報/ヘルプを事前にありがとう。質問形式に準拠していない場合は、初めての投稿でお詫びします。必要に応じて編集してください。
11 linux  systemd 

2
nginx:ssl_stapling_verify:正確に何が検証されていますか?
ssl_stapling_verify指令は正確には何ですか?回答の署名が正しいかどうかを確認しますか?公式のnginxドキュメントはこれを説明するのが非常に曖昧です: https://nginx.org/en/docs/http/ngx_http_ssl_module.html#ssl_stapling_verify サーバーによるOCSP応答の検証を有効または無効にします。 検証を機能させるには、サーバー証明書発行者の証明書、ルート証明書、およびすべての中間証明書を、ssl_trusted_certificateディレクティブを使用して信頼できるものとして構成する必要があります。
11 nginx  ocsp 

2
SystemdドロップインがPIDファイルの作成に失敗する
パスにsystemd-machinedのドロップインがあります/etc/systemd/system/systemd-machined.service.d/10-machined-pid-file.conf。走るsystemctl status systemd-machinedと線が見える Drop-In: /etc/systemd/system/systemd-machined.service.d └─10-machined-pid-file.conf しかし、/ var / run /にPIDファイルがありません。これは私のドロップインに基づいています: [Serivce] PIDFile=/var/run/machined.pid そのPIDファイルを作成するときに問題は発生しないはずです。何か足りないものはありますか?
11 files  systemd  pid 

2
プログラムでsudoersファイルにsecure_pathを追加する方法
私は、githubからノードとnpmを構築し、サービスを開始するEC2インスタンスのユーザーデータスクリプトを構築しようとしています。これらのホイールにグリースを塗布するには、以下を追加する必要があります。 :/usr/local/bin / etc / sudoersの次の行の終わりまで: Defaults secure_path=" /superuser/927512/how-to-set-path-for-sudo-commandsはvisudoを使用してこれを実現する方法について説明していますが、EC2ユーザーデータ内でプログラム的に実行したいと考えています。 /programming/16282789/adding-sudo-permissions-to-sudoers-for-user-via-shell-scriptはsudoersファイルの編集について話しますが、私がやろうとしていることに対してひどく焼きすぎているようです達成する。 行をgrepして置き換えるのは簡単だと思いましたが、困惑しました。迷惑な閉じ逆コンマだけではありません!
11 linux  grep 


弊社のサイトを使用することにより、あなたは弊社のクッキーポリシーおよびプライバシーポリシーを読み、理解したものとみなされます。
Licensed under cc by-sa 3.0 with attribution required.